Catalina 10.15.5 - Clover Update Problem

  • Hallo zusammen,


    ich scheitere seit geraumer Zeit mit dem Update von Clover. Das Durchschauen diverser Videos auf Youtube und das Lesen vieler Posts hat mir bisher leider nicht weitergeholfen.


    Der Hackintosh läuft nun knapp ein Jahr.

    Asrock H379M Mainboard mit i7 9700k, 32 GByte RAM, 4GB AMD Radeon RX560 Grafik.

    1. SSD im M.2 Slot mit OS, EFI, ...

    2. SSD als SATA mit einem Clone


    OS ist MacOSX Catalina 10.15.5. Clover ist noch auf Revision 5070.


    Ich versuche mittels Clover Configurator eine aktuelle Version zu installieren.

    Ich mounte mittels Configurator die EFI. Die config.plist lässt sich wunderbar laden.

    Nun versuche ich mittels "Installiere/Aktualisiere Clover" ein Update zu machen. Angeboten wird mir 5120. Ich habe es mehrmals sowohl mit "Package", als auch mit "Cloverx64.efi" versucht.

    Im Verlauf der Package-Installation habe ich die Möglichkeit, den Pfad auszuwählen. Hier werden mir nur meine 1. "Macintosh HD" oder meine 2. "Clone" SSD angezeigt. Das EFI-Volume auf der "Macintosh HD" wird nicht explizit angezeigt. Wähle ich 1., dann wird im Root-Verzeichnis der "Macintosh HD" ein EFI-Ordner mit Clover angelegt. Ebenso entsteht ein EFI-Backups Ordner.

    Das gemountete EFI Volume bleibt leider unangetastet. Also kein Update.


    Während der Clover-Installation kommt außerdem die Meldung "Dieses Paket ist nicht mit dieser macOS-Version kompatibel.". Ich hatte aber gelesen, dass ich dies wohl ignorieren kann.


    Hat jemand einen guten Tipp für mich?


    Danke!

  • Herzlich willkommen im Hackintosh-Forum. :)


    Angeboten wird mir 5120.


    Soweit ich das mitbekommen habe, hatten Andere hier im Forum auch schon Problem mit der 5120. Nimm die 5119.

    Meines Wissens sind die Ordnerstrukturen der neuen Clover anders aufgebaut - hier ist also etwas Handarbeit gefragt.Sichere aber vor dem Aktualisieren den bestehenden EFI-Ordner von 5070 irgendwo als Backup, wo er sicher ist (Stick z. Bsp.). Man weiß nie. ;)

    Dann könntest Du auch auf normalem Weg Clover 5119 installieren und dann mit Leben füllen. Die Zutaten liegen ja in Deiner 5070.

    Gruß

    LOM


  • Es gibt auch eine 5121, aber ich weiß nicht, ob die besser als die 5120 ist... https://www.hackintosh-forum.d…108-clover-r5121-pkg-zip/

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • Clover bitte als ZIP Version herunterladen und manuell aktualisieren. Den Installer braucht kein Mensch. Idr. reicht das Ersetzen der bootx64 und cloverx64 efi executables. Eventuelle Änderungen an der Ordner Struktur von Clover sind ja im ZIP Archiv auch zu sehen.

    Hier findest du die offiziellen Releases: https://github.com/CloverHacky…CloverBootloader/releases

    LG Chris


    Meine Hardware:

  • Von dem habe ich damals nur den installer gefunden, mit KU. Wird es nur alx64 auch geben.

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • Den Installer braucht kein Mensch.


    Eventuelle Änderungen an der Ordner Struktur von Clover sind ja im ZIP Archiv auch zu sehen.

    Naja - soweit würde ich nicht für Andere sprechen wollen.

    Mit der einmaligen Installation hat er diese Struktur aber in einem Rutsch da, wo sie sein soll. Was wohl schneller geht? ;)

    Gruß

    LOM


  • 1. Geht der Installer nicht mehr einfach so in Catalina

    2. Verpfuscht er gerne die Config wenn man nicht aufpasst


    Manuelles Updaten dauert nicht länger als den Installer zu nutzen. Wenn man die Methode gewohnt ist geht es sogar schneller. Im Regelfall ersetzt man ja nur zwei Dateien.

    LG Chris


    Meine Hardware:

  • wenn man nicht aufpasst

    Das ist der Punkt, wenn auch anders gemeint: Du vergisst bei Deiner Betrachtung, dass nicht Jeder soviel Hintergrundwissen und Sicherheit im Umgang mit diesen Dingen hat wie Du. ;)

    Die normale Installationsprozedur gibt dem Unerfahrenen "mehr" Sicherheit, weil direkt alles an seinem Platz ist. Bei händischem Vorgehen können mehr Fehler entstehen.

    Gruß

    LOM


  • Verpfuscht er gerne die Config wenn man nicht aufpasst

    Das habe ich bisher nie festgestellt. Wie sollte das passieren?

    Ansonsten gebe ich CMMChris recht, das einfache Kopieren ist völlig ausreichend und geht schneller.

    Die entsprechenden Dateien findet man auch in meinen Downloads (siehe Signatur).

  • das einfache Kopieren ist völlig ausreichend

    Nicht, wenn es das erste Mal ist, denn erst durch die Installationroutine ergibt sich die gewünschte EFI-Struktur. Oder ist die clover.pkg schon fertig zum einfachen Kopieren? Habe ich noch nicht gesehen. Oder irre ich mich?

    Bei ersten echten Update auf z. Bsp. 5122 ist ein reines Kopieren der einfachere Weg - da ist Alles schon vorhanden - praktizieren wir ja meist eh so.

    Gruß

    LOM


  • Also ich hab schon seit nem dreiviertelJahr den Installer nicht mehr genutzt. Auch nicht für frische Installationen. Wozu sollte man den da brauchen?! Legacy Installation ok, aber für ne klassische UEFI Installation definitiv nicht.


    g-force Unerwünschte EFI Treiber oder ungewollt gelöschte EFI Treiber. Solche Fälle kennt man doch aus dem Forum zu genüge.

    LG Chris


    Meine Hardware:

  • Vielen Dank an euch für die Rückmeldungen und Tipps!


    Nach Sicherung meines EFI Folders mit der Clover Version 5070 auf einen bootfähigen MacOS X Install-USB-Stick, habe ich nun BOOTX64.efi und CLOVERX64.efi auf der EFI Partition manuell ersetzt.

    Das ist gelungen und das System bootet mit Clover 5120.


    Eine Folgefrage habe ich noch.

    Wenn ich den Hackintosh neu starte, dann bootet er grundsätzlich ein Recovery Volume. Ich muss also immer aufpassen, durch rechtzeitigen Tastendruck in den Clover Bootmanager gehen und dort das richtige Volume auswählen: "Boot macOS from Macintosh HD".


    Das DefaultBoot Volume in der Clover Konfiguration (laut Configurator) ist "LastBootedVolume". Das hat aber nicht den gewünschten Effekt. Dieses Problem bestand allerdings schon vor dem Update auf 5120.


    VG

    ak1

  • Du hast keinen NVRAM Zugriff. Welchen Aptiofix nutzt du?

    LG Chris


    Meine Hardware:

  • ich hab schon seit nem dreiviertelJahr den Installer nicht mehr genutzt.

    Könnte bei mir (so wie bei vielen Anderen) auch hinkommen - das war meiner Erinnerung nach dann, als Clover den Aufbau etwas änderte.

    Auch nicht für frische Installationen. Wozu sollte man den da brauchen?!

    Ja - wozu?

    Du hast also - Deiner eigenen Empfehlung für den TE folgend - bei Deiner ersten Clover-Anwendung damals die Clover.zip heruntergeladen. Und dann? Hast Du einen Stick danebengelegt und die EFI-Struktur ist nach dem Entpacken aus der .pkg auf den Stick rübergegangen?

    Oder hast Du Dir nach einem Bild aus einem Hackintosh-Forum die Ordnerstruktur händisch selbst angelegt und dann ... ? Ja - wie hast Du die besagten Dateien zum Kopieren überhaupt aus der .pkg heraus bekommen?

    Wenn ich auf die .pkg klicke, erhalte ich das:


    Das ist die Installationsroutine.

    Kennst Du einen anderen Weg? Dann her damit. Vielleicht ist das total an mir vorbeigegangen, es geht viel einfacher und ich habe das Thema immer verkehrt angepackt - dann nehme ich Alles zurück. Im Moment kann ich es mir allerdings noch nicht vorstellen.


    Insofern bleib doch mal bitte praxisbezogen: Jeder, der Clover im Einsatz hat, - ob Du im schönen Donauwörth, g-force an der Waterkant, ich im Westzipfel oder Räuber Hotzenplotz im finsteren Wald - hat bei beiden Varianten jeweils mindestens einmal die Installationsroutine angeworfen und so seine Vorlage - neudeutsch Template - inkl. aller Dateien erhalten, die dann die Möglichkeit bot, später lediglich besagte Dateien auszutauschen. Also braucht man sie genau dann und dafür.

    Man sollte also gegenüber Anfängern nicht den Eindruck erwecken, es ginge ohne.

    Nebenbei sehe ich keinen Unterschied in der Anwendung zwischen Legacy & UEFI. Eine Erst-Vorlage als Unterbau braucht man immer.

    Gruß

    LOM


  • LuckyOldMan Diese Seite hatte CMMChris auch schon verlinkt: https://github.com/CloverHacky…CloverBootloader/releases

    Wenn ich dort das "CloverV2-5120.zip" herunterlade, habe ich die komplette Struktur fertig auf dem Rechner und muß sie nur noch in die EFI verschieben.


    CMMChris Ich hatte das falsch verstanden - ich dachte, es wären Veränderungen an der "config.plist" gemeint. Daß es Veränderungen an der Config (Kexte, Drivers) geben kann, ist natürlich klar.

  • Wenn ich dort das "CloverV2-5120.zip" herunterlade, habe ich die komplette Struktur fertig auf dem Rechner und muß sie nur noch in die EFI verschieben.

    OK - habe ich wieder was gelernt, war mir nicht geläufig. Dann hat CMMChris in der Tat mit seiner Darlegung recht und ich muss mein Geschriebenes zurücknehmen.

    Gruß

    LOM


  • g-force

    Ja, das zip kann man natürlich auch verwenden, aber dort gibt es noch kein 5121, welches ich oben als pkg verlinkt habe. ;)

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!

  • Welche Relevanz hat das? 5121 wurde noch nicht veröffentlicht.

    LG Chris


    Meine Hardware:

  • Du hast keinen NVRAM Zugriff. Welchen Aptiofix nutzt du?

    Offensichtlich habe ich "OsxAptioFixDrv.efi" installiert. Eine Version vom 05.09.2019 laut Dateidatum.

    Sollte ich dort etwas anderes haben?

  • Aptiomemoryfix wäre besser. Noch besser ist immer ocquirks.

    System 2: I7 3770, B75M-D3V, 8GB 1600 DDR3, Powercolor Red Dragon RX 570 8GB, Catalina 10.15.6 Beta, OZMOSIS und macOS Big Sur mit OpenCore/Ozmosis

    :hackintosh:

    !!Kein Support per PN!!