Eigenbau NAS ---> XPenology System

  • Xpenology schon seit Jahren im Einsatz und nie Probleme gehabt außer mal zu schnell ein Update eingespielt, aber auch dann keine Problem muss der USB Stick halt angepasst werden. Derzeit verweilen 6 x 8 TB Platten und 2 x 120GB SSDs für Schreib/LeseCache und läuft wie man so schön sagt, wie SAU.


    :groesten:

  • @'burzelbaum' ich weiß, dass es nun etwas spät ist wahrscheinlich, aber auch für alle anderen, die sich dafür interessieren, habe ich mal ein Video angefügt, die die Kerneltreiber-Compiliation zeigt:


    https://www.youtube.com/embed/x9gBx8JX_V8


    Hackmac:

    • Mainboard: GA-Z97X-Gaming 5
    • Cpu: Intel Core XEON 1231 v3
    • RAM: 12GB HyperX Savage
    • HDD: 1TB Seagate Drive, 3x 1TB WesternDigital NAS Drives, 128GB m.2 SATA-SSD
    • Grafikkarte: AMD Radeon RX 580 von Sapphire
    • OS: Windows 10, Arch Linux, macOS Mojave (Ozmosis/auf der SSD)


    :hackintosh:


    Dell Latitude 5580:

    • Cpu: Intel Core i5 7440HQ
    • RAM: 8GB
    • HDD: 256GB SanDisk SSD
    • OS: Windows 10, Fedora 29, macOS Mojave
  • Asrock j4105 mit 32GB Ram, 2x4GB + 120GB SSD.

    Wie kann ich die SSD als lese und schreibcache benutzen? Ich kann da nur als lesecache auswählen.

    Volume als BTRFS, JBOD oder SHR oder Raid 0 oder Basis ausprobiert.


    Und kann man da was machen...

    wenn ich über Finder auf den Server zugreife, sehe ich mit allen Benutzern die Ordner. Zugreifen können nicht alle aber Ordner sind für alle sichtbar, das würd ich gern auch verstecken.

    Bilder

    Gigabyte Z77X-UD5H Rev.1.0 - Ozmosis F16j 167X/ i7 3770K / 16GB 1600 MHz DDR3 Corsair Vengance / OS X 10.10.5 / GeForce GTX 580 3072 MB
    Intel® NUC Kit NUC6i7KYK / i7-6770HQ 2,6-3,5Ghz 45W TDP / Iris Pro 580 HDMI 2.0 / 2x8GB DDR4 2133 SODIMM / 64Mb Flash EEPROM, WLAN AC8260, Bluetooth 4.2, IR, NFC, SDXC mit UHS-I, 4x USB 3.0, Thunderbolt 3


    Xpenology: ASRock Celeron J4105-ITX, 32GB RAM, 4TB IronWulf, 4TB WD Red, 120GB Adata SSD Jun's Loader 1.03a2 ds918+ 6.2

  • Skorpi08

    Die 32GB ram kann man sich sparen, da Synology damit nicht umgehen kann.und für die Cache Geschichte benötigst du zwei SSDs, eine reicht nicht. Und als weiteren Tipp: so klein wie möglich die SSD wählen 32gb würde reichen, da der Cache selbst nach 1 Jahr nicht riesig wird. In meinem Xpenology mit 32TB Speicher sind die Cache Dateien auf meinem zwei 120gb SSDs gerade mal 3,4GB groß.


    :groesten:

    Einmal editiert, zuletzt von scarface0619 ()

  • Da sagt der iDomix was anderes, er hat 500GB Cache und die sind wohl voll.

    Die 32GB sind bei 918+ zu viel weiß ich. Aber allgemein kann doch Synology mit mehr umgehen, meine gesehen zu haben dass einige bis 48GB können.

    Habe manchmal das Problem, dass beim kopieren denkpausen sind, gestern hab ich eine Datei 22GB kopiert und bei hälfte sagt der dass es die Datei schon gibt.

    Loader ist 6.2 und auch DSM 6.2

    Gigabyte Z77X-UD5H Rev.1.0 - Ozmosis F16j 167X/ i7 3770K / 16GB 1600 MHz DDR3 Corsair Vengance / OS X 10.10.5 / GeForce GTX 580 3072 MB
    Intel® NUC Kit NUC6i7KYK / i7-6770HQ 2,6-3,5Ghz 45W TDP / Iris Pro 580 HDMI 2.0 / 2x8GB DDR4 2133 SODIMM / 64Mb Flash EEPROM, WLAN AC8260, Bluetooth 4.2, IR, NFC, SDXC mit UHS-I, 4x USB 3.0, Thunderbolt 3


    Xpenology: ASRock Celeron J4105-ITX, 32GB RAM, 4TB IronWulf, 4TB WD Red, 120GB Adata SSD Jun's Loader 1.03a2 ds918+ 6.2

  • 500GB ist das Limit bei Enterprise Nutzung heißt man verwendet ISCSI LUNS usw. ich würde mal sagen, dass dies nicht der Fall bei dir ist. Was für Netzwerkkarte bzw. Karten benutzt du denn ? Wie ist das Netzwerk konfiguriert ? Jumbo Packages ?

    Was hast du denn für Hardware verwendet für dein XPenology ? Ich hatte früher das Problem auch schon jetzt nach Umstellungen am Router und auch der Verwendung von mehreren Netzwerkports bzw. derzeit nur 10Gbit hab ich es nicht mehr. Wichtig sind auch die verwendeten Festplatten :)


    :groesten:

  • ISCSI und LUNS hab ich in der GUI zwar mal getroffen aber kA was des ist.

    Ich hab einmal WLAN von Z77x-UD5H drin https://www.gigabyte.com/Mothe…-Z77X-UD5H-WB-WIFI-rev-10

    Funktioniert aber mit Synology nicht, hatte davor OMV drauf.

    Nutze LAN vom https://www.asrock.com/MB/Intel/J4105-ITX/index.asp mit Netgear GS105 v4

    Was Jumbo Package ist, kA.

    WD Red 4 TB und Iron Wulf 4TB sind neu, Adata 120GB SSD (schon älter, SMART meckert). 2 verschiedene deshalb, damit ich ein Vergleich hab, WD ist leiser.

    Fritzbox ist 7240, ist am Netgear angeschlossen.

    DSM hab ich 918+ gewählt weil ich gelesen hatte dass es damit läuft, andere hab ich noch nicht getestet.


    Ich hätt gerne Rockstor drauf, läuft aber mit UEFI nicht und das Board hat nix anderes.

    Gigabyte Z77X-UD5H Rev.1.0 - Ozmosis F16j 167X/ i7 3770K / 16GB 1600 MHz DDR3 Corsair Vengance / OS X 10.10.5 / GeForce GTX 580 3072 MB
    Intel® NUC Kit NUC6i7KYK / i7-6770HQ 2,6-3,5Ghz 45W TDP / Iris Pro 580 HDMI 2.0 / 2x8GB DDR4 2133 SODIMM / 64Mb Flash EEPROM, WLAN AC8260, Bluetooth 4.2, IR, NFC, SDXC mit UHS-I, 4x USB 3.0, Thunderbolt 3


    Xpenology: ASRock Celeron J4105-ITX, 32GB RAM, 4TB IronWulf, 4TB WD Red, 120GB Adata SSD Jun's Loader 1.03a2 ds918+ 6.2

    Einmal editiert, zuletzt von Skorpi08 ()

  • Lass uns heute Abend mal schauen, ich melde mich bei dir. Xpenology ist schon was sehr geiles, man muss am Anfang bissle was beachten bzw. verändern dann laufen sie aber super.


    :groesten:

  • Bei mir läuft das Teil aktuell mit DSM 6.2 im aktuellen Stand der Software.

    Ohne Probleme, ohne Murren.

    Ebenso gut wie die originale Diskstation.


    Ist aber auch mit der Installation einfach, bei guter Vorbereitung.

  • Was muss man da vorbereiten?

    Loader downloaden, aufm USB Stick installieren.

    USB Stick ins NAS, vom Stick starten.

    Von Synology das pat File laden, im Browser bei der installation das File auswählen und das wars.

    Gigabyte Z77X-UD5H Rev.1.0 - Ozmosis F16j 167X/ i7 3770K / 16GB 1600 MHz DDR3 Corsair Vengance / OS X 10.10.5 / GeForce GTX 580 3072 MB
    Intel® NUC Kit NUC6i7KYK / i7-6770HQ 2,6-3,5Ghz 45W TDP / Iris Pro 580 HDMI 2.0 / 2x8GB DDR4 2133 SODIMM / 64Mb Flash EEPROM, WLAN AC8260, Bluetooth 4.2, IR, NFC, SDXC mit UHS-I, 4x USB 3.0, Thunderbolt 3


    Xpenology: ASRock Celeron J4105-ITX, 32GB RAM, 4TB IronWulf, 4TB WD Red, 120GB Adata SSD Jun's Loader 1.03a2 ds918+ 6.2

  • Anpassung VID / PID und das setzen einer Seriennummer sollte auch erledigt werden.

    Kann man aber bequem direkt in Grub erledigen.

  • Hab ich nichts von gemacht, lief so an.

    Ich kann den Loader aber auch garnicht mounten und den Stick zeigt der mir im Mac nicht an, kann da also nix verändern.


    Der Kollege hier, sagt dass 32GB doch funktionieren:

    https://xpenology.com/forum/to…ab=comments#comment-91762

    Was ich nur nicht verstehe, alle sagen bis 2.4 oder 2.5Ghz läuft das Board, wie kann ich es denn übertakten?

    Überall, bei allen Systemen die ich drauf hatte, steht dass es nur 1.5Ghz hat, im Bios auch nur 1.5Ghz.

    Gigabyte Z77X-UD5H Rev.1.0 - Ozmosis F16j 167X/ i7 3770K / 16GB 1600 MHz DDR3 Corsair Vengance / OS X 10.10.5 / GeForce GTX 580 3072 MB
    Intel® NUC Kit NUC6i7KYK / i7-6770HQ 2,6-3,5Ghz 45W TDP / Iris Pro 580 HDMI 2.0 / 2x8GB DDR4 2133 SODIMM / 64Mb Flash EEPROM, WLAN AC8260, Bluetooth 4.2, IR, NFC, SDXC mit UHS-I, 4x USB 3.0, Thunderbolt 3


    Xpenology: ASRock Celeron J4105-ITX, 32GB RAM, 4TB IronWulf, 4TB WD Red, 120GB Adata SSD Jun's Loader 1.03a2 ds918+ 6.2

    3 Mal editiert, zuletzt von Skorpi08 ()

  • Posten kann ich auch viel, also die Synology Firmware unterstützt offiziell 8GB Ram, alles drüber hat keinen Support. Wofür benötigst du denn 32GB in einer NAS ?


    :groesten:

  • Asrock sagt: Max. capacity of system memory: 8GB

    Hatte aber gelesen dass die auch mehr können, wollt ich halt testen und nun hab ichs.

    Auch hatte ich gelesen, RAM kann man bei NAS gut gebrauchen, also besser mehr als weniger.

    Bekomme das .img File immer noch nicht geöffnet.

    http://blog.pztop.com/2017/07/…2b-for-DSM-6.1-on-Ubuntu/

    Gigabyte Z77X-UD5H Rev.1.0 - Ozmosis F16j 167X/ i7 3770K / 16GB 1600 MHz DDR3 Corsair Vengance / OS X 10.10.5 / GeForce GTX 580 3072 MB
    Intel® NUC Kit NUC6i7KYK / i7-6770HQ 2,6-3,5Ghz 45W TDP / Iris Pro 580 HDMI 2.0 / 2x8GB DDR4 2133 SODIMM / 64Mb Flash EEPROM, WLAN AC8260, Bluetooth 4.2, IR, NFC, SDXC mit UHS-I, 4x USB 3.0, Thunderbolt 3


    Xpenology: ASRock Celeron J4105-ITX, 32GB RAM, 4TB IronWulf, 4TB WD Red, 120GB Adata SSD Jun's Loader 1.03a2 ds918+ 6.2

    Einmal editiert, zuletzt von Skorpi08 ()

  • Ich rede hier nicht von deinem Mainboard Möglichkeiten sondern das was Xpenology bzw Synology unterstützt. Für was das Image File öffnen ? Und bei einer NAS bzw. der Performance kommt es auf CPU und Festplatten an und nicht ob du 32GB Ram hast oder was meinst du warum die Original Synology Boxen mit 2-4 GB Ram so gut laufen ? Ich hätte an deiner Stelle eher auf eine andere CPU gebaut...


    :groesten:

  • Ich mein damit, Asrock sagt es werden nur 8GB unterstützt, ich hab aber 32GB.

    Synology sagt 8GB, ich hab ebenfals 32GB, zumindest angezeigt.

    Meiner würde mit 4GB genauso laufen, nur mit 32GB läufts besser ;)

    Viele schreiben auch dass es zu wenig RAM ist, für VMs.

    Wie kann ich dass denn testen ob die 32GB angenommen werden?

    img öffnen um das .cfg zu bearbeiten.

    Ich hab die beiden anderen (3617 und 3615) getestet, damit wird die NAS nicht gefunden.

    Gigabyte Z77X-UD5H Rev.1.0 - Ozmosis F16j 167X/ i7 3770K / 16GB 1600 MHz DDR3 Corsair Vengance / OS X 10.10.5 / GeForce GTX 580 3072 MB
    Intel® NUC Kit NUC6i7KYK / i7-6770HQ 2,6-3,5Ghz 45W TDP / Iris Pro 580 HDMI 2.0 / 2x8GB DDR4 2133 SODIMM / 64Mb Flash EEPROM, WLAN AC8260, Bluetooth 4.2, IR, NFC, SDXC mit UHS-I, 4x USB 3.0, Thunderbolt 3


    Xpenology: ASRock Celeron J4105-ITX, 32GB RAM, 4TB IronWulf, 4TB WD Red, 120GB Adata SSD Jun's Loader 1.03a2 ds918+ 6.2

  • Und damit sind wir jetzt an dem Punkt den dir umax1980 oben geschrieben hat, Anpassen von VID/PID und Seriennummer.

    Du willst aber jetzt nicht wirklich mit der von dir ausgewählten Hardware VMs auf die Diskstation packen oder ? Schau dir mal wenn schon viel von IDomix zum Thema anschaust, das Video zur Virtualisierung an. Die CPU Last ist mit einer VM schon ordentlich und dann wirst du Einschnitte mit der DSM Umgebung haben.


    Und wie man die VID/PID und Seriennummer bearbeitest, findest du beim Entwickler des Bootloaders. Hier gibt es dann auch einen Seriennummern Generator usw.


    Du solltest vielleicht mal sagen was du vor hast, denn kann man dir auch besser helfen oder dir Infos geben ob das klappen wird. Bei mir läuft Xpenology auf einem Dell R430 Server, damit das mit dem Virtualisieren überhaupt Sinn macht.


    :groesten:

  • Apropos Xpenology ... Auf welcher Version seid ihr aktuell, mit welcher Hardware und welchem Loader

    Zum Verkauf geplant -> Board: GA-Z97X-UD5H-BK / CPU: i7-4790K / Grafikkarte: R280X / RAM: 16GB DDR3
    CNC Maschine (Apple Power Mac G5): Board: GA-Z77N-WiFi / CPU: i5-3570K / R280X / RAM: 16GB DDR3


    Rechtschreibung, Grammatik, Satzzeichen, Textformatierung und manchmal auch ein Komma führen zu einer besseren Verständlichkeit ;) :D

  • Juns Loader 1.03b, DSM 6.2 und Hardware

    Dell R430 6 Kern Xeon, 32GB RAM, 8 x 4 TB HDDs und 2 x 120GB SSDs

    und PC System für Backups mit Intel I3 8100, 8GB RAM, 6x 8TB, 2x 120GB SSDs


    :groesten: