Lenovo ThinkPad W540 - diverse Fragen

  • die steckt in meinem efi-ordner (dem 2. glaube ich) /EFI/Clover/ACPI/patched.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • grt Im Anhang die EFI, funktioniert leider noch nicht, habe ich etwas falsch eingetragen, oder vergessen?

    Files

    • EFI.zip

      (13.66 MB, downloaded 6 times, last: )
  • 5T33Z0 Booten kann ich nur, wird halt 0% angezeigt, wie ohne patch

  • da kommst du selbst drauf... lies doch mal meinen beitrag #175 genau durch... ;-)

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • grt Habe jetzt den ACPIBatteryManagement kext entfernt, geht allerdings immer noch nicht

    Files

    • EFI.zip

      (13.59 MB, downloaded 6 times, last: )
  • gib doch mal im terminal ein:


    log show --predicate "processID == 0" --start $(date "+%Y-%m-%d") --debug | grep "ACPI"


    und hab ein augenmerk auf zeilen mit SSDT und insbesondere stichworte wie "acpi error" "W540" und "batt". verdächtige zeilen bitte screenshotten.

    die efi ist ein wenig vermurgelt, da könnte es einige fehlerquellen geben...


    ausserdem starte das programm "maciasl" ruf die "System dsdt" auf, und guck nach, ob die renames greifen: edit -> find und dort mal (nacheinander) nach XBIF XBST XWAK und XL1D suchen, wenn die nicht auftauchen, dann such nach GBIF GBST _WAK und _L1D. davon screenshots bitte.


    EDITH: und im verbose boot guck nach zeilen, die was über GBST, GBIF und errors erzählen.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • das sind die versuche, den batteriestand auszulesen.


    ich hab 3 neustarts in der letzten halben stunde gefunden, das ist der 3. von 10.24 uhr (*muskelkater-im-scrollfinger-hab* ;-) )


    die beiden anderen sehen so gut wie identisch aus. da werden 2 SSDT's geladen, die eigentlich gar nicht mehr da sind, zumindest in dem ordner, den du hochgeladen hast, gibts die nicht. von der batterypatch-ssdt ist weit und breit nix zu sehen, weder erfolgreiches laden, noch errors, die sich auf probleme mit der ssdt-w540-bat beziehen.

    dafür gibts aber einen error bzgl. _SB.PCI0.GFX0. dieser pfad ist definitiv nicht in deiner dsdt oder in einer der originalen ssdts vorhanden, dort "heissen" die grafikkarten _SB.PCI0._VID und _SB.PCI0.PEG._VID.

    deswegen ist übrigens auch der rename GFX0 -> IGPU in der config unsinnig. GFX0 gibts nicht, und kann auch nicht umbenannt werden. der error stammt aus der SSDT-PNLF.aml. wenn du die einsetzt, solltest du den pfad der grafik dort (_SB.PCI0.GFX0) an den richtigen aus deiner DSDT anpassen (_SB.PCI0.VID). und haken pnlf in der config und auch noch die ssdt-pnlf ist doppelt gemoppelt. eins davon reicht aus.

    aber zurück zum akku...

    mir scheint, du bootest mit einer falschen efi.. guck doch mal nach wovon du tatsächlich startest.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • grt Also eigentlich kann er nur davon starten, usb und so weiter sind nämlich ab, und unter windows ist auch nur der EFI Ordner, hast du eine Idee, wie ich es hinkriege, das der Patch mit geladen wird? Kann es sein, das die DSDT im falschen Ordner liegt, liegt momentan in Origin? Hier nochmal die EFI.zip

  • der kollege lädt eine ssdt, die nicht in dem ordner steckt, den du hochgeladen hast, und er meldet weder, dass er die batteriepatch-ssdt erfolgreich geladen hat, noch, dass er mit ihr ein problem hatte. wenn du mit einer efi startest, in der die ssdt am richtigen platz liegt (ist richtig in dem hochgeladenen ordner), gäbe es im log hinweise darauf.

    und ssdts, die nicht da sind, können auch nicht geladen werden, und würden demzufolge auch nicht im log auftauchen. tun sie aber. ergo...


    EDITH: in dem ordner, den du hochgeladen hattest, als den, der funktioniert ist die ssdt am richtigen platz, nur die beiden batterymanager beissen sich. bitte erzähl uns zukünftig alle details, die du veränderst.. so stochern wir wirklich total unnötig mit der stange im von dir verursachten nebel.

    und lies dir dringend noch mal die grundlagen der häckintosherei in der wiki und in g-forces beginners guide durch. dann passieren solche blöden fehler, wie zu ladende ssdts im origin-ordner auch nicht mehr. wo notwendige dateien hin müssen, solltest du einfach mal wissen.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • grt Tut mir Leid. Also ich hatte eigentlich den ACPI Battery Manager entfernt. Habe doch meine Efi hochgeladen. Vor deinem Beitrag, und da ist kein ACPI Battery Management kext

  • ja, den schon. das war auch richtig. aber irgendwas ist mit der aktuell genutzten efi seltsam, und dem sollten wir jetzt erstmal auf den grund gehen.

    erzähl einfach mal, wie der rechner aufgesetzt ist:

    - wieviele und welche festplatten hast du verbaut?

    - wie sind die festplatte(n), konfiguriert - welche partitionen, was ist auf welcher partition drauf? wo ist die efi, gibts bei 2 platten mehrere efis?

    - und im dock steckt der läppi auch die ganze zeit definitiv nicht?

    schreib das mal ganz genau auf, und mach einen screenshot von der terminalausgabe diskutil list.

    und nebenbei: am sinnvollsten ist es echt, wenn man die ganzen basteleien mit "efi hier, efi da, kexte und ssdts rein und wieder raus, haken ja oder besser doch nicht... ", mit einem usbstick macht. auf der platte eine efi, mit der der rechner definitiv starten kann (zur sicherheit), die bastel-efi auf den stick, und zum testen vom stick starten.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • menno.... was soll denn das jetzt?

    du bootest mit einer efi, in der die ssdt nicht drin ist. das solltest du als erstes mal lösen. ob der batterypatch funktioniert, oder nicht, kriegt man erst dann raus, wenn die ssdt geladen wurde, oder aber im log entsprechende errors zu finden sind, anhand derer man die evtl. vorhandenen fehler beheben kann.. das setzt aber voraus, dass du/wir an einem roten faden dran bleiben, und zusammenarbeiten, indem z.b. fragen (umfassend) beantwortet werden.

    den vortrag kenne ich übrigens, da sass ich nämlich im publikum.. wie man einen batterypatch baut, kam nicht drin vor, und es geht auch nicht um ssdts, sondern um komplette dsdts, was eine inzwischen nicht mehr empfohlene methode ist (trotzdem ist der vortrag spannend und informativ, guck ihn dir ruhig mal an)

    und wenn du meine hilfestellung nicht haben willst, dann sag das bitte, und ich verschwende meine zeit dann anderweitig.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • grt Ok, es geht jetzt, mit deiner SSDT, das Problem war, ich habe in Clover nicht eingetragen, das er die mitlesen muss.:danke: Habe noch das Problem, das Sleep nicht geht, also wenn ich den Laptop zu Klappe schlägt er, und wenn ich weiter arbeiten möchte, startet er neu und sagt, das es eine Kernel Panic gegeben hat

  • prima. dann ist ja jetzt das "erledigt" label zu recht am thread dran...

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • maxt2007 Hast du USB schon gepatcht?

  • Okay, hast du Hackintool schon heruntergeladen?