Posts by gene-x

    Ich musste seit 14.3 für 14.4/14.4.1/14.5:


    SecureBoot im Bios aus

    SecureBootModel in der OC Config auf Disabled setzen

    WLAN Kexte und BT Kexte disable


    Dann das Update machen.


    Ansonsten hatte ich einen Boot loop...


    Wenn das Fertig ist wieder alles enablen aber auch die Kette aktuell halten.

    Für deine Grafik Karte ist MacPro7,1 optimal aber beim Booten musst du zwingend die -V Option rausnehmen sonst bleibt der Bildschirm Schwarz, du brauchst kein whatevergreen.kext und das Bild kommt erst wenn nachdem ersten Drittel vom Fortschrittsbalken der Sichtbar ist die 2 folgenden Drittel durch sind und der Anmeldeschirm wird dann wieder angezeigt.


    Das Problem hast du nicht bei Verwendung des SMBIOS iMacPro1,1 es läuft aber sehr gut mit MacPro7,1.


    Zudem währe es noch von Vorteil zu wissen welche Grafikkarte genau es ist und welches MacOS du nutzt.


    Im Systembericht müsste auch die Metal Version stehen so sieht das seltsam aus wie bei dir:


    AMD Radeon RX 6600:


    Chipsatz-Modell: AMD Radeon RX 6600

    Typ: GPU

    Bus: PCIe

    PCIe-Lane-Breite: x16

    VRAM (gesamt): 8 GB

    Hersteller: AMD (0x1002)

    Geräte-ID: 0x73ff

    Versions-ID: 0x00c7

    ROM-Version: 115-D534P00-100

    Metal-Unterstützung: Metal 3

    Displays:

    DELL S2722DC:

    Auflösung: 2560 x 1440 (QHD/WQHD - Wide Quad High Definition)

    UI sieht aus wie: 2560 x 1440 @ 165.00Hz

    Framepuffertiefe: 30-Bit Farbe (ARGB2101010)

    Display-Seriennummer:

    Hauptdisplay: Ja

    Synchronisierung: Aus

    Eingeschaltet: Ja

    Rotation: Unterstützt


    SIP deaktivieren und mehr nicht...


    Ich finde die Argumentation "nutze ich nicht weil muss man die SIP für deaktivieren" am Hackintosh einigermaßen amüsant. Auf der einen Seite schleust man mit OpenCore oder Clover schon im Startprozess einen ganzen Haufen von Dingen an der SIP vorbei ins System auf der anderen Seite hat man Bedenken dabei die SIP zu deaktivieren. Wer seinen Rechner einigermaßen bedacht verwendet und nicht jedesmal einfach sein Passwort eingibt wenn er von irgendeinem Prozess dazu aufgefordert wird der kommt gut und gerne ohne den Schutz der SIP aus. Die SIP bringt einen zusätzlichen Layer Sicherheit indem sie verhindert das Systemdateien verändert werden selbst dann wenn das Root Passwort eingegeben wurde allerdings erreicht man meiner Meinung nach den selben Effekt indem man seinen Computer achtsam verwendet. Naja am langen Ende muss das jeder für sich selbst entscheiden ich finde das Risiko mehr als überschaubar insbesondere Vergleich mit dem Gewinn an Komfort den ich bekomme weil ich Features wie Airdrop, Universal Remote, Cotinuity usw. einfach nutzen kann.

    Am Anfang der Entwicklung musste noch so einiges mehr an Mechanismen ausgehebelt werden (AMFI get out of my way) damit das läuft und das hat dann auch zu diversen Problemen geführt die ich jedenfalls nicht haben wollte und mit der IntelKarte nicht habe.


    Da ich die von dir zitierten Apple Dienste alle nicht nutze bzw. nur an meinem MBA M2 habe ich auch keine Probleme damit.


    Wenn es nur SIP gewesen währe... aber es läuft sehr geschmeidig mit der IntelAX210 und dem Airportitlwmt.kext. Ich nutze weiter den BCM USB BT Stick.


    Continuity Camera funktioniert am USB Kabel ohne Probleme sowie auch Wlan im Installer oder vor dem Login für die Bildschirmfreigabe oder FileSharing.


    Sleep und Wake funktioniert zu 100% bei mir nach 3 Minuten und auch nach dem xten Mahl.


    Mann kann das Thema natürlich auch so betrachten:

    https://www.naut.ca/blog/2020/…mmands-to-liberate-macos/


    Dabei habe ich noch etwas gefunden das eventuelle Probleme bei deaktivierten AMFI beheben kann:


    Step 4: Disable Apple Mobile File Integrity. AMFI is the macOS kernel module that enforces the code-signing validation from Step 1 and the library validation from Step 2. However, even after disabling the services above, AMFI is still checking the signatures of every app that is run, and will cause non-Apple apps to crash when they touch extra-sensitive areas of the system.

    Code
    1. # While still in Recovery Mode
    2. nvram boot-args="amfi_get_out_of_my_way=1"
    3. # Additional parameter below fixes Electron app crashes
    4. nvram boot-args="ipc_control_port_options=0 amfi_get_out_of_my_way=1"

    Step 5: Reboot & Enjoy Liberty. No explanation required.

    Caveats:

    • If GateKeeper is enabled while AMFI is disabled, some apps will hang while opening.
    • If AMFI is disabled, prompts to allow apps access to the camera, microphone, accessibility etc. will not be shown. The tccplus utility, found here, alleviates this (there is a GUI script in the repo).

    Okay, ich bin nun endlich auch auf 14.5 RC. Allerdings musste ich dazu BlueToolFixup.kext deaktivieren...

    Vielleicht sollte ich den BT Dongle wieder abstecken, die Fenvi wieder einbauen und mich mal mit OCLP beschäftigen...

    Bist du sicher das nach Aktualisierung das wieder aktivieren nicht funktioniert ?

    Ich hatte das auch ab 14.3 und 14.4 zusätzlich noch SecureBootModel musste ich deaktivieren und den BT kext und Wlan Airport habe ich für das Update deaktiviert und danach wieder aktiviert ohne Probleme.


    Allerdings habe ich AX210 WLAN und BCM2072 USB BT Stick.


    Das lässt mich zögern den Hacky auf 14.5 Upzudaten...war fast auf dem weg dazu...


    Wobei egal geht auch ohne BT...und wird bestimmt wieder...


    Also habe SecureBootModel auf disabled SecureBoot im Bios deaktiviert BT Fixup deaktiviert und Airportwlm auch mal sehen läuft jetzt...


    noch ungefähr 4 Minuten zeigt mir jetzt via Bildschirmfreigabe an...(en0 Kabel)



    Next step aktivieren von BT und WLAn und SecureBootModel


    Nach erneutem Blessen im Terminal der Recovery läuft problemlos BT und Wlan mit den beiden kexten ...


    Problemloses Update so far.



    hda-gfx bei Audio ?


    https://dortania.github.io/Ope…ml#finding-your-layout-id


    VoodooHDA schon mal probiert anstelle von AppleALC ?


    AppleALC not working from Windows reboot

    If you find that rebooting from Windows into macOS breaks audio, we recommend either adding alctcsel=1 to boot-args or add this property to your audio device in DeviceProperties:

    Code
    1. DeviceProperties
    2. | --- > Add | --- > PciRoot(0x32)/Pci(0x0,0x0)/Pci(0x0,0x0)(Adjust to your device) | ----> alctcsel | Data | 01000000



    Hast du noch ein Windows drauf und mal im Geräte Manager die Energie Einstellungen überprüft ?


    Ich gehe mal davon aus das du diverse Layout Optionen durch probiert hast ?


    ConexantCX8400layout 12, 1313 (10.9)



    Unter Windows ist das auch so ? (Hardware-Mechanisch wegen Kopfhörer Einstecken ? Da ist ein Switch drin...)


    Wie bitte stellst du um auf Kopfhörer ? Das müsste automatisch gehen....


    Schaltet oben in der Leiste auch von Lautsprecher auf Kopfhörer Symbol ?


    Systemeinstellungen->Kontrollzentrum->



    Ich hatte mal ein seltsames Problem das mir eine APP um die Helligkeit an einem normalen Monitor zu regeln automatisch nach einem MacOS Update das Display abgedunkelt hat und biss ich das rausgefunden hatte... dann habe ich mit Taschenlampe die App beendet und dann runtergeschmissen danach war alles gut...


    Oder du installierst die mal EQMac... da kannst du dann evtl. sehen ob auch die Lautstärke geregelt wurde, im besten falle das Problem beheben...


    Es gibt aber auch Probleme die genau so sind unter Windows:

    https://h30434.www3.hp.com/t5/…akers/td-p/5723180/page/3

    Mieze


    Da habe ich auch schon dran gedacht, aber hier ist noch kram vom Nachbarn an den das passt und wo der so günstig ist dachte ich mir kann nix schaden.....


    So ähnlich war das auch mit der PCIE AX210 die ich günstig geschossen habe und die jetzt schon länger im Dienst ist wegen der Broadcom WLAN Problematik seit Sonoma.


    Meine Hausverkabelung ist sehr Hochwertig also sollte das Reichen vom DG Büro bis zum Switch in den Keller aber Glasfaser kommt irgendwann evtl. mal rein wenn ich es brauche.


    Meinen Energie Verbrauch habe ich obwohl mich der Versorger schon besucht hat weil ich angeblich zu wenig Strom verbrauche noch einmal um 25% senken können durch Messungen und Optimierungen im Jahr 2022.


    Ich habe mich noch nicht an Glasfaser Technik und die Tools die ich Brauche rangemacht da alles in der Cloud ist und ich so sehr gut klarkomme.


    Besten Dank für die Info und das wird sicher mir und auch allen anderen hier gut als Referenz dienen können :-)


    Erfolg auch mit meinem geliebten HP 8300 im 4 Fach PCIE Slot direkt neben der Grafik Karte.


    10 Gbit/sec muss ich noch probieren aber hat auf anhieb funktioniert mit dem betagtem BigSur und OC091.


    Einen Port habe ich deaktiviert wegen Stromverbrauch mit dem Jumper...


    Allerdings will der gerade nicht schlafen und das stört erheblich...

    Das muss ich noch eruieren denn ohne Sleep ist die für mich unbrauchbar....


    Er schläft, zeigt nur trotzdem in der Seitenleiste vom Mac weiter an, wecken lässt er sich dadurch zwar nicht, aber dafür habe ich ja miniWOL oder den Router.


    Ob der sich auch über die 10Gbit ohne die interne wecken lässt muss ich noch sehen, aber die Blinklichter an der Netzwerk Schnittstelle sehen Positiv aus.


    -<leider kein WOL möglich bis jetzt, ich habe zwar AMT nicht aktiviert und das Bios gibt nix her um PCIE Ereignisse zum Wecken einzustellen aber über die Interne läuft das wecken und es gibt ja Link Aggregation.>-



    -----

    WOL muss ich noch checken. Das ist unter anderem so gut an den alten Kisten, wenn der schläft (0,7W) dann kann ich den immer Wecken und der läuft.


    Ob nun von Windows / Mac / Linux aus ist der im Netz sofort da und kann eben lässig via Bildschirmfreigabe administriert werden.


    Ein Minecraft Server mit NordVPN Private Mesh läuft auch darüber dann brauche ich keine DMZ.


    Richtig Sinn macht das als NAS weil der HP8300 so schön schläft, fraglich was aus PCIE an Datenrate so raus zu quetschen ist für NVME und zusammen mit 10Gbit/sec oder x2 da gehen da eh Max 2000MB/sec. das währe schon viel und die unkaputtbaren HP8300 gibt es geschenkt zusammen mit so einer Karte für 17 Taler und Unraid ist das evtl. eine Option. Vor allem der SFF.

    ------

    Also nichts aussergewöhnliches, ausser das ich noch nicht wüsste welche Basis ich zur Generierung des CPUfriendDataProvider.kext hernehmen sollte.

    Aktuell habe ich auch MacPro7,1 mit CPUfriendDataProvider.kext auf Basis iMac20,2.


    Füher mussten wir immer eine Spezielle SSDT für die CPU mit einem Script generieren, bei meiner Laptop CPU musste ich das mit manuell eingetragenen Werten machen.....


    Gigabyte Z690 DDR4 Gaming X


    Gut Dokumentiert, ich mag aber keine Gigabyte Boards....

    Mal sehen hat noch Zeit....


    Besten Dank soweit :-)

    So ähnliches hatte ich auch damals :-) inkl. dem modifiziertem Juno 6 mit Midi original TB-303 eine Quasimidi 309 Vollausbau mit der ich auch Live oder während eines DJ Set sowie am Ende (MBP Late 2008 und KDJ-500) so einiges angestellt habe... manchmal bis 8:00 Uhr Morgens Solo nonstop da brauchst echt ein gutes Gedächtnis weil so einiges nicht speicherbar war....aber die Kiste hatte einen brachialen Sound...dagegen klangen die späteren Neu auflagen der TB-303 von Roland wie aus der Waschmaschine oder hinter einem Vorhang...


    [External Media: https://youtu.be/gNgk6z4cRYQ]


    Den Juno Chip / Mod musste ich für einige umsetzen :-)

    Jetzt gibt es da anscheinend so einige aber damals ging nur Hardcore Löten... ich glaube auch da musste noch ne Firmware aufgespielt werden aber keine Ahnung wie das war, ich so viel gebaut da verliert man den Überblick...


    P.S.: bei der Asrock Thunderbolt 4 AIC sind ja zumindest die DP Patchkabel etc. dabei also sollte alles laufen nach ROM Edit.....


    Some real examples of Fixed 9-Byte Values:


    • 01 58 00 01 00 10 00 01 00 Mac Pro 7,1
    • 01 58 00 01 00 0d 00 01 00 iMac 19,1
    • 01 58 00 01 00 0d 00 01 00 MacBook Pro 15,2
    • 01 5e 00 01 00 0C 00 01 00 iMac 18,3


    • Yellow = Fixed/Pre-Defined 9 bytes for each Mac Model

    KungfuMarek


    Das "wie" ist kein Problem für mich ob Flaschen Rom Editieren etc... ich komme noch aus der pre Dos Zeit damals gab es noch keinen bunten Desktop und ich habe vor den Dosen angefangen (Apricot) und die ersten Macs für DTP und SG Irix AU/X für Special Effects - Kino Film genutzt...


    Also wenn ich für teures Geld Apple 5K Displays oder und auch Audio Hardware im Wechsel mit mehreren Geräten inkl. einem Hackintosh nutzen würde evtl. oder weil ich aus welchen Gründen auch immer bessere Latenzen erreiche oder einfach weil´s Spaß macht, dann würde ich mir eine TB Karte in einen Hackintosh Desktop einbauen.


    Mein Board würde es unterstützen aber ich brauche es nicht.


    Wobei ich hatte so Latenzen von 1,5ms mit PCI Karte und Breakout vor sehr langer Zeit.........3ms war die FailProof Einstellung... Da konnten wir aber auch noch nicht alles auf dem Rechner emulieren lassen und mussten uns mit einem Axe-FX Ultra oder einer selbstgebauten reactive Load und den ersten IR Loadern begnügen.


    Danke für alle Antworten :-)



    KungfuMarek Coole Katze... Ich sehe du hast einen 14th gen auf Z690er Board...wie geht denn das mit den unterschiedlichen Kernen, alle aktiv ?


    OK Spezialanwendung aber im Bereich Audio ... da war auch ordentliche USB-2 schon kein Problem was Latenz angeht und Bandbreite bei 192khz 24bit reichte bei USB2 auch schon für 52+ Streams vor 10 Jahren da sollte das doch jetzt wirklich kein Ding sein mit USB 4 usw.


    Ich habe da eher an anderen schrauben gedreht vor allem ASIO und Buffer und Prioritäten von Prozessen - CPU Speed usw.


    Ist aber auch schon was her das ich ein Studio hatte und das meiste war Analog.


    Es gibt auch stimmen gegen TB Latenz bezogen:


    Die meisten Probleme Tauchen doch auf bei kombinieren von USB4 - PCIE 32 fach TB und DP Signalen würde ich mal schätzen, TB USB PD für Laptop braucht ja eigentlich keiner um den Laptop an den Desktop anzuschliessen.


    Das habe ich am Monitor und da funktionieren meine Laptops die ja USB-C mit PD und DP haben respective TB3 beim MBA M2 beide gleichermaßen gut.


    Der USB Hub am Monitor funktioniert am Mac nicht so zuverlässig (TB3 MBA M2)

    Ich habe da mal ne Frage an die Titan Ridge oder besser Thunderbolt an Desktop Nutzer:


    Wofür ? Habt ihr alle ein Apple Studio Display ? Ultra Fine ?

    Der Samsung 5K ViewFinity S90PC LS27C902PAUXEN hat DP.


    Ich habe ein DP / USB auf USB-C Kabel für meinen Monitor. (nur bis 4K 60Hz aber das reicht für meine Anwendungen.

    NVME sind 3 mit PCIE 4 Schneller als an TB.


    Warum also TB Karten ?

    Ich habe mal drüber nachgedacht, mir sind aber keine nützlichen Einsätze eingefallen.


    Ausser dem den ich mit dem Kabel gelöst habe.

    Hätte ich nur einen Hacky Desktop mit dem ich unbedingt einen Monitor ansteuern will für den ich mir locker Apple Hardware mit einem TB Port kaufen könnte....


    An HDMI hatte ich mit dem Monitor keine Variable Frequenz und kein RGB

    Mit dem Kabel schon, da der Monitor nur HDMI und USB-C hat dachte ich mir ich teste das mal und es läuft.


    An meinem Laptop HP 440 G5 lief das überraschenderweise OOB als ich noch keinen USB-C Monitor hatte einfach als ich mal einen Monitor an USB-C angesteckt habe in meiner alten Firma. Die Gesichter waren lustig als da ein MacOS zu sehen war an einem HP Laptop via Usb-c angeschlossenem Monitor in 4K :-)

    Dann hat er seine alte EFI genutzt nach der Installation.

    Die ich hochgeladen habe waren auf 0.9.9 und alle kext aktuell.


    :pics:


    Btw. wie wäre es mal mit Daumen Hoch für die mühe ?

    Das ich das schon wieder jemanden erklären muss...


    Im übrigen bitte erstelle in Zukunft dafür bitte einen Thread und poste das nicht in den Sonoma BETA Thread...

    Michael1965


    dann bist du ja schon nah an deiner alten EFI und wie du berichtet hast musstest du nur die kexte aktivieren.....


    Allerdings habe ich auf Open Core 0.9.9 Updated und die Kexte.


    Must du evtl. mal NVRAM reset durchführen.....


    Ich bin übrigens Baujahr 1966 btw. :-)

    UEFI -> Output:

    • Resolution: set to Max for best results
      • Optionally can specify resolution: WxH@Bpp (e.g. 1920x1080@32) or WxH (e.g. 1920x1080)

    ist schon auf MAX also UISCALE:


    UEFI->OUTPUT->UISCALE->-1


    steht noch auf 0 ich habe zudem noch einen Wert im NVRAM:


    btw. für bt habe ich noch für Sonoma:


    Ist ja schon mal gut das die Installation durchgelaufen ist.


    Benutzt du Bluetooth ?

    Mit welcher EFI hast du installiert ?

    Bei der EFI-von-Michael1965-NewSN-v1 musst du die entsprechenden kexte aktivieren für BT aber evtl. vorher die Patche nach der Anleitung durchführen da bin ich nicht Pro.


    Evtl. ist ja auch eine Überlegung Wert das du eben beide Systeme laufen lassen willst....


    Wenn du die Fenvi nutzen möchtest musst du halt noch ein paar Meter gehen für Sonoma am besten mal die Anleitung durchgehen....

    Anleitung für Broadcom-WLAN-Patch unter macOS Sonoma