Posts by mitchde

    Nun, verunsichern wollte ich natürlich niemanden. Bei den anderen barefeats Tests - mag sein auch nicht für diesen FCP 4K Fall relevant, sah die Vega aber auch nicht besser aus als die RX 580. Klar, kanns unter FCP anders aussehen.

    Kann man mal, für alle transparent mit FCP nachtestbar, ein 4 K Demovideo (irgendwo FREI zum download, wie ein Trailer) nehmen und dann FCP RELEVANTE Tests machen wie sehr sich die GPU dann auf die Speed auswirkt?

    Klar ist, dass wahrscheinlich nur ein Export zeitlich messbar ist = SPEED. Schnitt und Vorschau "scrollen" wahrscheinlich nur "beschreibbar" wie sehr flüssig, leicht ruckelig, ruckelig... aber nicht messbar vermute ich.

    Bei DaVinci ist die RX 580 (eine) schneller wie die VEGA 56m die VEGA 64 wird max. gelich schnell sein.

    Mit zwei RX 580 hängst du bei der App eine VEGA 64 mit Sicherheit locker ab ;)

    PS: Mit SLI hat das bei OS X nix zu tun. Mehrere GPUs werden von OpenCL, METAL(compute) normalerweise automatisch fürs GPU computing genutzt. Alles was nicht GPU computing ist, wie Games (OpenGL, METAL) läuft NICHT schneller da es keine SLI Funktion bei OS X dafür gibt.



    davinci-looping-playback-with-3x-noise-reduction.png

    Du, sind denn nicht schon Vegas( etwas heruntergetaktet) in den neuen iMacs verbaut? Dann hätten die ja auch etwas zu viel Verbrauch im reinen Desktop (Idle) Modus bei OS X. Oder fällt das bei denen weniger stark auf, dass die Vega Treiber noch unvollständig sind bzw. hat Apple die Treiber bisher nur für genau deren AMD Vega Chip Art in Imacs bugfrei gemacht?

    Ach so. Wusste nicht, dass die Vegas IDLE zu viel Watt saugen. Meine AMD RX 460 ist davon wohl nicht betroffen... hoffe die RX 580 auch nicht, weil ich die mir im Herbst gebraucht kaufen werde.

    Die gemessene Leistunsgaufnahme in Watt bei Luxmark und Games - mit einfachem Messgerät zwischen Steckdose und PC - sind etwas zweifelhaft.

    Da bei anderen Test die Grafikkarte ALLEIN bei Hochlast deutlich mehr Watt braucht wie die Werte des gesamten PC Systems. (ganz unabhängig Win / OS X)


    Hier PCGames Hardware (xxx Watt = Verbrauch allein der Grafikkarte, nicht gesamter PC.

    MAn sieht, dass die VII sparsamer ist bei IDLE / wenig Last gegenüber den VEGAs, aber auch dass die TPD von 300 Watt (Grafikkarte allein!) bei einigen Games/Benches schon erreicht werden.



    Computerbase:

    Hier wurde auch Undervolting getestet - und hat gute Auswirkungen auf den Verbrauch - ohne die Speed zu senken.

    Nunja dann gehts den early birds halt selbst unter Win fast noch schlechter wie den Nvdia OS X Usern unter Mojave ... waaaarten auf bessere Karten, nicht nur auf die Treiber :)

    Thema Undervolting und Speed(Clockrate) bzw. Leistungsaufanhme( Hitze).


    Hier zwei aktuelle Bilder zu diesem Thema + neuer Radeon die auch Laien zeigen, wie sich das mit Stock GPU Volt und etwas unervolting verhält.

    Macht man das richtig = nur etwas undervolting und nicht massives uv, hat man sogar einen Speedgewinn sowie zugleich weniger Watt (Hitze).

    Hintergrund: Die GPU kann bei etwas weniger Volt (weniger Watt) länger oder gar Dauerhaft auf hohen/höchsten MHz laufen und muss seltener oft den GPU Takt redizieren = langsamer.


    Hier Leistungsaufnahme während einem Game mit Stock Volt vs etwas undercolting:

    AMD-Radeon-VII_ASIC-power-log_Anno-2070-4K-pcgh.png


    Man sieht schon die Einsparung zw. Stock und undervolting von ca. 30-50 Watt. Und 40 Watt weniger im Schnitt Wärme sind schon nicht wenig :) Trotzdem saugen die Highend GPUS , speziell AMD leider etwas viel Watts. Lässt man die Kirche im Dorf muss man trotzdem sagen dass zumindest Speed / Watt bei der neuen Pre Vega AMDs natürlich deutlich besser ist wie bei AMDs Baujahr 2015-2017.


    Hier diese Wirkung auf die GPU Speed (Mhz) Stock Volt vs leichtes undervolting:

    AMD-Radeon-VII_Sustained-clock-GPU-boost-log_Anno-2070-4K-pcgh.png


    Mit dem undervolting taktet die GPU fast durchgängig (beim game) sehr hoch durch und muss nicht andauernd auf 150 Mhz niedrigere Takt runterschalten. Paar % Speed also mehr sind drin. Und nebenbei spart man etwas Geld (Watt) und Hitzeentwicklung.


    ERGO: Leichtes GPU undervolting (ohne gleichzeitige GPU Clock Reduzierung) bringt etwas mehr Speed , nicht weniger Speed!!

    PS; Dieses Prinzip gilt natürlich für alle GPUS nicht nur die neue AMD. Auch bei meiner RX 460 im Prinzip gleich - wenn auch auf gaaanz anderen Watt Niveau, lach.

    In der Tat problematisch BIOS anderer Hersteller zu nehmen.

    Jedoch möglich, wenn man VORHER vergelich welches RAM (Hersteller) da verbaut wurde. Wenn gleich (gleiche GB Größe, max. Takt und RAM Hersteller) gehts durchaus.

    Passt das mit dem RAM aber nicht, stimmen die durchaus unterschiedlichen RAM Timing Werte nicht mehr und erstmal Briefbeschwerer. Viel weniger kritisch sind die leicht unterschiedlichen Timings (MHZ) für die GPU, das macht selten Probleme da viel weniger Unterschiede wie beim RAM.

    PS: Bei den BIOS Downloads steht immer mir dabei was da für RAMs (Gersteller und Timings) verbaut wurden.

    https://www.techpowerup.com/vgabios/

    PS2: Man muss das BIOS wirklich flashen! Das als Datei mit Clover als VBIOS zu nutzen bringt nix. Man kann damit max. Änderungen beim Kartennamen / Bios Version herbeiführen, die Settings der Karte jedoch nicht verändern.

    Bei solchen Dinge ist es stets wichtig, auch in der Realität zu prüfen - 2 GPUs spürbar schneller bzw. Last auf beiden GPUs - ob die 2 GPUs (oder in anderen Fällen HW Encoding) auch wirklich genutzt werden und nicht nur theoretisch...


    Bei barefeats sieht man das 2*RX 580 durchaus fast 2 fach schneller ist. (NVidias dort unter HS, AMDs unter Mojave). Die Vegas sind im Vergelich zur RX 580 eher schwach bei diesem Test ....

    davinci-looping-playback-with-3x-noise-reduction.png

    Da geht was beim prelinked kernel schief, was nix mit dem bootloader (egal ob Clover oder OZM!!!) zu tun hat.


    Damit wird der vorhandene prelinked lernel noch die alte Version drin haben, die natürlich nicht mit der neuen OS X Sicherheitsversion läuft.


    sudo kextcache -system-prelinked-kernel
    sudo kextcache -system-caches

    ....

    kxld[com.nvidia.NVDAStartupWeb]: The following symbols are unresolved for this kext:

    1. kxld[com.nvidia.NVDAStartupWeb]: ___strncpy_chk
    2. Link failed (error code 5).
    3. Prelink failed for com.nvidia.NVDAStartupWeb; omitting from prelinked kernel.

    Nee, wenn da nur 5 MB bei Display steht wird der Webdriver eben nicht richtig geladen.

    Wenn der Driver zur Build Nr passt und das Webdriver flag in Clover (NvidiaWeb=TRUE am Ende der .plist) gesetzt ist UND dein NVRAM richtig funktioniert (die NVRAM variable nvda_drv muss ungleich 0 sein!) , wovon ich ausgehe, wäre nun mal angesagt kernel cache / prelinked kernel zu erneuern.

    sudo kextcache -system-prelinked-kernel
    sudo kextcache -system-caches


    Dann reboot.

    Genau.

    Ganz weg ist die IGPU nur wenn du die im MB Bios deaktivierst.

    Wenn im MB Aktiv entweder (unter OS X) als "normal", mit connector= da gibt es Videoausgabe über die IGPU Ports UND die iGPU erscheint auch im Systembericht ODER connectorless = keinerlei Videoausgabe an den IGPU Ports(= Buchsen am MB für Video) UND iGPU erscheint auch nicht im Systembericht und dient NUR als Quicksync Device.

    Je nach CPU Typ gibt es verschiedene ig-platform-id für jeweils mehrere IDs für connector (auch mehere jenahcdem welche Videoausgänge genutzt werden sollen) und meist auch mind- 2 für connectorless.


    PS: Das Hacktool , https://www.insanelymac.com/fo…c/335018-hackintool-v177/ zeigt dir die möglichen IDs je nach CPU Typ an. Die Connectorless IDS haben bei allen Ports DUMMY als Portausgang. Sobald da was von DVI, HDMI etc steht is es eine ID mit connector.


    Hier BSP für meine IVY, die 07er ID hat lauter DUMMY als Port = connectorless, die andere LVDS, DP,,, connector . Das zweite Bild zeigt ID für connectorless = alles DUMMY...



    Wobei das Undervoltung / Takten über das Ändern PowerTab Werten nur bei den VEGA Treibern vorhanden ist. Meines Wissens gibts diese PowerTab Einträge (vomAMD Treiber) nicht bei RX 4xx/5xx AMD Treibern. Hier muss man das ganze (GPU / VRA; Volt, max. Takt ) am Kartenbios ändern und umflashen - VBIOS Nutzung (Clover) geht bei Undervolting/Taktenveränderungen nicht. Habe ich natürlich zuerst probiert. Erst das modifizierte BIOS (mit PolarisEditor, Win) statt VBIOS/ Clover richtig flashen brachte die Wirkung bei meiner RX 460.