Dell Optiplex 3040 Bootloader Wechsel

  • Hallo,


    mein Optiplex funktioniert hervorragend mit meiner Clover EFI. Nun würde ich mich gerne mit OpenCore beschäftigen um Vor- und Nachteile kennen zu lernen.

    Im Moment lädt meine OC Konfiguration bereits ganz gut, freezed aber an einer Stelle. Die Log.txt (262kb im Anhang) ist leer. Ich habe aber einen Screenshot gemacht, den ich anhänge. Bei ersten Recherchen konnte ich den Fehler auf der Internetseite von OC nicht finden. In einem Youtube Video von Technolli, sagte er, dass er OC nicht zum laufen gebracht hat. Ich denke aber, dass es gehen müsste, da es ein simpler Skylake Desktop PC ist.


    Ich würde mich über Hilfestellungen sehr freuen.


    Gruß

    Micha

    Images

    Files

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Moin,


    check mal deine BIOS Einstellungen bei EHCI/XHCI Hand-off. Sollte auf Enabled stehen. Das war zumindest bei mir das Problem und danach lief er dann sauber durch.

    Hast du es sonst mal mit der USBInjectAll.kext probiert? Dazu sollte aber deine USBPorts.kext raus.

    Meet me at 127.0.0.1

  • Hallo. Diesen Punkt gibt es in meinem Bios leider nicht.

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Ui, da ist schon mal ein fetter Bock in deinen Kexten, siehst Du das selber?


  • g-force der intelmausiethernet.kext und virtualsmc gehört da nicht rein. Muss wohl beim updaten und testen passiert sein. Normal nehme ich nur fakesmc.

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Richtig erkannt, FakeSMC und VirtualSMC nie zusammen. Entsprechend unter "Driver" kontrollieren. :top:

  • g-force ich habe die Fehler ausgemerzt und noch etwas nach besten Wissen und Gewissen zu optimieren. Der Bootvorgang schreitet voran, bleib aber bei "root" hängen. Ich habe die aktuelle EFI und ein Screenshot angehangen.

    Images

    Files

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Ob OC überhaupt mit FakeSMC funktioniert, bin ich nicht sicher. Da deine Hardware meiner recht ähnlich ist, schicke ich Dir meinen letzten OC-Versuch.


    EDIT: Du solltest aber mal diesen Thread von mir durchlesen: Clover zu OC - Migration von SMBIOS, Serial ?

  • g-force dein Ordner bootet mich direkt in mein Bios. Habe natürlich auch den EFI/Boot/ Ordner noch hinzugefügt.

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Mein OC-Ordner ist auch nur ein Anhaltspunkt für Dich, wie sowas aufgebaut sein könnte. Die Unterschiede sollten Dir klar ins Auge springen.

    Ich bin zu unerfahren in OC, um Dir eine fertige EFI zu bauen (ich kämpfe ja selber), aber diese EFI von mir funktioniert auf meiner Hardware, sollte Dir also eine brauchbare Grundlage sein.

  • @Michael1984


    Könntest du nach mal die Clover EFI hier hochladen , würde da gerne mal rein kucken ;)

  • OSX-Einsteiger anbei zwei Versionen meines EFI Ordners. Einmal virtualsmc basiert und einmal fakesmc basiert. Fake smc endet bei root und virtualsmc bei pci configuration ended


    g-force ich habe deinen Ordner natürlich nicht eins zu eins kopiert, falls das so rüber kam. Hat mir leider nur nicht weiter geholfen. Ich verstehe nicht, warum sich OC so schwer tut mit meiner Konfiguration. Clover läuft hervorragend.


    EDIT: Ich habe bei der virtualsmc Variante den Bootflag npci=0x3000 gesetzt, danach bootet weiter bis "Ethernet". Hier bleibt er wieder hängen. Foto anbei.


    EDIT2: Wenn ich den ethernet kext entferne, dann bleibt er bei rooting via boot-uuid from /choosen.... stecken. Foto anbei .

  • @Michael1984


    Teste mal die EFI , ich habe noch nicht alle Kext in der config eingetragen Zwangs Sicherheit .

  • OSX-Einsteiger Danke für deine Mühe. Er bleibt direkt am Anfang beim EXITBS:Start stecken. Also im Grunde beim memoryfix.

    Images

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Ich habe heute noch so einiges ausprobiert. Nichts hat geklappt. Ich bin mit meinem latein leider langsam am Ende.

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Habe es hinbekommen. Thread ist somit erledigt.

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Michael1984 Kannst Du bitte Deinen funktionierenden OC-Ordner posten? Würd mich interessieren :)

    Kleiner Geheimtipp zu "das" und "dass" ;) Kannst Du das umgangssprachliche "des" einsetzen? => "das" :) (sonst immer "dass")


    Systeme:


    AIO Desktop - i5-9500 CPU - iGPU - UHD630; aktuell das berüchtigte Framebuffer-Problem unter 10.15.5. Siehe auch hier.

    Fujitsu T904 - CPU: i5-4300U - iGPU: HD4400 - RAM: 8GB - SMBIOS: MacBookPro11,1; aktuell das "kein USB2.0"- und "Flackern bei vollen 2560x1440"-Problem

  • itisme habe ich bereits hochgeladen. Du findest das Archiv hier: EFI

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1

  • Habe es hinbekommen. Thread ist somit erledigt.

    Es wäre schön, wenn Du uns deine Lösung etwas näherbringst. Was hast Du geändert, damit es zum Erfolg führte?

  • Hallo. Ja kann ich gern machen. Folgende Dinge habe ich durchgeführt:


    - SSDT-PLUG.aml selbst kompiliert

    - SSDT-EC-USBX.aml mit Hackintool erstellt

    - die config.plist nochmal komplett neu erstellt

    - SMBIOS von iMac17,1 zu iMacPro1,1 geändert

    - alle Kexts als nightly geladen (mit Kext-updater)

    - mit einen speziellen AirportBrcmFixup.kext von lukakeiton die DW1560 zum laufen gebracht


    der SMBIOS Wechsel war ziemlich wichtig und zielführend (noch unter Catalina)


    Mit dem EFI Ordner war es mir dann schließlich möglich Big Sur 11.0 (Beta 3) direkt zu installieren (ohne VM).

    Meine Projekte


    HP 15" Pavilion p207ng | i3 - 5010u | Intel HD 5500 | 8 GB DDR3 Ram | Broadcom DW1560 | 256GB SSD | Mojave | Clover 5117 | Macbook Pro 15,4


    DELL Optiplex 3040 SFF | i5 - 6500t | Intel HD 530 | Nvidia GT710 2GB | 16 GB DDR3 Ram | Broadcom DW1560 | 256 GB SSD | Big Sur 11.0 | OC 0.6.0 | iMacPro1,1