Bericht HP-Probook 440 G6 - mit Clover-Ordner

  • Hallo an Alle - wie versprochen, hier nachfolgend mein Bericht, mit der Bitte um Hilfe


    Update - 23.02.2020 - So wie es aussieht, läuft nun alles.


    Es soll ein HP-Probook 440-G6 mit MacOS Catalina zum laufen gebracht werden, dies aber möglichst ohne im eigentlichen Betriebssystem herum zu ändern. Soweit bin ich dank Eurer vielen Beiträge und Hilfestellungen hier ganz gut durch gekommen. Noch gibt es aber Probleme mit der internen Grafik, die trotz aller Versuche nach wie vor zwar richtig erkannt, jedoch mit nur 7 MB Speicher angezeigt wird und so die Grafikbeschleunigung fehlt.


    Vielleicht hat jemand eine Idee? (unten dazu mehr)


    Unabhängig davon, wie bin ich vorgegangen:

    1. Vorbereitung
      Zunächst habe ich dem Gerät neue RAM-Riegel, eine größere SSD und eine SATA SDD verbaut, sowie die interne WLAN-Bluetooth-Karte gegen eine DM-1830 auf Empfehlung von DSM2 ausgetauscht. Danach ergibt sich folgende Konfiguration:

      Intel Core i5-8265U, Intel UHD Graphics 620, DDR4-2400 16 GB, M.2 NVMe Samsung 970 Evo mit 500 GB, SATA-SSD mit 480 GB, Realtek RTL811, WLAN + Bluetooth mit DM-1830. HD-Kamera, Mikrofon, Anschlüsse: (2 USB 3.1, 1 USB 3.1 Type C, 1 USB 2.0, 1 HDMI 1.4b, 1 Ethernet 1Gb, 1 Audio),

      Nach dem alles verbaut war, habe ich die üblichen Einstellungen im Bios angepasst:
      - Fastboot - disable,
      - Securityboot - disable
      - VTx und VTd - disable
      - Intel SGX - disable
      - TPM (Trusted Plattform Modul) - disable
      - DPTF - disable
      - Wake-on-LAN - disable
    2. Installation
      Für die Installation habe ich mir mit TINU - wie hier vielfach beschrieben - einen Install-Stick erstellt, dann einen halbwegs lauffähigen EFI-Ordner in die von TINU erstellte leere EFI-Partion kopiert. Den EFI-Ordner habe ich mit nach zahlreichem Lesen hier im Forum selbst zusammengestellt. Das heißt, die nötigen (vermuteten) Kexts zusammengesucht und so die Ordner gefüllt. Irgendwann hatte ich einen EFI-Ordner und eine Config, mit der ich installieren konnte.

    3. Nach der Installation
      Nach der Installation habe ich durch viel probieren und wieder Lesen und wieder probieren den EFI-Ordner und die Config „feinjustiert“ und weiter ergänzt. Und siehe da, Stück für Stück kamen weitere Funktionen dazu. Dabei habe ich mir soweit wie möglich alle Änderungen am Cover-Ordner dokumentiert, so dass ich möglichst später noch nachverfolgen konnte, warum nun wieder etwas anderes nicht funktionierte. Die Kexts sollten jetzt alle aktuell sein und ich hoffe meine Config enthält nicht soviel Müll. Auf die gleiche Weise habe ich das Patchen der DSDT dokumentiert und nach einander den Erfolg oder Misserfolg getestet. Die DSDT habe ich mit MaciASL wie folgt gepatcht: Fehler auskommentiert, GFX0 to IPGU -Patch, Replace-Names-Patch und Laptop-Audio 3 - Patch, Voodoo-Patch für das Trackpad und - da leider nichts passendes für die Batterieanzeige gefunden - den Bereich manuell gepatcht. Hier gab mir grt den richtigen Impuls. Der daraus entstandene Clover-Ordner entspricht dem angefügten Stand.
       
      Mit diesem Ordner habe ich vorsorglich die Installation von MacOS wiederholt. Einfach nur, um sicher zu sein, dass mein zahlreichen Versuche nicht doch irgendetwas am System verändert haben.
    4. Fazit und wo brauche ich Eure Hilfe
      Mit dem angefügten Clover-Ordner funktioniert schon recht viel:
      - Das Geräte boote fast fehlerfrei (so weit ich das selbst auf einen Video sehen kann).

      Was funktioniert:
      - WLAN, Bluetooth, Ethernet
      - Grafik UHD-620 funktioniert mit 1536MB
      - Hintergrundbeleuchtung
      - alle Funktionstasten
      - Monitor am USB-C-Anschluß
      - Monitor am HDMI-Anschluß
      - Sound, Mikrofon
      - Trackpad mit allen Gesten
      - Kamera
      - Airdrop und Handoff

      Sleepmodus muss noch ausführlich getestet werden, scheint jedoch zu funktionieren.

      Soweit bin ich schon einmal zu frieden. Allerdings bleibt eine Frage offen. Bei meinen zahlreichen Tests hatte ich einmal gesehen, dass die Grafik mit 2048 MB angezeigt wurde. Wie kann ich den Wert ändern, sofern dies überhaupt Sinn macht?

    Für Interessierte, stelle ich den Clover-Ordner gern zur Verfügung.


    Update 07/2020:


    neuer EFI-Ordner läuft mit Catalina 15.5. Enthält auch weitere Device/Properties-Einträge für eine nahezu vollständige PCI-Liste.

    Manche Kexts sind bewußt nicht die neusten, weil neue Kexts manchmal auch Probleme machen. Mit dieser Version läuft alles. Da der erste Ordner mehr als 200-mal herunter geladen wurde, werde ich den Ordner von Zeit zu Zeit aktualisieren. Nicht vergessen, die Serien-Nummern anzupassen.

    Files

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

    Edited 8 times, last by RenStad: update neuste Version - läuft mit Catalina 15.5 ().

  • RenStad

    Changed the title of the thread from “Bericht HP-Probook 440 G6 - Intel UHD Graphics 620 bleibt bei 7MB” to “Bericht HP-Probook 440 G6 - mit Clover-Ordner”.
  • bzgl. der grafik wird ein patch im bereich clover > devices > properties (unten den reiter anklicken) drin gewesen sein. bin am handy, kann ich nachher genau nachgucken.

    ob der sinnvoll ist, kann ich nicht sagen. mein nur-igpu-quasidesktop hat den nicht, eins meiner hackbooks hatte ihn (ich glaub das T440s), laufen tun beide, abheben tut der läptop aber nicht...

    der patch kann auch in die dsdt, bzw in den bereich igpu/gfx0 der betreffenden ssdt.

    würde vorschlagen, wir gucken uns das beim nächsten stammtisch mal an, und schauen, ob wir nicht besser die ganze dsdt-bearbeitung in eine ssdt verfrachten.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • Ja das ist richtig, ich habe für die Grafik in der config unter Device Properties mit Layout und Geräte-ID eingetragen. Bis dahin hatte ich die Grafik ohne Beschleunigung mit nur 7MB.

    Aber das hat auch Zeit - wir können uns das gern beim nächsten Stammtisch ansehen.

    P.S. Ändere mal bitte gelegentlich den 19.02. in Deiner Signatur..

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • P.S. Ändere mal bitte gelegentlich den 19.02. in Deiner Signatur..

    sofort und danke :-)


    und erledigt..

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist ERSTMAL WIEDER WEG!! nächster termin: fällt wg. lockdown leider aus

  • Für die Installation habe ich mir mit TINU - wie hier vielfach beschrieben - einen Install-Stick erstellt, dann die EFI-Partion erzeugt.

    Das ist nicht ganz richtig beschrieben. TINU erzeugt die EFI-Partition automatisch selber - aber diese ist leer, muß also befüllt werden. Es gibt sogar die Funktion, daß TINU eine bestehende EFI in diese Partition kopiert.

  • Danke für den Hinweis. Du hast natürlich recht. Ich habe die Partition natürlich nicht erzeugt, sondern "den zuvor halbwegs lauffähigen EFI-Ordner in die von TINU erzeugte EFI-Partition des Sticks kopiert". Dies ist die bessere Formulierung.


    Auch wenn es für die Erstellung eines Install-Stick doch reichlich allgemeine Anleitungen gibt, möchte ich hier nicht falsch verstanden werden und habe die Formulierung oben angepasst. Mir ging es in der Hauptsache um dieses Gerät.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • Das war auch tatsächlich nur eine kleine Kritik an der Formulierung.

    Ich finde es toll, daß Du hier einen detaillierten Bericht zu deinem Hackintosh-Projekt schreibst.

    Dies hilft sicher anderen Usern, ihr Projekt zu optimieren.

    Dank dafür! :top:

  • Guten Morgen,


    habe das Probook 450 G6, bei mir zeigt er mit dem hier hochgeladenen Clover-Ordner die Installation nicht an. Bin momentan Ratlos.

  • Wie hast Du denn den Install-Stick erstellt?

  • @RenStad

    Danke für deinen ausführlichen Bericht!


    Ich bin selber beim Überlegen mir ein HP 440 G6 zu ordern und daraus einen Hackintosh zu machen.


    Kannst du deine Erfahrungen der letzten Monate mit dem Gerät mit uns teilen?

    Wie läuft der Sleepmodus?

  • Hallo, Ich nutze Google Translate. Vielen Dank, RenStad. Ihre harte Arbeit hat es mir ermöglicht, mein Probook 440 g6 in ein voll funktionsfähiges Macbook umzuwandeln. Alles außer dem SD-Kartenleser funktioniert einwandfrei, einschließlich HDMI-, Audio- und Sleepmode. Keine Probleme in den letzten 2 Wochen des täglichen Gebrauchs.

  • ich kann mich Steviethetv nur anschließen. Auch bei mir funktioniert alles. Sleepmodus läuft perfekt, schläft ein, wie eingestellt, auch beim zuklappen. Zum Aufwecken aufklappen oder Einschaltknopf drücken. Ansonsten alles prima Touchpad läuft mit allen Gesten und sehr flüssig, Batterieanzeige nach DSDT-Patch. Bin 😀

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • RenStad. Hier ist eine Kopie meiner config.plist, die ich geändert habe. Es zeigt 2048 MB für Video. Lassen Sie mich wissen, ob es für Sie funktioniert. HDMI und HDMI Audio Funktioniert einwandfrei.

    Files

    • config.plist

      (9.55 kB, downloaded 91 times, last: )

    Edited 3 times, last by Steviethetv: Codebox entfernt ().

  • bitte löschen - danke

    Mein Desktop:

    AsRock H87 Pro4 mit Intel Core I5-4570 @ 3,2Ghz, 24 GB DDR3-RAM, Sapphire RX580 PULSE, macOS BigSur 11.1, FENVI T919 BCM94360CD (für WLAN und Bluetooth), openCore 0.6.3

    2x BENQ LEW3270U (32") Monitore


    Mein Hackbook:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, macOS BigSur 11.1, W-1830 für WLAN und Bluetooth, openCore 0.6.3


    Mein altes HackBook (Lenovo T510):

    Lenovo T510 4349KG, Intel i7-620M, 8GB RAM, NVIDIA NVS3100M, macOS HighSierra 10.13.6, Clover

    Edited once, last by Tardar ().

  • @Steviethetv danke, ich teste die config, gelegentlich.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • RenStad Hast du den USB C Port mit einer externen Festplatte ans laufen bekommen ?

    Mein Desktop:

    AsRock H87 Pro4 mit Intel Core I5-4570 @ 3,2Ghz, 24 GB DDR3-RAM, Sapphire RX580 PULSE, macOS BigSur 11.1, FENVI T919 BCM94360CD (für WLAN und Bluetooth), openCore 0.6.3

    2x BENQ LEW3270U (32") Monitore


    Mein Hackbook:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, macOS BigSur 11.1, W-1830 für WLAN und Bluetooth, openCore 0.6.3


    Mein altes HackBook (Lenovo T510):

    Lenovo T510 4349KG, Intel i7-620M, 8GB RAM, NVIDIA NVS3100M, macOS HighSierra 10.13.6, Clover

  • Tardar Ja, USC-C-Port funktioniert.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • RenStad Ich habe erfolgreich einen Opencore-Boot für mein Probook 440 G6 mit MacOS Big Sur zusammengestellt. Es funktioniert auch für Catalina. Alles außer SD-Kartenleser funktioniert. Bitte testen Sie und sehen Sie, ob es für Sie funktioniert.

    Files

    • OC.zip

      (5.41 MB, downloaded 30 times, last: )
  • Steviethetv Vielen Dank für Deine Arbeit.


    Ich bin mit dem HP Probook inzwischen (Mitte November) auch auf OpenCore (0.6.3) umgestiegen und habe BigSur installiert. Offenbar haben wir uns beinahe gleichzeitig an die selbe Arbeit gemacht und waren wohl beide erfolgreich. Klasse! Mit meinem Ordner läuft alles problemlos. Nun habe ich Deinen OC-Ordner mal getestet. Es läuft auf den ersten Blick genauso problemlos. Dein Start-Menü gefällt mir. Mal sehen, ob ich das übernehme.

    So wie es aussieht, hast Du als WLAN-Karte die DW-1530 verbaut. Die wollte ich auch mal testen, hatte die 1830 drin und war nicht so ganz zufrieden. Inzwischen habe ich eine Original-Apple-Karte eingebaut. Ich betreibe diese mit einem flexiblen Adapter

    https://www.amazon.de/gp/produ…tle_o02_s00?ie=UTF8&psc=1


    Ursprünglich war ich neugierig, ob das überhaupt funktioniert und habe den Adapter zum Test eingebaut und mir eine AppleWLAN-Karte besorgt. Der Test war so erfolgreich, dass ich das Ding gleich fest eingebaut habe. War etwas schwierig einen geeigneten Platz zu finden, aber letztlich fand sich noch eine Lücke. Die Karte läuft natürlich ohne Kexts. Seitdem habe ich keine Probleme mehr, das Probook mit dem iPhone zu verbinden. Reichweite und Stabilität haben sich deutlich verbessert, wie auch alle Funktionen, wo Bluetooth und WLAN gleichzeitig benötigt werden.

    Ich hatte jetzt nicht die Zeit unsere beiden Ordner bis ins Detail zu vergleichen. Vieles scheint ähnlich. Was gleich auffällt ist, dass Du im SMBIOS den MacBookPro15,2 ausgewählt hast. Ich hatte damals mit Clover immer wieder zwischen MacBookPro15,4 und 15,2 hin- und her gewechselt, war mir nie ganz sicher, welche Auswahl die bessere ist. Bin dann beim 15,4 hängen geblieben. Beim Wechsel auf OpenCore habe ich die Auswahl übernommen. Ich konnte jetzt keinen Unterschied feststellen, behalte das aber mal im Kopf.


    Ich hänge meinen Ordner auch mal an.


    Beste Grüße

    Images

    Files

    • OC HP.zip

      (13.31 MB, downloaded 19 times, last: )

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • USB-C funktioniert bei mir leider noch nicht.

    Was habt ihr getan, damit es funktioniert?


    Laden funktioniert - normal.

    Allerdings werden keine Festplatten etc erkannt, die ich am USB C Port anschließe.


    Danke Euch und viele Grüße

    Mein Desktop:

    AsRock H87 Pro4 mit Intel Core I5-4570 @ 3,2Ghz, 24 GB DDR3-RAM, Sapphire RX580 PULSE, macOS BigSur 11.1, FENVI T919 BCM94360CD (für WLAN und Bluetooth), openCore 0.6.3

    2x BENQ LEW3270U (32") Monitore


    Mein Hackbook:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, macOS BigSur 11.1, W-1830 für WLAN und Bluetooth, openCore 0.6.3


    Mein altes HackBook (Lenovo T510):

    Lenovo T510 4349KG, Intel i7-620M, 8GB RAM, NVIDIA NVS3100M, macOS HighSierra 10.13.6, Clover