AMD Framebuffer Utility

  • Hast du damit schon gearbeitet und konntest Erfahrungen sammeln, ist nicht so ganz meine Muttersprache? :D

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Habe es bis jetzt nur an zwei BIOSen ausprobiert.


    Einmal meine ältere HD7870XT, welche OOB läuft mit dem Radeon FB, und meine aktuelle Sapphire R9 390 Nitro 8GB, welche zurück vom minen im Häcki werkelt.


    Das angenehme ist, dass es selbständig nachschaut, ob die device id schon in einer Kext eingebunden ist und den BIOS Decode von der GPU ROM Datei alles zusammen macht.


    Unten einmal das Programmfenster und die Ausgabe wenn man auf "save all" klickt.



    Werde es noch mit den verschiedenen Einstellungen am Häcki ausprobieren und dann berichten.

  • Kannst du das Tool bitte hier im Thread hochladen, ich finde ja nicht mal den Link/Download auf der Release Seite?

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Hast du das jeweilige ROM von TechPowerUp geladen und oder kennst du noch andere Quellen?



    Edit: ehrlich gesagt habe ich keinen Plan ... :D

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

    Edited once, last by derHackfan ().

  • Die ROMs waren meine. :)


    Bin jetzt gerade am übersiedeln von meinem Frankenstein Z77-DS3H-1.1, welches nur mit einem gesicherten 1479 BIOS macOS starten ließ. Dafür auch 10.12 und 10.13 ohne neues OZ dafür mit zugepatchtem NVMe-Modul.


    Ich hab keinen blassen Schimmer wieso mein Backup-Mutationsbios alles mitmacht, ausser dass bei meinem funzenden BIOS der Bereich bei 03 anfängt und bei allen anderen bei 02.


    Hab ein Z77X-UP5TH ergattert und bin gerade dabei das BIOS für meine Samsung Eva 960 NVME zu paschen ... patchen, Autokorrektur.


    Bezüglich dem AMD Framebuffer Utility:


    Anscheinend kann man fehlende Anschlüsse komplett mit Nullen auffüllen und dies wird dann von macOS ignoriert. Weglassen hat zumindest bei mir immer zu einem Nichtladen des FB geführt und ich liess den default Eintrag dann halt drin.


    Vielleicht auch ein Ansatz für die Notwendigkeit der Helper iGPU oder auch nicht.


    Auf jeden Fall wird das Ausprobieren der verschiedenen BIOS Varianten leichter mit den zwei BIOS-Chips und der Umschaltmöglichkeit. Der Ein-Aus-, Reset- und BIOS-Wechselschalter ist genial.


    Genug der Schwafelei. Berichte dann morgen mehr.


    P.S.:


    Unser iMac 27 Mid 2010 mit i7 und der 5750 kriecht seit dem Update auf die 10.13 DP3 und ich bin mir nicht sicher, ob ich im DPCI Manager früher einen FB Eintrag hatte oder nicht ...


    Guds Nächtle



    P.P.S.:


    Netkas ist noch eine Quelle. Die verweisen aber auch häufig auch techpowerup.


    Hatte meine 7870Xt aber selber gepatcht, Fan Mod und UEFI Patch für AMD 7xxx bez. Checksum. Bei der Sapphire Nitro R9 390 hab ich die Fuzzy Steuerung ausgeschalten, Power +8% und die Fan Control manuell angepasst .. unter Win10.


    Wird jetzt lustig ob meine Win98->Win7->Win8->WIn8.1->Win10-jetzt digitale Upgrade Lizenz den Mainboard-Tausch auch noch toleriert. Vom vorigen System ist ja nicht mal das Gehäuse übrig, jetzt ein G5-Mod. War immer meine EFI-mount-Option zwecks DSDT wieder rausschmeissen.

  • Hmmm ... :rolleyes:


    Interessant ist das Tool auf jeden Fall, auch wenn ich bis jetzt keinen Erfolg damit hatte, meine HIS HD 6950 macht einfach einen Reboot.
    Ich hatte die Hoffnung dass das Framebuffer Dingens mich wenigstens auf den Desktop bringt, der AMD6000Controller.kext ist da und miniDP läuft auch aber nix geht, der Load VBIOS Haken in Clover ist schon lange abgelutscht.


    Berichte mal beizeiten wie es dir so ergangen ist ... :thumbup:

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • @HackFan


    Seit dem ich auf Whatevergreen gestoßen bin, hab mich nicht mehr damit beschäftigt. Hoffe es hat dir ebenso geholfen.


    Falls noch jemand hier landet um seine AMD GPU zum Laufen zu bringen:


    Lily + Whatevergreen installieren

    Meine Sapphire R9 390 Nitro 8GB Backplate läuft jetzt als Primary mit Beschleunigung :D


    Meine i7-3770 HD4000 hab ich als Secondary noch aktiviert, da ich immer noch hoffe - wie vielleicht auch Griven - die Hardwarebeschleunigung nutzen zu können.


    Bootet aber schneller, wenns sie im Bios deaktiviert ist

  • Moment. Heißt das, mit dem whatevergreen lädt die 390 ohne Helper gpu?
    ist das mit der 390x ähnlich??

    Hack 1: Gigabyte GA-Z77X-D3H, i7 3770k, 16GB DDR3, Powercolor R9 390x AIO Red Devil - Ozmosis
    Hack 2: Gigabyte B75M-D2V, i5 2500k, 8GB DDR3, GTX460 - Ozmosis

  • Jep und Sleep geht damit auch, einfach den Kext in der EFI ablegen, vorher mit dem Clover Configurator unter dem Reiter Graphics alles abhaken.

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Cool. Dann warte ich mal bis melden 390x da ist und teste direkt.

    Hack 1: Gigabyte GA-Z77X-D3H, i7 3770k, 16GB DDR3, Powercolor R9 390x AIO Red Devil - Ozmosis
    Hack 2: Gigabyte B75M-D2V, i5 2500k, 8GB DDR3, GTX460 - Ozmosis

  • Hab jetzt mal ein bisschen gestöbert, aber wie mache ich denn bitte daraus einen kext??

    Hack 1: Gigabyte GA-Z77X-D3H, i7 3770k, 16GB DDR3, Powercolor R9 390x AIO Red Devil - Ozmosis
    Hack 2: Gigabyte B75M-D2V, i5 2500k, 8GB DDR3, GTX460 - Ozmosis

  • Keine Ahnung wie man daraus das eine Kext macht, aber das Utility ist doch seit dem erscheinen von WhateverGreen.kext überflüssig, oder was hattest du noch mal vor? :D

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Naja aber wo krieg ich den Whatevergreen.kext.. da auf der Seite ist ja nix, oder doch?

    Hack 1: Gigabyte GA-Z77X-D3H, i7 3770k, 16GB DDR3, Powercolor R9 390x AIO Red Devil - Ozmosis
    Hack 2: Gigabyte B75M-D2V, i5 2500k, 8GB DDR3, GTX460 - Ozmosis

  • Na klar ist das Kext da ... https://github.com/vit9696/WhateverGreen/releases ... bitte die Version 1.0.4.RELEASE.zip laden.

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • :facepalm:
    Hab den Button "releases" nicht gesehen...
    Vielen Dank. :thumbsup:

    Hack 1: Gigabyte GA-Z77X-D3H, i7 3770k, 16GB DDR3, Powercolor R9 390x AIO Red Devil - Ozmosis
    Hack 2: Gigabyte B75M-D2V, i5 2500k, 8GB DDR3, GTX460 - Ozmosis

  • Kein Problem, dann teste das Ding mal bitte in Verbindung mit deiner Grafikkarte und berichte anschliessend hier im Thread, bin gespannt wie ein Bogen. :D

    iMac16,2 (Late 2015): Gigabyte Z97X UD3H - Intel Core i5 5675C - 16GB DDR3 - GTX 960 2GB - 10.14.5 - OpenCore-v0.0.2
    iMac14,2 (Late 2013): ASRock Z87 Pro4 - Intel Core i5 4670 - 16GB DDR3 - GTX 760 2GB - 10.12.6 - Ozmosis + Clover r4674
    iMac13,2 (Late 2012): ASRock Z77 Pro4 - Intel Core i5 3550 - 16GB DDR3 - GTX 660 2GB - 10.13.6 - Ozmosis + Clover r4910


    Metzger für angewandte Mettologie

  • Hab’s mal unter other in der Efi geladen. Karte müsste morgen ankommen.

    Hack 1: Gigabyte GA-Z77X-D3H, i7 3770k, 16GB DDR3, Powercolor R9 390x AIO Red Devil - Ozmosis
    Hack 2: Gigabyte B75M-D2V, i5 2500k, 8GB DDR3, GTX460 - Ozmosis

  • So Karte ist drin. Wenn ich CSM auf disabled setze, lädt Clover nicht...
    mit CSM enabled startet MacOS, beim Wechsel den Anmeldeschirm schaltet der Monitor ab...

    Hack 1: Gigabyte GA-Z77X-D3H, i7 3770k, 16GB DDR3, Powercolor R9 390x AIO Red Devil - Ozmosis
    Hack 2: Gigabyte B75M-D2V, i5 2500k, 8GB DDR3, GTX460 - Ozmosis