Probleme mit der Soundkarte ALC 269

  • Liebe Community,


    seit längerem versuche ich nun auf meinem Hackintosh meine Soundkarte zum laufen zu bekommen. X(


    Allerdings, habe ich keinen Erfolg gehabt. Ich habe mehrere Versionen von VoodooHDA getestet,
    mehrere Anleitungen durchsucht, wie man den Kernel Panic patcht, alles ohne Erfolg.


    Auch modifizierte AppleHDA.kexts zeigten keine Wirkung.


    Wie kann ich das ganze nun zum laufen bekommen. (Wahrscheinlich ist es mal wieder ganz einfach und man siehts nur wieder nicht)
    Meine Soundkarte ist laut Realtek Treiber unter Windows eine ALC 269.


    Ich habe eine gepatchte DSDT da, allerdings weiß ich nicht, ob diese auch wirklich korrekt ist, da ich beim erstellen von der Cloverdatei einige Fehler hatte, welche ich mit dem DSDT Editor rausgemacht habe.


    Ich danke schon mal ich für die Hinweise. :danke:

  • Hallo DelphiXE,


    hast du es schon mit dem AppleALC versucht? Die ALC269 sollte unterstütz werden.
    Hier hat @al6042 eine Anleitung dazu verfasst:
    AppleALC - der dynamische AppleHDA Patcher


    Die aktuelle Version ist hier zu finden:
    AppleALC - der dynamische AppleHDA Patcher - immer aktuell

    iMac13,2: Gigabyte Ga-Z77X-UD3H, i5-3450, XFX Radeon HD 7850 2GB, 8GB RAM, Ozmosis, OSX 10.12.6, 10.13.6, 10.14


    iMac13,3: Asus H61M-K, i3-3225, intel HD4000, 4GB RAM, Clover 4630, OSX 10.10.5, 10.11.5, 10.12.6, 10.13.6, 10.14, Ubuntu 18.04, Windows 10


    MacBookPro11,1: Lenovo Y50-70, i5 4210H, intel HD4600 (nVidia GTX960), 16GB RAM, Clover 4359, OSX 10.12.6

  • Ja, diese Version habe ich schon getestet. Der kext wurde zwar geladen, allerdings hatte ich immer noch keinen Ton.


    Allerdings kann es natürlich sein, das meine AppleHDA.kext durch die vielen Versuche vorher schon ausgetauscht oder beschädigt war, weshalb ich das ganze noch mal versuche, in dem ich mir noch mal die AppleHDA.kext frisch herunterlasse und den ganzen Spaß noch mal durchführe.


    Weißt du zufällt, welche ID ich nutzen muss für diese Soundkarte (in der Datei sind mehrere Nummern für diese Soundkarte enthalten (Bsp.: 8, 5))

  • das kommt darauf an in welchem Gerät die ALC269 verbaut ist.
    Bei Lenovo Laptops habe ich festgestellt, das ID 28 und 29 am ehesten laufen, während hier irgendwo ein Acer- oder Asus-Laptop mit ID 3 herum schwirrt.


    Hier kannst du anhand der Layout-Dateien ablesen, welche IDs möglich wären:
    https://github.com/vit9696/App…e/master/Resources/ALC269

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4798

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4798

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ok, vielen dank. Da ich einen Toshiba habe würde ich dann wohl die 9 nehmen?

  • Einfach mal versuchen... :)


    Wenn du die ID per Clover Config.plist einträgst, kannst du ja mit wenig Aufwand die einzelnen IDs mal durch testen.

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4798

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4798

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Wie ist das mit DSDT? Muss ich da noch irgendwas machen?
    Von dem Bereich habe ich nämlich noch so gar keine Ahnung.

  • Nun,
    Die DSDT ist die grundlegende Variante der Übergabe von verbauten Geräten des Mainboords/Laptops/Computers an das Betriebssystem.
    Da Mac OSX hier eine dedizierte Angabe von Begriffen erwartet, ist das immer meine Empfehlung.
    Du kannst aber auch einiges davon mit den Clover DSDT-Fixes erschlagen, dummerweise aber auch nicht immer alles und manchmal mit dem Problem, dass damit die Kiste auch träger wird.


    Da du von einem Toshiba gesprochen hast, gehe ich davon aus, dass es sich um einen Laptop handelt.
    Bitte trage den Modell Namen in dein Profil ein (Anstatt "Mainboard: keine Angabe").


    Funktioniert bei dir die Batterie Anzeige, die Helligkeitsregelung, der Sleep-Mode wenn du den Deckel zuklappst? ;)

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4798

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4798

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Also, es ist ein Laptop.


    Es funktioniert weder die Batterieanzeige, noch die Helligkeit, noch der Sleep-Mode(PC hängt sich komplett auf).


    Das mit dem Eintragen tut mit leid, ich dachte wenn ich das bei Gerät eintrage wird das hier mit angezeigt.


    Ich habe jetzt auch einige Zahlen durch, es passiert allerdings nie irgendetwas.
    Kext ist aber geladen.


    Ich hänge mal noch die AppleHDA.kext, welche ich jetzt dem System neu hinzugefügt habe (weil die alte wahrscheinlich nicht mehr die originale war) an. Vielleicht ist ja auch an der was faul.

    Dateien

  • Ich kann die AppleHDA nicht großartig prüfen, das solltest du selbst tun.
    Gehe in den Systembericht unter "Software" -> "Erweiterungen" und warte bis die Liste der Kexte angezeigt wird.
    Dann suchst du darin nach der AppleHDA und prüfst am Ende der Zeile, ob sie noch als "Apple" (Original) oder "Unbekannt", bzw. "Nicht signiert" angezeigt wird.
    Ist letzteres der Fall, solltest du die genaue OSX-Version mitteilen, damit man dir die Original AppleHDA wieder zur Verfügung stellen kann.

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4798

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4798

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Es steht Unbekannt dahinter.
    Ich habe OS X 10.11 (15A284)


    Schon mal vielen Dank an dich al6042.

  • Deine Version ist noch komplett die erste Variante?
    https://de.wikipedia.org/wiki/…apitan#Versionsgeschichte


    Du solltest das Update auf 10.11.6 durchführen, da es seit September 2015 einige wichtige Sicherheits-Lücken gab, die damit geschlossen wurden.
    Dadurch wird auch die AppleHDA wieder auf eine Original-Version gesetzt.

    Gruß
    Al6042


    Asus Prime Z390-A 0602 | i9 9900k | 32GB | Vega56 8GB | NVMe 250 GB | BCM943602CSAX | macOS 10.14.2 | Clover 4798

    GA H170N-WIFI F22e | i5 6600 | 16GB | HD530 1,5GB | NVMe 250 GB | BCM94352Z | macOS 10.14.2 | Clover 4798

    MBP 13,3 | i7 6700HQ | 16GB | Intel HD530 & AMD Pro 450 | NVMe 256 GB | BCM943602CSAX | macOS 10.14.2


    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ok, vielen Dank.


    Habe jetzt die Version OS X 10.11.6 (15G31)


    Und die AppleHDA wurde nicht zurückgesetzt.


    Edit: Das mit der Batterie habe ich gerade hinbekommen durch einen deiner anderen Posts. (Intel HD 4600 unter Clover nur 5mb)
    Es wird jetzt zuverlässig die Prozentzahl angezeigt. Das mit der Helligkeit und sleep-mode geht nicht.



    Edit2: Habe jetzt ein komplett neu Aufgesetzten Hackintosh.
    Nun habe ich wie beschrieben die AppleHDA installiert und aller möglichen id's durchprobiert.
    Mit dem selben Ergebnis. Was wäre jetzt sinnvoll?
    Mit anderen Sachen rumspielen oder eine DSDT.aml verwenden? (Auch wenn ich nicht weiß wie ich die DSDT erstelle.)


    Hallo, ich wollte diesen Thread mal wieder aktivieren, da ich immer noch keine Lösung für mein Problem habe. al6042 hatte schon mal über TeamViewer bei mir reingeschaut, allerdings ohne erfolg.
    Jetzt wollte ich noch mal fragen ob irgendjemand noch etwas weis.
    Das System hat folgenden Status: AppleALC installiert, bei keiner ID irgendeine Reaktion.
    VoodooHDA: Das System bekommt beim Hochfahren ne Kernelpanic und lässt den Lautsprecher ungesund knacken.
    Mehr kann ich erstmal nicht sagen, bis auf dass die batterieanzeige ohne DSDT Patch läuft. Auch der Sleepmodus dank der config.plist die ich bekommen habe.

    5 Mal editiert, zuletzt von DelphiXE ()