OpenCore 0.7.5 - zeigt alte MacOS-Versionen nicht in Boot-Picker

  • Hallo Zusammen,


    vermutlich nur irgendwo eine kleiner Eintrag. Ich habe hier ein ASUS-Board am Wickel, eine EFI erstellt und MacOS Monterey installiert. Soweit alles ohne Probleme. Nun möchte ich zum Abschluss noch die USBPort.kext erstellen und habe - um sicher zu gehen - dafür eine alte SSD mit macOS Catalina mit angeschlossen. Die Catalina-Installation ist ok und sollte laufen.


    Jedoch wird sie mir im Boot-Picker gar nicht angezeigt. Ich nutze OC 0.7.5. Gab es irgendwo eine Einstellung, die ich übersehen habe?


    Danke für Eure Hilfe.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, MacOS Big Sur, OpenCore - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, MacOS Monterey, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - MacOS Monterey OpenCore - iMac 20.2

  • RenStad


    Bei mindate und minversion als Wert -1 einsetzen in der Config.plist

    Dell Optiplex 3020 SFF / Core I5 4590 / Intel HD4600 / 8GB Ram / 250 GB Samsung SSD 850 EVO / Aukru USB Nano Bluetooth Adapter V4.0/ OpenCore 0.77 / Magic Mouse 2 / Magic Keyboard 2 / Magic Trackpad 2 / MONTEREY 12.1 (21C52)


    Real Mac / MacBook Pro 13 Zoll Mitte 2012 /2,5 GHz Dual-Core Intel Core i5 / 8GB Ram / 250 GB Samsung SSD 850 EVO/ Intel HD Graphics 4000 / BigSur 11.6.2 (20G314) via Opencore 0.76


  • Vielen Dank :klatschen:für die schnelle Antwort.


    Seit wann ist das eigentlich so und vor allem, woher weiß OpenCore, welche Version nicht angezeigt werden "soll"?


    Und hätte OpenCore mir Catalina gezeigt, wenn kein anderes MacOS vorhanden wäre oder muss immer -1 eingetragen, wenn ein älteres als das aktuelle MacOS gestartet werden soll.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, MacOS Big Sur, OpenCore - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, MacOS Monterey, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - MacOS Monterey OpenCore - iMac 20.2

  • Seit 072. Also 3 Monate minimum…


    Es geht nicht darum, was nicht "angezeigt werden soll", sonder darum, ob der APFS Treiber geladen wird, wenn er die Sicherheitsanforderungen nicht erfüllt. Dass die Laufwerke nicht angezeigt werden ist also nur ein Symptom der Sicherheitseinstellungen. Das hat man halt davon, wenn man permanent mehr Sicherheit fordert aber nicht weiß, was das so mitsichbringt – nämlich genau das: 100-fach dieselbe Frage, warum die Laufwerke nicht angezeigt werden. Ist ja okay, dass es das feature gibt, aber das einem jedes neue Sicherheitsfeature permanent als neues default aufgedrückt wird, nervt brutal. Ist vom Duktus her schon genauso wie bei Apple.


    MinDateMinVersionDescription
    00Default. Allows APFS driver in macOS ≥ Big Sur
    -1-1Disabled. Allows any APFS driver
    202101011600000000000000Default
    202105081677120009000000req. macOS ≥ Big Sur (11)
    202003061412101001000000req. macOS ≥ Catalina (10.15)
    201908209452750070000000req. macOS ≥ Mojave (10.14)
    201806217480770080000000req. macOS ≥ High Sierra (10.13)

    Edited 2 times, last by 5T33Z0 ().

  • Na dann, danke ich Euch und besonders 5T33Z0 für die ausführliche Erläuterung. Wieder etwas gelernt.


    Bisher ist mir das nie aufgefallen, denn ich versuchte bislang keine ältere Version zu laden. Erstaunlicherweise bin ich auch hier noch garnicht darüber gestolpert oder habe Beiträge dazu bisher stets übersehen. Dabei müsste es ja alle betreffen, die ihre EFI regelmäßig aktualisieren, nicht aber ihr MacOS.


    Nun gut, dann setze ich das Thema auf "erledigt" und wünsche weiterhin frohes Schaffen.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, MacOS Big Sur, OpenCore - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, MacOS Monterey, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - MacOS Monterey OpenCore - iMac 20.2