Mojave entfernt Support für AR928x

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Heute ist wieder Stammtisch in Essen :-) Wir würden uns über einen Besuch freuen. Hier gibt's nähere Info's

    Mojave entfernt Support für AR928x

    Apple hat die Kext für meine Atheros Karte anscheinend in Mojave entfernt (reddit.com/r/hackintosh/commen…ros_ar928x_wireless_card/)
    Ich habe jetzt schon zwei Dinge versucht: AirPortAtheros40.kext direkt in CLOVER/kexts/other/ sowie AirPortAtheros40.kext in die Mojave IO80211Family.kext packen. Leider beides ohne Erfolg.
    Bekomme ich das Atheros Kext irgendwie mit Clover injected? Habe keine Lust bei jedem Update ein manuelles Prozedere anzufahren in /S/L/E.


    Grüße von der dunklen Seite,
    byteturtle
    "Meine Systeme"

    - MacBookPro9,2 - HP Pavillion g6-2348sg - i7-3632QM - HD Graphics 4000 - 16GB DDR3 - SSD 500GB macOS 10.12.6 dead

    - MacBookPro9,2 - Lenovo Thinkpad T430 - i5-3320M - HD Graphics 4000 - 8GB DDR3 - SSD 240GB macOS 10.14 GM - SSD 160GB ArchLinux - SSD 32GB Windows 10 - ModBIOS

    - iMac13,2 - Asus H81IPlus - i5-4460 - 16GB DDR3 - RX560 - 120GB SSD System + 320GB TimeMachine + 320GB Daten - macOS 10.14 Beta

    Alle Systeme verwenden Clover

    Echte Apple Devices:

    - iPad7,6 - WiFi + LTE - 32GB

    - iPhone3,1
    Du kannst den AirPortAtheros40.kext wieder zu den Plugins der IO80211Family.kext packen und diese dann mit dem KextUtility wieder installieren und dann rennt die Atheros erstmal wieder. Wegen der Updates musst Du Dir keine Sorgen machen Apple überschreibt mit einem Update nicht den kompletten kext sondern ändert nur aktualisierte Bestandteile sprich Dein eingefügter AirPortAtheros40.kext dürfte mögliche Updates ohne weiteres überleben.
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, macOS Mojave 10.14
    System 2 (MacBook Pro 10.2): ThinkPad T430, i5-3360M @ 2.8 GHz, 8GB DDR3, IntelHD 4000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Dual Boot MacOS Mojave 10.14, Windows10 Pro 64Bit

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<
    -------------------------------------------------------------------------------------
    Habe mir gestern beim Harken den Haken in die Hacken gehauen

    -------------------------------------------------------------------------------------
    Bitte keine Supportanfragen auf meiner Pinnwand bzw. per PM. Dafür ist das Forum da!



    Intel Systeme

    Z97X UD5H BK - i7 4790k (4,4Ghz) - 16 GB Ram - MSI GTX 970 (4GB) - Clover - Aktuelles macOS / Win 10

    Thinkpad T530 - 15,6" (1920x0180) - HD 4000 - i7-3630QM - 8 GB Ram - 128 GB SSD - OS X 10.13.x

    Thinkpad T440 - i5-4300U - 4GB Ram - OS X 10.11.6

    Thinkpad L412 - 4TB WD Red via eSata - 4 GB Ram - Debian 9 - NAS

    Hyundai/Foxconn - G31MG-S - C2D E8500 3,16GHz - AMD Radeon 6450 (OOB) - 4 GB Ram - OS X 10.11.x

    Andere Systeme

    RaspberryPi 2 - Retropie

    Odroid C2 (x265 Support) - LibreElec

    Amiga 1200 - 68030@50 Mhz - 64 MB Ram - 8 GB CF-Card - RJ45 - OS 3.1
    Das reinkopieren hat funktioniert, allerdings wurde die Kext nach dem letzten Update (Beta auf GM) geradewegs wieder rausgeworfen. Nach erneutem reinkopieren klappts nun wieder.
    "Meine Systeme"

    - MacBookPro9,2 - HP Pavillion g6-2348sg - i7-3632QM - HD Graphics 4000 - 16GB DDR3 - SSD 500GB macOS 10.12.6 dead

    - MacBookPro9,2 - Lenovo Thinkpad T430 - i5-3320M - HD Graphics 4000 - 8GB DDR3 - SSD 240GB macOS 10.14 GM - SSD 160GB ArchLinux - SSD 32GB Windows 10 - ModBIOS

    - iMac13,2 - Asus H81IPlus - i5-4460 - 16GB DDR3 - RX560 - 120GB SSD System + 320GB TimeMachine + 320GB Daten - macOS 10.14 Beta

    Alle Systeme verwenden Clover

    Echte Apple Devices:

    - iPad7,6 - WiFi + LTE - 32GB

    - iPhone3,1
    Ja klar. Das wird öfters passieren. Der ersetzt beim Update das ganze Paket. Meistens zum.
    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<
    -------------------------------------------------------------------------------------
    Habe mir gestern beim Harken den Haken in die Hacken gehauen

    -------------------------------------------------------------------------------------
    Bitte keine Supportanfragen auf meiner Pinnwand bzw. per PM. Dafür ist das Forum da!



    Intel Systeme

    Z97X UD5H BK - i7 4790k (4,4Ghz) - 16 GB Ram - MSI GTX 970 (4GB) - Clover - Aktuelles macOS / Win 10

    Thinkpad T530 - 15,6" (1920x0180) - HD 4000 - i7-3630QM - 8 GB Ram - 128 GB SSD - OS X 10.13.x

    Thinkpad T440 - i5-4300U - 4GB Ram - OS X 10.11.6

    Thinkpad L412 - 4TB WD Red via eSata - 4 GB Ram - Debian 9 - NAS

    Hyundai/Foxconn - G31MG-S - C2D E8500 3,16GHz - AMD Radeon 6450 (OOB) - 4 GB Ram - OS X 10.11.x

    Andere Systeme

    RaspberryPi 2 - Retropie

    Odroid C2 (x265 Support) - LibreElec

    Amiga 1200 - 68030@50 Mhz - 64 MB Ram - 8 GB CF-Card - RJ45 - OS 3.1
    Das reinkopieren hat funktioniert, allerdings wurde die Kext nach dem letzten Update (Beta auf GM) geradewegs wieder rausgeworfen. Nach erneutem reinkopieren klappts nun wieder.


    Eine andere Herangehensweise war die AirPortAtheros40.kext nackt nach SLE zu kopieren, dann sollte die auch das Update überleben.
    Gigabyte Z170X-Gaming5 | BIOS F + DSDT| i5-6600K | Skill 4x8Gb DDR4 HD530 + NV750 Ti HDMI | M.2 Intel 256GB + Seagate 1,5TB = Fusion Drive| Apple Pro Keyboard | Monitor DELL UP2716D | S 10.12.6 | iMac 17.1 | Clover

    Dell XPS L421X | DSDT | i7-3537 | HD4000 | 4GB DDR3 | mSATA Samsung 256GB | HS 10.13.3 | MBA 5.2 | Clover | WIN10 Dualboot
    Was ist eigentlich der Unterschied zwischen Kext per Clover laden und aus S/L/E laden lassen? - Die Atheros Kext läuft ja nicht wenn sie über Clover geladen werden soll.
    "Meine Systeme"

    - MacBookPro9,2 - HP Pavillion g6-2348sg - i7-3632QM - HD Graphics 4000 - 16GB DDR3 - SSD 500GB macOS 10.12.6 dead

    - MacBookPro9,2 - Lenovo Thinkpad T430 - i5-3320M - HD Graphics 4000 - 8GB DDR3 - SSD 240GB macOS 10.14 GM - SSD 160GB ArchLinux - SSD 32GB Windows 10 - ModBIOS

    - iMac13,2 - Asus H81IPlus - i5-4460 - 16GB DDR3 - RX560 - 120GB SSD System + 320GB TimeMachine + 320GB Daten - macOS 10.14 Beta

    Alle Systeme verwenden Clover

    Echte Apple Devices:

    - iPad7,6 - WiFi + LTE - 32GB

    - iPhone3,1

    Neu

    Die Kexte aus der EFI werden direkt in den KextCache geladen, bevor das Betriebssystem den Riegel vorschiebt.
    Einige Kexte können aber aus der EFI heraus nicht genutzt werden, wie z.B. der AirportAtheros40.kext-
    Ist dies der Fall, bleibt dir nur noch die Variante, solche Kexte aus /Library/Extensions (/L/E) oder /System/Library/Extensions (/S/L/E) zu laden.

    Auch hier hat sich bisher wohl gezeigt, dass der AirportAtheros40 am ehesten aus /S/K/E funktioniert.
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4674
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 DevBeta | Clover 4674
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 DevBeta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Neu

    Mal sehen was da in Zukunft aus ATH9KFixup wird, vll ein Plugin weniger.

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB RAM |250GB SSD |10.13.6 |Clover 4674

    MacBook 9,1 XiaoMi 12" |m3-6Y30 HD515 |4GB RAM |SSD 128 & 250 GB |10.13.6 |10.14 DevBeta |Clover 4674
    MacBookPro15,2 XiaoMi Pro 15,6" |i5-8250U UHD620 |8GB RAM |250 & 250GB SSD |10.13.6 |10.14 DevBeta |Clover 4674
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U HD520 |8GB RAM |128SSD 1TB HDD |Win10 - 10.13.6 |10.14 DevBeta |Clover 4674



    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!


    Bootflags-zu-Lilu-Plugins-mit-Beispielen