Intel Quick-Sync mit WhateverGreen

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Kurzes Update auch von meiner Seite - es läuft! ;)

    Ausgangslage siehe mein Posting Nr. 52 in diesem Thread Intel Quick-Sync mit WhateverGreen

    Hier auch ein TLDR zu dem alten Posting: Auf meinem System hat das En- und Decoden über Quicksync - wie es Whatevergreen verspricht - nicht geklappt. Nur das Encoden lief bei mir (mit dem berühmten VDADecoderChecker-Fehler) über die "alte" Methode mit Nvidiagraphicsfixup und Shiki.

    Neu: Ich war noch auf macOS Sierra und habe mich heute einmal dazu entschlossen, komplett auf High Sierra upzudaten (quasi als Vorbereitung auf Mojave, damit der Sprung nicht zu groß ist). Das Update hat auch reibungslos funktioniert.

    In dem Zusammenhang kam mir der Gedanke, Whatevergreen nochmal auszuprobieren. Und was soll ich sagen - es läuft:
    - VDA Decoderchecker gibt "Hardware fully supported" aus
    - VideoProc gibt sowohl bei h264 als auch h265 überall ein grünes Häkchen
    - Beim Encodieren einer MKV in HEVC springt im Intel Power Gadget die Frequenz der GPU auf 1,15GHz - das ist besonders bemerkenswert da ich davor immer bei 300-400 MHz dahingedümpelt bin. Wusste zwar dass dies nicht korrekt ist, hab es dann aber nie lösen können bzw. hat mir der Nerv dazu gefehlt. Also umso besser jetzt ;)

    Nochmal kurz was ich alles eingestellt habe für diejenigen mit einem ähnlichen System wie in meiner Signatur:
    In Clover:
    Unter Boot: Bootarg "agdpmod=pikera" um eine bestimmte Methode für den Blackscreenfix zu nutzen (die funktioniert bei mir am Besten für Wake after Sleep etc.)
    Alle anderen Argumente die ich vorher hatte (shikigva etc.) sind nicht mehr nötig.
    Unter ACPI Patches: Wie im ersten Post geschrieben, Change GFX0 to IGPU etc. alles deaktivieren/disablen (also Häkchen aktivieren) - übernimmt Whatevergreen ab sofort
    Unter Graphics: Intel Inject Haken raus und Platform-IG löschen
    In der EFI-Partition bei den Kexten folgende gelöscht und Whatevergreen hinzugefügt:
    - Intelgraphicsfixup
    - Nvidiagraphicsfixup
    - Shiki


    Ich bin hin und weg - so nah am Original war ich in 1,5 Jahren noch nie mit meinem System ;)

    Cheers
    _______________________________________________________________________________

    elMaccis Hackintosh - Gigabyte Z170X Gaming 5 - Intel i7 6700K - Gigabyte Aorus 1080 TI Xtreme Edition 11G- 32GB RAM - Tripleboot - 1TB 850 EVO m.2 SSD (macOS), 1TB 850 Pro SSD (Win10), 120GB Sandisk SSD Plus (Testsystem/Linux), BCM943602CS Combo WiFi + Bluetooth - LG27UD88 (3x)

    elMaccis T420 LapHack - Lenovo Thinkpad 420 - Intel i5 2520M - 8 GB RAM - IntelHD3000 - Dualboot - mSata 60 GB (Win 10) - SATA 240 GB (macOS 10.12.6), Dell DW1510 WiFi
    @elmacci
    Moin, da kann ich dir nur voll zustimmen.
    Ich hatte ein mulmiges Gefühl die Kexte aus der EFI zu löschen und die Werte aus der config.plist herauszunehemnen, waren sie doch für einen sicheren Boot unerlässlich.
    Was war das mal für ein gefrickel...
    Und nun mit WhateverGreen.kext eine Lösung die mich schon sehr überzeugt.
    Hut ab für die Entwickler

    Ich kann den Umstieg auch wärmstens empfehlen.
     iMac13,2  Im PowerMac G5 Wakü●Gigabyte GA Z77-DS3H●i7 3770K●16 GB DDR3
    EVGA GTX 1070 SC Gaming●WIFI+BT BCM94360CD PCI-E Card●Samsung 500GB SSD Evo 840
    Style/Umbau - zum Showroom hier lang
     MacBookPro10.1  Lenovo G500 i5 3230m●2x4 GiByte DDR3●SSD 120●WIFI BCM94312MCG
     MacBookAir5,2  Lenovo G500 i5-3320m●4 GiByte DDR3●SSD 240●WIFI+BT BCM94352HMB

    Vor einer Weile habe ich auch Probiert Quicksync ans laufen zu bekommen, habe mich am Thread: Quicksync, Virtual-Screen Abstürze und iGPU+ded. GPU mit Grafikbeschleunigung versucht entlang zu hangeln, ist mir allerdings nicht gelungen bzw bin ich zu keinem positiven Ergebnis gekommen.
    Ich habe dann letzte Woche diesen Thread hier entdeckt und mich dazu entschlossen das Update auf High Sierra vorzunehmen und es mal nach dieser Methode mit Quick Sync zu probieren. Was soll ich sagen es funktioniert einfach. Kexte rein und fertig, ist schon nice. Wie andere schon schrieben mit Sierra hat es auch bei mir nicht geklappt aber nach dem Update läuft es wie es soll, vielleicht liegt es auch daran, dass meine Hardware mittlerweile "gut abgehangen" ist und damit auch entsprechend verbreitet. Rede ich mir zumindest ein, dass macht es einfacher für mich nicht auf CoffeeLake umzusteigen ;)
    MacBook Pro: Retina 13" early 15

    Imac 14.2: GA B150M DS3P, I5 6500, GB 960 GTX 4GB, 16GB Ram
    Habe gerade auch mal testhalber versucht Quick Sync ohne Fake ID und IG-Platform-ID laufen zu lassen. Bei mir wird allerdings die iGPU im Systembericht angezeigt. Dachte erst dann wird auch Quick Sync nicht funktionieren. Falsch gedacht! Es geht trotzdem.
    Edit: Lag daran, dass ich "InjectIntel" nicht rausgenommen hatte. Nachdem ich das nachgeholt habe, ist Quick Sync tot. Funktioniert hier also nicht mit Whatevergreen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „CMMChris“ ()

    Hast du denn die passende AAPL,ig-platform-id unter Devices > Properties eingetragen?
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

    Neu

    Ich habe die Anleitung hier befolgt. Diese besagt, dass Quick Sync ohne Fake ID und IG-Platform-ID läuft. Das ist wie gesagt bei mir nicht der Fall. Ich muss mindestens "InjectIntel" anhaken, dann läuft Quick Sync. Dabei wird allerdings die iGPU noch im System Profiler angezeigt. Mit der passenden Connectorless IG-Platform-ID (0x59120003) verschwindet die iGPU dann im System Profiler und Quick Sync läuft weiterhin einwandfrei.
    Bilder
    • Bildschirmfoto 2018-09-14 um 10.42.00.png

      498,32 kB, 1.220×681, 34 mal angesehen
    • Bildschirmfoto 2018-09-14 um 10.42.14.png

      372,58 kB, 1.221×681, 20 mal angesehen
    • Bildschirmfoto 2018-09-14 um 10.42.25.png

      336,55 kB, 1.219×679, 20 mal angesehen
    • Bildschirmfoto 2018-09-14 um 10.42.37.png

      292,01 kB, 1.221×680, 20 mal angesehen
    • Bildschirmfoto 2018-09-14 um 10.43.05.png

      111,92 kB, 885×589, 31 mal angesehen

    Neu

    Vermutlich funktioniert das auf einigen Systemen (insbesondere bei Coffee Lake CPUs) noch nicht automatisch. Dann passt das doch so, wie du es jetzt umgesetzt hast.
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

    Neu

    Ja klar passt das, wollte nur meine Erfahrungen teilen ;)

    Neu

    Und hier auch noch mal der Tipp den ich gerade in einem anderen Thema gegeben habe:
    Habe gerade durch Zufall herausgefunden, dass Quick Sync auch ohne die IG-Platform-ID (Graphics) und IntelGFX ID (Devices) läuft.-disablegfxfirmware und Haken bei InjectIntel reicht bei mir unter High Sierra aus (8700k + Vega64 ohne WhateverGreen).

    Neu

    Ja die Lüfter drehen immer noch hoch. Man kann das aber per PowerPlayTable lösen. Ich habe mit der Vega Gaming OC auch noch diverse andere Schwierigkeiten. Kann sie nicht auf dem Stock Takt laufen lassen. Massives Coil Whine (doppelt so laut wie unter Windows), Überhitzung, Crash nach wenigen Sekunden unter Last. Habe sie ebenfalls per PPTable auf 1442MHz runtergetaktet, so läuft sie stabil und das Coil Whine ist nicht ganz so schlimm.

    Neu

    "Überprüfung der InstallationFolgende Systemparameter solltet ihr nach einem Neustart überprüfen:
    Über diesen Mac --> Systembericht --> Grafik/Displays: Hier sollte nur eure GPU, nicht jedoch die Intel iGPU gelistet sein"

    -----
    Ich brauche die Funktion des OS nicht, trotzdem wollte ich die Methode mit WhateverGreen ausprobieren.
    Es geht nicht. Ich schaffe es nicht, dass die Intel HD Graphics 4600 aus Systembericht --> Grafik/Displays verschwindet.
    Ohne Inject Intel + ig-platform-id: 0x04120004, als auch mit, geht das nicht, dass die HD Graphics 4600 verschwindet.
    Alles ist auch auf dem neusten Stand. Übersehe ich was? Ist die ig-platform-id falsch?
    Bilder
    • Bildschirmfoto Kopie 2.png

      186,48 kB, 1.562×722, 19 mal angesehen

    Neu

    Die aktuelle Vorgehensweise in Kombination mit WhateverGreen ist, die connectorlose AAPL,ig-platfom-id 04001204 oder 0B001204 für die HD4600 ausschließlich in der config.plist unter Decives > Properties einzutragen. Die PCI-Adresse für die iGPU ist meist PciRoot(0x0)/Pci(0x2,0x0). Eventuell ist noch die device-id nötig, das müsste dann die 04120000 sein.

    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

    Neu

    Noch überlege ich wie ich die Werte da rein quetsche.
    Meist du so?:
    Bilder
    • Bildschirmfoto.png

      314,51 kB, 2.664×1.584, 14 mal angesehen

    Neu

    Macht Intel FBPatcher, wenn Du es mit Hand nicht hinbekommst

    iMac17,1 GA-Z170N WiFi F22f |i5-6600 HD530 |RX 560 |16GB RAM |250GB SSD |10.13.6 |Clover 4612

    MacBook 9,1 XiaoMi 12" |m3-6Y30 HD515 |4GB RAM |SSD 128 & 250 GB |10.13.6 |10.14 DevBeta |Clover 4671
    MacBookPro15,2 XiaoMi Pro 15,6" |i5-8250U UHD620 |8GB RAM |250 & 250GB SSD |10.13.6 |10.14 DevBeta |Clover 4671
    MacBookPro14,2 Lenovo 510-15IKS |i5-6200U HD520 |8GB RAM |128SSD 1TB HDD |Win10 - 10.13.6 |10.14 DevBeta |Clover 4671



    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!


    Bootflags-zu-Lilu-Plugins-mit-Beispielen

    Neu

    Mit Mojave (letzte Beta) friert das System beim verwenden von QS ein.
    Hackintosh I: GA-Z170X-UD5 TH - Intel Core i7 6700K 4x 4.00GHz So.1151 GA RX 460 und Intel 530 für QS

    Hackintosh II (Office"Mac" für den Vater): GA-Z170-HD3 (Bios F20) -Intel Core i5 6500 Intel 530

    Neu

    Ja, stimmt. Der FBPatcher ist ein sehr nützliches Tool.
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP