Geerbtes System nach Update 10.12.6 aufräumen, bes. Kexts in /L/E und /S/L/E

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Geerbtes System nach Update 10.12.6 aufräumen, bes. Kexts in /L/E und /S/L/E

    Erster Post!
    Dank dieses Forums habe ich es geschafft, meinen geerbten (nicht selbst installierten) Hackintosh auf aktuellen Stand zu bringen, bes. die Sicherheitsupdates und Safari waren mir wichtig. Es hat mit einiger Arbeit soweit alles funktioniert, aber Endstand zur Zeit ist, dass ich nur mit „-alcoff“ booten kann (Ton geht aber; einziger offensichtlicher Fehler: Keynote stürzt bei Animationen/Übergängen ab). Mein System ist also nicht „sauber“, was mir auch aufgefallen war, weil der enorm hilfreiche Kext-Updater von Sascha_77 immer noch veraltete Kernel Extensions anzeigt, obwohl in /EFI/CLOVER/kexts/10.12 die aktuellen liegen.

    Der Systembericht weißt einige nicht signierte und unbekannte Kexts auf, die teilweise auch nicht geladen werden (gebootet mit „-alcoff“).

    Jetzt bin ich unsicher, welche ich löschen soll, welche eh quatsch sind, welche ins /EFI sollten und ob ich nicht originale Kexts haben sollte. Gibt es da eine sinnvolle Strategie? Kann jemand direkt Müll oder Unsinn erkennen?
    Vielen Dank!

    Gruß,
    Robbe

    Inhalt von /Library/Extensions/:
    ACS6x.kext
    ATTOCelerityFC8.kext
    ATTOExpressSASHBA2.kext
    ATTOExpressSASRAID2.kext
    AppleALC.kext
    ArcMSR.kext
    BJUSBLoad.kext
    CIJUSBLoad.kext
    CalDigitHDProDrv.kext
    DirectHW.kext
    DuetDisplay.kext
    FakePCIID.kext
    FakePCIID_XHCIMux.kext
    FakeSMC.kext
    GenericUSBXHCI.kext
    HighPointIOP.kext
    HighPointRR.kext
    Niresh's Extra.kext
    NullCPUPowerManagement.kext
    PromiseSTEX.kext
    SoftRAID.kext
    USBInjectAll.kext
    VoodooPS2Controller.kext
    VoodooTSCSync.kext
    hp_io_enabler_compound.kext

    Inhalt von/EFI/CLOVER/kexts/10.12/:
    ACPISensors.kext
    AppleALC.kext
    AppleHDA.kext
    CPUSensors.kext
    FakePCIID.kext
    FakePCIID_Broadcom_WiFi.kext
    FakeSMC.kext
    GPUSensors.kext
    LPCSensors.kext
    Lilu.kext
    NvidiaGraphicsFixup.kext
    Shiki.kext
    USBInjectAll.kext
    VoodooHDA.kext
    realtekALC.kext

    Nicht signierte und unbekannte Kexts laut Systemprofiler (bis auf AppleHDADisabler, Disabler, RealtekRTL8111, VoodooHDA, AppleHDA, ApplePolicyControl alle in /L/E):

    robbe schrieb:

    Niresh's Extra.kext

    das sieht aber verflixt nach einer distro aus... (verlinktes bitte aufmerksam durchlesen...)
    deswegen wäre dein weg, dir eine legale install.app / die snowleoparddvd aus dem appstore zu besorgen, dir einen "anständigen" installationsstick zu erstellen und von vorne anzufangen. alles andere ist nicht legal, und wird hier nicht supportet
    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T420: i5-2540m, HD3000, 6gb, systemvorkoster

    ersthilfe vor ort für altes zeugs (-> laptops)
    8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 15.8.2018, 19.00 Uhr

    grt schrieb:

    das sieht aber verflixt nach einer distro aus

    Danke für den Hinweis. Diese "Niresh"-Kexts sind allerdings alle nicht geladen, vielleicht hat der, das installiert hat, einfach raufgeschmissen, was er kannte? Ich will ja ausmisten.
    Schmeiß im ersten Step schon mal alles was mit Niresh zu tun hat runter damit bist Du dann wenigstens einigermaßen sauber unterwegs. Dann sieht /Library/Extensions nach einer Installation der Art Gießkanne aus einfach mal alles rein was geht das OS wird sich schon raussuchen was es braucht. Am besten guckst Du mal was davon wirklich geladen wurde und alles was nicht geladen wurde kann per se schon mal weg einfach weil es nicht benutzt wird. Die FakeSMC würde ich aus /L/E entfernen und von Clover aus injecten lassen gleiches gilt für alles andere was in /L/E liegt und vom System gebraucht wird...
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.3
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.3, Windows10 Pro 64Bit

    Das sie gepached sind erkennt man unter anderem daran das die Signatur dann nicht mehr gültig ist. Sieht man recht schön im System Profiler.
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.3
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.3, Windows10 Pro 64Bit

    Ich würde ganz einfach die ganzen Unbekannten und Nicht signierten Kexte aus L/E in einen Ordner verschieben. Falls doch einer noch benötigt wird ist er wenigstens nicht weg. Neustarten und schauen was geht.
    Danke fürs Mitdenken. Ich werde mich dranmachen und berichten. Ich habe jetzt die /S/L/E und /L/E von meinem "echten" Mac mit gleicher Build-Nr. gesichert, um die gepanschten Kexts zu ersetzen.
    So.. eine Fummelei war es, und ab und zu wollte ich schon aufgeben, aber jetzt sind im System nur noch originale Kernel Extensions, bzw. welche von "verifizierten Entwicklern". Ton spielt, Video geht in 4k@60Hz, iTunes DRM, iCloud laufen, dank Sascha_77s Kext-Updater und den Aktualisierungen in /EFI/.../kexts/...

    Schlafen geht nicht mehr - in den Systemeinstellungen fehlt sogar die Option für den Ruhezustand (hat vorher stabil geklappt). Was kann ich jetzt noch testen (wo können sich noch gepanschte Modifikationen befinden?) Lohnt es sich, SIP zu testen?
    Hat jemand eine Idee?
    was liegt denn jetzt in /EFI/Clover/kexts/other? immer noch so, wie auf dem bild oben?
    da sollte eine konsequente audiostrategie rein: appleHDA.kext und VoodooHDA.kext weg, sollte sich irgendwo noch ein HDADisabler.kext herumtreiben, den auch weg (falls nicht schon geschehen).
    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T420: i5-2540m, HD3000, 6gb, systemvorkoster

    ersthilfe vor ort für altes zeugs (-> laptops)
    8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 15.8.2018, 19.00 Uhr
    Danke Fräulein Düsentrieb - ja, Disabler ist raus, /S/L/E und /L/E sind "clean". Im /EFI/Clover...-Ordner sind diese Kernel Extensions:

    ACPISensors.kext
    AppleALC.kext
    AppleHDA.kext
    CPUSensors.kext
    FakePCIID.kext
    FakePCIID_Broadcom_WiFi.kext
    FakeSMC.kext
    GPUSensors.kext
    LPCSensors.kext
    Lilu.kext
    NvidiaGraphicsFixup.kext
    RealtekRTL8111.kext
    Shiki.kext
    USBInjectAll.kext
    VoodooHDA.kext

    Ist die Existenz von AppleHDA und VoodooHDA ein Überbleibsel der geerbten Gieskannenmethode und konkurrieren sie mit Lilu und AppleALC? Ich habe beide (AppleHDA und VoodooHDA) rausgeworfen, danach hatte ich kein Audio, nur VESA-Grafik und viele weitere Nebeneffekte.
    Ist da noch anderes unnötiges dabei?
    Wo - außer bei den Kexts - kann ich noch weiteres Gepansche finden?

    (EDIT: Liste war doppelt drin)
    Dateien
    • config.plist

      (14,94 kB, 2 mal heruntergeladen, zuletzt: )
    hmmm....
    appleHDA und VoodooHDA sollten raus, die kommen mit lilu und appleALC ins gehege, und haben eigentlich auch nix mit der grafik am hut. da ist dann wohl noch was anderes im argen.
    hast du nach der aufräumaktion mal das kextutility zwecks reparieren von rechten und neuaufbau des caches durchlaufen lassen?
    und hast du evtl. die appleHDA wg. als unbekannt im systembericht gelistet mitverschoben? wenn ja, dann schnapp dir bitte aus dem originalen mac eine nicht manipulierte appleHDA.kext, leg sie nach System/Library/Extension und schmeiss natürlich die aus other weg.
    danach unbedingt noch einmal kextutility anwerfen.
    wenn das passiert ist, kommt die richtige layoutID für deinen audiocodec (was ist das für einer?) dran
    thinkpad W520: i7-2720qm, nVidiaQuadro1000m/intelHD3000, 16gbRam, 10.11.6/clover
    thinkpad X220: i5-2520m, intelHD3000, 16gbRam, 10.12.6/clover
    temporär: T420: i5-2540m, HD3000, 6gb, systemvorkoster

    ersthilfe vor ort für altes zeugs (-> laptops)
    8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD
    nächster Termin: voraussichtlich MITTWOCH der 15.8.2018, 19.00 Uhr
    Lade mal den EFI-Ordner hoch, aber ohne den Apple-Ordner.
    Die config.plist muss man auch noch überarbeiten. Die ist für eine Skylake-CPU und 10.13.x angelegt. Du bist aber noch mit 10.12.6 und einer Haswell-CPU unterwegs. Habe schon mal was geändert, mal sehen ob da schon einiges läuft.
    Muss bestimmt noch nachgearbeitet werden. Vergiß nicht die alte vorher zu sichern.
    Was ist eigentlich an Laufwerken verbaut? Weil jede Menge an Patchen für NVMe drin ist.
    Was für eine Wlan/Bluetooth-Karte ist eigentlich drin?

    Audio-Codec ist übrigens ALC892.
    Dateien
    • config.plist.zip

      (1,84 kB, 1 mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von „ebs“ ()

    Danke Fräulein Düsentrieb, die im System liegenden Kexts sind alle "clean", da treibt sich nichts mehr rum. Im /EFI liegen noch

    ACPISensors.kext
    AppleALC.kext
    CPUSensors.kext
    FakePCIID.kext
    FakePCIID_Broadcom_WiFi.kext
    FakeSMC.kext
    GPUSensors.kext
    LPCSensors.kext
    Lilu.kext
    NvidiaGraphicsFixup.kext
    RealtekRTL8111.kext
    Shiki.kext
    USBInjectAll.kext

    Ton und Video gehen nun wunderbar, sogar der richtige Tonausgang "BenQ LCD" Typ "Displayport" werden angezeigt.

    Schlaf/Ruhezustand gehen noch nicht.

    @abs, tausend Dank für deinen kritischen Blick. Die config habe ich ausprobiert, es gibt scheinbar ein Problem mit der FakeSMC ("DSMOS: SMC returned incorrect key:" mit ganz vielen "0" (Nullen] und "DontStealMacOS")

    Ich habe drei SSDs über SATA drin, kein internes optisches Laufwerk, kein WLan, Bluetooth über USB reicht mir fürs Trackpad.

    Ich sende meine EFI-Partition mal mit, wie du sagtest, wenn du da mehr Ungereimtheiten entdeckst - ich bin sehr neugierig, aber auch entspannt. Der Sommer und die Familie gehen erstmal vor.

    Danke und schönen Sonntag!
    Bilder
    • boot-ebs_config.JPG

      1,11 MB, 4.032×3.024, 6 mal angesehen
    Dateien
    • EFI.zip

      (11,26 MB, 1 mal heruntergeladen, zuletzt: )
    Habe deine config.plist mit der Endung old abgespeichert und die andere etwas abgeändert. Ansonsten den Ordner drivers64UEFI aktuallisiert und den kext-Ordner bereinigt um die unnötigen Wlan- und Bluetooth-Kexte.
    Probier mal die Sache aus und gib Bescheid.
    Dateien
    • EFI.zip

      (11,02 MB, 2 mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „ebs“ ()

    Die kexts und der Ordner drivers64UEFI harmonieren, bootet auch ohne wie bisher immer auf ein timeout zu warten *VIEL* schneller [danke!], aber mit deiner config.plist kommt es zum selben "SMC returned invalid key"-Problem. Mit der alten fährt er hoch, bis auf Ruhezustand geht vorerst scheinbar alles.
    Das mit der config.plist verstehe ich zwar nicht ganz, kann es aber hier nicht nachstellen, weil ich eine andere Hardware habe. Wenn es aber erst mal läuft, bis auf Kleinigkeiten, ist schon mal ein wichtiger Schritt getan. Das mit dem Feintuning hört eigentlich nie auf, weil die Entwicklung immer weiter geht.
    Was zeigt Systembericht bei der Grafik an und geht der Sound?
    Sound geht über DisplayPort und wird korrekt in den Systemeinstellungen angezeigt.

    Systembericht zur Grafik sieht gut aus:
    NVIDIA GeForce GTX 950:
    Chipsatz-Modell: NVIDIA GeForce GTX 950
    Typ: GPU
    Bus: PCIe
    Steckplatz: Slot-1
    PCIe-Lane-Breite: x16
    VRAM (gesamt): 2047 MB
    Hersteller: NVIDIA (0x10de)
    Geräte-ID: 0x1402
    Versions-ID: 0x00a1
    ROM-Version: VBIOS 84.06.3d.00.50
    Metal: Unterstützt

    Stabil ist das System aber nicht. Ruhezustand ist schwierig, und bei jedem zweiten oder drittem Bootvorgang geht irgendwas nicht, was immer mit vesa-Treibern starten und Neuinstallation der Grafiktreiber behoben werden kann (schräg, ich weiß). Deine Hinweise auf OS-Version und Prozessorfamilie scheinen da in die richtige Richtung zu gehen.

    Schönen Abend!

    Neu

    Die Familie ist entschwunden, ich habe drei Abende Zeit, am Hackintosh zu arbeiten.
    @ebs - wie erkennst du, dass die config.plist nicht meinem Chipsatz/OS entspricht bzw. an welcher Stelle kann ich das ändern? Im Clover Configurator ist für meine Augen da nichts zu erkennen.

    ebs schrieb:


    [...]Die config.plist muss man auch noch überarbeiten. Die ist für eine Skylake-CPU und 10.13.x angelegt. Du bist aber noch mit 10.12.6 und einer Haswell-CPU unterwegs.[...]

    Gruß und Dank,
    Robbe