[SOLVED] Wake on Lan stopped working on High Sierra (Ozmosis)

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    [SOLVED] Wake on Lan stopped working on High Sierra (Ozmosis)

    Hi,

    after updating HS my WOL stopped working. It worked for sure in El Capitan, not sure in what version of HS stopped to work. I'm using Ozmosis as bootloader and IntelMausiEthernet (in S/L/E) for network. I created ssdt.aml with ssdtPRGen, and put it in EFI/Oz/Acpi/Load/.

    WOL is enabled in BIOS, wake for network access is checked

    Quellcode

    1. pmset -g
    2. System-wide power settings:
    3. DestroyFVKeyOnStandby 0
    4. Currently in use:
    5. standby 0
    6. Sleep On Power Button 1
    7. womp 1
    8. hibernatefile /var/vm/sleepimage
    9. powernap 0
    10. networkoversleep 1
    11. disksleep 10
    12. sleep 15
    13. autopoweroffdelay 28800
    14. hibernatemode 0
    15. autopoweroff 0
    16. ttyskeepawake 1
    17. displaysleep 15
    18. standbydelay 10800


    If I put machine to sleep, WOL works for a short time, but not working if I let it sleep for a while.

    WOL packet is reaching the machine from LAN and from WAN (set with port forwarding), tested with "nc -l -u 9".

    I deleted Ethernet in Network, rebooted and recreated it, but still the same.


    Hardware:

    MOBO: Gigabyte Z97-D3H rev 1.1 with Oz 167X
    processor: i5-4460 Haswell
    graphic: Gigabyte GeForce GT 740 OC GDDR5 2GB (GV-N740D5OC-2GI)
    memory: 2 x 8GB Kingston
    disks:
    Samsung SSD 850EVO 120GB
    Seagate 2TB
    LG DVD±RW

    Sound: VoodooHDA (in ROM)

    Network: IntelMausiEthernet.kext


    Any advice?

    Best regards,
    Goran
    Sorry, I don't use Wake On LAN at home...
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.4 | Clover 4458
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13.4 | Clover 4458
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13.4

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Do you have a certain darkwake mode set as a bootarg? Have you tried different ones?

    How do your settings in system-preferences --> energy-saver look like?

    Neu

    I use darkwake=0 since 10.9 and it worked before. Didn't try other values.

    In energy saver there are checks at "Put hard disks to sleep..." and "Wake for Ethernet...".

    There is an interresting thing in kernel log when going to sleep:

    2018-05-11 15:58:34.550248+0200 0x76 Default 0x0 0 0 kernel: (AppleCredentialManager) AppleCredentialManager: powerStateWillChangeToGated: SYSTEM WILL SLEEP.
    2018-05-11 15:58:34.550314+0200 0x151 Default 0x0 0 0 kernel: (AppleCredentialManager) AppleCredentialManager: handleEventGated: called, eventID = 3.
    2018-05-11 15:58:34.552578+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) setWakeOnMagicPacket() ===>
    2018-05-11 15:58:34.552580+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) Ethernet [IntelMausi]: Wake on magic packet enabled.
    2018-05-11 15:58:34.552582+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) setWakeOnMagicPacket() <===
    2018-05-11 15:58:34.552585+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) disable() ===>
    2018-05-11 15:58:34.552602+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) Ethernet [IntelMausi]: LPIC=0x11000011.
    <snip>
    2018-05-11 15:58:34.563872+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) clearDescriptors() ===>
    2018-05-11 15:58:34.563914+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) clearDescriptors() <===
    2018-05-11 15:58:34.584143+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) Ethernet [IntelMausi]: WUFC=0x00000002.
    2018-05-11 15:58:34.584191+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) Ethernet [IntelMausi]: Link down on en0
    2018-05-11 15:58:34.584378+0200 0x76 Default 0x0 0 0 kernel: (IntelMausiEthernet) disable() <===
    2018-05-11 15:58:34.584407+0200 0x1aa Default 0x0 0 0 kernel: (IntelMausiEthernet) setPowerState() ===>
    2018-05-11 15:58:34.584422+0200 0x1aa Default 0x0 0 0 kernel: (IntelMausiEthernet) Ethernet [IntelMausi]: switching to power state 0.
    2018-05-11 15:58:34.584426+0200 0x1aa Default 0x0 0 0 kernel: (IntelMausiEthernet) setPowerState() <===
    2018-05-11 15:58:41.261306+0200 0x74 Default 0x0 0 0 kernel: Time 1526047121 Message
    2018-05-11 15:58:41.261308+0200 0x74 Default 0x0 0 0 kernel: PMRD: System Sleep

    Neu

    gorans schrieb:

    WOL is enabled in BIOS, wake for network access is checked

    If I remember correctly, there are more WOL options enabled when you view the BIOS in Classic Mode. I don't think that the current issue is connected to BIOS settings (since the package reaches the system) but double checking is always good ;)

    Theoretically AppleIntelE1000e.kext should also work as an alternative to IntelMausi. You can try it out and see if the behaviour changes or new messages appear in the Log...
    Dateien

    Neu

    I tried with attached kext. WOL still not working and also ethernet not working after waking from sleep.

    The package reaches the system when awake but i think the problem is that ethernet port powers down during sleep. And I'm stuck there.


    WOL works now. What I did:

    1. Installed AppleIntelE1000, didn't work, reinstalled IntelMausiEthernet. WOL didn't work.

    2. Installed latest FakeSMC sensors and went through BIOS settings. Turned on Intel Rapid Start and checked in Network Adapter that WOL is turned on there also. WOL worked but no sensors in HW Monitor.

    3. Reinstalled old Sensors and rebooted. WOL still works

    4. Turned off Intel Rapid start in BIOS. WOL still works!


    So, I have exactly the same setup as before but WOL is working. I have no idea why. :cursing:

    Best regards,
    Goran

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „gorans“ ()

    Neu

    That are some very weird bugs you experienced there but I'm glad that it works now!

    I had similar experiences... Functions come back as unpredictable as they dissappear ;)