Hilfe für DSDT HP Elitebook 2170p

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Hilfe für DSDT HP Elitebook 2170p

    Neu

    Liebe Community,
    zwar habe ich erfolgreich High Sierra auf das kleine Elitebook gebracht und es funktioniert zu 90 Prozent tadellos, es gibt aber noch ein paar Kleinigkeiten, die stören. Weiß vielleicht noch jemand mit DSDT-Patching-Kenntnissen einen Rat? Vielen Dank!!

    Also zunächst ist es nervig, dass die Webcam nach nem Sleep immer rausgeworfen wird. Der gesamte EH02-Hub geht flöten und wird nicht wieder eingehängt (die Kamera hängt an PR21-HP23 an EH02), XHC funktioniert tadellos (auch eine USB 2-Maus wird wieder eingebunden nach dem Aufwachen). Komme da einfach nicht weiter. Leider gibt es ohne Camera Control auch kein Bild bei FaceTime, aber damit könnte ich notfalls leben.
    Zweitens würde ich gerne wissen, wie ich die Clover-Patches für das Routen von BAT0 und 1 auf BATC in die DSDT integrieren kann. Die Patches stammen ursprünglich mal von Rehabman, verstehe aber ihre Funktionsweise leider nicht und weiß dementsprechend nicht, wie und an welcher Stelle ich sie in meine DSDT kriege.
    Drittens habe ich momentan Powermanagement über Clover aktiviert, weil ich einfach keine SSDT hinbekomme, mit der der Laptop auch booten will. Die CPU wird immer als 2,4 GHz i5 erkannt (auch von Clover), selbst mit einem Wechsel von einer MacbookPro 9,2 auf eine MacbookAir 5,2 SMBIOS (wo genau der passende Prozessor mit 1,8 bzw. 1,9 GHz drin steckt), geht macOS (und Clover) weiterhin von einer 2,4 GHz Baseclock aus. Wie gesagt, mit manuellem Takt setzen über Clover geht es, aber vielleicht hat jemand eine Idee, wie es auch ohne diesen unschönen Umweg funktionieren könnte.
    Dateien
    iMac18,2: ASUS Prime B250M-C, Core i5 7500, 16 GB RAM, Gigabyte AMD RX560, BCM943602CS Wifi/BT, 1 TB Samsung PM961 NVMe, 256 GB Samsung PM961 NVMe, 256 GB Sandisk SSD, OS: macOS 10.13, Windows 10

    iMac14,2: Gigabyte EP43-DS3L, Core2Quad Q9300, 6 GB RAM, ASUS Geforce GT1030, TP-Link AC1200 USB Wifi, 128 GB Sandisk SSD, OS: macOS 10.13

    Neu

    Die Büchse klingt ganz spannend, aber hast du tatsächlich renames von EHCx auf EH0x drinnen?
    Das Teil hat nicht genug USB-Ports um den USBInjectAll dafür zu nutzen... mein damaliges HP EliteBook 8470p lief auch ohne...
    Eventuell hilft das schon mal...

    An deiner DSDT könnte ich ggf. am Ende der Woche oder am Wochenende basteln, vorher habe ich leider keine Zeit...
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | RX Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.4 | Clover 4439
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13.4 | Clover 4439
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13.4

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Neu

    Ja, das wäre großartig, vorab vielen Dank!

    Die Renames sind in der DSDT, ja. Werde mal den USBInject rausnehmen. Hatte nur von einem Trick gelesen, den Port, an dem die Webcam hängt, mit USBInject und zugehöriger USB-SSDT auf 0x04 zu definieren, um damit das Auswerfen zu verhindern. Aber das hat ohnehin nichts gebracht ;)

    EDIT: Wenn ich USBInject entferne, wird die Webcam gar nicht mehr erkannt. Was mir aber auffällt: Die USB2-Maus wird laut Ioregistryexplorer unter XHC eingehängt, während die Webcam unter EH02 auftaucht. Könnte es sein, dass die nicht über XHC geroutet wird, wie es eigentlich sein sollte?

    EDIT2: Habe eine neue DSDT gebastelt, mit der man auf USBInject verzichten kann, die Kamera wird damit erkannt. Allerdings löst das nicht das Wake-Problem, macOS schmeißt sie nach dem Sleep immer noch raus... Kurios ist, dass der USB-Port HPT2 (an dem die Kamera hängt) zwei Mal im ioreg auftaucht. Auch wenn ich das CAM0 device rausnehme (welches unter HPT2 eingetragen ist) und macOS die Kamera so selbst entdecken lasse, bleiben zwei HPT2 aktiviert. Tatsächlich ein Routing-Problem?
    Dateien
    iMac18,2: ASUS Prime B250M-C, Core i5 7500, 16 GB RAM, Gigabyte AMD RX560, BCM943602CS Wifi/BT, 1 TB Samsung PM961 NVMe, 256 GB Samsung PM961 NVMe, 256 GB Sandisk SSD, OS: macOS 10.13, Windows 10

    iMac14,2: Gigabyte EP43-DS3L, Core2Quad Q9300, 6 GB RAM, ASUS Geforce GT1030, TP-Link AC1200 USB Wifi, 128 GB Sandisk SSD, OS: macOS 10.13

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „macinsane“ ()