Batterieanzeige 100% trotz DSDT Patch, was nun?

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Batterieanzeige 100% trotz DSDT Patch, was nun?

    Hallo alle zusammen!

    Auf Anraten von @anonymous writer habe ich einen Clean Install mit High Sierra 10.13.4 durchgezogen, in der Hoffnung, dass das sehr wohl von High Sierra erkannte, dennoch nach wie vor nicht aktivierbare WLAN-Modul (Broadcom BCM43324) endlich brav mitspielt.

    Weit gefehlt. Unter High Sierra lässt es sich nach wie vor mit einem einem Klick auf „Wlan aktivieren“ leider nicht aktivieren. Das ist leider eine Tatsache die ich irgendwie nicht ganz so akzeptieren will :D Da ich weiß das dieses Modul bei anderen problemlos funktioniert! Da ich jetzt wieder an dem Punkt bin exakt genauso schlau zu sein wie zu Sierra Zeiten (vorgestern) wende ich mich noch einmal vertrauensvoll an die Community, mit der Hoffnung vielleicht diesmal eine Lösung dafür zu finden.

    Zum Modul: Dieses wird von High sierra sehr wohl erkannt, lässt sich allerdings weder mit einem Klick auf „WLAN aktivieren“, noch mit einem Terminalbegehl davon überzeugen in den Dienst zu treten. Testweise habe ich es mit Ubuntu und Windows probiert, da funktioniert das Modul OOB.

    Falls irgendjemand auch nur eine leiseste Ahnung hat dieses kleine fiese Modul zum
    arbeiten zu überreden, den würde ich doch um sein Wissen bitten :D

    Falls irgendwelche Screenshots, oder Ordner zur Einsicht gebraucht werden, sagt bitte Bescheid, ich stelle alles möglichst schnell zur Verfügung :)

    Über jede Antwort wäre ich durchaus erfreut ;)

    Grüße Mac
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A
    Wird denn das Teil im Fenster "PCI List" des Programms DPCI Manager aufgelistet?
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Hallo @al6042! Ja wird erkannt, anbei der Screenshot.

    Edit: Habe mal noch ein paar Screenshots hinzugefügt.
    Bilder
    • DPCI.jpeg

      244,29 kB, 1.036×576, 25 mal angesehen
    • IORegExplorer.jpeg

      198,73 kB, 1.043×600, 25 mal angesehen
    • Systembericht 1.jpeg

      110,25 kB, 1.003×550, 21 mal angesehen
    • Systembericht 2.jpeg

      107,53 kB, 1.003×550, 12 mal angesehen
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A
    Den AirportBrcmFixup hast du bereits im Einsatz?
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Ja der ist drin. Ich packe mal meinen EFI Ordner mit bei.
    Dateien
    • EFI.zip

      (18,16 MB, 8 mal heruntergeladen, zuletzt: )
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A
    Ändere mal spaßeshalber das Bootarg "brcmfx-country=DE" zu "brcmfx-country=a#"...
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Es ist wie an meinem alten "HP EliteBook 8460P". Wenn Wlan über den Wlan Schalter deaktiviert ist gibt es keine Möglichkeit das Modul zur Arbeit zu bewegen.
    Beim "HP EliteBook 8460P" funktionierte es dann durch mehrmalige Versuche diese Taste zu aktivieren und mehreren Neustarts. Wobei der Status der Taste oft falsch angezeigt wurde. Deaktiviert konnte auch bedeuten bereits aktiviert.

    Bei dir ist es aber glaube ich etwas anders und du hast einen ACPI-Taste zum Aktivieren. Da gehen mir leider die Ideen aus wie man über ein solche Taste das Modul aktivieren kann.

    Kannst du mal ein Bild einstellen von der Wlan Taste. Reagiert die mit Licht an und aus beim drücken?
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:
    @al6042 habe ich geändert, allerdings immer noch nicht aktiv.

    @anonymous writer Bild ist im Anhang. Das orangene Licht bedeutet unter Windows und Ubuntu deaktiviert. Wenn das WLAN aktiviert ist, leuchtet die LED bläulich wie die Caps-Lock Taste.
    Bilder
    • Foto 04.04.18, 15 09 41.jpg

      4,73 MB, 4.032×3.024, 8 mal angesehen
    • Foto 04.04.18, 15 09 46.jpg

      4,52 MB, 4.032×3.024, 6 mal angesehen
    • Foto 04.04.18, 15 09 49.jpg

      4,58 MB, 4.032×3.024, 14 mal angesehen
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A
    Also bedeutet unter OSX ist das Licht immer rot bzw. an der Caps-Lock aus und es gibt keine Möglichkeit es auf Blau zu bewegen?
    Auch nicht wenn man einmal drückt und dann wartet oder neustartet.
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:
    Schlichtweg Nein. Die Farbe der LED verändert sich nicht. Selbst einmaliges drücken und neu starten. Einmaliges drücken von fn + f12 und Neustart hat nicht geholfen. Das WLAN bleibt vom Status her ausgeschaltet, sucht nach nichts, zeigt mir keine Netzwerke an.

    Heißt das im Klartext, dass man die ACPI Taste mit der WLAN Funktion in macOS nicht belegen kann? Noch nicht einmal per DSDT Patch?

    Edit: Capslock verändert sich beim Drücken. LED an und LED aus mit entsprechender Funktion. Die WLAN LED leuchtet immer orange und hat ihre Farbe unter macOS auch noch nie geändert.
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A
    Hast du mal versucht mit einem Live-Linux zu prüfen, ob die Karte damit läuft?
    Vielleicht benötigt sie noch den Anschubser...
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Nein das habe ich durchaus noch nicht probiert. Also einen Live Linux Stick erstellen, starten, dann versuchen macOS zu booten?
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A
    Natürlich im Linux schauen, ob die Karte, ggf. Auch mit zusätzlichen Treibern, genutzt werden kann.
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Es gibt ein erfreuliches Update! WLAN funktioniert sporadisch. Wenn ich beim Start, wie ein bekloppter abwechselnd die fn und f12 Taste drücke, ist das WLAN verfügbar. Das hält leider nur solange ich den Laptop benutze. Nach einem Neustart ist das WLAN nicht verfügbar, außer ich smashe die beiden Tasten.

    Ist das jetzt wirklich die einzige Möglichkeit mein WLAN zu verwenden?

    P.S.: Die Farbe der LED verändert sich dabei nicht, genau wie du das gesagt hast @anonymous writer.

    P.P.S.: @al6042 Ich konnte lokalisieren, dass ich während des Bootvorgangs (also quasi während im Verbose Mode der Text runterrattert) Diesen Button Smash hinlegen muss. Mal ne bescheidene Frage: Kann man der DSDT die Aufgabe nicht übergeben das für mich während des Starts zu tun? Gibt es eine Möglichkeit den Bootvorgang komplett zu dokumentieren um genau zu schauen, inwiefern der Häcki auf meine Tastendrückerei reagiert? Ich spinne ja nur mal rum.
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Mac“ ()

    Die DSDT ist kein Script, dass Aufgaben ausführen kann... das wird nix...
    Bevor der Startvorgang an macOS übergeben wird, gibt es das Boot.log, dass du per Clover auslesen kannst.
    Alle anderen Logs sind im macOS selbst zu finden und zu nutzen.
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Schade, aber danke für die Info. Mehr fällt mir dazu dann leider auch nicht mehr ein!
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A
    Guten Abend,

    wenn dein WLan mit der rum drückerei bei boot funktioniert. Und dein NVRam funktioniert sollte dein WLAN nach einem Reboot wieder funktionieren. Da doch die Einstellungen im NVram gespeichert werden oder liege ich das falsch @al6042?

    Gruß Mocca55
    iMac9,1|Intel Pentium E5400 @ 2.50Ghz|GeForce GT530 1GB|3GB DDR2|OSX 10.11.6 El Capitan auf 500GB WD Green |Clover r4411
    iMac14,1|Intel Xeon W3550 @ 3.07Ghz|nVidia Quadro FX1800 768MB|4GB DDR3|OSX 10.13.6 High Sierra auf 500GB |Clover r4449
    iMac14,2
    |Intel Core i7-2600k @ 3.40Ghz|
    MSI R9 270X 2GB|2x 4GB Samsung DDR3|OSX 10.12.6 Sierra + 10.13.6 High Sierra auf 120GB Thoshiba A100 SSD|Win7 64bit auf SSD Samsung Evo 850|Clover r4411
    MacBookPro6,1|i3 330M @ 2.13 Ghz|ATI Radeon HD 5650|2x 2GB RAM DDR3|OSX 10.11.6 El Capitan + 10.13.6 High Sierra|250GB SanDisk SSD|Cloverr4449
    ———>Kein Support über Privatnachrichten<———
    Ein NVRAM-Reset wäre da ggf. Mal angebracht.
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Versuche auch mal die beiden dsdt.aml ob sich was am Verhalten der WLAN Taste ändert.
    Kann sein das an ein der der beiden Varianten WLAN gar nicht zu aktivieren ist. Vermutlich Variante 2. Dafür bei Variante 1 sofort.

    Umbenennen der Datei welche du verwendest in dsdt.aml nicht vergessen.
    Dateien
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „anonymous writer“ ()

    Hallo @Mocca55! NVRAM Reset durchgeführt, allerdings ohne Erfolg. Ohne Button-Smashing kein WLAN.

    @anonymous writer weder Variante 1 noch Variante 2 deiner DSDT´s ändern den WLAN-Status, noch die LED.
    Gruß
    Mac


    HP Envy 6 1171-SG (15.6 Zoll, Ende 2010)

    1,7 GHz Intel Core i5 I5-3317U
    8GB SK Hynix 1600 MHz
    Intel HD4000 2GB VRAM

    El Bastardo (Selbstbau 2018 MK I)

    3,5 GHz Intel Core i5 8500
    8GB Crucial Ballistix Sport LT 2666 MHz
    Intel® UHD-Grafik 630
    AMD Radeon RX 570 8GB OC
    ASUS B360M-A