[gelöst] Acer Spin 5: Finetuning !

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    [gelöst] Acer Spin 5: Finetuning !

    Im Anhang nun mein Clover-Ordner zu meinem bestens funktionierende Acer Spin 5 als Hackintosh mit macOS 10.13.4, also High Sierra - und zum Download für andere, die damit ihr Acer Spin 5 auch mit dem besseren Operating System bestücken wollen!
    CLOVER.zip

    Allen, die mir geholfen haben, ganz besonders @anonymous writer und @Harper Lewis, einen ganz herzlichen Dank!

    :klatschen:

    -----------------------------------------------------------------------------
    Ab hier die Diskussion, die zum gewünschten Erfolg geführt hat
    -----------------------------------------------------------------------------

    Ich habe hier ein Acer Spin 5 mit macOS Sierra.

    Die Installation hat geklappt, und soweit funktioniert alles, außer der Regelung der Helligkeit.
    Der Bildschirm ist viel zu dunkel, die Helligkeit läßt sich aber auch gar nicht regeln, richtig: der Schieber in den Einstellungen "Monitore" ist nicht vorhanden.
    AppleBacklightInject.kext wie auch IntelBacklight.kext habe ich auch schon probiert, hat aber nichts geholfen.
    Gut, das Display ist ja ein Touchscreen. Brauche ich da vielleicht einen zusätzlichen Kext?

    Technische Daten:
    Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD

    Auf jeden Fall stehe ich auf dem Schlauch und bitte Euch um Eure Hilfe!
    :bitte:

    Im Anhang mein Cloverordner.
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6

    Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von „iPhoneTruth“ ()

    Den Brightness Fix Broadwell Haswell von Rehabman hast du schon ausprobiert? Der funktioniert ja auf unseren Lenovo-Kisten ohne Kext.
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP
    Ich habe schon eine DSDT.aml mit diesem Patch erstellt, nur startet er momentan nur ohne DSDT.aml. Mit gibt es immer Panic und dann Neustart. ;(

    Ich vermute, daß es an irgendwelchen Einstellungen in der config.plist liegt, die mit der DSDT nicht harmonieren. Die DSDT habe ich von Rehabmann, passend für die HD 620, allerdings ist die so gehalten, daß man mit dieser theoretisch keine DSDT bräuchte. Ich vermute daher, daß irgendwelche Einstellungen darin deaktiviert werden müßten, damit er meine DSDT.aml läd.

    Im Anhang mal meine DSDT.aml
    Dateien
    • DSDT-13.aml

      (166,02 kB, 1 mal heruntergeladen, zuletzt: )
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6
    Hast du es mal nach dieser Anleitung versucht?
    Helligkeitssteuerung bei Intel HD Prozessorgrafikkarte (Laptop)

    IntelBacklight.kext kannst du vergessen. Der funktioniert schon lange nicht mehr.

    Noch ein Punkt. Warum nutzt du MacBook10,1? Zur HD620 passt viel besser MacBookPro13,1.
    Und wenn du High Sierra benutzt kannst du dir den Fake ID sparen und solltest du auch.
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von „anonymous writer“ ()

    Ich habe es nun mal nach dieser Anleitung versucht, hat aber leider auch nichts geändert. Leider!
    :(
    MacBoo10,1 habe ich ausgewählt, weil nach dieser Definition Kabylake und Hd 615 drin ist. Da dachte ich, das würde meinem Hackbook am ehesten entsprechen. Ich kann es natürlich mal mit MacBookPro13,1 probieren.

    Und: ich verwende Sierra.
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6
    Ich weiß das High Sierra nicht bei allen erwünscht ist.
    Ich jedoch sehe es als das System für Kaby Lake aus dem Grund weil es das einzige OSX ist welches auch dafür gemacht wurde.
    Nochmals daher der Hinweis auf den Fake ID welchen du dir unter High Sierra sparen kannst.
    Die HD-620 läuft bei mir unter High Sierra mit voller Helligkeitssteuerung.
    Kurzanleitung: High Sierra auf ASUS Zenbook UX330UAK
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:
    Ok. Dann werde ich mal HS installieren.

    Kannst Du mir mitteil, warum die Definition MacBookPro13,1 die bessere ist? Würde mich interssierenen.
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „iPhoneTruth“ ()

    Die MacBook Prozessoren sind abgespeckt billig Varianten. Daher würde ich diese SMBIOS nicht verwenden.
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „anonymous writer“ ()

    Ok! Gut zu wissen! HS ist in der Zwischenzeit drauf. Habe auch gerade zunächst mal das Update auf 10.13.3 durchgezogen. Nun werde ich mal Dein Anleitung umsetzen.

    Dürfte ich Dich bitten, mir mal Deinen Clover-Ordner hier hochzuladen. Zwecks Vergleich! Wäre sehr nett und hilfreich!

    Besten Dank schon mal für alle Tipps!
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:
    Hallo @anonymous writer
    Du hast MacBookPro14,1 als SMBIOS in Deiner Config.plist drin, nicht MacBookPro13,1!

    Was ist nun richtig, für mich das Bessere?
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6
    Sorry, war mein Fehler. MacBookPro14,1 ist richtig :)
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „anonymous writer“ ()

    Ich habe momentan andauernd das Problem, daß nach dem Anpassen von Clover der Bootvorgang sehr oft nicht klappt, und die angefügte Meldung kommt. Dann geht natürlich gar nichts mehr, und ich habe Mühe, irgendwie das System wider zu starten.
    Was bedeutet das?
    Bilder
    • IMG_0267.png

      1,44 MB, 1.875×642, 10 mal angesehen
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6
    Probier mal einen anderen AptioFix, z.B. AptioMemoryFix.efi. Damit benötigst du auch keinen EmuVariable mehr.
    MfG, docplag

    ..................................................................................................................................................................................................................................................................................
    GA-Z170M-D3H, i5-6600, 16 GB DDR4 RAM Corsair 2400, Gigabyte RX 560 Gaming OC 4GB | macOS 10.13.5 / 10.14 Beta, KDEneon, Ubuntu 18.04, Windows 10 Pro
    GA-X58A-UD3R, i7-960, 12 GB DDR3 RAM 1600, Asus GTX660 | OS X 10.11.6
    HP Envy 13-d071ng, i56200U mit HD520, 8GB DDR3L RAM | OS X 10.12.6, Windows 10 Home
    3.12.2017
    MacBook Pro Late 2011, optisches Laufwerk rausgeflogen, SSD eingebaut | OSX 10.9.5, macOS 10.13.2, Windows 7 Pro als VM
    E35M1-I Deluxe, AMD-CPU E350, EVGA-GTX210, 8 GB DDR3 RAM
    | Ubuntu-Server 16.04
    Dell XPS 15-9560, i7-7700HQ, 16GB DDR4 RAM, HD630, GTX1050M
    | macOS 10.13.5, Windows 10 Pro
    Habe schon AptioMemoFix.efi, OsxAptioFix2Drv.efi und OsxAptioFix3Drv.efi probiert, immer wieder das gleiche Problem. Nur die EmuVariable habe ich noch nicht probiert.

    Grad probiert, da kommt dann genauso Blackscreen mit der Frage "does printf work?" …

    ?(

    Probiert gerade in Clover unter Boot-Flags: slide=128
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „iPhoneTruth“ ()

    Schonmal einen anderen Wert für slide getestet? Ich habe hier glaube ich mal gelesen, dass slide=128 oft helfen soll.

    AptioMemoryFix funktioniert auf all meinen drei Hackis völlig problemlos.
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
    Kabylake Laptop: Dell Vostro 5370, i5-8250U, UHD 620
    Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP
    Ist deine Clover Version auf dem neusten Stand?
    Nutzt du die neuste apfs.efi?
    Sammlung neuste apfs.efi
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:
    slide=128 scheint die Lösung zu sein. Habe gerade dreimal gebootet ohne Probleme. AptioMemoryFix ist nun drin und funktioniert. Deo gratias!

    Nun geht es an die DSDT.aml. Ich vermute, daß ich das Helligkeitsproblem ohne DSDT.aml nicht in Griff bekomme. Nun geht es also ans Patchen.
    Mit der von mir erstellten hängt er sich auf und bootet dann neu.

    Kann wer von Euch eine Liste der Patches angeben, die für mich sinnvoll wären?
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6
    Wenn der Laptop ohne die dsdt.aml starte dann versuche es erst mal ohne diese nach dieser Anleitung.
    Helligkeitssteuerung bei Intel HD Prozessorgrafikkarte (Laptop)

    In der original Anleitung von @RehabMan steht ausdrücklich drin das diese nicht nötig ist für die Helligkeitssteuerung und das eine falsch gepatchte dsdt.aml die Helligkeitssteuerung verhindern kann.

    Ist in der config.plist der Fake ID gelöscht?
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    MacBookPro 10,2: Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)
    MacBookPro14,1: ASUS Zenbook UX330UA-FB161T 13,3" QHD+ i7-7500U, 16GB RAM, 256GB SSD, Broadcom BCM94352Z DW-1560


    :hackintosh:

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „anonymous writer“ ()

    So, jetzt habe ich endlich normale Helligkeit! Und zwar mit der SSDT-IGPU.aml!

    :thumbsup:

    Der Slider zum Verstellen der Helligkeit ist zwar noch nicht da, aber das bekommen wir (Ihr mit mir :) ) auch noch hin!

    @anonymous writer
    Ja, ich bin danach vorgegangen. Es hat aber zunächst nichts gebracht. Habe den dabei erstellten Kext allerdings momentan in S/L/E, werde ihn mal nach L/E verschieben. Und ja, die Fake ID ist rausgenommen aus der config.plist.
    Dateien
    • SSDT-IGPU.dsl

      (19,44 kB, 4 mal heruntergeladen, zuletzt: )
    Hackbook 15'': Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520, 8GB DDR3 1600 MHz, Broadcom BCM94352HBM Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.13.6

    Hackbook 13'': Acer Spin 5, Intel Core i5 7200U, 8 GB RAM, Kaby Lake, Intel HD Graphics 620, 256 GB SSD, MacOS 10.13.6

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von „iPhoneTruth“ ()