Sleep->Wake = Crash bzw. Reboot

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    kuckkuck schrieb:

    Beim Hibernatemode 0 + gesperrtes Sleepimage bleibt ja sicher komplett alles im RAM. Damit hat dein PC Probleme, wenn 32 GB installiert sind...


    Richtig, genau so scheint es zu sein. Habe es jetzt mehrmals getestet und mit 32 Gb kommt so gut wie jedes Mal ein Absturz. Bei 16 Gb bislang nicht ein Absturz.

    kuckkuck schrieb:

    (PS: Wieso belässt du es nicht einfach dabei, funktionierender 25 ist doch beneidenswert? )


    Das Hibernatemode 25 funktioniert, freut mich sehr! Leider kann ich das Sleepimage nicht auslagern. Jedenfalls ist es mir nicht gelungen. Die Location lässt sich ändern, aber dann funktioniert Mode 25 nicht.
    Folglich, wenn ich mit Hibernatemode 25 arbeite, leidet meine SSD.

    kuckkuck schrieb:

    Mach mal das Sleepimage wieder veränderlich und probiert Hibernate 0 Sleep aus. Schau dann mal ob etwas ins Sleepimage gelegt wurde. Vielleicht geht ja bei dir sogar Sleep mit aktiviertem Sleepimage besser als mit deaktivierten...


    Dies habe ich bereits versucht, leider ohne Erfolg. Es wird zwar etwas in Sleepimage gelegt, aber i. d. R. kommt es zum Absturz, wahrscheinlich weil der Rechner nicht in den Hibernatemode geht.

    kuckkuck schrieb:

    Auf wieviel mhz läuft der eigentlich?


    Auf 1600 MHz.
    Wie hast dus denn probiert? pmset -g muss nach dem ganzen Vorgang schon den neuen Ordner unter "hibernatefile" anzeigen...

    Erstmal brauchst du einen neuen Ordner im richtigen Verzeichnis, zB mit:

    Quellcode

    1. mkdir -p /Volumes/Deine2.Platte/private/var/vm


    Und dann musst du den neuen Ordner noch hinterlegen:

    Quellcode

    1. sudo pmset -a hibernatefile /Volumes/Deine2.Platte/private/var/vm/sleepimage

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „kuckkuck“ ()

    kuckkuck schrieb:

    Und dann musst du den neuen Ordner noch hinterlegen:
    Quellcode
    sudo pmset -a hibernatefile /Volumes/Deine2.Platte/System/vm/sleepimage


    Ich habe es genau so gemacht.

    Deinen ersten Schritt verstehe ich nicht. Muss ich meine Hauptplatte klonen bzw. brauche ich eine Platte mit Systemverzeichnissen?
    Nicht unbedingt, aber du kannst das Sleepimage analog zur Standardkonfiguration nach /Volumes/Deine2.Platte/private/var/vm legen... Was gibt denn pmset -g nach ändern des Pfades aus?
    Warum gibst du als Pfad denn genau "/Volumes/Deine2.Platte/private/var/vm" an?
    Den Pfad habe ich geändert, allerdings einfach in "/Volumes/Meine2.Platte/sleepimage"
    Das hat auch die Ausgabe mit pmset -g ergeben. Allerdings funktioniert der richtige Hibernatemode
    dann nicht.
    Der original Pfad wäre /Volumes/Deine1.Platte/private/var/vm und analog dazu habe ich ihn in /Volumes/Deine2.Platte/private/var/vm geändert um möglichst nahe am original Zustand zu bleiben. Das ganze sollte aber eigentlich genauso gehen wenn du einen x beliebigen anderen Ordner angibst...
    Sorry da kann ich dir nicht helfen wenn die Funktion nicht will. Frage ist ob die Abnutzung der SSD überhaupt so immens ist...?

    Hast du mal im BIOS nach Settings geschaut?
    sorry vllt wurde das schon gefragt: aber hast du schon mal ein neues bios versucht? bei einigen gigabyte boards der 9 serie konnte ich sleep probleme mit einem beta bios beseitigen, das „memory problems“ gefixt hat.
    iMac late 2013, 3.5ghz i7, 16gb ram, 1TB fusion drive, gtx 780m
    H A C K i N T O S H in progress :)

    kuckkuck schrieb:

    Sorry da kann ich dir nicht helfen wenn die Funktion nicht will. Frage ist ob die Abnutzung der SSD überhaupt so immens ist...?

    Ja, zur Not muss ich den höheren Verschleiß in Kauf nehmen.

    kuckkuck schrieb:

    Hast du mal im BIOS nach Settings geschaut?

    Im Export-Mode ist relativ viel einzustellen, quasi unendlich viele Werte.

    iMarc schrieb:

    sorry vllt wurde das schon gefragt: aber hast du schon mal ein neues bios versucht? bei einigen gigabyte boards der 9 serie konnte ich sleep probleme mit einem beta bios beseitigen, das „memory problems“ gefixt hat.

    Danke, der Sache gehe ich mal nach.
    Was genau heißt "bei einigen gigabyte boards..." ? Hattest du das gleiche, d. h. das von mir beschriebene Problem?
    Hallo Kuckuck,

    das würde ich gerne mal testen mit Hibernatemode 25!

    Leider war bei dem Versuch das Sleepimage wieder veränderlich zu schalten das Problem, dass im Ordner VM/VAR nix mehr drinnen ist :)

    Wie kann eines erstellen und dann das Ganze testen - ja, ich weiss ich kann Google fragen...aber weil Du gerade dabei bist..bitte..bitte :)

    Quellcode

    1. sudo touch /var/vm/sleepimage
    wenn da wirklich nichts mehr drinnen liegt..
    ich muss ehrlich sein ich hab den thread nur kurz überflogen, aber ich hatte speziel bei 9er boards dieses sleep bzw wake/crash problem wie du es beschreibst. die hacks waren für freunde, das letzte board das ich auswendig weiß war das h97-hd3 und dafür gabs ein beta bios das memory probleme fixt - bzw gabs eben für viele gigabyte boards ein besagtes beta bios. mit dem hats dann funktioniert. solch nicht heißen dass das auch bei 7er boards funzt.

    edit: gigabyte.de/Motherboard/GA-Z77X-UP5-TH-rev-10#support-dl

    ab F10 dürfts tatsächlich interessant werden für dich. drück dir die daumen ;)
    iMac late 2013, 3.5ghz i7, 16gb ram, 1TB fusion drive, gtx 780m
    H A C K i N T O S H in progress :)

    Neu

    @iMarc
    Danke für die Info. Ich habe sogleich nach den verschiedenen BIOS Versionen geschaut.
    Allerdings verwende ich bereits seit Monaten, vielmehr Jahren die aktuelle Version F12.
    Einzige Hoffnung ist, dass die Sache mit dem Memory aus F10 dort unterschlagen wurde?

    Es gibt auch eine F13 Beta Version. Mit der werde ich es dann in jedem Fall versuchen.

    Wie gesagt, die RAM Riegel scheinen alle völlig okay und die Steckplätze des Mainboards ebenfalls.

    Crashes treten nur in Verwendung von 32 Gb RAM auf...

    Neu

    hm. kannst du evtl testen ob das unter windows auch passiert? bin noch immer nicht zum lesen gekommen, sorry falls ihr das schon durch hattet
    iMac late 2013, 3.5ghz i7, 16gb ram, 1TB fusion drive, gtx 780m
    H A C K i N T O S H in progress :)

    Neu

    Nene, mach ruhig weiter @iMarc, sehr gute Einwände die du da hast :thumbup:

    @enjoylinus Du könntest auch mal das BIOS auf defaults zurücksetzen und lediglich die aller nötigsten Einstellungen für OS X setzen (AHCI) und schauen ob dabei ebenfalls das Problem auftritt.

    Neu

    @iMarc und @Kuckuck

    Ich habe jetzt alle modifizierten Bios Roms sowie das Beta Bios durch, leider OHNE Erfolg!
    Weiterhin habe ich es jedes Mal auch mit den Default Settings versucht, was auch nichts gebracht hat.
    Dann habe ich noch an den Memory Settings 'gedreht' soweit ich mit den Einstellungen etwas anfangen konnte,
    bzw. mir diese als sinnvoll erschienen.
    Es ist mir nicht möglich, das Problem in den Griff zu kriegen und dass obwohl der Rechner ansonsten stabil läuft
    und die RAM Riegel i. O. sind.
    F CK...!

    Neu

    hmm..
    schon mal den ram getestet ob der ok ist? und ich würd auch mit windows oder linux probieren.. wenns dort auch auftaucht is es zumindest mal kein hackintosh problem mehr. evtl motherboard oder eben ram
    iMac late 2013, 3.5ghz i7, 16gb ram, 1TB fusion drive, gtx 780m
    H A C K i N T O S H in progress :)