Generelle Fragen zu DSDT

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Generelle Fragen zu DSDT

    Ich habe mir ein Hackintosh zusammen gebastelt und OSX 10.10 mit Clover drauf installiert. Graka lief von Anfang an und Netzwerkkarte hatte ich mit einen tool aus dem Download-bereich direkt ans laufen bekommen. Aber das audio will nicht und das Starten dauert noch recht lange. Im Vergleich zum iMac 2009 fast doppelt solange. Noch was herum Gesuche und Tipps drauf gestoßen, dass ich die DSDT anpassen muss.

    Erst mal ein kurze Frage zwischen durch... Ist es einfacher eine PCI Audio-karte wofür es Treiber gibt - sprich M-Audio Audiophile - zu installieren? Oder ist das genau so schwierig?

    Also zum Audio, da habe ich einiges rumprobiert und ich denke ich werde den Hacky mal neu installiere um das ganze mal auf null zu setzten.

    Zum DSDT. Ich habe mir die Anleitungen im Wiki mal durchgelesen und stoße da gegen einige Probleme. Ich habe mir das tool MaciASL 1.4 (269) herunter geladen. Dass müsste die neuste Version sein. Dann die Repository eingetragen die hier im Wiki stehen. Allerdings kann er davon einige nicht finden. Weiterhin, was mache ich mit dem Asus P5K se der ein Intel P35 Chipset hat? Hier bin ich jetzt auf einem GB- PH67A-D3-B3 am werkeln. Dann wenn ich Compile drücke, oder nur speicher möchte, bekomme ich Fehler angezeigt, 6 an der zahl. Im Wiki steht was von einfach löschen. Das geht auch bei 3, aber bei den anderen 3 nicht, weil dort erscheinen dann wieder neue Fehler.

    Dann habe ich mir von der Verbotenen Seite mal eine DSDT Datei für genau dieses Mainboard mit dieser Bios Version runter geladen. Resultat: Kernel Panic beim hochfahren. ACPI Error, der gleiche Fehler wie bei meinem MSI Mainboard wo ich noch gar nichts ans laufen bekommen habe. Aber zurück zum Gigabyte und DSDT. Was kann ich jetzt als nächstes tun um Fehler zu beseitigen?

    1) zu M-Audio Audiophile: nutze die Hersteller Treibern, diese werden arbeiten:siehe hier: m-audio.com/support/download/drivers/firewire-osx-1.10.3

    2) lade deine DSDT als Zip Datei hier hoch
    (kann dir die DSDT erst heute Abend fertig machen, im Moment komme ich nicht an meinen Hackintosh drann )
    wenn du die DSDT selber patchen möchtest, dann benutze die aktuelle MacIASl version (RehabMan-MaciASL-2017-0117.zip) , siehe hier: bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/
    generiere damit eine neue DSDT, anschließend compile diese dsdt. Eine nette Auswahl an patches für MacIASL sind die patches von pjalm, diese nutze ich persönlich gerne, siehe hier: bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/[/url]
    sourceforge.net/p/maciasl/wiki/Repository Index/

    @Nightflyer :danke: habe es getutet

    GA 990 FXA-UD3 - AMD Phenom II X6 1100T - GTX 550 TI 3 GB - WIN 7 - and OS X 10.11.6
    P&B AMD APU 2500 RADEON HD 8250 - Windows 8.1 and OS X 10.11.6
    IMac12.1 4 GB RAM-500-GB-HDD-AMD Radeon HD 6750M, OS X 10.9.5 - OS X 10.11.6
    hat leider die letze Renovierung nicht ganz überlebt, Frontscheibe und Display sind defekt.
    --- keine Auskunft wenn Distros benutzt werden --- :pics:

    Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von „spakk“ ()

    @spakk
    Bitte keine Vollzitate wenn du direkt antwortest :)
    Meine Systeme
    Spoiler anzeigen
    Midi Tower Fractal Define R4 - 10.12.6 und High Sierra 10.13
    Z97X-UD3H, i5 4590 4x 3.30GHz, Samsung EVO 960 - WLAN+BT: BCM94360CD 16GB Ram,
    2048MB Radeon R9 270X, Clover aktuell
    Z77m-d3h v1.1
    i5 3570k, gtx 650ti, 12 GB Ram, 12.13 Beta (17A315i) auf APFS
    OZMOSIS
    HackBook:
    T420 * i5 2540M * HD3000 * 8GB DDR3 * 10.12.5 + macOS High Sierra APFS
    Clover
    In Arbeit: MSI Z370 - i5 8400 -16GB - Samsung Evo 960 - GTX 960 -WLAN+BT: BCM94360CD
    Clover aktuell - 10.13+Win 10

    iPhone5 Black 64GB
    @spakk die von die verlinkte MaciASL ist die 1.31 (252.3). Die die ich habe ist die 1.4 (269), die habe ich von sourceforge.net/projects/maciasl/

    Schon seltsam. Jetzt wo ich in den Einstellungen nachsehe geht die 1.4 nur auf ACPI 4 5.0 und 5.1. Die 1.31 geht auf ACPI 6.1 und macht nur noch 2 Fehler statt 6. Die anderen Fehler stehen jetzt als Warnings drin.

    Ich würde die schon gerne selber Patchen, damit ich weiß was ich mache. Ist ja nicht der einzige mac den ich habe... :D Ich habe mir jetzt die von dir verlinkte MaciASL auf jeden Fall installiert und die Repository zugefügt. Allerdings findet er von denen nichts. Wenn ich die Repositories mit HTTP:// schreibe kommt etwas, aber das sind alles nur HTML Seiten. Mach ich da was Falsch? Wenn ich z.b. das Gigabyte Repository nehme ist das doch: "http://pjalm.info/repos/gigabyte"

    Das laden der DSDT macht er ja beim starten von MaciASL automatisch, oder? Ich habe zumindest im Clover bootloader - wie im Wiki beschrieben - auf F4 gedrückt um die DSDT in der EFI zu erzeugen.

    Das erinnert mich an das Kompilieren eines Linux Kernels...
    warnungen kannst du getrost vernachlässigen.
    pjalm.info/repos/gigabyte muss neben den anderen Repositories in maciasl unter einstellungen mit eingefügt werden. Da ich des öffteren für unterschiedliche hackintoshes dsdt's generiere, habe ich alle Repositories aus pjalms webseite eingefügt
    Das generieren der DSDT mittels F4 Taste während des bootens mittels Clover ist schon Okay, aber du kannst es natürlich auch mittels MacIASL.app generieren.

    lade mal die beiden Fehlern hier hoch, mal schauen ob ich dir sofort Lösungsvorschläge zur beseitigung der fehlern geben kann
    klicke entsprechend auf die Zeile im Compiler und füge auch die entsprechende Zeile aus der DSDT hier an
    GA 990 FXA-UD3 - AMD Phenom II X6 1100T - GTX 550 TI 3 GB - WIN 7 - and OS X 10.11.6
    P&B AMD APU 2500 RADEON HD 8250 - Windows 8.1 and OS X 10.11.6
    IMac12.1 4 GB RAM-500-GB-HDD-AMD Radeon HD 6750M, OS X 10.9.5 - OS X 10.11.6
    hat leider die letze Renovierung nicht ganz überlebt, Frontscheibe und Display sind defekt.
    --- keine Auskunft wenn Distros benutzt werden --- :pics:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „spakk“ ()

    Die richtigen Versionen findet ihr hier in unserem Downloadbereich inklusive Patch für die Repos.

    MaciASL
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    Apple MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    Apple MacBook Air 5,2:
    Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)

    :hackintosh:
    Was man vielleicht beachten sollte ist die ACPI Specification. Stellt man die, die installierte BIOS Version verwendet, kriegt man weniger Fehler und Warnungen.
    Z.B. mein BIOS verwendet 5.0A und diese habe ich in Präferenzen von MaciASL eingestellt.
    Ich habe ja die Repositories eingetragen, aber sie funktionieren nicht. Ich habe sowohl mit HTTP:// als auch ohne.



    Bei den mit HTTP:// erscheint dies, ohne HTTP:// kommt gar nichts. Ist es eventuell etwas anderes als HTTP://?



    Und hier die beiden Fehler. ich hab jetzt nur ein screendump, der mac ist nicht am Netzwerk angeschlossen. Der Fehler ist in 345 und 350.



    Noch was lustiges. Wenn ich den Computer eine Zeitlang nicht nutze, geht er ins standby. Soweit so gut. Er kommt allerdings nicht mehr zurück. Auch neu starten hilft nicht, ich muss das BIOS per Jumper resetten um ihn wieder ans laufen zu bringen. Wenn ich ihn nur neu starte, geht er direkt wieder aus. Habe jetzt mal die Stanby Zeit auf Nie eingestellt.

    Unter ACPI 6.1 hab ich die wenigsten Fehler. Wie weiß ich welche ACPI-Version ein Mainboard benutzt? Und wie sieht es mit meinem 10 Jahre alten ASUS aus?
    Hallo Roman78,

    Die org.rehabman.githib.MaciASLv1.31.plist aus unserer Anleitung möchtest du nicht nutzen?
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    Apple MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    Apple MacBook Air 5,2:
    Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)

    :hackintosh:
    Meinst du diese hier? Die habe ich auch schon mal unter der 1.4 eingegeben. Aber bis auf das ALC bringt mir das doch nicht all zu viel, oder? Dies sind die die ich in der WIKI gefunden habe. Oder stehen da noch irgendwo andere?

    ALCInject - Toleda raw.github.com/toleda/audio_ALCinjection/master
    HDMI-8Series - Toleda raw.github.com/toleda/audio_hdmi_8series/master
    HDMI-9Series - Toleda 9 raw.github.com/toleda/audio_hdmi_9series/master
    Laptops - Rehabman raw.github.com/RehabMan/Laptop-DSDT-Patch/master
    Wifi-Half-Mini - Toleda raw.github.com/toleda/wireless_half-mini/master
    Ich meinte das hier



    aus dem Downloadbereich. Damit hast alle Repos die benötigt werden.
    Spoiler anzeigen

    iMac (27 Zoll, Ende 2012):
    ASUS P8H77-M PRO, Intel i7 3770 Quadcore, Corsair CMY8GX3M2A1866C9B Vengeance Pro Series 8GB, STRIX GTX950 ,Logitech HD WEBCAM C310
    Apple MacBook Pro (8,1 Early 2011): HP EliteBook 8460P, Intel Core i7-2620M, AMD Radeon HD 6470M, Intel SSD,Arbeitsspeicher: 8 GB (2x4GB) RAM
    Apple MacBook Air 5,2:
    Dell Latitude E6330, Intel Core i7-3520M mit HD4000, Arbeitsspeicher: 8 GB (2x4GB) RAM,128 GB Micron RealSSD (C400)

    :hackintosh:
    Oh-Ha... die hab ich übersehen. Hau ich da gleich mal rein.

    /Edit: Gefunden. Da die nicht unter DSDT steht, sondern in Tools hab ich die nicht direkt gefunden.

    /edit2: Jetzt kommt MaciASL mit der Fehlermeldung: Code 6126: Input file does not appear to be an ASL or data table source file

    /edit3: Nach neustart scheint MaciASL wider zu funktionieren. Aber ich hab keine neuen Repositories.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Roman78“ ()

    Installier bitte die MaciASL Version 1.3, die auch in dem von G4_Hacker gezeigten Thread hochgeladen ist. Die ist was die iASL Version angeht soweit ich weiß sogar neuer und macht normal keine Probleme beim öffnen von DSDTs ;)
    Im Link von G4_Hacker ist keine 1.3, nur die 1.4 (269) und die 1.31 (252.2). Oder hab ich da wieder was übersehen? Hab jetzt diese beide Versionen drauf. Allerdings kommt die Plist irgendwie nicht in die Sources liste rein. Ich habe die plist, wie beschrieben, bei nicht gestarteten Programm in den Ordner ~/Library/Preferences kopiert und anschließend das Programm gestartet. Aber die repositories tauchen nicht auf. Auch wenn ich auf "Patch" gehe, stehen da nur die Daten von denen die ich per Hand eingegeben habe. Und es scheint, als ob pjalm die Daten nicht mehr bereit stehen hat, oder verschoben hat.
    Das Problem liegt daran, dass du vor dem kopieren der plist nach ~/Library/Preferences bereits eine der Maciasl-Versionen geöffnet hattest.
    Somit wird der Inhalt der kopierten Datei nicht angenommen.
    Ich empfehle einen Neustart, um dann die plist zu kopieren, bevor du Maciasl 1.31 erneut öffnest.
    Gruß
    Al6042

    GA Z270-HD3P F7 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.1 | Clover 4297
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13.1 | Clover 4297
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13.1

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    hab ich ja gemacht. Warte mal 30 Minuten. ich mach das Ding mal platt.

    /edit... Jetzt will der nicht mehr installieren. Kann BaseSystemBinaries.pkg nicht extrahieren.

    /edit2: Ich glaube mein Stick hat ein Schatten. Auch auf einem anderen PC will der nicht mehr.

    /Edit3: So. Ich bin jetzt zuhause auf meinem Asus P5K SE. Hie geht es mit der Plist. Aber auf dem habe ich kein internet. Ich bekomme die Atheros L1 nichts ans laufen. Und MaciASL kann die DSDT nicht einlesen. Nicht über das ACPI als noch direkt aus der Datei. Kann es sein, dass das mainboard zu alt ist?

    Dies ist der Fehler wenn ich es direkt von MaciASL aus dem ACPI lesen lasse:


    Und dies ist der Fehler wenn ich die von Clover generierte Datei einlesen lasse:


    Und dies ist die Datei. Vielleicht kann mir dabei jemand helfen.
    DSDT.aml

    Und was mir auch aufgefallen ist - nun ja aufgefallen ist gut - wenn ich auf dem Mainboard ein Core2Quad installiere booten es, wenn ich ein Xeon installiere bleibt er während des booten hängen mit dieser Meldung bei einem Verbose boot:

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von „Roman78“ ()

    Kann mir da einer weiter helfen, so dass ich wenigstens mal diesen einen Mac zum laufen bekomme. Kann es sein, dass wenn ich nach dem kopieren einer KEXT in einen der beschriebenen Ordner, noch etwas machen muss um diesen zu aktivieren? Ich bekomme nämlich immer Meldungen, dass die KEXT nicht richtig installiert sind. Habe jetzt mal gegoogled um einen KEXT für meine Netzwerkkarte als PKG gefunden - also mit installer - und dieser geht auf Anhieb. Also Netzwerk funktioniert jetzt. Fehlt noch Audio und andere probleme hab ich noch nicht gefunden.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Roman78“ ()

    Hallo Leute,

    ich hab was interessantes app gefunden und zwar ssdtGen, das app findet die motherboard hardware automatisch und kann ssdt.aml Datei auf dem Desktop herunterladen. oder ihr könnt auch manuell hardware ssdt wählen.

    ich hab das link auch aber ich weiß es nicht ob das mit website rules stimmt

    hier ist mein Asus Z170i Pro Gaming Beispiel:

    ibb.co/ntH3aw

    Momentan ich hab HD7970 weil meine RX Vega 64 im RMA ist

    sorry for mine Deutschkenntnisse
    Welche CPU willst du denn jetzt installieren? Xeon oder Core2, du musst dich schon entscheiden...

    Häng mal bitte einfach deinen kompletten EFI Ordner an...
    @RandomTech
    Interessantes Tool, leider noch etwas eingeschränkt:
    ​—-ERROR—- This app only supports X99/Z170/Z97/H97 motherboards at the moment!

    und somit für @Roman78 nicht einsetzbar.
    Gruß
    Al6042

    GA Z270-HD3P F7 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.1 | Clover 4297
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13.1 | Clover 4297
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13.1

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!