4k/UHD über DP 1.2 an Intel HD4600

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    4k/UHD über DP 1.2 an Intel HD4600

    Guten Tag zusammen,

    gestern habe ich mit Clover meinen ersten Hackintosh aufgesetzt. Bin also absoluter Neuling. :whistling: Der Hackintosh läuft aber soweit ganz gut.

    Ich habe ein MSI B85i Mainboard mit einem i5 4440. Das Board verfügt über einen Displayport 1.2 welcher zur Verbindung zu meinem Monitor dient.
    Über Windows habe ich 4k/UHD bei 60Hz erreicht. Unter macOS habe ich 1080p bei 60Hz. Die HD4600 Grafik wird mit vollem Vram erkannt.

    Mein Ziel ist 4k/UHD bei 60Hz unter macOS. Hat hier jemand Erfahrung und kann mir einen Weg beschreiben?
    Willkommen im Forum!

    Kannst Du denn keine andere Auflösung unter Systemeinstellungen/Monitore auswählen? (mit der alt-Taste auf "Skaliert" klicken). Es kommen alle skalierten Auflösungen ohne den Zusatz "niedrige Auflösung" in Frage.
    Bilder
    • Bildschirmfoto 2017-05-19 um 10.59.26.png

      568,87 kB, 1.496×804, 36 mal angesehen
    New working horse: Gigabyte GA-Z170MX Gaming 5 BIOS F5e, i5 6600K@4GHz, Gigabyte RX460 4GB, 32 GB Ballistix Sport LT 2400 MHz, Samsung 850 Pro, TP-Link TL-WDN4800, Jonsbo UMX3, macOS 10.12.6, Clover

    Retired working horse (reliable since 2009): Gigabyte GA-EP45, E8400@3GHz, NVidia 9500GT, 8 GB DDR2 RAM, Samsung 830, Lian-Li PC-A05, OS X 10.9.5, Chameleon

    Outdoor buddy: MacBook Air 2012 11", 4GB RAM, 128GB SSD, macOS 10.13.0

    Plonker schrieb:

    Willkommen im Forum!

    Kannst Du denn keine andere Auflösung unter Systemeinstellungen/Monitore auswählen? (mit der alt-Taste auf "Skaliert" klicken). Es kommen alle skalierten Auflösungen ohne den Zusatz "niedrige Auflösung" in Frage.

    Hi, mir werden mehr Auflösungen angeboten, jedoch nur niedrigere.
    anbei ein Screenshot

    Dabei sehe ich gerade, dass der Hackintosh als iMac late 2015 (21,5 Zoll erkannt wird) Im Systembericht steht der Monitor jedoch richtig.

    @rubenszy: anbei auch die config
    Bilder
    • Bildschirmfoto 2017-05-19 um 11.33.20.png

      107,58 kB, 780×513, 27 mal angesehen
    • Bildschirmfoto 2017-05-19 um 11.36.41.png

      93,53 kB, 737×494, 24 mal angesehen
    Dateien
    • config.plist

      (5,22 kB, 4 mal heruntergeladen, zuletzt: )
    Versuche mal mit SwitchResX: madrau.com/srx_download/download.html

    Edit: Hast Du am LG-Monitor Displayport 1.2 (in Monitorsettings) aktiviert?
    New working horse: Gigabyte GA-Z170MX Gaming 5 BIOS F5e, i5 6600K@4GHz, Gigabyte RX460 4GB, 32 GB Ballistix Sport LT 2400 MHz, Samsung 850 Pro, TP-Link TL-WDN4800, Jonsbo UMX3, macOS 10.12.6, Clover

    Retired working horse (reliable since 2009): Gigabyte GA-EP45, E8400@3GHz, NVidia 9500GT, 8 GB DDR2 RAM, Samsung 830, Lian-Li PC-A05, OS X 10.9.5, Chameleon

    Outdoor buddy: MacBook Air 2012 11", 4GB RAM, 128GB SSD, macOS 10.13.0

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Plonker“ ()

    rubenszy schrieb:

    Lade mal die config hoch, da ich mal schätze das du mit einer DSDT und ssdt nicht arbeitest.


    anbei die Config!

    Plonker schrieb:

    Versuche mal mit SwitchResX: madrau.com/srx_download/download.html

    Edit: Hast Du am LG-Monitor Displayport 1.2 (in Monitorsettings) aktiviert?


    Hi, am Monitor ist Displayport 1.2 aktiv. Habe mal SwitchResX installiert. Wenn ich die Auflösung über "LG Ultra HD => Benutzerdefinierte Auflösung" einstelle kommt leider die Fehlermeldung, dass sie nicht valide ist.
    Die Informationen unter "LG Ultra HD => Bildschirminformationen" sind jedoch auch nicht richtig.
    Bilder
    • as.png

      130,88 kB, 817×600, 24 mal angesehen
    Dateien
    • config.plist

      (5,22 kB, 2 mal heruntergeladen, zuletzt: )
    HEy Jungs. Wollte gerade dasselbe Thema anfangen.

    Ich habe einen Dell 4k Monitor, den ich an einem Hackintosh betreibe. Dort über HDMI an einer GTX 950. Dort läuft das ding auch mit 4k.
    (es geht also)
    Jetzt überlege ich auf einen kompakteren Rechner ohne extra Graka zu wechseln. Habe hier ne zbox mit i7-4770s und ein brix pro mit i7-4770r.
    Bei beiden hat der Monitor nur Full HD Auflösung.

    Scheint also Schwierigkeiten mit der Intel Hardware zu geben.

    Habe auch schon so ziemlich alle Anschlussvarianten durchprobiert: HDMI DIsplay Port, Mini DisplayPort, DVI

    Spoiler anzeigen

    ShipSentenceRAMProziFestpladdeOS


    Dell E6230

    8 GB i5-3340M
    128 GB SSD
    Sierra
    Lenovo Y50-70
    8 GBi7-4710HQ512 GB SSDSierraUHD


    orbislacteus schrieb:

    HEy Jungs. Wollte gerade dasselbe Thema anfangen.

    Ich habe einen Dell 4k Monitor, den ich an einem Hackintosh betreibe. Dort über HDMI an einer GTX 950. Dort läuft das ding auch mit 4k.
    (es geht also)
    Jetzt überlege ich auf einen kompakteren Rechner ohne extra Graka zu wechseln. Habe hier ne zbox mit i7-4770s und ein brix pro mit i7-4770r.
    Bei beiden hat der Monitor nur Full HD Auflösung.

    Scheint also Schwierigkeiten mit der Intel Hardware zu geben.

    Habe auch schon so ziemlich alle Anschlussvarianten durchprobiert: HDMI DIsplay Port, Mini DisplayPort, DVI


    Unter El Capitan hat es wohl jemand geschafft. Leider bin ich technisch nicht ganz so versiert.
    reddit.com/r/hackintosh/commen…with_hd_4600_displayport/
    So die config und den kext Ordner in den Clover Ordner rein dann sollte es laufen
    Dateien
    • CLOVER.zip

      (217,52 kB, 7 mal heruntergeladen, zuletzt: )

    rubenszy schrieb:

    So die config und den kext Ordner in den Clover Ordner rein dann sollte es laufen


    Vielen Dank erstmal!
    Okay, habe EFI gemountet und denn in EFI ==> CLOVER die Datei "config.plist" ersetzt.

    Zusätzlich habe ich unter EFI ==> CLOVER ==> kexts ==> Other die 6 *.kext Dateien eingefügt. Neustart. Leider kein Erfolg - unter Monitore (Skaliert) sind leider keine neuen Auflösungen zu finden.

    edit: Unter EFI ==> CLOVER ==> kexts habe ich noch weitere leere Ordner mit OSX-Versionsbezeichnungen als Namen
    Bei mir auch kein Erfolg. Mit den Dateien hat er direkt ne bootloop hingelegt - mit Anpassungen von der alten config plist lief es dann, aber nach wie vor kein 4k. stattdessen geht jetzt der Bildschirm immer mal aus.

    Update:

    habe jetzt die Infos von der Redet Seite eingetragen und kriege jetzt automatisch die 2500 irgendwas Auflösung. mit SwitchresX kann ich auch in 4K schalten. Allerdings flackert das Bild an einigen Stellen bzw einige Icons sind verunstaltet.
    Woran könnte das liegen?

    Spoiler anzeigen

    ShipSentenceRAMProziFestpladdeOS


    Dell E6230

    8 GB i5-3340M
    128 GB SSD
    Sierra
    Lenovo Y50-70
    8 GBi7-4710HQ512 GB SSDSierraUHD


    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „orbislacteus“ ()

    orbislacteus schrieb:

    Bei mir auch kein Erfolg. Mit den Dateien hat er direkt ne bootloop hingelegt - mit Anpassungen von der alten config plist lief es dann, aber nach wie vor kein 4k. stattdessen geht jetzt der Bildschirm immer mal aus.

    Update:

    habe jetzt die Infos von der Redet Seite eingetragen und kriege jetzt automatisch die 2500 irgendwas Auflösung. mit SwitchresX kann ich auch in 4K schalten. Allerdings flackert das Bild an einigen Stellen bzw einige Icons sind verunstaltet.
    Woran könnte das liegen?


    Oh, kann ich leider nicht sagen.
    Ich kann nun Erfolg vermelden. Dazu muss ich aber sagen, dass ich die genaue Ursache dafür nicht nennen kann - insbesondere ob SwitchresX etwas beigetragen hat.

    Ich bin wie im von mir verlinkten reddet-post vorgegangen.
    1. EFI mounten und config.plist mit Editor öffnen.
    2. im Bereich "KernelAndKextPatches/KextsToPatch" folgendes einfügen.

    Quellcode

    1. <dict>
    2. <key>Comment</key>
    3. <string>framebuffer4K</string>
    4. <key>Find</key>
    5. <data>
    6. AwAiDQADAwMAAAACAAAwAQ==
    7. </data>
    8. <key>Name</key>
    9. <string>AppleIntelFramebufferAzul</string>
    10. <key>Replace</key>
    11. <data>
    12. AwAiDQADAwMAAAAEAAAAAw==
    13. </data>
    14. </dict>


    Eigentlich steht hier dabei, dass das Ganze nur 4k@30Hz freischalten soll. Doch es sind 60Hz, da bin ich mir sicher. Wird auch so angezeigt. Es kann sein, dass das an dem SwitchresX-Profil liegt, was ich zuvor schon für meinen Monitor angelegt hatte. Dort steht auch 4k@60Hz

    Hier nochmal der reddit link:
    reddit.com/r/hackintosh/commen…with_hd_4600_displayport/
    Hmmm vermutlich hat es das bei mir auch gebracht.
    Aber in den Systemeinstellungen selber taucht die Auflösung nicht auf. ich kann sie nur über switchresX einstellen. Geht das bei dir nativ?

    Ansonsten habe ich einen Dell Monitor, der laut aussage einiger Bewehrter bei Amazon zum Beispiel an MacBook Pros nur mit 30 Herz laufen soll, weil irgendwie nur ein Kanal verwendet wird von MacOS oder sowas. weiß nicht mehr genau. Insofern wäre es nicht überraschend, wenn es bei 30 Hertz bleibt.

    Bei meinem anderen PC, wo es über die Geforce Grappa geht, kriege ich bei em Monitor gar keine Auflösungsauswahl mehr. nur eine Skalierungsauswahl.

    Spoiler anzeigen

    ShipSentenceRAMProziFestpladdeOS


    Dell E6230

    8 GB i5-3340M
    128 GB SSD
    Sierra
    Lenovo Y50-70
    8 GBi7-4710HQ512 GB SSDSierraUHD


    orbislacteus schrieb:

    Hmmm vermutlich hat es das bei mir auch gebracht.
    Aber in den Systemeinstellungen selber taucht die Auflösung nicht auf. ich kann sie nur über switchresX einstellen. Geht das bei dir nativ?

    Ansonsten habe ich einen Dell Monitor, der laut aussage einiger Bewehrter bei Amazon zum Beispiel an MacBook Pros nur mit 30 Herz laufen soll, weil irgendwie nur ein Kanal verwendet wird von MacOS oder sowas. weiß nicht mehr genau. Insofern wäre es nicht überraschend, wenn es bei 30 Hertz bleibt.

    Bei meinem anderen PC, wo es über die Geforce Grappa geht, kriege ich bei em Monitor gar keine Auflösungsauswahl mehr. nur eine Skalierungsauswahl.

    Bei mir sieht es bzgl. des Monitors auch ziemlich wild aus im System. Anbei ein paar Screenshots - so sieht es Momentan bei mir aus.

    Die Auflösung wirklich wechseln kann ich auch nicht. Nur die Skalierung. Wenn ich dort auf "Mehr Fläche" gehe zeigt er mir links die Info "Sieht aus wie 3840 x 2160".
    Bilder
    • Bildschirmfoto 2017-05-20 um 11.51.28.png

      92,25 kB, 1.162×824, 13 mal angesehen
    • Bildschirmfoto 2017-05-20 um 11.51.56.png

      343,69 kB, 1.516×992, 14 mal angesehen
    • Bildschirmfoto 2017-05-20 um 11.52.40.png

      392,17 kB, 1.516×996, 15 mal angesehen
    • Bildschirmfoto 2017-05-20 um 11.53.34.png

      207,44 kB, 1.478×996, 14 mal angesehen
    Ist doch genauso, wie es sein sollte. Du hast volle UHD-Auflösung, 60Hz, die Skalierung kannst Du je nach Sehvermögen wählen.
    New working horse: Gigabyte GA-Z170MX Gaming 5 BIOS F5e, i5 6600K@4GHz, Gigabyte RX460 4GB, 32 GB Ballistix Sport LT 2400 MHz, Samsung 850 Pro, TP-Link TL-WDN4800, Jonsbo UMX3, macOS 10.12.6, Clover

    Retired working horse (reliable since 2009): Gigabyte GA-EP45, E8400@3GHz, NVidia 9500GT, 8 GB DDR2 RAM, Samsung 830, Lian-Li PC-A05, OS X 10.9.5, Chameleon

    Outdoor buddy: MacBook Air 2012 11", 4GB RAM, 128GB SSD, macOS 10.13.0
    Dann machen wir doch schon mal den grünen Haken locker und freuen uns mit dir... :)
    Gruß
    Al6042

    GA Z270-HD3P F7 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.1 | Clover 4297
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13.1 | Clover 4297
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13.1

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Ja, diese Anzeige habe ich bei der GeForce auch. Habe die auf die Größte Fläche eingestellt. Laut switchresx ist das aber nur wie 3000x irgendwas. Auf 3840 könnte ich auch nur mit dem Hilfsprogramm umstellen.

    Spoiler anzeigen

    ShipSentenceRAMProziFestpladdeOS


    Dell E6230

    8 GB i5-3340M
    128 GB SSD
    Sierra
    Lenovo Y50-70
    8 GBi7-4710HQ512 GB SSDSierraUHD