Lenovo ThinkPad T460s macOS Installation

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Lenovo ThinkPad T460s macOS Installation

    Habe versucht meine neue Errungenschaft mit zu installieren ja es ging voran mit den Clover Daten
    von @al6042 jedoch konnte ich nicht durch installieren da mir die macOS Installation immer mitteilte ich hätte keinen Netzteil dran.
    testhabe aus Frustration habe ich zu eine distro gegriffen um zu sehen ob es funktioniert siehe es läuft
    natürlich habe ich es wieder runtergeschmissen und probiere eine normale clean Setup zu machen wie es sich gehört jedoch scheitere ich an dem selbigen Problem.
    ah ja auf die verbaute SSD wurde auch keine EFI partition automatisch angelegt diese musste ich manuell anlegen.

    Kann mir da einer weiterhelfen ?


    EDIT DA KEINE PROBLEME MEHR BESTEHEN ANBEI IMMER AKTUEL MEIN CLOVER ORDNER STAND 15.11.17 Clover 4297 06.05.2018 Clover 4449 HS 10.13.4 (17E202)
    Bilder
    • Bildschirmfoto 2018-05-06 um 21.47.19.png

      133,67 kB, 583×355, 2 mal angesehen
    Dateien
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden

    Dieser Beitrag wurde bereits 8 mal editiert, zuletzt von „Ka209“ ()

    Ich hoffe du hast bei der Nutzung meiner Clover Daten die DSDT.aml nicht eingesetzt...
    Andererseits wäre es doch tatsächlich mal spannend gewesen, was für ein Clover-EFI-Konstrukt durch deinen Test genutzt wurde.
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    @al6042 Natürlich habe ich die DSDT und SSDT rausgeschmissen

    aktuell sieht der Clover Ordner wie in Anhang aus in diesem befindet sich auch gerade
    erstellte saubere DSDT mit F4

    EDIT

    als anlage noch die DPCI datei und IOReg Datei
    Bilder
    • Bildschirmfoto 2017-04-16 um 15.19.32.png

      141,22 kB, 633×549, 56 mal angesehen
    Dateien
    • CLOVER T460s.zip

      (17,49 MB, 12 mal heruntergeladen, zuletzt: )
    • T460s.ioreg.zip

      (1,83 MB, 16 mal heruntergeladen, zuletzt: )
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Ka209“ ()

    Cool... nach der IOREG wollte ich gerade fragen... :)

    EDIT:
    Weisst du zufällig die genaue Bezeichnung deines AudioCodecs und ist die im IOREG hinterlegte Layout-ID 0x0b (11) funktionell?
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „al6042“ ()

    ja sollte funtioniren da eine soundausgabe vorhanden war

    jedoch weis ich nicht ob die distro irgendwelche voodos dafür verwendet hatte
    da ich die dateien unter der testdistro erstellt hatte
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden
    Ich habe hier mal die detaillierten Specs gefunden:
    psref.lenovo.com/syspool/Sys/P…atform_Specifications.pdf
    Dabei sprechen die von einer ALC3245, die als ALC293 gelten sollte.
    Dort gibt es nur layout-ID 28 oder 29.
    Mit letzterer habe ich die beiliegende DSDT versehen...
    Viel Erfolg...
    Dateien
    • DSDT.aml

      (70,72 kB, 7 mal heruntergeladen, zuletzt: )
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „al6042“ ()

    Mit diese combi hatt es keine funktion das T460 und T460s sind nicht gleich

    trotz. desem sind anscheinend die audio chips geleich aber mit dem hinterlegten
    geht es nicht kannst du mir die 11 hinterlegen bitte

    Edit

    Jedoch ändert dieses auch nicht an der Situation das bei jeder insterlations versuch es behauptet das es nicht am strom angeschlossen ist

    Die meldun lautet wie folgt "Der Computer ist nicht an die Steckdose angeschlossen"

    habt ihr keine Idee @griven @al6042
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Ka209“ ()

    Ich bin gerade Feiertags bedingt nicht zuhause und kann erst heute Abend wieder danach schauen.
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    ah gut
    sorry wollte dich nicht stören danke schon mal in voraus
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden
    Kein Ding...
    kannst du bitte schonmal eine Linux-Live-Variante booten und per Terminal den genaueren AudioChip ausfindig machen?
    Hier nochmal die Linux Befehle:

    Quellcode

    1. cat /proc/asound/card0/codec#0 > ~/Desktop/codec00_dump.txt
    2. cat /proc/asound/card0/codec#1 > ~/Desktop/codec01_dump.txt
    3. cat /proc/asound/card1/codec#0 > ~/Desktop/codec10_dump.txt
    4. cat /proc/asound/card1/codec#1 > ~/Desktop/codec11_dump.txt


    BTW:
    Das T460s unterscheidet sich im Audio-Kram wenig vom T460:
    psref.lenovo.com/syspool/Sys/P…atform_Specifications.pdf
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Und nich habe hier: DSDT.aml mal die Patches für AC Adapter (AC Adapter fix) und die Akku Anzeige eingebaut. Zusammen mit dem ACPIBatteryManager.kext sollte der Akkuladestand angezeigt werden ohne den Kext sollte zumindest erkannt werden ob das Netzteil dran hängt oder nicht.
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.3
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.3, Windows10 Pro 64Bit

    mit der dsdt komme ich leider nicht weit


    live linux versuche ich gerade bereitzustellen dann kommen auch die infos
    Bilder
    • IMG_3399.JPG

      3,26 MB, 3.264×2.448, 37 mal angesehen
    • IMG_3400.JPG

      2,06 MB, 3.264×2.448, 24 mal angesehen
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden
    Die gezeigte Panik bezieht sich auf die IGPU und das kann eigentlich kaum im Zusammenhang mit dem DSDT Patch stehen denn die an den Bereichen wurde gar nicht geschraubt. Sehr merkwürdig. Naja hier mal eine Version die nur den AC Adapter Fix enthält und sonst nichts.
    Dateien
    • DSDT.aml

      (67,47 kB, 3 mal heruntergeladen, zuletzt: )
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.3
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.3, Windows10 Pro 64Bit

    also kaum füge ich eine dsdt anbei auch die unbearbeitete startet das system nicht KP
    ohne startet es mit der clover Einstellungen sauber durch nur die Grafik ist nich vollständig da mit 7mb

    mit der letzten dsdt @griven von dir besteht die meldung die im anhang ist

    habe mal komplett neue dsdt wieder generirt und lege die komplette origin ordner anbei

    und die von @al6042 gewünschte linux datei
    Bilder
    • IMG_3401.JPG

      2,15 MB, 3.264×2.448, 40 mal angesehen
    Dateien
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Ka209“ ()

    Das DSDT Thema scheint ein Clover Problem zu sein. Du bist inzwischen der 3. mir bekannte Fall bei dem das passiert. Gestern beim Stammtisch hatten wir einen Fall wo ein Rechner die DSDT nicht fressen wollte (Kernelpanik) dann ist es bei @connectit zugegeben auf einem KabyLake aber tut der Sache ja keinen Abbruch zu dem exakt selben Verhalten gekommen (KP sobald eine DSDT in /patched liegt selbst beim Original) und jetzt auch bei Dir...
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.3
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.3, Windows10 Pro 64Bit

    Gibt es denn keine andere alternative um AC Adapter Fix durchzuführen einen kext oder einen
    KextsToPatch eintrag
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden
    Ich habe in beiliegender DSDT mal den AC Adapter Fix weg gelassen.
    Die ALC293 aus deinem Linux Text-File wird in AppleALC eigentlich mit ID 28 oder 29 betrieben.
    Habe aber trotzdem ID 11 stehen lassen.

    Wegen dem Fehler mit dem AppleIntelSKLGraphicsFramebuffer:
    Denn kenne ich nur, wenn ich das Ideapad vom Install-Stick oder von der Recovery HD starten möchte.
    Dafür muss ich kurzfristig die ig-platform-id 0x12345678 in den "Options" des Clover-Bootmenüs eintragen.
    Dateien
    • DSDT.aml

      (70,71 kB, 1 mal heruntergeladen, zuletzt: )
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    leider klapp es damit auch nicht.
    Wie gesagt sobald ich eine dsdt oder ssdt einfüge geht es nicht weiter.
    mit dem Frampuffer ebenfalls kann eintragen was ich möchte es bleiben bei den 7mb

    der wichtigere paart währe das ich eine clean install schaffe dieses geht leider nicht da das system immer behauptet ich hätte keinen netzteil angeschlossen gibt es den dafür keinen kext oder so ohne es in die dsdt einzutragen so das es läuft ?
    System: Mac mini 5.1
    Spoiler anzeigen
    Fujitsu Q900 Mac mini 5.1 ---Intel i5-2520M Intel HD 3000 --Intel QM67 -Wifi - BT AR9285 DW1510- AR3011 High Sierra 10.13.2 - Clover (immer akt.) EFI


    System: MacBookPro 13.1 T460s
    Spoiler anzeigen
    Lenovo T460s -- i5-6200U 2,6 GHz -- 8 GB RAM Intel HD520 macOS 10.13.2 -- DW-1830/ Windows 10Pro - Clover (immer akt.) DSDT.aml
    Ein Like ist ein Zeichen des Respekts gegenüber dem Helfenden
    Nope es gibt keinen Kext der den AC-Adapter quasi faked das passiert über ACPI Aufrufe also letztlich über die DSDT trotzdem ist das ein interessantes Problem. Was passiert denn wenn Du einige Clover Versionen zurück gehst sprich mal so in die Richtung: Clover v2.4k r4012
    System 1 (iMac 13,1) PowerMac G5 Case: GA-Z77-DS3H, Clover, Intel XEON E3-1235V2 @ 3.2 GHz, 32GB DDR3, Powercolor R9-290X , Samsung 850 EVO 500GB + WD Caviar Blue 1TB, OS X 10.13.3
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot MacOS Siera 10.12.6,MacOS HighSierra 10.13.3, Windows10 Pro 64Bit

    Versuche es mal mit dem FIX_ADP1_800000 in Clover unter Acpi -> DSDT Fixes -> 2.
    Gruß
    Al6042

    GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4644
    GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4644
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!