Quicksync, Virtual-Screen Abstürze und iGPU+ded. GPU mit Grafikbeschleunigung

    Forum Unterstützen

    Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

    Team

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

      Also ich habe zwar die RX560 aber das sollte egal sein.
      Im Clover habe ich unter Boot - Custrom Flags noch die Variable shikigva=32 eingesetzt und damit lief bei mir iTunes und Netflix.
      Netflix und Amazon Video kriegst du die Filme nicht in HD angezeigt. Nur die Serien. Hat bei keinen wirklich funktioniert.
      Probier's mal.
      mit "shikigva=1" funktioniert jetzt alles. Hatte das wohl übersehen. Danke nochmals an das Forum, sehr toll hier!
      bei mir klappt Netflix und co nur in Chrome... Wenn es in Safari nicht klappt einfach mal in Chrome versuchen...
      Hackintosh I: GA-Z170X-UD5 TH - Intel Core i7 6700K 4x 4.00GHz So.1151 GA RX 460 und Intel 530 für QS

      Hackintosh II (Office"Mac" für den Vater): GA-Z170-HD3 (Bios F20) -Intel Core i5 6500 Intel 530
      Funktioniert in allen Browsern, Netflix und Co. Unterschiede sind; Serien in HD, Filme nicht oder sogar nur Teilweise.
      Update auf 10.13.6 final: Muss jetzt die ig-platform-id 50120000 zusätzlich zur FakeID 0x3e928086 eintragen, damit FinalCut ordentlich läuft. In der beta ging es damit gerade nicht, nun stürzt der Rechner ab, wenn ich sie weglasse. Was hat Apple bloß zwischen letzter beta und der final geändert? Naja, es läuft :)

      Edit: Leider nicht so richtig ;) Mit der id 50120000 stürzt er leider beim Exportieren ab, mit der headless 0003 nicht, aber dafür ruckelt's halt wieder beim Abspielen (so wie 10.13.5).

      Überlege, bei der 10.13.6 beta 5 zu bleiben. Unter der Mojave-beta läuft's nämlich auch rund. Warum laufen die betas zuverlässiger als die final versions?

      Nebenbei: iTunes DRM funktioniert bei mir nur, wenn die IGPU headless drin. Da ist mir FinalCut aber wichtiger :)
      Spoiler anzeigen
      iMac17,1: Asrock H370M-ITX/ac, Core i7 8700, Gigabyte AMD Radeon RX560, Intel UHD630, 16 GB RAM, BCM943602BAED (DW1830) Wifi/BT, 1 TB Samsung PM961 NVMe, OS: macOS 10.14 beta

      MacBookPro9,2: HP Elitebook 2170p, Core i5 3427U, 8 GB RAM, Intel HD4000, BCM94352HMB (Azurewave AW-CE123H) Wifi/BT, 512 GB Samsung EVO 850 SSD, OS: macOS 10.13.6

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „macinsane“ ()

      @macinsane
      wird das disablegfxfirmware Bootflag noch benötigt oder ist es ggf. sogar schädlich in diesem Zusammenhang, weil es irgendetwas wichtiges deaktiviert?
      iMac (iMac18,3):
      Intel Core i7-8700K | Gigabyte Z370N WIFI | Corsair Vengeance LPX 16GB DDR4-3000 | Sapphire Pulse ITX Radeon RX 570
      Samsung SSD 960 EVO 250GB, M.2 | Corsair Force Series MP500 120GB, M.2 | Crucial MX300 1TB, SATA
      Dr. Zaber Sentry Black | Corsair SF450 450W SFX12V | Dell DW1830 BCM943602BAED Wifi + BT | LG 2788B-W
      macOS 10.13.6 | Windows 10 Professional
      Hab's gerade mit der Mojave PB2 ausprobiert und weder IntelGraphicsFixup.kext noch der -disablegfxfirmware Schalter sind noch nötig. Genau genommen fährt er mit Mojave sogar ohne FakeID ganz normal hoch.
      Hach, es ist ein Kreuz mit Final Cut. Jetzt habe ich zwei config.plists: Mit der einen ist die Intel aktiviert und Final Cut ist benutzbar und schnell und mit der anderen ist die Intel headless drin, weil ich sonst beim Exportieren Artefakte im Video habe. Mit der ich also nur zum Exportieren hochfahre muss. Das ist nicht besonders convenient, aber Hackintosh ist halt kein echter Mac... Mmpf.

      Egal, was zu dem Thema bisher geschrieben wurde, die Intel headless wird bei mir NICHT zum Rendern genutzt, er fällt eindeutig komplett auf den Software Renderer zurück und lässt die Radeon alleine arbeiten, im Grunde könnte man die Intel im BIOS auch deaktivieren. Die headless Option (0003) führt dazu, dass man iTunes benutzen kann, aber bei Final Cut nützt sie NICHTS.


      EDIT:
      Endlich mal wieder eine Erfolgsmeldung! Alles zum Laufen bekommen unter der Mojave PB2. Wie?
      Habe eine neue DSDT gepatcht, in der die RX560 mit allen Anschlüssen und Acre-Framebuffer eingetragen ist (mal angehängt, falls sich das jemand anschauen will) und SMBIOS gewechselt auf iMac17,1 (mit iMac14,2 geht es im Prinzip auch, aber die Monitorausgabe über DP ist unschön). Fake-ID 3e928086 und die headless 59120003 eingetragen. Nun tut Final Cut wie es soll, in der Preview und der Timeline arbeitet die HD630 mit (schaltet eben auch in den Turbo bei 50p oder 4k-Material), kein Ruckeln mehr, und beim Rendern dreht die Radeon nun voll auf. Mit der iMac18,1 oder 18,2 SMBIOS, die für mein System eigentlich passender wäre, und ohne DSDT geht das alles nicht.

      Ich hoffe sehr, dass Apple für die Mojave-Final nicht wieder alles komplett ändert. Daher werde ich mal die jetzt verwendeten KBL- und Radeon-Kexte sichern, was ich bei der 10.13.6 beta leider versäumt habe ;)

      ZUSATZ:
      Das ging schnell: Bei der PB3 ist natürlich gleich alles anders ;) Da die nun CoffeeLake-Kexte enthält, kann man die 3e92-FakeID nicht mehr verwenden, sondern muss 51928086 eintragen, um die KBL-Kexte zu laden. Damit funktioniert es aber weiterhin wunderbar, schaue aber trotzdem demnächst mal, wie man die CL-Kexte headless ansprechen kann. Fast vergessen: Damit das alles läuft, darf man Shiki NICHT laden. Sobald Shiki mit einem beliebigen -shikigva Kommando geladen ist, kann man zwar iTunes Filme anschauen, aber FinalCut nutzt die Intel nicht mehr. Man hat also die Wahl ;)
      Dateien
      • DSDT.aml

        (252,82 kB, 1 mal heruntergeladen, zuletzt: )
      Spoiler anzeigen
      iMac17,1: Asrock H370M-ITX/ac, Core i7 8700, Gigabyte AMD Radeon RX560, Intel UHD630, 16 GB RAM, BCM943602BAED (DW1830) Wifi/BT, 1 TB Samsung PM961 NVMe, OS: macOS 10.14 beta

      MacBookPro9,2: HP Elitebook 2170p, Core i5 3427U, 8 GB RAM, Intel HD4000, BCM94352HMB (Azurewave AW-CE123H) Wifi/BT, 512 GB Samsung EVO 850 SSD, OS: macOS 10.13.6

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von „macinsane“ ()

      Neu

      Mit der aktuellen WhateverGreen hat sich einiges geändert in Punkte Quick-Sync Konfiguration. Kleiner Spoiler: Die Konfiguration ist nun wirklich Kinderleicht und bedarf praktisch keiner Anpassung der Clover Konfiguration.

      Hier geht es zum Guide.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „danielsogl“ ()

      Neu

      Dann sollten aber auch alle weiteren Infos zu @danielsogls Quicksync-Thread dort bearbeitet werden...
      Sonst ist hier ein heilloses Durcheinander... -> [GUIDE] Intel Quick-Sync mit WhateverGreen
      Gruß
      Al6042

      GA Z270-HD3P F9d | i7 7700k 4,2Ghz | 32GB RAM | Vega56 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.6 | Clover 4617
      GA H170N-WIFI F22e | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.14 beta | Clover 4617
      MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.14 beta

      Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!