Angepinnt Anleitung: USB 3.0 El Capitan / (High-) Sierra für jedermann (Zukunftssicher für Updates und komplett gepatcht)

    Forum Unterstützen

    Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

    Team

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

      Hier mal die DSDT nach Standard-Anleitung gepatcht...
      Dateien
      • DSDT.aml

        (74,8 kB, 2 mal heruntergeladen, zuletzt: )
      Gruß
      Al6042

      GA Z270-HD3P F9b | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13.3 | Clover 4380
      GA H170N-WIFI F22c | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13.3 | Clover 4380
      MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13.3

      Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

      Neu

      Den ASM1142 hat mein Mainboard auch verbaut, der funktioniert OOB. Es gibt zwar in den Logs eine Fehlermeldung (zumindest unter 10.12.6), die Ports laufen aber trotzdem.
      Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520
      Dell T20: Intel Xeon E3-1225 v3, MSI GeForce GT 710 2GD3H LP

      Neu

      Unter El Capitan habe ich diese Anleitung auch befolgt und alle meine USB Ports liefen einwandfrei, jetzt nach dem Update auf High Sierra und denselben exlcludes in Clover funktionieren nur noch meine USB 2.0 Ports.

      Ist mir aufgefallen als ich eine SSD via USB 3.0 Adapter verbinden wollte :D

      Muss das ganze nun wiederholt werden, da die Ports nun andere Nummerierungen haben durch den Wechsel auf High Sierra oder konntet ihr eure bisherige Exclude-Liste so übernehmen?

      EDIT: Ups...falscher Alarm :whistling: Die excludelist war komischerweise nicht in meiner config.plist...Nun geht wieder alles :totlachen:
      -> Skylake Hilfe & Diskussion <-
      iPhone 6S Plus:
      iOS 11.2.1 64GB Gold
      iPad Mini Retina: iOS 11.2 128GB Silber

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „biggasnake“ ()

      Neu

      Die Liste sollte sich nicht ändern.

      Ich würde an deiner stelle lieber mal überprüfen, dass die Kext geladen wird und sowohl Kext als auch Clover in der aktuellsten Version sind :)

      Welches SMBios benutzt du?

      Neu

      Alles in der aktuellsten Version, war meiner Fehler :facepalm:
      Hab's oben Editiert :whistling:
      -> Skylake Hilfe & Diskussion <-
      iPhone 6S Plus:
      iOS 11.2.1 64GB Gold
      iPad Mini Retina: iOS 11.2 128GB Silber

      Neu

      OK super, freut mich :D

      Am Mechanismus hat sich mit High Sierra nichts geändert. Die Updates von USBInjectAll bestehen meistens auch nur aus Ergänzungen von neuen SMBios Definitionen. Würdest du jetzt also zB mit dem neuen iMacPro fahren, wäre das eine andere Sache ;)

      Neu

      Danke für die Erklärung :thumbsup:

      Im ersten Moment der Verwunderung ist mir gar nicht in den Sinn gekommen, vielleicht mal in die config zu schauen :rolleyes:
      -> Skylake Hilfe & Diskussion <-
      iPhone 6S Plus:
      iOS 11.2.1 64GB Gold
      iPad Mini Retina: iOS 11.2 128GB Silber

      Neu

      Da ich nun mal mein AMD Asus Prime B350M-A nutze mit einem Ryzen 5 1400 mit HighSierra würde ich gerne die USB flott machen von dem Board leider finde ich die Einträge so nicht in der IORE die sind dort anders geführt.

      @kuckkuck hoffe du kannst mir helfen bekomme auch keinen wirklichen USB 3.0 oder 3.1 Speed 10MB's wird aber mit bis 5GBis angezeigt in der SystemInfo
      Bilder
      • Bildschirmfoto 2018-01-23 um 19.56.34.png

        286,2 kB, 1.792×844, 7 mal angesehen
      iMac 14,2 (27, Late 2013): Gigabyte GA-Z97-HD3 - Intel i5-4590 - 16GB DDR3 Crucial - Gigabyte RX560 Gaming OC 2G - macOS 10.12.6/10.13.x - Ozmosis/Clover
      Macbook Pro 13'' (Mid 2012): Intel i7-3110m - 16GB DDR3 Corsair Vengeance - HD 4000 1536MB - macOS 10.13.x
      iMac XX,X (XXXX):
      Asus B350M-A - AMD Ryzen 5 - 16GB DDR4 - Palit GTX 960 - macOS 10.12.6 - Clover "TestSystem" Stabil


      Neu

      Bei der hier beschriebenen Methode werden die Ports bei XHC verändert. Genauer, am Intel XHCI Controller. Ein AMD Ryzen Board wird keinen Intel XHCI Controller haben und dementsprechend wird das mit dieser Anleitung nichts werden.

      Du müsstest herausfinden welcher Controller bei deinem Board für die 3.0 und 3.1 Ports zuständig ist. Manche Asmedia Controller laufen zB OOB. Ansonsten wäre der GenericUSBXhci.kext ein Versuch wert. Eventuell gibt es in der Hacky Ryzen Szene auch noch andere Fixes ;)

      Neu

      Ok Super danke für den Tipp

      @kuckkuck also habe jetzt 2 DummyUSB drinne und der GenericUSBXHCI nun laufen hinten alle 6 USB die Front immer noch nicht und eine USB 3.0 platte kommt auch 50MB's und ein SanDisk Stick auf 30MB's ist das so normal ?
      iMac 14,2 (27, Late 2013): Gigabyte GA-Z97-HD3 - Intel i5-4590 - 16GB DDR3 Crucial - Gigabyte RX560 Gaming OC 2G - macOS 10.12.6/10.13.x - Ozmosis/Clover
      Macbook Pro 13'' (Mid 2012): Intel i7-3110m - 16GB DDR3 Corsair Vengeance - HD 4000 1536MB - macOS 10.13.x
      iMac XX,X (XXXX):
      Asus B350M-A - AMD Ryzen 5 - 16GB DDR4 - Palit GTX 960 - macOS 10.12.6 - Clover "TestSystem" Stabil


      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „SirusX“ ()

      Neu

      Das kommt auf die Platte drauf an... Was leistet diese denn auf zB einem Intel Hacky?

      Ich kann dir hier nicht wirklich weiterhelfen, ich habe mich noch nie mit in AMD Boards verbauten USB Controllern beschäftigt... Welcher Controller ist denn verbaut?

      Anleitung: USB 3.0 El Capitan / (High-) Sierra für jedermann (Zukunftssicher für Updates und komplett gepatcht)

      Neu

      Der den du meintest ich meine ob die Werte allgemein ok sind
      iMac 14,2 (27, Late 2013): Gigabyte GA-Z97-HD3 - Intel i5-4590 - 16GB DDR3 Crucial - Gigabyte RX560 Gaming OC 2G - macOS 10.12.6/10.13.x - Ozmosis/Clover
      Macbook Pro 13'' (Mid 2012): Intel i7-3110m - 16GB DDR3 Corsair Vengeance - HD 4000 1536MB - macOS 10.13.x
      iMac XX,X (XXXX):
      Asus B350M-A - AMD Ryzen 5 - 16GB DDR4 - Palit GTX 960 - macOS 10.12.6 - Clover "TestSystem" Stabil


      Neu

      Der SanDisk Stick könnte eher noch im USB 2.0 Bereich liegen. Die USB Platte hat aber schon Datenraten die ganz bisschen über maximum bei 2.0 liegen sollten...

      Aber welcher genaue Controller ist denn jetzt verbaut? Asmedia hat da nicht nur einen... Schau dir Vendor und Device ID in zB IOReg an und Google um was es sich genau handelt, bzw sag mir bitte diese IDs...

      Anleitung: USB 3.0 El Capitan / (High-) Sierra für jedermann (Zukunftssicher für Updates und komplett gepatcht)

      Neu

      Ja bin gerade dabei muss gleich noch schlafen spätestens heute Nachmittag bekommst alles Infos

      Es ist auf jedenfall ein ASMedia 1B21 1343 Ven & Dev , 1043 86F2 SVen & SDev
      Bilder
      • Bildschirmfoto 2018-01-24 um 08.01.13.png

        230,58 kB, 1.589×602, 3 mal angesehen
      • Bildschirmfoto 2018-01-24 um 08.01.22.png

        151,38 kB, 1.576×598, 3 mal angesehen
      iMac 14,2 (27, Late 2013): Gigabyte GA-Z97-HD3 - Intel i5-4590 - 16GB DDR3 Crucial - Gigabyte RX560 Gaming OC 2G - macOS 10.12.6/10.13.x - Ozmosis/Clover
      Macbook Pro 13'' (Mid 2012): Intel i7-3110m - 16GB DDR3 Corsair Vengeance - HD 4000 1536MB - macOS 10.13.x
      iMac XX,X (XXXX):
      Asus B350M-A - AMD Ryzen 5 - 16GB DDR4 - Palit GTX 960 - macOS 10.12.6 - Clover "TestSystem" Stabil


      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „SirusX“ ()