AppleALC ins BIOS

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    AppleALC ins BIOS

    Moin Leute,

    wie ich bei GitHub gelesen habe, soll es anscheinend doch gehen, dass die AppleALC, per Ozmosis Kext Injection diese Kext geladen wird. Hat das schon jemand geschafft bzw ausprobiert?

    LG modzilla
    Bilder
    • Screenshot_20160908-094009~2.png

      119,04 kB, 1.017×877, 100 mal angesehen

    Hackmac:

    • Mainboard: GA-Z97X-Gaming 5
    • Cpu: Intel Core XEON 1231 v3
    • RAM: 12GB HyperX Savage
    • HDD: 1TB Seagate Drive (Hauptdrive (voll :S ) mit Windows 10), 3x 1TB WesternDigital NAS Drives
    • Grafikkarte: AMD Radeon HD 7870 von VTX 3D

    :hackintosh:
    Klingt eigentlich spannend...

    werde ich mir heute Abend mal genauer anschauen.
    ich würde den Kext aber erstmal in der EFI ablegen um die grundsätzliche Nutzung aus der Position zu verifizieren.
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZM-HSReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.6
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.6 | Clover 4152
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.6

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Habe es schon getestet und es funktioniert allerdings war mir der Einbau ins Bios zu unflexibel weshalb ich es wieder entfernt habe. Ist aber sicher eine Option wen Sierra wirklich raus ist und man eine AppleALC Version gefunden hat die stabil mit Sierra und ElCapitan spielt :D
    System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

    Ja super, wenn das funktioniert, kannst du denn dann darüber eine kleine Anleitung bzw Erklärung schreiben? Wäre wirklich top!

    Hackmac:

    • Mainboard: GA-Z97X-Gaming 5
    • Cpu: Intel Core XEON 1231 v3
    • RAM: 12GB HyperX Savage
    • HDD: 1TB Seagate Drive (Hauptdrive (voll :S ) mit Windows 10), 3x 1TB WesternDigital NAS Drives
    • Grafikkarte: AMD Radeon HD 7870 von VTX 3D

    :hackintosh:
    Ich versuche mich auch schon im Hintergrund, aber der Link in deinem Screenshot greift ins Leere...
    Da muss ich mal schauen, was denn mit "merge IOKitPersonalities from PinConfigs.kext with AppleALC.kext" genau gemeint ist...

    EDIT:
    Got it... ;)

    Also...
    aus der Info.plist des PinConfigs.kext aus dem Ordner /AppleALC.kext/Content/Plugins/PinConfigs.kext/Contents muss die Sektion "HDA Hardware Config Resource"

    kopiert und in die Info.plist des AppleALC.kext aus dem Ordner /AppleALC.kext/Content hinzugefügt werden:

    In dessen Sektion "OSBundleLibraries" muss die Zeile "as.vit9696.PinConfigs String 1.0.0" gelöscht werden.
    Zu guter letzt sollte die geänderte Info.plist so aussehen:


    Ebenso kann auch der Ordner /AppleALC.kext/Content/Plugins entfernt werden, so dass es vorher so:

    und danach so aussehen sollte:
    AppleALC-OZM.jpg

    Damit läuft bei mir der aktuelle AppleALC direkt aus der versteckten EFI-Partition im Verzeichnis /EF/Oz/Darwin/Extensions/Common.
    Anbei packe ich mal noch das erfolgreiche Resultat... :)
    Dateien
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZM-HSReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.6
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.6 | Clover 4152
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.6

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „al6042“ ()

    Danke, danke, danke! :) Gleich mal versuchen es ins BIOS zu knallen :D

    Hackmac:

    • Mainboard: GA-Z97X-Gaming 5
    • Cpu: Intel Core XEON 1231 v3
    • RAM: 12GB HyperX Savage
    • HDD: 1TB Seagate Drive (Hauptdrive (voll :S ) mit Windows 10), 3x 1TB WesternDigital NAS Drives
    • Grafikkarte: AMD Radeon HD 7870 von VTX 3D

    :hackintosh:
    @Al6042

    Würde diese Methode auch bei einem Gigabyte GA-Z97-D3H mit Ozmosis funktionieren?

    Die beiden Board verfügen über den gleichen Soundchip Realtek ALC1150?
    iMacs 14.2:
    GA Z97-D3H:
    Intel I7-4790, 16 GB-RAM, MSI GTX 970 4 GB, OS Sierra 10.12.6 & Win 10
    GA Z97M-DS3H: Intel I5-4690, 16 GB-RAM, Zotac GTX 750 TI 2 GB, OS Sierra 10.12.6

    Macbook Air 7.2:
    Lenovo Ideapd Z51-70: Intel I7-5500U, 8 GB RAM, Intel HD5500, OS X Sierra 10.12.6 & Win 10

    alle Clover

    MS Surface Book (next project)

    Da der AppleALC in der Version auch wieder Layout-ID 1 unterstützt, sollte das funktionieren.
    Der "merged" Kext nutzt die gleichen Routinen wie das Original, nur ist der "PinConfigs"-Part direkt eingearbeitet, anstatt als Plugin mit zu laufen....

    EDIT:
    Und "by the way"...
    Es gibt die aktuellere Version 1.0.15 vom AppleALC für SIerra, jetzt auch ohne "-alcbeta" Boot-Argument nutzbar... :)
    AppleALC - der dynamische AppleHDA Patcher - immer aktuell
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZM-HSReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.6
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.6 | Clover 4152
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.6

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „al6042“ ()

    Ist die schon zusammengepackt @al6042 oder müsste ich das noch machen?
    System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

    Im Link gibt es die Original und die OZM-fertige Version... ;)
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZM-HSReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.6
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.6 | Clover 4152
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.6

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Sehr praktisch dann werde ich die gleich mal testen :D

    Edit: getestet und für gut befunden klappt sowohl mit ElCapitan als auch mit Sierra prima. Nebenher auch gleich mal den SHIKI aktualisiert und damit scheinen sich auch meine seltsamen Kernelpaniken unter ElCapitan in Wohlgefallen aufgelöst zu haben. Aktuell also wieder bei beiden Systemen einen absolut unberührten /S/L/E :D
    System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

    Sauber....
    So soll es doch sein... :)
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZM-HSReady | i7 4770k 3,9Ghz | 32GB RAM | GTX1080 8GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.6
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.6 | Clover 4152
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.12.6

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Grmph zu früh gefreut ElCapitan schiebt noch immer Paniken...
    Ich denke das Z77-DS3H und der ElCapitan werden in diesem Leben keine Freunde mehr um so mehr freut es mich das Sierra in der gesamten Beta Phase nicht ein einziges mal abgestürzt ist...
    System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
    System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

    Moin geht bei irgendwem die AppleALC_OZM.kext letzte Rev- 1.0.16 aus dem Bios herraus?

    Pack ich sie die nach Efi geht es. Pack ich die ins Bios als Convertierte AppleALC_OZM.ffs Compressed File liest er die nicht und läd dementsprechend keine Audiotreiber.
    Spoiler anzeigen
    Z97-D3H rev 1.0 | F10e Bios | i5 -4690 | 16gb | 10.12.34 Sierra Ozmosis | Everything Works

    Acer Aspire E15 (E5-575-5262) | v.1.20 Bios | i5-6267U | NEW 16GB |NEW WiFi/BT 4.0 - BCM94352Z | 10.12.4 Sierra CLOVER | Everything Works - Expect SDHC
    Hallo Download-Fritz.

    Kextstat listet die Kext nicht.

    AppleALC_OZM.kext die File muss als .ffs konvertiert werden damit ich Sie ins Bios einfügen kann. Aus dem OZ EFI läuft sie, aber nicht aus dem Bios wenn ich die dort einfüge.
    Spoiler anzeigen
    Z97-D3H rev 1.0 | F10e Bios | i5 -4690 | 16gb | 10.12.34 Sierra Ozmosis | Everything Works

    Acer Aspire E15 (E5-575-5262) | v.1.20 Bios | i5-6267U | NEW 16GB |NEW WiFi/BT 4.0 - BCM94352Z | 10.12.4 Sierra CLOVER | Everything Works - Expect SDHC
    kext2ffs ? Wie sonst? Oder gibts noch eine andere Möglichekit?
    Spoiler anzeigen
    Z97-D3H rev 1.0 | F10e Bios | i5 -4690 | 16gb | 10.12.34 Sierra Ozmosis | Everything Works

    Acer Aspire E15 (E5-575-5262) | v.1.20 Bios | i5-6267U | NEW 16GB |NEW WiFi/BT 4.0 - BCM94352Z | 10.12.4 Sierra CLOVER | Everything Works - Expect SDHC
    Nein die GUID's sind unterschiedlich. MMTool hätte dann gemeckert mit File with the same usw...

    Bei UEFITool im Screenshort sieht man das auch das es keine gleiche GUID gibt.


    Läd dann bei irgendjemand diese AppleAlc v1.0.1.6?? Also die letzte aus dem Bios?
    Bilder
    • screen.png

      1,21 MB, 1.680×1.050, 52 mal angesehen
    Spoiler anzeigen
    Z97-D3H rev 1.0 | F10e Bios | i5 -4690 | 16gb | 10.12.34 Sierra Ozmosis | Everything Works

    Acer Aspire E15 (E5-575-5262) | v.1.20 Bios | i5-6267U | NEW 16GB |NEW WiFi/BT 4.0 - BCM94352Z | 10.12.4 Sierra CLOVER | Everything Works - Expect SDHC

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Nanimos“ ()