Aufbau Netzwerk für NAS > 10Gbe oder Link Aggregation

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Aufbau Netzwerk für NAS > 10Gbe oder Link Aggregation

    Hallo Forengemeinde,

    stehe vor der Anschaffung eines neuen NAS. Zur Wahl stehen zwei Geräte von Q-Nap oder Synology mit 8 Einschüben.

    Die Geräte gibt es jeweils mit 4x 1Gb eLan Anschlüssen und 2x 1Gbe + 2x 10Gbe Anschlüssen.
    Beide Geräte mit 4x LAN lassen Link Aggregation zu, sprich man kann die 4 Ports zu einem virtuellen Port zusammen bündeln (300-400 MB/s Speed) .
    Ich gehe davon aus, dass ich an einem Arbeitsrechner von der Link Aggregation nur dann profitieren kann, wenn ich dort auch beispielsweise eine 4 Port PCI-e Netzwerkkarte einbaue und die 4 Kanäle bündele und diese dann über einen Switch mit dem NAS verbinde.

    Die 10Gbe Lösung dürfte trotzdem schneller sein (beide NAS schaffen so im RAID6 Betrieb wohl rund 1000-1200 MB/s) allerdings haben die 10Gbe Geräte einen SFP Anschluss.
    Kennt jemand eine Hackintosh kompatible (halbwegs bezahlbare) 10Gbe Netzwerkkarte mit SFP?
    Ich habe gelesen, dass die Intel X540-AT2 10Gbe Karte wohl im Hackintosh unterstützt wird. Diese hat dann leider nur 2x RJ45 Anschluss.
    Ich bräuchte hier also auch wieder einen Switch von SFP auf RJ45.

    Die Frage die sich also stellt: NAS mit Link Aggregation oder 10Gbe Netzwerk aufbauen.
    Jemand diesbezüglich Erfahrungen?

    PS: Da ich ab und an auch Videobearbeitung mache, würde ich natürlich am liebsten die schnellere Variante realisieren.
    Gruß,
    derpuma
    Wow,

    10GbE für den Heimgebrauch ist schon eine Hausnummer.
    Da kosten die DualPort Karten ohne weiteres zutun schon ca. 700-800 $ und dann brauchst du noch entweder vorkonfektionierte Kabel mit den SFP+-Transceivern oder die benötigten Einzelelemente.
    Was für einen 10GbE-Switch hast du denn im Einsatz oder im Auge?
    Wird das ein dedzierter 10GbE oder nutzt du ein Cisco-ähnliches Konstrukt, welches ein zusätzliches 10GbE Erweiterungsmodul mit 4 Ports zulässt?

    Bei folgenden Geräten habe ich den Begriff der OSX Unterstützung ausmachen können:
    small-tree.com/products/279/p2…xr-10gbe-two-port-10g-sfp
    sonnettech.com/product/presto10gbeserver.html

    Was die von mir präferierten Original Intel Karten betrifft, habe ich keinen Hinweis auf OSX Unterstützung gesehen, aus dem Thread beim Tomaten-Typen vom Februar 2015. Wobei zu erkennen ist, dass die SmallTree-Karten Intel-Chips einsetzen.
    Gruß
    Al6042

    GA Z270-HD3P F7 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13 | Clover 4243
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13 | Clover 4243
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Nein nicht für den Hausgebrauch. Ich arbeite ja mit meinem Hackintosh.

    Überlegung war diese Karte hier:
    sonnettech.com/product/presto10gbe.html

    ...dann direkt ohne Umwege mit dem NAS zu verbinden.
    qnap.com/i/de/product/model.php?II=237&event=2

    Ich arbeite mit großen Bild und Fotodaten und würde gerne meine Kameradaten auf das NAS legen.
    Lightroom ist mit 100 MB/s schon sehr langsam im Nachladen von Bildern.

    Ja, aus dem Thread hab ich rausgelesen das die Intel Karten gehen. Problem dann ist jedoch, diese haben 10Gbe über RJ45.
    Ich bräuchte dann also wieder nen 10Gbe Switch der schnell auch mal 500-800 Euro kostet.

    Ich denke ich werd die Sonnet Presto Lösung nehmen. Wobei ich mit der Dual-Port Karte zusätzlich noch die 2x10GBe Port virtuell zu einem LAN Port verbinden könnte.

    Zudem mache ich übers Jahr auch einige Videoprojekte, die schnell mal 500-1000GB an Platz brauchen.
    Bislang hatte dazu meine SSD mit 1TB und System am Ende nie ausgereicht.

    Bei der NAS Lösung würd ich gleichzeitig eine Portion Datensicherheit mit bekommen.
    Gruß,
    derpuma
    Wenn du diese NAS direkt und ohne Switch anbinden willst, solltest du aufpassen, das sich da kein Denkfehler einschleicht...

    ein komplett "totes" system benötigt dann nämlich erst mal eine aufgesetzte Link Aggregation um wieder an die Daten ranzukommen...
    wenn du über einen Switch arbeitest, kannst du bereits mit einer operativen NIC an die Daten ran.

    zusätzlich hast du die Option, dass andere Geräte ebenso auf die Daten zugreifen können, ohne zuerst über den Rechner gehen zu müssen.
    Gruß
    Al6042

    GA Z270-HD3P F7 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13 | Clover 4243
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13 | Clover 4243
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Das NAS hat ja neben dem 10Gbe auch noch zwei normale 1Gbe Anschlüsse. Die würden dann ganz normal ins Netz integriert.
    NAS würde also über zwei Adressräume angebunden.
    Am MAC würde die Sonnet Karte ne eigene IP bekommen und ans NAS laufen.
    Paralle holt sich der MAC sein Internet wie gehabt über die interne Motherboard Netzwerklösung.
    Müsste doch so gehen?
    Gruß,
    derpuma
    Jup...
    Damit wird halt die Switch/Routing-Funktion dem Rechner überlassen, aber das sollte tun.
    Gruß
    Al6042

    GA Z270-HD3P F7 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13 | Clover 4243
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13 | Clover 4243
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!
    Steht ja auch bei Sonnet im Kleingedruckten!

    Technical Notes
    Connection requires SFP+-terminated "Direct Attach" twinax copper cable (sold separately) or an SFP+ transceiver module (with an LC fiber optical cable; sold separately).

    Ich denke ich werd den Weg mal Antesten!

    Kurzes Update:

    Ich habe mir jetzt mal ne verhältnismäßig günstige 10GBe SFP+ Netzwerkkarte von Intel über ebay bestellt und werde diese patchen!

    Intel X520-DA2 Dual Port 10GBe
    > kommt nur auf ca. 115,- Euro! im Vergleich zur 450,- Euro teurern Sonnet also deutlich günstiger!
    Zudem waren im Kaufpreis noch zwei 3m SFP+ Kabel enthalten!

    Laut Infos wäre dann wie folgt vorzugehen:

    Unter Linux den Offset der Intel-Karte auf den Offset einer Small-Tree 10Gbe Karte, bringen.
    Die Small-Tree Karten haben alles samt einen Intel Chipsatz und verfügen über OSX Treiber.
    Man macht also quasi aus der Intel Karte ne Small Tree Karte.

    Unter Linux für meine Karte dann wie folgt:
    sudo ethtool -E eth1 magic 0x10fb8086 offset 0x32a value 0x0a
    sudo ethtool -E eth1 magic 0x10fb8086 offset 0x32b value 0x00
    sudo ethtool -E eth2 magic 0x10fb8086 offset 0x32a value 0x0a
    sudo ethtool -E eth2 magic 0x10fb8086 offset 0x32b value 0x00

    Achtung! Je nach Revision der Karte müssen die Offset Werte mit dem ethtool unter linux ausgelesen und betrachtet werden!

    Werde berichten wie ich damit klarkomme, wenn die Karte da ist!
    Mitunter wohl momentan der günstigste Weg auf einem Mac ein 10Gbe Netzwerk zu etablieren!




    Gruß,
    derpuma

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „derpuma“ ()

    Hallo Puma!

    Wie sehen denn deine Erfahrungen aus mit der gepatchten Karte? Ich überlege die Intel X540-T1 in meinen MacPros einzusetzen und würde mich vor allem über Stabilitäts-Infos freuen.

    VG
    Tirom
    Hallo,
    [UPDATE]:
    Funktioniert alles - hatte blöderweise die NIC an einen Gigabit Switch angesteckt und nicht an den 10GbE-Switch :) Läuft alles und ich genieße jetzt mal 10GbE auf meinem Hack.

    ich versuche auch 10GbE in meinem Hack zum Laufen zu bekommen. Hab schon die X540-T1 von SmallTree eingebaut,
    die passende kext installiert und bekommen auch Gigabit mit der Karte hin. Nur wenn ich im Hardware Tab in Network Preferences auf 10GbaseT wechsle, droppt die NIC und ist qausi tot (bis ich wieder auf Gigabit umschalte).

    Hat irgendwer eine Idee was ich probieren könnte?
    Danke schon mal!

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „criuz“ ()

    Neu

    Ich bin leider noch nicht dazu gekommen. ;(
    Aber ich wollte mal fragen, ob schon was über den iMac Pro Ethernet-Chip bekannt geworden ist? Über Prozessoren und GraKa hat man ja schon was herausgefunden. Vielleicht spare ich mir dann den Aufwand mit dem Flashen der X540.

    Neu

    Bisher ist noch kein Detail zum eingesetzten LAN-Chip bekannt.
    Gruß
    Al6042

    GA Z270-HD3P F7 | i7 7700k 4,2Ghz | 32GB RAM | GTX1080 8GB | NVMe SSD 960 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.13 | Clover 4243
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.13 | Clover 4243
    MBP 13,3 | i7 6700HQ 2,6Ghz | 16GB RAM | Intel HD530 & AMD Radeon Pro 450 | NVMe SSD SM00256L 256 GB | BCM943602CSAX | macOS 10.13

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!