Lenovo E560 - Clover - EL Capitan

Forum Unterstützen

Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

Team

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Die HACKCON geht in die 2. Runde. Am 04.06.2017 ist es wieder soweit, dann heißt es HCKCN 17.
Informationen findet Ihr hier: HCKCN17 - Programm, Anmeldung usw...
Zur Anmeldung geht es hier: Zur Anmeldung
    Der ARPT-Eintrag bezieht sich nur auf WLAN... ARPT = Airport.
    Je nach Device-ID wird die Karte auch ohne große Patcherei im OSX genutzt.
    Wenn man mal in die Info.plist des AirPortBrcm4360.kext rein schaut, sieht man die IDs, welche direkt funktionieren würden:

    Quellcode

    1. <key>IONameMatch</key>
    2. <array>
    3. <string>pci14e4,43ba</string>
    4. <string>pci14e4,43a3</string>
    5. <string>pci14e4,43a0</string>
    6. <string>pci14e4,4331</string>
    7. <string>pci14e4,4353</string>
    8. </array>


    Sollte das nicht direkt gehen, wird der "compatible"-EIntrag in der DSDT wichtig, z.B.:

    Quellcode

    1. "compatible",
    2. "pci14e4,43a0",


    Bluetooth würde wenn, nur über die EHC1/EHC2, bzw. EH01/EH02 oder XHC beeinflusst werden, da BT nur über USB angesprochen/angeschlossen wird.
    Es gibt auch einige BT-Chips in den Broadcom Kombi-Karten, welche die BRCM-Kexte nicht benötigen.
    Ist z.B. bei meiner Kombi-Karte im Z87X-UD3H der Fall...
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX770 2GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.5
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.5 | Clover 4061
    Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD 840 EVO 1 TB | BCM943602BAED | macOS 10.12.5 | Clover 4061

    Neu

    Ich habe festgestellt, daß in der alten DSDT überall Einträge mit XHC zu finden sind, während in der neuen DSDT überall XHCI steht!
    Was kann man da tun? Einfach ersetzen?

    EDIT:
    So, ich habe es gewagt, XHCI mit XHC in der DSDT ersetzt, mit der so geänderten DSDT gestartet und … Bluetooth funktioniert!
    :thumbsup:

    @al6042 besten Dank für den Tipp und Hinweis.

    Kann sein, daß es vielleicht noch Probleme oder Korrekturen gibt oder braucht, aber vorerst war das die Lösung:
    Bilder
    • Bildschirmfoto 2017-05-19 um 14.06.40.png

      65,26 kB, 1.025×182, 7 mal angesehen
    • Bildschirmfoto 2017-05-19 um 14.11.41.png

      83,87 kB, 539×442, 7 mal angesehen
    Hackbook: Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520 und AMD Radeon R7 370, 8GB DDR3 1600 MHz, Broadcom BCM943602BAED Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.12.4, Win10

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von „iPhoneTruth“ ()

    Neu

    Klasse, dass es jetzt funktioniert! Die ACPI-Namen sind in meiner (und auch in deiner alten) DSDT immer vier Zeichen lang, also XHC_ und nicht XHC. Scheint aber hier doch egal zu sein.
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520

    Neu

    Und dann habe ich festgestellt, daß in meiner DSDT gar kein Device (ARPT) zu finden ist! Dagegen ist sowohl bei @al6042 in seiner DSDT für das Thinkpad 500, wie bei @Harper Lewis in der DSDT für sein Thinkpad E460 ein Eintrag mit Device (ARPT) zu finden.

    Kein Wunder, daß bei mir WLAN nach dem Ruhezustand nicht mehr funktioniert, oder? ?(

    Ich habe schon versucht, den Code von al6042 an die Stelle einzufügen, die ich aus der DSDT von Harper Lewis erruiert habe, hat aber dann doch nicht geholfen. Könnt Ihr mir da sagen, was ich da machen muß? Vielleicht gibt es ja einen einfach Patch, mit dem ich den Eintrag in die DSDT einfügen kann.

    DSDT für das Thinkpad 500 mit BCM943602BAED:

    Quellcode

    1. Device (ARPT)
    2. {
    3. Name (_ADR, Zero) // _ADR: Address
    4. Name (_SUN, One) // _SUN: Slot User Number
    5. Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method
    6. {
    7. Store (Package (0x0C)
    8. {
    9. "AAPL,slot-name",
    10. "AirPort",
    11. "name",
    12. "AirPort Extreme",
    13. "model",
    14. "Broadcom BCM4360 802.11 a/g/n/ac Wireless Network Adapter",
    15. "device_type",
    16. Buffer (0x08)
    17. {
    18. "AirPort"
    19. },
    20. "compatible",
    21. "pci14e4,43a0",
    22. "built-in",
    23. Buffer (One)
    24. {
    25. 0x01
    26. }
    27. }, Local0)
    28. DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
    29. Return (Local0)
    30. }
    31. }


    DSDT für das Thinkpad E460 mit BCM94352ZAE

    Quellcode

    1. Device (ARPT)
    2. {
    3. Name (_ADR, Zero) // _ADR: Address
    4. Name (_PRW, Package (0x02) // _PRW: Power Resources for Wake
    5. {
    6. 0x69,
    7. 0x04
    8. })
    9. }
    10. Method (HPME, 0, Serialized)
    11. {
    12. If (LAnd (LNotEqual (VDID, 0xFFFFFFFF), LEqual (PMSX, One)))
    13. {
    14. Store (One, PMSX)
    15. Store (One, PSPX)
    16. }
    17. }

    Hackbook: Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520 und AMD Radeon R7 370, 8GB DDR3 1600 MHz, Broadcom BCM943602BAED Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.12.4, Win10

    Neu

    Mahlzeit,

    stimmt, in meiner DSDT gibt es diesen Eintrag für das Device ARPT. Ich haben diesen unverändert belassen, da bei meiner Karte alles über die config.plist von Clover läuft. Hast du den Eintrag Fake ID unter Devices>WIFI aus deiner config.plist entfernt, nachdem du das Device ARPT in der DSDT hinzugefügt hast? Das könnte sich ansonsten in die Quere kommen.
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Harper Lewis“ ()

    Neu

    Ich hatte den Eintrag abgeändert in "0x43ba14E4", passend für die ID der BCM943602BAED. Habe diese jetzt mal komplett entfernt und neu gestartet. Nach dem Start ist alles da, nach dem Ruhezustand WLAN trotzdem weg.

    Ich füge mal meinen Clover-Ordner an, vielleicht findet ihr den Fehler.

    EDIT:
    Müßte im Systembericht unter WLAN nicht die exakte Kartenbezeichnung "Broadcom BCM4360 802.11 a/g/n/ac Wireless Network Adapter" erscheinen, wenn er den Patch geschluckt hat?
    Bilder
    • Bildschirmfoto 2017-05-24 um 14.55.32.png

      170,56 kB, 919×963, 2 mal angesehen
    Dateien
    • CLOVER.zip

      (1,13 MB, 1 mal heruntergeladen, zuletzt: )
    Hackbook: Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520 und AMD Radeon R7 370, 8GB DDR3 1600 MHz, Broadcom BCM943602BAED Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.12.4, Win10

    Neu

    "Karte eines Drittanbieters..." klingt nicht so wirklich richtig. Ich meine, dass du bis auf den Patch für die Länderkennung keine weiteren Patches für den WLAN-Teil deiner Karte benötigst.

    Ist weiterhin IONetworkingFamily.kext unter "ForceKectsToLoad" nötig und falls ja, wofür?


    Ich sehe gerade, dass es diesen Eintrag in meiner hier hochgeladenen config.plist gibt. Ich muss da nochmal aufräumen...

    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520

    Neu

    Ich habe den Eintrag für die Whitliste mal deaktiviert, dafür den Eintrag von al6042 aus seiner config für Airport Extrem eingefügt. Damit sieht der Systembericht schon besser aus!

    IONetworkingFamily.kext unter "ForceKectsToLoad" hatte ich entfernt, soll ichs draußen lassen oder wieder reinnehmen?

    Allerdings nach wie vor kein WLAN nach dem Ruhezustand.
    Bilder
    • Bildschirmfoto 2017-05-24 um 15.20.37.png

      258,46 kB, 1.334×772, 2 mal angesehen
    • Bildschirmfoto 2017-05-24 um 15.19.39.png

      149,52 kB, 806×512, 3 mal angesehen
    Hackbook: Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520 und AMD Radeon R7 370, 8GB DDR3 1600 MHz, Broadcom BCM943602BAED Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.12.4, Win10

    Neu

    Ja, lass IONetworkingFamily.kext mal weg. Ich weiß ehrlich gesagt gar nicht, wie das in die config.plist gekommen ist.

    Was passiert dem nach dem Aufwachen genau? Ist die Karte aus dem Systembericht verschwunden, oder werden dir keine Verbindungen mehr angezeigt?
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520

    Neu

    Nach dem Aufwachen ist die Karte im Systembericht noch da, aber es werden keine Verbindungen mehr angezeigt.
    Bilder
    • Bildschirmfoto 2017-05-24 um 16.05.58.png

      179,14 kB, 919×963, 6 mal angesehen
    Hackbook: Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520 und AMD Radeon R7 370, 8GB DDR3 1600 MHz, Broadcom BCM943602BAED Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.12.4, Win10

    Neu

    Sehr seltsam. Ich hatte ja ein ähnliches Problem, aber bei mir waren nur die 5GHz-Verbindungen nach dem Aufwachen futsch, was die Länderkennung #a behoben hat. Das scheint bei dir nun leider nicht zu funktionieren. Vielleicht hat @al6042 noch eine Idee? Ich benutze ja auch mit der DW1560 eine andere Karte als du aktuell.
    Skylake Laptop: Lenovo E460 20ETS04U00, i5-6200U, HD520

    Neu

    Ich habe ja mal die DSDT von al6042 für sein Thinkpad 500 drin gehabt, womit WLAN nach dem Ruhezustand tatsächlich da war. Allerdings hat dafür Einiges andere nicht funktioniert und er startet mit dieser DSDT aktuell auch nicht mehr.

    Edit:
    Frage an @Harper Lewis und @al6042: war denn bei Euch der Eintrag Device (ARPT) schon drin, oder habt ihr den mit irgendeinem Patch eingefügt?
    Hackbook: Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520 und AMD Radeon R7 370, 8GB DDR3 1600 MHz, Broadcom BCM943602BAED Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.12.4, Win10

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „iPhoneTruth“ ()

    Neu

    ARPT = Airport...
    Kein "normaler" PC/Laptop arbeitet damit, deswegen gibt es DSDT-Patches, die dieses Mac-eigene Device in der DSDT setzen.
    Das muss aber als Ersatz des "Device (PXSX)" unter dem "Device (RPxx)" gesetzt werden, in dem die WLAN-Karte auch drinnen sitzt.
    Dummerweise sieht man das nicht ohne Hilfe, sondern erst durch Tools wie IORegistryExplorer oder IOJones.
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX770 2GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.5
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.5 | Clover 4061
    Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD 840 EVO 1 TB | BCM943602BAED | macOS 10.12.5 | Clover 4061

    Neu

    Dann wäre das bei mir das Device (RP09) ?
    Bilder
    • Bildschirmfoto 2017-05-24 um 22.14.35.png

      48,04 kB, 327×461, 5 mal angesehen
    Hackbook: Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520 und AMD Radeon R7 370, 8GB DDR3 1600 MHz, Broadcom BCM943602BAED Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.12.4, Win10

    Neu

    Sorry... mein Fehler...
    Bei Desktops wird das "Device (RPxx)" genutzt, während Laptops gerne das "Device (EXPx)" nutzen.
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX770 2GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.5
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.5 | Clover 4061
    Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD 840 EVO 1 TB | BCM943602BAED | macOS 10.12.5 | Clover 4061

    Neu

    Ok!
    Dann wäre das bei mir wohl EXP3.
    Und da vertausche ich jetzt den Code "Device (PXSX)" mit dem Code "Device (ARPT)" aus Deine DSDT ?!

    EDIT
    Und tausche
    Scope (\_SB.PCI0.EXP3.PXSX)
    in
    Scope (\_SB.PCI0.EXP3.ARPT)
    ?


    Bilder
    • Bildschirmfoto 2017-05-24 um 22.20.19.png

      69,3 kB, 840×276, 3 mal angesehen
    Hackbook: Lenovo ThinkPad e560, Intel Core i7 6500U, Intel HD Graphics 520 und AMD Radeon R7 370, 8GB DDR3 1600 MHz, Broadcom BCM943602BAED Wifi & BT Combokarte, 480 GB SSD (Toshiba Q300), MacOSX 10.12.4, Win10

    Neu

    Korrekt...
    Das sollte helfen.
    Gruß
    Al6042

    GA Z87X-UD3H F10b OZMSierraReady | i7 4770k 3,9Ghz | 32GB RAM | GTX770 2GB | SSD 840 EVO 250 GB / 3x3 TB | BCM943602CSAX | macOS 10.12.5
    GA H170N-WIFI F21 | i5 6600 3,3Ghz | 16GB RAM | HD530 1,5GB | NVMe SSD 960 EVO 250 GB | BCM94352Z | macOS 10.12.5 | Clover 4061
    Lenovo Ideapad 500-15ISK | i7 6500U 2,5GHz | 12GB RAM | Intel HD520 | SSD 840 EVO 1 TB | BCM943602BAED | macOS 10.12.5 | Clover 4061