Anleitung: El Capitan / Yosemite auf Lenovo T420

    Forum Unterstützen

    Wenn Du unsere Arbeit unterstützen möchtest, würden wir uns über eine Spende sehr freuen! :-)

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

      Dann bleibt eigentlich als einzige Möglichkeit nur noch das Deine config gar nicht genutzt wird...
      Schraub mal die Platte vom funktionierenden T420 in das bei dem es nicht funktionieren möchte passt es damit liest clover die config vermutlich nicht...
      System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
      System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

      Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
      Downloads: DSDT für T61,ModBios für T61,ModBios für T420s
      Und genau das habe ich gemacht und alles hat geklappt, irgendwie war da war da wohl der Fehler, habe dann alles noch einmal NEU gemacht und es funktioniert, vielen Dank für die Hilfe es macht immer wieder Spaß mit Euch zusammen zu arbeiten...
      SHUTTLE XH61v i5-3570-K HD4000 8GB RAM 256GB SSD Mavericks 10.9.2
      GA-H61N-USB3 i3 (2105) HD3000 4GB RAM Mountain Lion 10.8
      LENOVO G770 i3 HD3000 4GB RAM 500GB HD Mountain Lion 10.8.2
      LENOVO U410 i5 HD4000 8GB RAM 250GB SSD Mountain Lion 10.8.3
      Packard Bell EasyNote LV11HC-53214G50 i5 HD4000 4GB RAM 500GB HD
      HP PAVILION G7-2304SG i7 HD4000 8GB RAM 640GB HD Mountain Lion 10.8.4
      LENOVO G500 I3-3110M HD4000 4GB RAM 500GB HD Yosemite 10.10.1
      Sehr gerne und viel spaß mit dem 2. Klapptop :D
      Die T420(s) sind einfach extrem dankbare Hackbooks die machen richtig Freude :D
      System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
      System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

      Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
      Downloads: DSDT für T61,ModBios für T61,ModBios für T420s
      Hallo @recai! Willkommen im Forum! Du kannst über den Appple Store die Snow Leopard dvd kaufen! Damit hast du eine offizielle lizenz! Die brauchst du unbedingt! Danach kannst du über die VirtualMachine SnowLeopard installieren und dir den Sierra offiziell runterladen. Anleitungen gibt's hier im Forum!

      edit: wenn du dich mit englisch gut auskennst gibt es hier die original anleitung: insanelymac.com/forum/topic/28…only/page-25#entry1952283. Die ist immer aktuell (vom 23.11.).
      Gruß
      Jan

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „jboeren“ ()

      Sagt mal, Freunde ... bleibt bei Eurem Thinkpad nach dem Aufwachen (via on/off-Taste) aus dem Ruhezustand das Display auch ersteinmal aus und springt erst an, wenn ihr ne andere Taste drückt?

      Wenn ja (und auch nein) ... was kann man/kann ich dagegen tun.

      Ich fänds gut, wenn auch der Bildschirm gleich mit aufwacht. :)
      .
      .
      cHeErS 8) aLeX

      GA-Z97N-Wifi| i7 4790k 4.0Ghz | 16GB RAM | MSI GTX760 2GB | AR5B195 | macOS 10.11.6 | Ozmosis 167X-MAS
      ThinkPad T420s | i7 2.6 Ghz | 8GB RAM | Intel HD3000 | BCM94352| macOS 10.11.6 | Clover 3794
      Hallo Freunde der Nacht,


      ich habe ein T420s mit Sierra installiert (mit dem aktuellen Pack von insanely-mac). Es funktioniert fast perfekt!

      Ich habe den Kartenleser mittlerweile mit VoodooSDHC.kext perfekt zum laufen bekommen (war mein erstes Problem), allerdings scheitere ich noch am USB3.0.

      Problematik:
      Ich nutze GenericUSBXHCI.kext und es funktioniert auch WENN beim hochfahren ein Stick oder eine Maus eingesteckt ist. In diesem Fall funktioniert es mit auswerfen und anderen Stick einstecken und Maus einstecken und und und, bis es in den Sleep geht, danach wird der Port wohl nicht mit aufgeweckt.

      Wenn der Port beim hochfahren leer ist, funktioniert er gar nicht (auch kein Strom drauf).

      Hat jemand eine Idee?!
      Das nicht-mehr-aufwachen wäre das kleinere Übel, ich hätte nur gerne das ich nicht etwas in dem Port haben muss beim hochfahren!


      Vielen Dank & Gruß
      Habe bei meinem aktuell das selbe Problem wobei das vorher nicht der Fall war sprich unter elCapitan hat es noch funktioniert. Mir wäre das jetzt nicht wirklich aufgefallen da ich den Port nicht oft nutze...
      System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
      System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

      Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
      Downloads: DSDT für T61,ModBios für T61,ModBios für T420s
      Ich hab auf'm T420s noch das Problem, dass sich der Mauzeiger via Trackpointer nur sehr schnell und ruckartig bewegt ... also in riesen Sprüngen (von vlt. 20, 30 Pixeln - wie auf einem Raster).

      Jemand ne Idee, wie ich das Problem beseitige?

      @griven ich hab ja viel von Deiner Config/Extensions ... ist das bei Dir auch schon vorgekommen?
      .
      .
      cHeErS 8) aLeX

      GA-Z97N-Wifi| i7 4790k 4.0Ghz | 16GB RAM | MSI GTX760 2GB | AR5B195 | macOS 10.11.6 | Ozmosis 167X-MAS
      ThinkPad T420s | i7 2.6 Ghz | 8GB RAM | Intel HD3000 | BCM94352| macOS 10.11.6 | Clover 3794
      Ich nutze den Trackpoint eigentlich nicht aber es gibt eine neue Version vom VoodooPS2.kext welche die genannten Probleme beseitigen soll...
      Dank geht an der Stelle an TLuck von InsanelyMac der sich um die T420 spezifischen Anpassungen gekümmert hat :D
      Die Version im Anhang ist für Sierra optimiert und funktioniert nicht oder nur eingeschränkt unter früheren Versionen.
      Dateien
      System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
      System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

      Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
      Downloads: DSDT für T61,ModBios für T61,ModBios für T420s
      Cool werd ich morgen mal testen ... allerdings bleibe ich langfristig bei El Capitan. Nunja ... so wichtig ist mir der Trackpoint auch nicht, aber schön wenn er benutzbar wäre.
      .
      .
      cHeErS 8) aLeX

      GA-Z97N-Wifi| i7 4790k 4.0Ghz | 16GB RAM | MSI GTX760 2GB | AR5B195 | macOS 10.11.6 | Ozmosis 167X-MAS
      ThinkPad T420s | i7 2.6 Ghz | 8GB RAM | Intel HD3000 | BCM94352| macOS 10.11.6 | Clover 3794
      da es hier grad um den roten Knubbel geht, ich hab da auch schhon länger ein (eigentlich nicht gravierendes) Problem:
      Bei mir ist der Track Point beim Start öfter nicht verfügbar, Wenn ich das T420 schlafen schicke und wieder wecke, ist er wieder da.
      Stört mich eigentlich nicht weiter, Deckel zu und wieder auf, und das Problem ist erledigt.


      Kennt das jemand?
      Ich hab nach der Anleitung von Insanaly installiert. Jetzt läuft Sierra 10.12.2
      Meine Systeme
      Spoiler anzeigen
      Midi Tower Fractal Define R4 10.11.6 + 10.12.2
      Z97X-UD3H, i5 4590 4x 3.30GHz, Sound: SB1040 WLAN+BT: BCM94360CD 16GB Ram,
      2048MB MSI GeForce GTX 960 2GD5T OC Aktiv, Oz 167X-MASS
      ITX: 10.11.6
      Lian Li PC-Q33 B85N (OZ 167X)-i3 HD 4600 8GB Ram 250GB SSD
      HackBook:
      T420 * i5 2540M * HD3000 * 8GB DDR3 * 10.12.2
      T61p * Core2Duo 2,5 GHz * 4 GB DDR2 * 10.11
      Clover
      Test Hacki: 10.12.2 imac 14.1 /Z77m-D3h /i5 3570k 12GB Ram /Samsung Evo 850 /oz Z77MD3H-15a-OZM-DSDT-G-166X_M.rom
      iPhone5
      Der knubbel hat so seine tücken... Ich benutze den fast nie und habe mich nicht darum gekümmert.
      Gruß
      Jan
      Ja @Nightflyer ... ist bei mir auch so. Auch mit der neuen Kext oben. Ich forsche nach her mal ein bisschen, ob sich was im Netz zu findet.

      @griven ... also die neue Kext läuft auch auf El Capitan und der Trackpoint läuft deutlich besser/normaler (wenn auch nicht so smooth wie bei meinen anfänglichen Hackintosh-Versuchen unter Yosemite, würde ich behaupten).
      .
      .
      cHeErS 8) aLeX

      GA-Z97N-Wifi| i7 4790k 4.0Ghz | 16GB RAM | MSI GTX760 2GB | AR5B195 | macOS 10.11.6 | Ozmosis 167X-MAS
      ThinkPad T420s | i7 2.6 Ghz | 8GB RAM | Intel HD3000 | BCM94352| macOS 10.11.6 | Clover 3794
      Hallo

      Danke an die Forumsgemeinde für die Super Anleitung und den Support ;)

      Frage : Sollte man den Seriennummer des Geräts ändern ? Wenn ja, wie ... im Clover Configurator sind die Felder leer ...
      Gibt es evtl. Probleme wenn viele die gleiche Seriennummer haben im App Store ?
      Steht die Seriennummer in der DSDT ?

      Kann man Online auf 10.11.6 Updaten oder gibts da Probleme nachher ?

      Zum Bios hätte ich auch noch eine Frage :
      Im Reiter Startup / Boot kann ma da Einträge löschen ?
      Wenn ja , wie ?

      MfG Vicy

      Mobil: Thinkpad T420 / Bios 1.48 Orig. / i5 2520M / 10 GB RAM / MacOS 10.11. /Clover
      Mobil: Thinkpad T61 (Type 6458-6QG) / Middleton Bios 2.29 / C2D 2.2GhZ / 4 GB RAM / Nvida NVS140 / MacOS 10.10.5 /Clover
      Mobil: PowerBook G4 / 5.8 / MacOS 10.5.8 & MorphOS
      AMIGA 1200 / 68020 / 28MhZ / 6 MB / 4 GB CF-CARD / OS3.1 / WHDLoad

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Vicybaby“ ()

      Die SMBIOS Werte sollten immer möglichst Individuell sein da es sonst zu Problemen mit diversen Apple Diensten kommen kann (nicht nur AppStore sondern auch FaceTime, iMessage, iCloud und unter Sierra Siri). Wenn Du die Werte über den Clover Configurator ändern möchtest wechsele dort auf den Punkt SMBIOS und klicke auf das Symbol mit dem Zauberstab es öffnet sich dann ein Fenster in dem das entsprechende Mac Modell ausgewählt werden kann.

      Nachdem Du Dich für das passende Modell entschieden hast (MacMini, MacPro, iMAC, MacBook, MacBook Pro) kannst Du im nächsten Dialog Deine Auswahl weiter verfeinern indem Du eine bestimmtest Modell aus der Serie auswählst. Hierbei ist ein wenig Vorsicht und Bedacht gefragt denn nicht jedes Modell passt zu jeder Hardware grundsätzlich gilt aber je näher die Komponenten des gewählten Modells an der eigenen Hardware sind um so besser. Vorsicht ist bei folgenden Modellen geboten: MacPro5.1 (funktioniert nur wenn AppleTyMCEDriver.kext gelöscht wird), MacPro6.1 (Funktioniert nicht mit NVIDIA Grafik), iMAC < iMAC14.2 funktioniert nicht mit NVIDIA Grafik.

      Wenn Du Deine Auswahl getroffen hast klickst Du bitte mehrfach auf beide Shake Buttons und übernimmst Die Werte dann mit eine Klick auf den OK Button. Jetzt bist Du schon fast fertig mit dem Individualisieren Deines Mac´s allerdings fehlen noch 2 Werte die noch ausgefüllt werden möchten.

      Wie Du siehst ist der Wert für SmUUID und der für Board Serial Number noch leer. Im letzten Fall kannst Du einfach den Wert aus Serial Number kompieren und auf 17 Stellen auffüllen wobei die Füllzeichen aus den Werten 1-9 und den Buchstaben A-F bestehen dürfen im ersten Fall brauchst Du eine UUID diese bekommst Du im Terminal indem Du dort den Befehl uuidgen eingibst.

      Den generierten Wert einfach kopieren und in das Feld SmUUID einfügen. Jetzt wird auf den Reiter RTVariables gewechselt und die Felder dort ausgefüllt...

      In das Feld MLB kommt der Wert aus dem Feld Board Serial Number aus dem SMBIOS und in das Feld ROM ein Wert mit 12 Stellen wobei die ersten 6 Stellen idealerweise dem Prefix einer Apple MacAdresse entsprechen und die letzten 6 Stellen den letzten 6 Stellen der MAC Adresse der Netzwerkkarte. Angenommen die Mac Adresse der Netzwerkkarte ist 14:D2:4F:CD:D1:D2 dann übernehmen wir davon CDD1D2 und fügen davor ein Prefix von Apple ein zum Beispiel 40D32D zusammen ergibt sich also 40D32DCDD1D2 einen guten Überblick darüber welche Prefixe zu Apple gehören kann man sich hier verschaffen: coffer.com/mac_find/?string=apple

      Was da Bios anghet man kann diese Einträge löschen, wie ist hier beschrieben: Clover Boot-Einträge löschen und erneutes auftreten verhindern
      System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
      System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

      Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
      Downloads: DSDT für T61,ModBios für T61,ModBios für T420s

      Neu

      @griven
      Danke ;)

      Bei SMBIOS hat alles Funktioniert.

      Bei Rt Variables kann ich oben nur das Feld MLB anklicken und Ausfüllen. Die Untern Felder unter Variables kann ich nicht anklicken. Nur der Calculate Button geht.

      mfg

      Mobil: Thinkpad T420 / Bios 1.48 Orig. / i5 2520M / 10 GB RAM / MacOS 10.11. /Clover
      Mobil: Thinkpad T61 (Type 6458-6QG) / Middleton Bios 2.29 / C2D 2.2GhZ / 4 GB RAM / Nvida NVS140 / MacOS 10.10.5 /Clover
      Mobil: PowerBook G4 / 5.8 / MacOS 10.5.8 & MorphOS
      AMIGA 1200 / 68020 / 28MhZ / 6 MB / 4 GB CF-CARD / OS3.1 / WHDLoad

      Neu

      Ist auch richtig so, einfach wie oben beschreiben nur die 4 Felder im oberen Bereich befüllen.
      System 1 (iMac 15,1) PowerMac G5 Case: GA-Z77-DS3H, Ozmosis_167X F11, Intel XEON E3-1225V2 @ 3.2 GHz, 32GB DDR3, Sapphire R9-270X Dual X, Toshiba Q-Series 128GB SSD + WD Caviar Blue 1TB, OS X 10.12.1
      System 2 (MacBook Pro 8.1): ThinkPad T420s, i5-2520M @ 2.5 GHz, 4GB DDR3, IntelHD 3000, Toshiba Q300 240GB SSD, Sandisk 128GB SSD, Triple Boot OS-X 10.11.6, MacOS Sierra 10.12.1, Windows10 Pro 64Bit

      Im Schrank: PointOfView Geforce GTX-7600, Gigabyte Geforce GTX750Ti Windforce, Intel T7250
      Downloads: DSDT für T61,ModBios für T61,ModBios für T420s