Posts by Plonker

    Schaue mit Hackintool nach, ob der betroffene USB-Anschluss aktiv ist. Wenn nicht, muss Du erstmal Deine max. USB-Anschlüsse sauber definieren. Es gibt mehrere Threads zu diesem Thema.

    Damit die Fenvi auch nach Standby funktioniert, muss der betroffene USB-Anschluss als intern gekennzeichnet sein.

    Erste Hilfe bzw. fsck zeigen folgendes Bild (fsck bricht die Überprüfung der SSD mit "Snapshot is invalid." ab). Lokale TM-Snapshots sind nicht vorhanden.

    Der Fehler lässt sich nich korrigieren, auch wenn ich im Recovery Mode boote und von dort fsck aufrufe.

    Sorry, habe Dich missverstanden.


    Die Treiber brauchst Du nur, wenn Du tatsächlich Apple Mouse oder Keyboard benutzt. Der eigentliche Bluetooth-Stack hat bei mir unter Windows bereits automatisch funktioniert, nur konnte ich beide Apple-Geräte nicht pairen...


    Ansonsten bietet Fenvi Bluetooth-Treiber für Windows an, die hast Du aber schon ausprobiert...


    P.S. Vielleicht hängen aber die Verbindungsprobleme mit dem Kopfhörer mit schlechten Reichweite von Bluetooth, wenn Du gleichzeitig WLAN mit 2,4GHz nutzt. Schalte auf auf 5GHz um, falls Dein Router mitmacht.

    LL0rd Lass mich mal raten: Du hast eine AMD-Karte im System und benutzt iMacPro1,1-SMBIOS.


    Das Problem haben einige User seit 10.14.4, Stichwort Freezes.


    Bild freezt


    Es gibt momentan keine Lösung. Ich habe die Problematik ein wenig entspannt (wesentlich seltener auftretende Freezes) mit der nicht iMacPro1,1-konformen Zuschaltung von der iGPU im BIOS.


    Die Freezes tauchen bei mir immer im Zusammenhang mit Videos auf (z.B. Youtube, Scrollen im Facebook bei aut. startenden Videos, usw.). Es sieht exakt so aus, wie bei Dir - zuerst stottert das System und nach ein paar Minuten geht nichts mehr.

    Apples "Erste Hilfe" ist leider keine Hilfe! Jetzt nachdem zwischenzeitlich TM weitere Backups angelegt hatte, wurde fsroot tree is invalid durch Snapshot is invalid ersetzt. Man beachte das grüne Häckchen und Vorgang erfolgreich:


    Übrigens, nachdem ich das TM-Snapshot mit tmutil entfernt habe, steht jetzt wieder fsroot tree is invalid, garniert durch grünes Häckchen und "Vorgang erfolgreich".




    Fazit:

    Bin von APFS bedient.


    sudo fsck_apfs -n -l /dev/rdiskXsX meldet Fehler (fsroot tree is invalid). Erste Hilfe (GUI-Wrapper für fsck) sagt "Vorgang erfolgreich" und zeigt grünes Häckchen an. Wenn man aber "Details einblenden" klickt, sieht man die Fehlermeldung auch dort.


    Macht man zwischenzeitlich TM Backup, wird fsroot tree is invalid durch Snapshot is invalid ersetzt.


    fsck -y behebt den Fehler unter single user mode oder Recovery mode nicht.


    Files im betroffenen Directory sind doppelt vorhanden (aus der Sicht von ls) oder gar nicht (rm).


    SSD is übrigens laut SMART völlig ok.


    Es gibt keine seriöse Third-Party-Reparatursoftware für APFS, da anscheinend nicht von Apple dokumentiert.


    Nur am Rande: das "-f" mit fsck funktioniert nicht, obwohl "-f" in der man-Seite erwähnt ist. fsck ist ein Wrapper und ruft bei APFS fsck_apfs auf (hier fehlt das -f) oder bei HFS fsck_hfs (hier -f vorhanden).

    Ist schon strange, rm findet die Datei(en) nicht, ls aber wohl.


    In single user mode:

    Code
    1. fsck -fy
    2. warning: option -f is not implemented, ignoring
    3. error: container /dev/rdisk2 is mounted with write access.

    Korrektur - das war kein single user mode (-s), sondern safe mode (-x). Mein Fehler!

    Im richtigen single user mode wird /sbin/fsck -fy ausgeführt, korrigiert aber den Fehler nicht...


    im Recovery:

    cd /Volumes/System wechselt natürlich richtig (mit pwd geprüft), fsck -fy wird trotzdem auf /dev/rdisk3s1 (die Recovery-partition) ausgeführt


    Edit:

    Angeregt durch die Fehlermeldung habe ich mir den betroffenen Ordner angeschaut (/private/var/db/fud/com.apple.MobileAccessoryUpdater.AppleEAAccessoryUpdater/com.apple.MobileAccessoryUpdater.EA.app.A1598.19)


    Im Parentordner befinden sich mehrere Ordner mit identischen Namen (Screenshot im Anhang). APFS Fehler?

    Habe gerade mit dem Festplattendienstprogramm unter Mojave meine Systempartition (APFS) überprüfen lassen:

    Code
    1. Checking the fsroot tree.
    2. error: drec_key object (oid 0x3000b5ef6): invalid hash (0, expected 37ed21) of name (com.apple.MobileAccessoryUpdater.EA.app.A1598.19)
    3. fsroot tree is invalid.
    4. The volume /dev/rdisk2s1 could not be verified completely.
    5. Exit-Code für Dateisystemprüfung lautet 0.
    6. Der ursprüngliche Zustand (aktiviert) wird wiederhergestellt.

    Der Fehler wird nicht behoben. Beim Reparaturversuch im Recoverymodus heisst es: "Das Volume kann nicht für die Reparatur deaktiviert werden". Die SSD startet normal, aber die Meldung macht mich natürlich unruhig. Wie behebe ich das?