Ventura- MacBook 2014- einzelne Programme starten nicht

  • Hallo,

    ich habe schon des öfteren MacOS Ventura auf älteren Mac´s mithilfe des OCLP installiert und bin zunächst begeistert. Jedoch merke ich, dass einige Programme die ich intsalliert habe nicht starten möchten. Wie zum Beispiel RustDesk oder noch viel wichtiger SPSS (Ein Programm welches zwingend für ein Studium benötigt wird).


    Hat jemand eine Ahnung weshalb diese Programme nicht starten möchten und eine dazu passende Lösung?


    Vielen Dank im voraus!

  • Da ich noch nie mit OCLP gearbeitet habe, kann ich dazu nur wenig beitragen.

    Aber:

    Welche Version von SPSS benutzt du denn?

    Auf Ventura läuft nur die 29!


  • Dafür kann es unterschiedliche Gründe geben und leider ist "startet nicht" auch keine sehr ausführliche Beschreibung des Problems. Starteten die Programme kommentarlos nicht oder gibt es Fehlermeldungen und wenn ja wie lauten diese?


    Man darf halt auch immer nicht vergessen das OCLP es zwar ermöglicht aktuelle Systeme auf eigentlich abgekündigter Hardware zu verwenden man sich das aber mit einem ganzen Haufen Flickwerk erkauft (je älter umso mehr wird modifiziert). Dein 2014er MBP zum Beispiel basiert auf der Broadwell CPU Generation und kommt mit einer Intel Iris iGPU. Diese iGPU bzw. das gesamte Gerät wurde offiziell bis macOS 11 (BigSur) unterstützt. Im Falle des Patchers bedeutet das das hier im Grafikstack und diversen anderen Komponenten ältere Treiber (maximal bis BigSur) Verwendung finden. Wenn nun eine Software Features benötigt die die alten Treiber nicht liefern (Metal 2 oder 3 zum Beispiel) dann kann das schon dazu führen das einzelne Programme nicht funktionieren. Ich kenne nun SPPS und dessen Systemvoraussetzungen nicht kann mir aber vorstellen das speziell diese Software (Statistik Software) regen Gebrauch von eben solchen Funktionen macht um zum Beispiel die GPU zum beschleunigten Rechnen zu verwenden.

  • Mmm danke für eure Antworten. Das Programm hüpft 2-3 Mal und dann passiert kommentarlos nichts. Es handelt sich um die Version 29.0.2.0.


    Außerdem habe ich dasselbe Problem mit Rustdesk auf einem 2011er iMac.

  • Okay welche Version von OCLP hast Du verwendet und hast Du ggf. irgendwas am Start das AMFI unterdrückt zum Beispiel das BootArg -amfi=0x80 ?! Die älteren OCLP Versionen haben AMFI Standardmäßig deaktiviert was bei einigen APPS zu Problemen führt...

  • Was bedeutet älter ?

    Ich habe mir im März einen Bootstick mit Ventura über OCLP erstellt.

  • Kalender App funktioniert aber noch? ;)

    Wir haben bald Ende Mai. Da tut sich dann doch schon einiges.

  • Ich habe die Erfahrung gemacht, dass meistens die Grafik daran schuld ist ...


    Native Access von Native Instruments will auch nicht mehr ...


    Leider war auf dem Lenovo T520 mit Big Sur das Ende der Fahnenstange erreicht,

    um damit noch einigermassen vernünftig arbeiten zu können.


    Allen Leuten ein frohes Pfingstfest

  • Naja "älter" meint in dem Fall die Version von OCLP und damit einhergehend der Patchsets wobei März unkritisch sein sollte weil da der AMFIPass.kext schon integriert war und OCLP AMFI nicht mehr standardmäßig deaktiviert. Es wäre eine Idee gewesen aber in dem Fall wird es dann doch eher so sein wie ich eingangs vermutet habe und die App etwas verwenden wollen das die alte Maschine selbst mit Patches einfach nicht (mehr) leisten kann. Der Patcher dreht halt (notwendigerweise) einiges an Libraries und Frameworks auf ältere Versionen zurück wenn eine App nun Funktionen zum funktionieren braucht die es in diesen älteren Version noch nicht gab erklärt das warum die App nicht läuft.


    In Deinem Fall sind das ja nun auch einigermaßen spezielle Anwendungen die möglicherweise wirklich auf Funktionen aus dem Metal 3 Framework zurückgreifen um Berechnungen auf die GPU auszulagern...

  • griven so ist es. Kann mir gut vorstellen, dass auch einige neue Programme die GPU und Metal aus Gründen der Geschwindigkeit nutzen. Ist unter Windows und Linux schon lange der Fall. Ausgediente Hardware ist nichts für das neue Mac OS.
    Habe den Umstieg auf meinen kleinen Mac keinen Tag bereut.

  • Danke für eure Ideen.
    also das SPSS lief tatsächlich auf dem alten Betriebssystem wie es soll. Das Upgrade auf Ventura wurde durchgeführt um den Mac mit dem MS Office nutzen zu können. Jetzt funktioniert das Office aber SPSS nicht.


    😅😅


    Naja wenn es dafür keine Lösung gibt, dann soll es wohl so sein.

  • Mal ein ganz anderer Ansatz.


    Mit welchem MacOS liefen die denn davor.

    Apple hat ja den 32 Bit support entfernt. (ab Big Sur)

    (Das nervt mich auch ganz hart da einige Programme keine Updates bekommen ... -> Da hat man dann gelitten)

    Macbook Pro Retina 2015 + 16GB ram 1TBGB ssd AMD Radeon R9 M370X 2048 MB  OSX 10.14.6)
    GA-Z77 DS3H + i7 3770 + 24GB RAM, RX580 8GB,240GB evo960 NMVe, TP-Link T8E (AC Wlan) + Bluetooth usbstick OSX 10.14.6 OC(on stick)


  • Der Ansatz ist gar nicht so abwegig Moorviper aber SPSS gibt es bis Sonoma (V. 29.0.2 wäre dafür die erforderliche) demnach kann man 32Bit Support wohl ausschließen ;)

    SPSS ist halt eine ziemlich spezielle und offenbar auch ziemlich leistungsfähige Statistik Software. IBM bietet einen Testversion an und ich habe mich mal registriert und versuche das mal auf dem 2015er MacBook mit Sonoma und OCLP nachzuvollziehen...


    Edit: Das Dingen ist zwar lahmarschig wie die Hölle aber...


     


    Es läuft auf dem 2015er MBP mit Sonoma und OCLP. Der Patcher und AMFI Themen scheinen hier also auszuscheiden der Fehler muss also irgendwo anders liegen schätze ich...