Intel UHD 620 Schwarzer Bildschirm

  • Hallo alle zusammen,


    Ich habe ein Problem. Habe erfolgreich OS-Monterey auf mein HP-Laptop (17 by-2335ng) nach Dortania-Guide installiert. Es funktioniert alles soweit ganz gut bis auf den internen Bildschirm. Habe verschiedene Anleitungen und Foren durchgelesen, finde aber einfach keine Lösung.



    Wenn ich device-id aus dem Config-Datei rausnehme, funktioniert der interne Bildschirm, aber ohne Grafikbeschleunigung und im IoReg wird keine Framebuffer angezeigt.


            




    Wenn ich eine device-id einfüge bleibt der Bildschirm dunkel (der leuchtet nur ganz leicht), aber wenn ich ein externer Monitor anschließe, dann funktioniert es mit Grafikbeschleunigung, aber leider kein Bild auf dem internen Bildschirm.



         



    Habe schon alle Framebuffer-Werte durchprobiert aber ohne Erfolg. Ich hoffe Ihr könnt mir paar Tips geben, vielleicht hab ich was übersehen. Danke im Voraus


    Gru Splin

  • splin Zeige mal Deine EFI und schreiben um welche CPU + iGPU es sich handelt.

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • Es ist eine Comet Lake i5-10210U. Efi ist im Anhang.


    Gruß Splin

    Files

    • EFI.zip

      (4.98 MB, downloaded 18 times, last: )
  • ich meine das Comet Lake eine UHD630 verbaut hat.

    Probiere mal die angepasste EFI und wenn es nicht klappen sollte, dann schau mal hier in der Framebuffer Patching Guide vorbei


    EDIT: evtl. diese config.plist (umbennen)

    Files

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

    Edited once, last by Arkturus ().

  • Vielen Dank für die schnelle Antwort. Leider funktioniert das auch nicht. Ich habe auf dieser Seite gelesen, dass diese CPU eine 620 GPU hat, deshalb habe ich das so in meinen Einstellungen übernommen. Habe die Seite schon mehrere Male durchgelesen, aber ich krieg das einfach nicht hin meine GPU zum Laufen zu bringen. Ich hab schon alle Framebuffer ausprobiert, habe mit "alldata" versucht und jeden Anschluss: con0, con1, con2 einzeln, aber nichts hilft. Hast du irgend eine Idee, was das Problem sein könnte?



    Gruß Splin

  • Kannst Du im Bios noch Einstellungen zur iGPU vornehmen? Ansonsten andere Varianten zur ig-plattform-id und device-id probieren.

    Hat die Möhre noch eine Nvidia zusätzlich an Board? Dann müsste die deaktiviert werden

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • hm, mal so nebenbei- ist das bios vom book aktuell?


    lg und nun weitermachen :)

  • hier findest du eine EFI mit DP-Eintrag für UHD630. evtl. funzt dieser bei Dir. splin

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"

  • Arkturus Nein, leider sind keine Einstellungen zur IGPU und habe keine zusätzliche GPU drin. Wie bereits schon oben geschrieben, habe sie alle schon probiert mit device-id und ohne.


    apfel-baum Ja, Bios ist aktuell. Was ich einwenig komisch finde, habe eine zusätzliche SSD-Platte mit win10 drin und die wird im bios angezeigt, aber die mit OSX-NvMe-Platte nicht... Habe schon überlegt bios zu modden, damit ich mehr Einstellungen habe, aber ich kenne mich damit leider nicht aus.




    Gruß Splin

  • hm, das mit der osx-platte, den booteintrag-

    kannst du ggf. mit bootice oder easyuefi /uefi shell regeln, würde ich meinen. Boot-Eintrag im BIOS verschwunden - Wege zur Wiederherstellung


    lg :)


    biosmodding beim notebook-kann klappen, muß aber nicht- soein notebookbios ist nocheinmal eine spur anders, auch wie man da rankommt bzw. es bei glück, wieder zum laufen bewegt

    edit-

    eine 10th gen cpu wäre mir für nen brick etwas zu schade

  • es geht nicht darum den DP rein oder raus zu nehmen. Da musst Du dich mit beschäftigen. splin


    Diese Einträge kannst Du mit den möglichen Varianten ändern, Siehe die FrameBuffer Patching GUIDE zum, WEG anpassen. Du kannst auch die Framebuffer aus der oben verlinkten EFI probieren, welche du am 23.11. schon besucht hattest.

    Grüße

    Arkturus

    "Ein Hackintosh ist wie ein Garten - es gibt immer was zu tun"