Stromverbrauch nach Update auf Monterey

  • Hi Forum,


    ich stehe gerade auf dem Schlauch. Mit Monterey verbraucht mein System über 100W im Idle, mit Big Sur nur 60W (3 SSD und eine HD inklusive),.


    Ich hatte Monterey 12.6.1 neu installiert, dann per Migration die Daten übertragen. Das jetzige Efi ist eine leicht modifizerte Variante von McCallumDillons EFI, der fast dasselbe System hat. (Danke an dieser Stelle)


    Mit demselben Efi läuft auch Big Sur, verbraucht aber nur 60W, also ist bei Monterey was schief. "kernel_task" verbraucht konstant 50%, was vermutlich den Stromverbrauch erzeugt. Das soll mit Lüftern bzw. Hitze zusammenhängen. Was kann das bei Monterey bewirken?


    Probiert:

    Alle passenden EFIs aus dem Netz ausprobiert (5-6 Stück funktionieren), Schmocklord usw. Immer dieser hohe Verbrauch.

    Verschiedene USB Mappings

    Nur ein Bildschirm

    iMac 20,2 oder Mac Pro 1.1

    Bluetooth/Ethernet/Wifi aus


    Nichts davon macht einen Unterschied. Jemand eine Idee?

    Hier mein EFI-Ordner. Die Datei "AirportItlwm dummy.kext" ist leer wegen Dateigröße.


    Danke im voraus

  • Ich finde 60 Watt schon zu viel für Idle. Mein damaliges z390 System mit i7 und RX580 war im Idle bei runde 40 Watt mit 2 drehenden HDD´s.

  • Ich wäre mit 60 Watt völlig zufrieden, entspricht 50 Watt System. Ist übertaktet bei 10 Kernen und das System ist sehr schnell. Momentan ist es nur blöderweise der doppelte Verbrauch, skaliert bei Belastung auch schlecht.

    Wie erreiche ich mit meinem System wieder normalen Verbrauch unter Monterey?

  • Den wirklichen Stromverbrauch misst man nicht mit dem unkalibrierten Schätzeisen Taskmanager oder Aktivitätsanzeige, sondern mit sauteuren Messgeräten.

    Ich würde mir da jetzt nicht ins Hemd machen.


    Ein Computer ist nicht automatisch im Leerlauf, nur weil man die Maus nicht bewegt. Moderne Betriebssysteme nutzen diese Zeit für systemnahe Hintergrund-Prozesse.


    Wer Energiesparen möchte, der sollte lieber das Terminal benutzen.

    Finder und FDP verbrauchen mehr Watt [wech]

  • Ich würd mir an der Stelle einfach mal ein Weiteres APFS Volumen erstellen, dort mal Ventura installieren und schauen ob es da auch so ist. Wenn nicht, dann hättest du ja die Möglichkeit Ventura anstatt Monterey zu nutzen.

  • Das ist mit einem externen Messgerät gemessen, was bei mir ständig am Computer hängt. Damit ist auch zu sehen, wie schlecht das System kalibriert wenn es arbeitet - viel schlechter als vorher mit Big Sur. Das Verhalten und der doppelte Stromverbrauch sind Symtome, dass was nicht stimmt mit System.

    Ventura wäre höchstens als Test interessant, ist mir zu buggy als Produktivsystem, braucht noch ein paar Updates.


    Keiner eine Idee, was das sein könnte? Gibt es signifikante Änderungen in der Grafik oder im Powermanagement von Big Sur zu Monterey? Sonstige Anpassungen oder Erweiterungen, die man probieren könnte?

  • Ich warte jährlich immer auf die letzte Version eines Systems um zu updaten - Marotte.

    Kannst Du denn was zu dem Problem mit Monterey sagen bzw. ist Dur das kernel_task Problem schon über den Weg gelaufen? Es scheint sehr viele Leute auch mit echten Macs zu betreffen.


    Update: ich habe gerade ein weiteres Monterey installiert. Völlig out of the box gibt des kein kernel_task als aktiven Prozess. Der Stromverbrauch landet aber wieder auf exakt 100 Watt, wie festgemeißelt. Also doch ein opencore-Problem.

    Edited once, last by Smallersen: Update: ich habe gerade ein weiteres Monterey installiert. Völlig out of the box gibt des kein kernel_task als aktiven Prozess. Der Stromverbrauch landet aber wieder auf exakt 100 Watt, wie festgemeißelt. Also doch ein opencore-Problem. ().

  • Kannst du mal im istat menüs schauen, was die CPU und, falls es dir angezeigt wird, was die GPU verbraucht?

    Und lad doch mal deine EFI hoch, dann kann man da mal schauen.

    Bei mir ist alles von Big Sur - Ventura gleich im Verbrauch.


    grad gesehen EFI ist ja oben schon.


    edit: Du lädst die komplette DSDT. Die würde ich niemals laden. Schau mal hier, dass sind die SSDTs die du für dein system brauchst. Pack mal nur die rein und schau ob es sich schon bessert.

    https://dortania.github.io/Ope…list/comet-lake.html#acpi

    Gerad die Plug ist fürs Powermanagement wichtig.

  • Smallersen su schreibst oben

    Probiert:

    Alle passenden EFIs aus dem Netz ausprobiert (5-6 Stück funktionieren), Schmocklord usw.


    Wie wäre es mal mit Selbermachen? Gibt für Opencore die tolle Anleitung auf dortania.


    In deiner EFI geistert eine pachted DSDT rum.

    SSDT-Plug.aml für CPU-Speed-Stepping-Mode fehlt.

    Du betreibst einen i9-10850 der zehnten Generation der sich eigentlich mehr auf einem Z490 zuhause fühlt.

    Mac OS selbst ist der i9-10850 nicht bekannt.

    Daher ist für dein Board CPU-Friend schon Pflicht für ein geordnetes Speed-Stepping.


    Das kann ja nichts werden. Kein Wunder das die CPU auch im Leerlauf soviel Strom zieht. Die taktet nicht mehr richtig.

    Aber die DSDT tut - weh :bag_head:


    Bitte lesen. Auch wenn es viel ist. Es lohnt sich auf alle Fälle.


    CPUFriend Guide, HWP & Speedstep: X86PlatformPlugin vs ACPI_SMC_PlatformPlugin

    Edited 5 times, last by bluebyte ().

  • user232 das ist ganz was anderes. Dort werden keine Vektoren für die Frequenzen generiert.

  • user232 Ich muss sagen, dass wir uns damals viele Wochen mit dem Thema beschäftigt haben. Schau dir mal den Thread-Verlauf an.

  • schon mal daran gedacht?: das neu aufgespielte Betriebssystem indiziert am Anfang auf alle Dateien für die Spotlight Suche im Hintergrund .. das könnte schon der Kernel Task sein .. je nach Fülle kann das ziemlich lange dauern .. ich würde n paar Tage warten und dann nochmal neu bewerten ..

    iCAD (iMac13,2):

    i5 3570K, Gigabyte GA-Z77X D3H, MSI Geforce GTX 770 TF 4GB, 16 GB XMS3-1333

    AeroCool DS200, black

    OpenCore, OS X 10.14, Win 10 Pro


    critical iMac (iMac19,1):

    i5 9600K, Asus Z370-I Gaming, MSI RX 6650 XT Mech2x 8G OC, 16 GB Vengeance 2666

    Bitfenix Prodigy, white

    OpenCore, macOS 13, Win 11 Pro


    iPhone SE 64GB, iPadPro 10,5 64 GB, Apple TV 4k 64 GB, 13“ MacBook Pro Late-2016 Touchbar

  • Danke an alle für die Antworten, super.


    hObelware: Ja, weiß ich. Monterey ist aber so lange gelaufen dass das die Indizierung definitiv durch ist.

    Ich habe testweise Ventura installiert, scheint sich genauso zu verhalten. Das ist aber noch nicht lange genug gelaufen um eine finale Aussage machen zu können.


    @bluebyte: Interessante Anregungen, danke.

    Wegen Dortania:

    Dort wird explizit der Prozessor i9-10850K erwähnt - glücklicherweise.

    Die Comet Lake Anleitung dort gilt für Catalina, ist leider nicht mehr aktuell. Für Big Sur passte es noch, danach hat sich weiß der Kuckuck was alles geändert. Das ist quasi meine Ausgangsfrage.

    Meine zusammengebaute EFI, die in Big Sur schön funktionierte, ließ sich absolut unter Monterey nicht mehr zum Spielen bringen, sehr lange probiert.


    Wegeg DSDT:

    McDillonCallum hat dasselbe Board und denselben Prozessor. Er hat diese DSDT von Olarilla generieren lassen. Deshalb das momentane EFI-Setting mit DSDT (via Github). Eine DSDT einzubinden scheint der Weg zu sein, den Olarilla grundsätzlich vorschlägt, oder? Gibt es sicher verschiedene Meinungen zu.


    Bis auf das Power Managemant macht das Olarilla-Efi einen guten Eindruck, es scheint alles zu funktionieren, auch stabil. Könnte man da eine Plug-SSDT zusätzlich einbinden?

  • Smallersen wie wäre es zur Abwechslung mal mit nem vanilla System?
    Wenn du dir irgend ein Zeugs aus dem Netz lädst, dann wende dich an die Quelle.
    Hier im Forum gilt: selber machen, dein System verstehen lernen. Hilfe zur Selbsthilfe.


    Zwischen deinen Zeilen verbirgt sich eine Menge Faulheit und kein bisschen Verständnis.


    Erstelle dir eine eigene efi , Hilfe dazu findest du auf den dortania GitHub Seite sowie hier im Forum.


    Steckst du fest melde dich.


    Diese Einstellung …ich lad mir mal… und hoffen das es funktioniert, kannste Knicken.


    Hackintoshing ist keine Windows Installation und schon garkein einfach mal drauf Zimmern.


    Mach es richtig oder lass es. Aber lass auf jeden Fall das Flamen.