(Bluetooth) Magic Mouse 2 Verbindungsabbrüche im Sleep Modus

  • Hallo Freunde,


    ich habe ein Problem. Seit geraumer Zeit disconnected sich meine Magic Mouse 2, wenn mein Hacky in den Sleep geht.


    Manchmal funktioniert das Aufwecken mit der Maus. Manchmal erkennt der Hacky die Maus überhaupt nicht mehr. Dann hilft nur noch ein Neustart des Computers oder Neu Verbindung der Magic Mouse 2 in den Bluetooth Einstellungen.


    Mein Build:

    Mainboard: Gigabyte Z390 Designare, CPU: Intel i7-9700K, Speicher: 16 GB DDR4 (3466 MHz), WLan: Fenvi T919, Grafik: Radeon RX Vega 56

    OC 0.85


    Ich wäre über jede Hilfe und jeden Rat dankbar!

    Mein Build:

    Mainboard: Gigabyte Z390 Designare, CPU: Intel i7-9700K, Speicher: 16 GB DDR4 (3466 MHz), WLan: Fenvi T919, Grafik: Radeon RX Vega 56

    OC 0.85

  • Hi,

    ist der interne USB-Port, für den BT-Anteil der Fenvi-Karte, in deinem USB-Ports.kext, bzw. der vergleichbaren SSDT auf "intern" eingestellt?

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hallo al6042

    Ich bin leider noch Amateur. Wo sehe ich das denn genau ein?

    Mein Build:

    Mainboard: Gigabyte Z390 Designare, CPU: Intel i7-9700K, Speicher: 16 GB DDR4 (3466 MHz), WLan: Fenvi T919, Grafik: Radeon RX Vega 56

    OC 0.85

  • Nun,

    ich nutze in OpenCore für das USB-Mapping einen Kext, der in der EFI-Partition im Ordner /EFI/OC/Kexts liegt und in der config.plist eingetragen ist:


    In dem Kext gibt es nur die Datei USBPorts.kext\Contents\Info.plist, in der die einzelnen USB-Ports ihre Konfiguration erhalten haben.

    An meinem Beispiel hängt der BT-Anteil meiner Broadcom-Karte am internen USB-Header unter der Bezeichnung HS12:


    Der Wert 255 unter "UsbConnector" definiert diesen Port als "intern" und ändert somit das Verhalten im Sleep-Mode gegenüber Standard-USB-Definitionen.

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • al6042

    In meiner PLIST ist kein solcher Eintrag. Auch in meinen Kexts nicht.
    Ich habe Jimsalabim seine EFI am Laufen.

  • Da ist noch der alte USBInjectAll.kext, der natürlich hierfür nicht geeignet ist.

    Versuche mal nach folgender Anleitung einen dedizierten Kext für deine Kiste zu erstellen -> https://github.com/5T33Z0/OC-L…ed/tree/main/03_USB_Fixes

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • al6042

    Hey, ich weiß ja nicht, was USB mit Bluetooth zu tun hat. Kannst Du mir das Näher erklären, bevor ich mich da ranmache?

    Mein Build:

    Mainboard: Gigabyte Z390 Designare, CPU: Intel i7-9700K, Speicher: 16 GB DDR4 (3466 MHz), WLan: Fenvi T919, Grafik: Radeon RX Vega 56

    OC 0.85

  • Bluetooth-Module werden zwar in die PCIe-WLAN-Kombikarten verbaut, aber über USB-Ports angesprochen.
    Bei m.2 NGFF-Karten sind ein paar der Steckkontakte an den USB-Bus angebunden und bei den PCIe-Adpater-Karten wie die Fenvi wird ein USB-Header-Kabel mitgeliefert, um über die Onboard-USB2.0-Header der Mainboards die BT-Funktion nutzen zu können.
    Beispiel der Fenvi-Karte:


    Erläuterung der m.2 Key-Typen:

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • hey al6042


    Danke für Deine Mühe. Ich frag mal im anderen Thread, ob das ratsam ist.
    Was würdest Du sagen vom Niveau her? Kriegt das ein Amateur hin?

    Mein Build:

    Mainboard: Gigabyte Z390 Designare, CPU: Intel i7-9700K, Speicher: 16 GB DDR4 (3466 MHz), WLan: Fenvi T919, Grafik: Radeon RX Vega 56

    OC 0.85

  • Du meinst das Erstellen eines Kexts für die Definition der USB-Ports?
    Klar... dafür gibt es entweder die von mir verlinkte Anleitung oder du suchst im Forum nach einer der anderen Herangehensweisen.
    Aber das solltest du tatsächlich damit auch selbst hinbekommen.

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!