Sound auf eine U430p Ideapad

  • Hallo zusammen,


    ich habe mein System von Mac OS 10.10 auf 10.12 geupdatet. Unter 10.10 lief das System mit Audio problemlos inkl. Sound auf dem LENOVO U430p mit Clover als Bootloader.


    Weder mit VoodooHDA.kext noch mit AppleHDA.kext bzw. AppleALC.kext werden unter Moc OS 10.12 jetzt Audio-Geräte erkannt. Ich habe mal das EFI zum Start für 10.12 mit Clover beigefügt.


    Da scheint noch irgendeine Kleinigkeit nicht richtig eingestellt zu sein.:think:


    Danke, viele Grüße.:danke2:

    Files

    • EFI.zip

      (9.86 MB, downloaded 9 times, last: )

    U430p Ideapad ; CPU: Intel Core I5-4210U ; 4GB RAM ; 500 GB Festplatte ; Grafik: Intel HD 4400 ; OS X 10.10.4 ; Win 8.1

  • Hallo New_User_U430p
    Ich habe deine Frage mal in einen eigenen Thread verschoben, da diese im ursprünglichen Vorgang nichts verloren hat, bzw. den anderen Vorgang gekapert hätte.

    Gruß
    Al6042

    Keine Unterstützung per PN oder Pinnwand... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Hast Du noch die funktionierende EFI von 10.10 ?

    In der aktuellen EFI sind keine Fixes gesetzt, welche vielleicht gebraucht werden, damit es mit AppleALC geht. Nur mal zum Vergleich.

    Ferner sind Deine Kext's in der EFI uralt, kann so nie was werden mit aktuellem macOS, also erst einmal alle Kext's erneuern und dann schauen.

    AppleHDA gehört da auch nicht hin.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  BCM94360NG  SSD 512GB + NGFF M2 SSD 512GB  macOS 12.6.2 / 13.1 DP4

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema 32" LG 4k  SSD 250GB+512GB  macOS 12.6.2 / 13.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  4k-TV 42"  BCM94360CD  SSD 2x250GB + 480GB  macOS 10.15.7 / 12.6.2 / 13.1 DP4

    MacMini2014: i5  2,8GHz  16GB DDR3  Intel Iris 5100  23" Apple-Cinema  1,12 TB Fusionsdrive  macOS 12.6.1

    iPhone8 64GB: iOS 16.1.1  iPad Pro 9,7" WiFi 32GB: iPadOS 16.2

  • Hallo MacPeet,


    das funktionierende EFI von 10.10 habe Dir jetzt hier in der Nachricht angehängt.

    Files

    • EFI.zip

      (4.2 MB, downloaded 6 times, last: )

    U430p Ideapad ; CPU: Intel Core I5-4210U ; 4GB RAM ; 500 GB Festplatte ; Grafik: Intel HD 4400 ; OS X 10.10.4 ; Win 8.1

  • Ok, die config.plist's von dieser 10.10 sind ziemlich leer und hier hast Du mit VoodooHDA gearbeitet.


    Wie ich bereits oben schrieb, müssen die Kext's erneuert werden, da Deine alle viel zu alt sind. Dies ist zwingend notwendig.

    Ferner vermutlich auch die Clover-Version, wenn Du dies nicht schon getan hast.

    Wenn Du statt VoodooHDA nun mit Lilu und AppleALC arbeiten möchtest, dann musst Du im CloverConfigurator in Deiner config einige Haken setzen.

    FixHDA setzen, wenn Du die jeweilige LayoutID bei Audio Inject gesetzt hast.

    Ferner muss auf Laptops der IRQ-Fix gemacht werden, d.h. Haken bei FixRTC und FixTIMR setzen. FixIPIC kann man auch noch machen, ist zwar nicht für's Audio relevant, aber schadet nicht.

    Letztendlich Clover und Kext's erneuern musst Du schon selbst machen. Fertige Lösungen kann keiner Backen.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  BCM94360NG  SSD 512GB + NGFF M2 SSD 512GB  macOS 12.6.2 / 13.1 DP4

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema 32" LG 4k  SSD 250GB+512GB  macOS 12.6.2 / 13.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  4k-TV 42"  BCM94360CD  SSD 2x250GB + 480GB  macOS 10.15.7 / 12.6.2 / 13.1 DP4

    MacMini2014: i5  2,8GHz  16GB DDR3  Intel Iris 5100  23" Apple-Cinema  1,12 TB Fusionsdrive  macOS 12.6.1

    iPhone8 64GB: iOS 16.1.1  iPad Pro 9,7" WiFi 32GB: iPadOS 16.2

  • New_User_U430p

    Changed the title of the thread from “Sound auf eine U340p Ideapad” to “Sound auf eine U430p Ideapad”.
  • Hallo MacPeet,


    der Sound läuft jetzt wunderbar. Allerdings nicht mit AppleALC, sondern mit VoodooHDA. Im CloverConfigurator habe ich noch einige Haken gesetzt und ich habe den VoodooPS2Controller.kext aus dem EFI rausgeschmissen. Es gab wohl einen Konflikt zwischen den Kexten VoodooHDA und VoodooPS2Controller.


    Demnächst werde ich dann auf Mojave oder Catalina upgraden.


    Ein schönes Wochenende wünsche ich. :feuerwerk:

    U430p Ideapad ; CPU: Intel Core I5-4210U ; 4GB RAM ; 500 GB Festplatte ; Grafik: Intel HD 4400 ; OS X 10.10.4 ; Win 8.1

  • Ok, wenn Du damit zufrieden bist, alles gut. Der Ton mit VoodooHDA ist oft nicht so gut, wie mit AppleALC.


    Hast Du denn ohne VoodooPS2Controller überhaupt Tastatur und Trackpad an dem Laptop?

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  BCM94360NG  SSD 512GB + NGFF M2 SSD 512GB  macOS 12.6.2 / 13.1 DP4

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema 32" LG 4k  SSD 250GB+512GB  macOS 12.6.2 / 13.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  4k-TV 42"  BCM94360CD  SSD 2x250GB + 480GB  macOS 10.15.7 / 12.6.2 / 13.1 DP4

    MacMini2014: i5  2,8GHz  16GB DDR3  Intel Iris 5100  23" Apple-Cinema  1,12 TB Fusionsdrive  macOS 12.6.1

    iPhone8 64GB: iOS 16.1.1  iPad Pro 9,7" WiFi 32GB: iPadOS 16.2

  • VoodooHDA hat aber den Vorteil das er das Mic eher mal zum laufen bekommt als der AppleHDA auf Laptops. Was in meinen Augen ziemlich sinnvoll ist für später Facetimeanrufe :)

  • Hast Du denn ohne VoodooPS2Controller überhaupt Tastatur und Trackpad an dem Laptop?

    Ich habe am Notebook einen HD-Monitor und eine externe Tastatur+Maus angeschlossen. Im Grundsatz nutze ich das Gerät so. Für mobiles Arbeiten muss ich somit doch noch etwas tüfteln, :think:ohne VoodooPS2Controller läuft die Tastatur + Trackpad nicht, wie ich gerade getestet habe. Danke für den Hinweis.

    U430p Ideapad ; CPU: Intel Core I5-4210U ; 4GB RAM ; 500 GB Festplatte ; Grafik: Intel HD 4400 ; OS X 10.10.4 ; Win 8.1

  • a1k0n

    Mag sein, aber trotzdem ist der Voodoo-Ton oft schlechter und man muss zumeist die Schieberegler des Prefpan's richtig einstellen.

    Mir ist das Problem der Kombibuchsen natürlich bekannt.

    Für die Serie T440/T440S, T450/T450S, X240 und alle mit gleichem Audio-Chip habe ich es damals mittels ManualMode gelöst (ID15), wo alles nativ geht mit AppleALC.

    Andere Nutzer haben ID28 verwendet, welche dann Zusatz-Kext's (ALCPlugFix und Codeccomander) brauchten, damit es halbwegs ging (Bei manchen wohl erst nach Sleep). Diese Lösung habe ich aber nie getestet, da mein Ziel immer nativ ist.

    Welchen Chip das U430p verbaut hat, keine Ahnung bislang.


    New_User_U430p

    Wenn dies das Ziel ist, dann ist's doch gut.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  BCM94360NG  SSD 512GB + NGFF M2 SSD 512GB  macOS 12.6.2 / 13.1 DP4

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema 32" LG 4k  SSD 250GB+512GB  macOS 12.6.2 / 13.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  4k-TV 42"  BCM94360CD  SSD 2x250GB + 480GB  macOS 10.15.7 / 12.6.2 / 13.1 DP4

    MacMini2014: i5  2,8GHz  16GB DDR3  Intel Iris 5100  23" Apple-Cinema  1,12 TB Fusionsdrive  macOS 12.6.1

    iPhone8 64GB: iOS 16.1.1  iPad Pro 9,7" WiFi 32GB: iPadOS 16.2

  • @MacPeet


    Natürlich hast du Recht was den Ton betrifft. Aber jeder weiss wie Laptoplautsprecher klingen und dort macht VoodooHDA keinen wirklichen Unterschied. Beim Lenovo G500 ging Jahre lang kein Mic mittels AppleHDA und man war auf Vooodoo angewiesen. Irgendwann gab s mal einen JackHDA Fix oder so ähnlich lässt sich heute aber wohl garnicht mehr so leicht installieren da man SIP deaktivieren muss.

  • Ja, das ist sehr schade, dass diese Art Fixes oft zwar entwickelt werden, jedoch dann nicht weiter aktualisiert werden. Irgendwann laufen sie dann nicht mehr.

    Daher versuche ich immer Lösungen direkt in der AppleALC einzubauen, da diese ja bislang gut betreut wird.


    Edit:

    Mit Umbau nativer Wlan/BT-Karte kann man dieses Problem ext. Mic auch umgehen und man verbindet seine AirPods oder was vergleichbares.

    Mache ich nur noch so am T450s, obwohl hier das ext. Mic ja geht.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  BCM94360NG  SSD 512GB + NGFF M2 SSD 512GB  macOS 12.6.2 / 13.1 DP4

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema 32" LG 4k  SSD 250GB+512GB  macOS 12.6.2 / 13.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  4k-TV 42"  BCM94360CD  SSD 2x250GB + 480GB  macOS 10.15.7 / 12.6.2 / 13.1 DP4

    MacMini2014: i5  2,8GHz  16GB DDR3  Intel Iris 5100  23" Apple-Cinema  1,12 TB Fusionsdrive  macOS 12.6.1

    iPhone8 64GB: iOS 16.1.1  iPad Pro 9,7" WiFi 32GB: iPadOS 16.2

    Edited once, last by MacPeet ().