Geht das problemlos?

  • Hallo zusammen, habe noch einen "Server" hier rumstehen mit folgendem Board. Im Moment ist da noch ein Pentium G6400 Gold drauf, der ja leider nicht unterstützt wird.

    Da ich jetzt von Android auf Iphone umgestiegen bin, kam mir die Idee den "Server" auf einen Hackintosh umzubauen. Leider bin ich ziemlich lange raus aus dem Thema, hatte aber schon mal einen Hackintosh am laufen.

    Deshalb vorweg die Frage der Machbarkeit, da ich es so einfach wie möglich gestalten will. Würde mir dann einen i3 10100 oder einen i5 10400 besorgen. Würda das dann funktionieren?


    Danke vorab für die Antworten.

  • Hi,

    Der Pentium sollte mit passender CPUID und zusätzlicher Grafikkarte (radeon rx) auch mit macos funktionieren.

    I3 / i5 mit iGPU läuft auch unter macos.

    Würde aber eher einen gebrauchten i5 10600(k) (oder gar einen 10700 der kann höheren RAM takt auf dem H410) nehmen, als den 10400 neu.

    Z. b. Der ist recht günstig.

    https://www.ebay-kleinanzeigen…s&utm_content=app_android

    !!Kein Support per PN!!

    Vorsicht beim Update von CLOVER (v.5123 und neuer) !

    Wenn dein System gut läuft, erstell' einen Thread im Hardware Center mit EFI, und gib die verwendete Hardware dazu an.

    Bewegen im Hardware Center


    Welchen Bootloader sollte ich wählen? Hier gibt's eine Erklärung der Unterschiede, die einem bei der Entscheidung hilft: OpenCore EFI Bootloader 


    Grafikkarte defekt? - hier finden sich Infos dazu: Grafikkarten reparieren durch backen?!


    curse_pic.png

  • hallo technodj23 ,

    das du lange raus bist ist nicht so schlimm, als das sich zwar so einiges verändert hat- aber es nachlesbar ist-


    zu opencore im speziellen, gibt es den dortania guide, welcher auf der durchaus aktuellen version 0.8.3 aufbaut. - https://dortania.github.io/OpenCore-Install-Guide/


    für das thema ansich- kennst du vielleicht noch oder nicht- den beginners guide zum etwas auffrischen.

    - Beginner's Guide - der Einstieg in das Hackintosh-Universum


    lg :)

  • Würde aber eher einen gebrauchten i5 10600(k) (oder gar einen 10700 der kann höheren RAM takt auf dem H410) nehmen, als den 10400 neu.

    Z. b. Der ist recht günstig.

    https://www.ebay-kleinanzeigen…s&utm_content=app_android

    Danke für den Tip, konnte sogar noch ein bisschen runterhandeln :-D

    Dann werde ich mal berichten ob alles funktoniert hat wenn die CPU da ist. Gibt es evtl. schon eine fertige EFI für das Motherboard?

  • Googel einfach das Board mit den Worten github und OpenCore


    Oder schau mal im Hardware Center, hier im Forum.


    Eine efi selbst zu erstellen ist selbst ohne große Kenntnisse in einer Stunde durch wenn man z.B. Auf YouTube seperat ein Video dazu schaut.


    Wichtig ist das man erst ein usb mapping macht, falls du direkt Big Sur oder höher gehen magst. Bis catalina geht's auch noch mit dem usbinjectall kext

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Beta 7

    MacMini 6,1  Late 2012 - Monterey - OC Legacy Patcher

    MacBookPro 11,1 Mitte 2014 - Monterey - OC Legacy Patcher

    Dell XPS 13 7390  Intel® Core™ i7-10510u -OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Beta 7

  • Wichtig ist das man erst ein usb mapping macht, falls du direkt Big Sur oder höher gehen magst. Bis catalina geht's auch noch mit dem usbinjectall kext


    Da fängt es schon mal an :-D brauchte ich früher alles nicht, oder doch? :think:

  • Bis Catalina geht s es mit dem usbinjectall. Kext mit dem booten…. Danach nur noch mit einem usbmapping. Kannst du aber auch mit einem Tool schon unter Windows vorher machen


    https://github.com/USBToolBox/tool/releases/tag/0.1.1


    und hier die Anleitung


    USB-Ports mappen unter Windows

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Beta 7

    MacMini 6,1  Late 2012 - Monterey - OC Legacy Patcher

    MacBookPro 11,1 Mitte 2014 - Monterey - OC Legacy Patcher

    Dell XPS 13 7390  Intel® Core™ i7-10510u -OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Beta 7

  • So, ich glaube ich bin doch zu alt für die ganze Aktion :-D Hab mich genau nach Anleitung/Video von (Dortania's OpenCore Install Guide+Video) aber wenn ich jetzt vom Stick booten will, wird mir nur Windows als System angezeigt. Ich möchte gerne ein Dual Boot System haben und habe gelesen dass man vorher Windows installieren soll. Liegt es vielleicht daran? Irgendwie kam mir das damals alles bisschen leichter vor :-D

  • hallo technodj23 ,

    hast du im apfsreiter (uefi-apfs) via des ocat ,bei "minversion" sowie "mindate" , "0" oder "-1" stehen, falls ersteres, ändere dies jeweils mal zu "-1"

    sowie,- hast du windows im gpt-uefi modus installiert?


    edit- und als vid - dies hier

    nicht vergessen- auch die videos altern, deswegen kann es zu fehlern kommen, von dem die ersteller noch nix gewußt haben- sowie ändert sich z.b. auch die opencoreversion/build ;)


    lg :)

  • hast du im apfsreiter (uefi-apfs) via des ocat ,bei "minversion" sowie "mindate" , "0" oder "-1" stehen, falls ersteres, ändere dies jeweils mal zu "-1" <-- Ja, hab ich


    sowie,- hast du windows im gpt-uefi modus installiert? <-- was bedeutet das? Sagt mir jetzt auf Anhieb nichts.


    Die Videos kenne ich, leider wird da ja anhand eines vorhandenen Apples erklärt wie der Stick erstellt wird. Habe aber leider nur Windows Rechner zur Hand.

  • wie war das - versuchst du auf die hardware im profil osx86 einzuspielen, und welche osx-version soll es erstmal werden, catalina?


    edit-

    eine reihe wintools gibt es mittlerweile auch-

    sei es nun das ältere bdu und oder die ocat


    lg :)

  • du Kannst ein Catalina Recovery Stick unter windows erstellen. http://cvad-mac.narod.ru/index/bootdiskutility_exe/0-5 Voraussetzung für die Installation ist, das der ethernet Adapter während der Installation aktiv funktioniert.


    Wie man einen full Installer unter windows erstellt...glaub per Terminal , aber frag mich nicht wie das geht


    Wegen der schon vorhandenen windows Installation ... https://www.chip.de/downloads/…ree-Edition_37391095.html dort kannst du im Notfall die Partition Table auch noch nachträglich ändern

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Beta 7

    MacMini 6,1  Late 2012 - Monterey - OC Legacy Patcher

    MacBookPro 11,1 Mitte 2014 - Monterey - OC Legacy Patcher

    Dell XPS 13 7390  Intel® Core™ i7-10510u -OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Beta 7

  • technodj23


    Lade doch mal hier deine Versuchs EFI hoch , dann könnte mann dir dann sagen was vielleicht verkehrt ist :)

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • technodj23


    Teste es mal mit dieser EFI :) , dies mal ist das eine DEBUG version sollte es nicht Funktionieren dann findest du auf denn UZSB Stick eine Text Datei log die hier dann mal hochladen.

  • technodj23


    das kann auch an den Bios Einstellungen liegen, wenn dort nicht alle SecureBoot Optionen deaktiviert sind, zeigt dir das Boot Menü vom Bios den USB Stick nicht als startbare Option an, bzw. bootet auch nicht von USB.


    Anbei mal eine PDF für ein HP Bios, die Optionen kannst du aber auch mal einfach durchgehen sofern vorhanden.


    Bei Video Memory Size: aber 64MB lassen in der Regel......


    HP EliteDesk 800 G4 Mini BIOS Configuration


    Security

    • TPM Embedded Security

    o TPM Device: Hidden

    o TPM Activation Policy: No prompts

    • BIOS Sure Start

    o All options unchecked

    • Intel SGX: Disable

    Advanced

    • Boot Options

    o Startup Delay: 5. (useful during testing to give time for Function key presses)

    o Fast Boot: unchecked

    o USB Storage Boot: checked

    o Network (PXE) Boot: unchecked

    o Audio Alerts During Boot: unchecked (to disable beep after pressing F9 at boot)

    o UEFI Boot Order

    § USB

    § Other boot drives as desired

    o Legacy Boot Order

    § Unchecked

    • HP Sure Recover

    o Unchecked

    • Secure Boot Configuration

    o Legacy Support Disable and Secure Boot Disable

    o Secure Boot Key Management

    § All options unchecked

    • System Options

    o Configure Storage Controller for RAID: unchecked

    o Configure Storage Controller for Intel Optane: unchecked

    o Turbo-boost: checked

    o Hyperthreading: checked

    o Multi-processor: checked

    o Virtualization Technolgy (VTx): checked

    o Virtualization Technology for Directed I/O (VTd): unchecked

    o M.2 SSD 1: checked

    o M.2 SSD 2: checked

    o M.2 WLAN BT (unchecked if you have Intel WLAN / BT device or don’t have

    WLAN / BT)

    o Allow PCIe/PCI SERR# Interrupt: checked

    o Power Button Override: 4 sec

    o USB Type-C Connector System Software Interface (USCI): unchecked

    o HP Application Driver: unchecked

    • Built-In Device Options

    o Embedded LAN Controller: checked

    o Wake On LAN: Disabled

    o Dust Filter: Unchecked

    o Video Memory Size: 64MB 512MB

    o Audio Device: checked

    o Microphone: Enable

    o Internal Speakers: checked

    o Increase Idle Fan Speed (%): 0

    o M.2 USB / Bluetooth: Unchecked (disabled in System Options)

    • Port Options

    o Front USB Ports: checked

    o Front USB Port 1: checked

    o Front USB Port 2: checked

    o Front USB Port 3: checked

    o Rear USB Port 1: checked

    o Rear USB Port 2: checked

    o Rear USB Port 3: checked

    o Rear USB Port 4: checked

    o USB Legacy Port Charging: unchecked

    o Front USB Type-C Downstream Charging: unchecked

    o SATA 0: checked

    o Restrict USB Devices: Allow all USB Devices

    • Option ROM Launch Policy

    o This is grayed out for me (probably as a result of another selection)

    • Power Management Options

    o Runtime Power Management: checked

    o Extended Idle Power States: checked

    o S5 Maximum Power Savings: checked

    o SATA Power Management: checked

    o PCI Express Power Management: checked

    o Power On from Keyboard Ports: this option is grayed out for me

    o Unique Sleep State Blink Rates: unchecked

    • Remote Management Options

    o Intel Management Engine (ME): checked (required for proper UHD 630 Sleep /

    Wake)

    o Intel Active Management Technology (AMT): unchecked

  • technodj23


    Teste es mal mit dieser EFI :) , dies mal ist das eine DEBUG version

    Tja, was soll ich sagen, konnte MacOS mit deiner EFI problemlos installieren :-D Was habe ich denn jetzt bei meiner EFI falsch gemacht? Was nicht läuft ist Bluetooth und auch die 5.1 Audioausgabe funktioniert nicht, heißt der Subwoofer geht nicht :-/ Wie gehe ich denn jetzt weiter vor? Die EFI auf die Festplatte ziehen? Achse, das mit dem Dualboot hat auch nicht wirklich funktioniert, habe zwar Partitionierung anzugeben bei der Installation, aber leider wurde die komplette Windows Partition gelöscht...