Lenovo T470s EFI oder bzw. an der Config scheitert es

  • och, ich würde die flinte noch nicht ins korn werfen, du brauchst zum erstellen und beim arbeiten mit dem hacky, solange es nicht läuft vorallem eines: geduld- und wenn es für heute genug ist, ist es eben genug und du kannst dann ggf. morgen weitermachen.


    zudem diese efi vom netzfund auch einiges an *.aml enthält - war ja nur ein versuch :)


    ich kann da jetzt grade nix draus lesen, bzw. gab es schon ein applelogo oder eine installauswahl?


    edit- bzw. probiere die efi netzfund mal ohne deine anpassungen aus - der airport ist für big sur

    lg :)

  • Das ist auf aus gestellt, so ist es ja doch auch richtig, oder ?


    Ist VT-D in BIOS deaktiviert dann muss das auch in Kernel/Quirks/DisableIoMapper false/no


    Teste noch mal die EFI ich auf das Minimumm reduziert was mann für denn erst versuch haben kann muss [wech]

  • apfel-baum


    An sich bin ich schon seit Anfang der Woche dran und einiges an Stunden dafür verbraten, da ist es irgendwann echt schwer am Ball zu bleiben, obwohl ich bei sowas sehr ehrgeizig bin.


    Nee, kein Apple Logo, nur halt das Open Core Boot Menu, wo ich den Stick fürs Booten auswählen konnte.


    Hatte es einmal ohne Anpassungen und einmal direkt so auf den Stick gezogen, wie du es geschickt hattest.


    Wie gesagt, ich bin gewillt es zu schaffen und werde nicht so schnell aufgeben, aber leider tritt man ja irgendwie auf der Stelle.

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • kentallica

    das ist leider normal und gehört dazu- das es auf anhieb mit einem tragmich klappt ist glückssache,- die können wenn sie wollen auch gut herumzicken-


    , als nächstes bitte die efi von OSX-Einsteiger nehmen. bei meiner bzw. de, netzfund hatte ich die switches für vt-d und co gesetzt, so als wenn diese im bios auf enabled wären.


    lg :)

  • apfel-baum


    Die V2 hab ich jetzt auch nochmal probiert, leider am Ende mit gleichen 2 Fehlern.


    Ok, ich probiere dann einfach mal nochmal ein bisschen rum mit der EFI von OSX-Einsteiger, vielleicht kann ich da noch eventuell was finden, was vielleicht nicht, passt und es läuft eventuell dann.


    Was mich irgendwie immer ein bisschen nervt, was man an Videos und so sieht wo alles eben klappt und so viele bekommen das ja hin, dann denkt man sich schon woran liegt das jetzt, dass es bei einem selbst nicht funktioniert.

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • öhm videos ... ja "wie im film" ist aber auch meist wie im film, der videomacher weiß eben (meist) ganz genau was er wann tut/ oder schneidet- damit es für das video passt. er kennt das system bereits usw. ..


    außerdem möchten dich manche auch einfach nur abzocken ala morga...



    wie ein backvorschlag, bei dem es-das ergebnis- bei dir dann nicht aussieht wie auf der packung ;)

    edit-


    das video soll ja auch toll aussehen,- ich weiß nicht wieviele takes der user SchmockLord hier im forum für sein tut gemacht hat :) , einfach war das bestimmt nicht. ob es dazu auch noch ein behind the scenes oder outtakes gibt weiß ich nicht


    lg :)

  • apfel-baum


    Stimmt natürlich auch wieder, da war sicher auch vorher viel Fehlerkorrektur im Spiel, aber vielleicht hab ich es einfach auch unterschätzt, wie kompliziert das Thema Hackintosh ist.


    Hatte ich mir irgendwie einfacher vorgestellt

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • was hinzukommt ist, die videos altern,- das heißt : video ist z.b. opencore stand 0.6.0... osx ist z.b. mojave - aktuell ist die 0.8.3 auch in verwendung- da hat sich dann widerum einiges getan usw. - selbes bei den osx-versionen je nach build kann sich darin etwas ändern :)


    lg :)

  • Die V2 hab ich jetzt auch nochmal probiert, leider am Ende mit gleichen 2 Fehlern.

    Geht das noch etwas genauer :) Plus ein Foto und log


    Edit:

    Hatte ich mir irgendwie einfacher vorgestellt

    ich hätte denn Notebook auch als einfach eingeschätzt :rolleyes:

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • Könnte das immer noch ein USB Problem sein :?:

    Code
    1. 00:000 00:000 OC: Setting NVRAM 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:boot-path = PciRoot(0x0)/Pci(0x14,0x0)/USB(0x1,0x0)/HD(1,MBR,0x1352F5B1,0x800,0xEEF800)/EFI\OC\OpenCore.efi - Invalid Parameter

    Nach welcher Guide hast du denn USB Stick erstellt.


    macOS Internet Recovery Stick: Installation ohne Mac oder VM

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • OSX-Einsteiger


    Das ist eben die Frage was für ein USB Problem, hab verschiedene Ports sowie Sticks probiert, kann es da noch andere USB Probleme geben?


    Eigentlich hab ich mich am Ende dann nach ein paar Videos nach dem OpenCore Guide gerichtet und danach den Stick erstellt.


    Den Link oben, ist doch aber einen Clover Boot Stick erstellen.

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • An statt Clover nimmst du die OpenCore EFI


    Versuch es erstmal mit Catalina :)

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • was hinzukommt ist, die videos altern,- das heißt : video ist z.b. opencore stand 0.6.0... osx ist z.b. mojave - aktuell ist die 0.8.3 auch in verwendung- da hat sich dann widerum einiges getan usw. - selbes bei den osx-versionen je nach build kann sich darin etwas ändern :)


    lg :)

    Das ist aus meiner Sicht das, was für Einsteiger am schwersten ist: Herauszufinden, was noch state-of-the-art ist und was man mittlerweile anders macht. Dadurch entstehen auch diese Configs, wo alles aus verschiedenen configs und Dekaden zusammenkopiert ist.


    Bezgl. der Videos. Aufwändig war es schon die zu machen. Aber ich hab die schon größtenteils in einem Rutsch gemacht. Klar, manchmal öffnet man die falsche config und musst die Passage nochmal wiederholen. Oder das Handy geht. Das schneidet man dann raus. War aber auch nach jedem Video platt, das kannst du mir glauben :D. Aber ich lern auch mit jeder config dazu und mittlerweile würd ich einige Sachen anders machen.

  • SchmockLord


    Danke für deinen Einblick :)


    Was ich halt schwer finde, ist die Fehlerbehebung bzw. dass es anscheinend keine eindeutigen Ansätze zur Fehlerbehebung bei Problemen gibt.


    Sprich, man hat die und die Fehler und so kann man sie beheben. Das gibt es hier wohl nicht so in der Form, zumindest so mein Eindruck.


    Hast du denn noch Tipps, was man noch machen könnte?


    Ich hatte ja an sich schon einen passenden Efi Ordner mit einer Config, die ja laut Feedback eigentlich passen müssten.

    Was dann noch hinzu kommt, dass mit Thinkpads, das Thema Hackintosh eigentlich gut funktionieren sollte.

    Lenovo T470s

    Intel i7 7600U


    OpenCore

  • Ich denke das liegt daran wie mann denn USB Stick erstellte hat , wenn mann nur einen Windows PC hat dann ist das aktuellste was mann mit der Recovery kriegen kann ist Catalina .

    Unter MacOX sieht das wieder anders aus :)

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • kentallica


    Beschreibe mal kurz was passiert wenn du versuchst Catalina zu installieren , wenn er jetzt direkt aus geht kann schon mal bei einer Recovery USB Stick vor kommen dann muss mann zum Beispiel Misc/Security/DmgLoading Disabled ;(

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0