Ryzentosh - Auros B550i PRO AX - "3,6GHz Unbekannt" fix ?

  • Schönen guten Tag,


    seid langer zeit habe ich mal wieder einen Hackintosh Projekt vor mir.

    In diesem Fall mein erster Ryzentosh.

    Es funktioniert soweit ich bisher gesehen hab alles einwandfrei sogar inkl WLAN, auch wenn es noch ständig abbricht.

    Leider aber bekomme ich die Anzeige in der Übersicht nicht richtig eingestellt, hier hab ich bereits versucht mit den "RestrictEvents.kext" in diversen Versionen und durch eintragen von "Generic" und "AMD Ryzen 5 3600 6-Core Processor" Abhilfe zu schaffen, leider ohne Erfolg.


    Hat von euch schonmal jemand das Problem gefixt bzw hat eine Idee an was es liegen könnte?


    Das EFI lässt sich hier leider nicht hochladen

  • Moin,


    https://github.com/acidanthera/RestrictEvents


    einbinden…


    Und dem ReadMe.md folgen…


    Lilu.Kext nicht vergessen und die muss vor RestrictEvents geladen werden.


    Ich hab es mal hier hoch geladen.

    Externe Links sind nicht erwünscht.


    Hab nun deine EFI gesichtet...


    ...hast das richtig eingebunden, ich weiß nicht ob ProvideCurrentCPUInfo dann aber aus muss...oder umgekehrt: RestricEvents.kext raus und den Quirk rein...


    Da den Namen einzutragen ist aber falsch...

  • user1_

    this is wrong

    put there 0 or 3841

    then you can delete also:

    if you did all well cpu is seen well only with restrictevents

    I would also suggest to enable Nvram Reset button and reset your NVRAm after this modifies

  • ok, so scheint es dann zu passen?

    leider finde ich den resetnvram nicht, hideaux ist auf false und allownvramreset auf true.

    Files

    • config.plist

      (37.67 kB, downloaded 10 times, last: )

    Aktuelles System:

    Aorus Z590I Aorus Ultra - Intel Core I5 11400 - RX6800 16GB - 2x32GB 3200 DDR4 - macOS Monterey OpenCore - Stable

  • user1_ Which version of OpenCore are you using?

    You have some error in your config

    If you use in PlatformInfo Automatic value on Yes

    you don't need of DataHub and SMBIOS options (these are useful if you have automatic on NO and then it is mandatory to fill all that config.plist part


    To back to your question, if you use latest OpenCore you have to add a driver on Uefi/drivers section to see reset Nvram button

  • fabiosun

    I use OC 0.8.3 nvramreset is now shown, thanks.

    I set platform info to false, processortype to 3841 (I also tested 0) and deleted revcpu/ revcpuname.

    unfortunately the cpu is still not recognized, even after a nvram reset

    Files

    • config.plist

      (38.64 kB, downloaded 9 times, last: )

    Aktuelles System:

    Aorus Z590I Aorus Ultra - Intel Core I5 11400 - RX6800 16GB - 2x32GB 3200 DDR4 - macOS Monterey OpenCore - Stable

  • These are the kexts I am using

    backup yours and if you like try

    Reset always Nvram when you do some adjustment in this section


    and this is your config.plist modified

    Backup always yours

    Files

    • Archive.zip

      (550.26 kB, downloaded 10 times, last: )
    • config.plist.zip

      (5.88 kB, downloaded 7 times, last: )
  • same result, 3,6 GHz unknown =/

    Aktuelles System:

    Aorus Z590I Aorus Ultra - Intel Core I5 11400 - RX6800 16GB - 2x32GB 3200 DDR4 - macOS Monterey OpenCore - Stable

  • mmhm

    open a terminal window and run this command:

    kextstat | grep -v com.apple


    post output then

  • user@users-iMac-Pro ~ % kextstat | grep -v com.apple


    Executing: /usr/bin/kmutil showloaded

    No variant specified, falling back to release

    Index Refs Address Size Wired Name (Version) UUID <Linked Against>

    52 9 0 0x2f000 0x2f000 as.vit9696.Lilu (1.6.2) 264B15BE-8923-3A33-A9F5-8F0FFBB80595 <9 7 6 3 2 1>

    53 0 0 0xd000 0xd000 as.vit9696.RestrictEvents (1.0.8) E03048B9-2DE0-38A2-9A31-529F5120360E <52 9 7 6 3 2 1>

    54 0 0 0x7000 0x7000 com.cdf.Innie (1.3.0) DAF7FB11-5303-3B26-BE94-45F4BB79D3CE <6 3>

    55 0 0 0xd000 0xd000 org.acidanthera.NVMeFix (1.1.0) 3E9F615E-3C87-304D-946B-36ABFAE7B8ED <52 9 7 6 3 2 1>

    56 0 0 0x14000 0x14000 aluveitie.RadeonSensor (0.3.1) 6CD8218D-B214-34E9-85A4-53955A58DC31 <52 16 12 7 6 3 2 1>

    57 0 0 0x19f000 0x19f000 as.vit9696.AppleALC (1.7.4) 7406785A-9A53-36FD-97D5-77440E2B471F <52 16 9 7 6 3 1>

    58 0 0 0xa000 0xa000 com.khronokernel.FeatureUnlock (1.0.9) 6EB4C19A-F137-3A86-AE40-70B69557A82A <52 9 7 6 3 2 1>

    59 0 0 0xf000 0xf000 as.lvs1974.HibernationFixup (1.4.6) FF92D695-89CC-313F-8A68-7A22091F7266 <52 9 7 6 3 2 1>

    60 1 0 0x20000 0x20000 wtf.spinach.AMDRyzenCPUPowerManagement (0.7.1) 08416898-FC70-3057-9256-34AC0F79D0C0 <52 16 12 9 7 6 3 2 1>

    68 1 0 0x1a000 0x1a000 as.vit9696.VirtualSMC (1.3.0) 40CF5E80-248F-35B7-833D-2DABF724B391 <52 15 9 7 6 3 1>

    80 0 0 0x33000 0x33000 com.insanelymac.LucyRTL8125Ethernet (1.0.0) FBA5C8B0-6CBA-3448-AAC4-DA321181C4D4 <50 16 7 6 3 1>

    85 0 0 0xcf0000 0xcf0000 com.zxystd.AirportItlwm (2.0.0) 8D72B887-C419-3630-9D5A-1538E67DFD89 <84 50 16 7 6 3 1>

    86 0 0 0xce0000 0xce0000 com.zxystd.itlwm (2.0.0) 33B0CBAD-6F5A-3DB7-A01D-92CC39549103 <50 16 7 6 3 1>

    104 0 0 0x10000 0x10000 wtf.spinach.SMCAMDProcessor (1) 7B87D25C-F2A9-3D9E-A7D1-1A044A041190 <68 60 52 16 12 9 7 6 3 2 1>

    user@users-iMac-Pro ~ %

    Aktuelles System:

    Aorus Z590I Aorus Ultra - Intel Core I5 11400 - RX6800 16GB - 2x32GB 3200 DDR4 - macOS Monterey OpenCore - Stable

  • could you try to disable feature unlock kext and SMCADProcessor kext and innie.kext? then reset Nvram again and see?

    and also from terminal:


    sysctl -n machdep.cpu.brand_string

  • could you try to disable feature unlock kext and SMCADProcessor kext and innie.kext? then reset Nvram again and see?

    and also from terminal:


    sysctl -n machdep.cpu.brand_string

    nothing changed.



    user@users-iMac-Pro ~ % sysctl -n machdep.cpu.brand_string


    AMD Ryzen 5 3600 6-Core Processor

    user@users-iMac-Pro ~ %



    I ask like n newb :D

    possible to use bootarg revcpuname=AMD Ryzen 5 3600 6-Core Processor

    ?

    Aktuelles System:

    Aorus Z590I Aorus Ultra - Intel Core I5 11400 - RX6800 16GB - 2x32GB 3200 DDR4 - macOS Monterey OpenCore - Stable

  • user1_ yes you cn use to give a name you like...but it should not be mandatory for you to see a real value different from Unknown


    in my case without those nvram arg:


  • ok, but apparently the bootarg doesn't change the cpu name either "revcpuname=AMD Ryzen 5 3600 6-Core Processor"

    Aktuelles System:

    Aorus Z590I Aorus Ultra - Intel Core I5 11400 - RX6800 16GB - 2x32GB 3200 DDR4 - macOS Monterey OpenCore - Stable

  • ok, but apparently the bootarg doesn't change the cpu name either "revcpuname=AMD Ryzen 5 3600 6-Core Processor"

    try with this one

    overwrite yours with this one , reboot, reset Nvram and cross finger

    :)

    Files

  • same unknown cpu, yes I've resetted nvram.

  • user1_ some AMD users have some problem to reset correctly their NVRAM parameter with latest OpenCore

    I do not know if this is also your case

    Some users with this problem reset NVRAm with old OpenCore version before 080

    But I can't say precisely, and it is difficult to open an issue because our CPUs are not supported and to open an issue we must be very precise!

  • ok, ive tested another OC from GitHub.

    it will boot with show right CPU but have no wifi/ bt ^^


    i compare the plists later to find my bug :D

    Aktuelles System:

    Aorus Z590I Aorus Ultra - Intel Core I5 11400 - RX6800 16GB - 2x32GB 3200 DDR4 - macOS Monterey OpenCore - Stable

  • user1_ a thing to check could be lilu and RestrictEvents kexts version


    Then when you are sure about the right combination from Lulu/RestrictEvents/Opencore, you can use revcpu parameters in NVRAM to change CPU's name as you like:




  • can you upload the combination that worked for you?

    Aktuelles System:

    Aorus Z590I Aorus Ultra - Intel Core I5 11400 - RX6800 16GB - 2x32GB 3200 DDR4 - macOS Monterey OpenCore - Stable