Matebook X Pro 2020 (i7) Monterey 12.4. ready

  • Nachdem ich nun schon seit einer ganzen Weile auf der Suche nach etwas "Nettem" war habe ich mir einen Matebook 13 Zoll i7 10. Gen UHD 630 16 GB und einer 1TB zugelegt.

    Ist ein tolles Gerät und unter Windows einfach klasse mit dem hochauflösenden Touchscreen;)


    Aber als Hacki bekomme ich es irgendwie nicht gescheit zum Laufen.

    Habe eine EFI von Github geladen, von der er auch startet und mich auch Monterey 12.5 laufen lässt, allerdings rebootet er entweder nach beliebiger Zeit oder hängt sich auf.

    Den Versuch Monterey auf die interne zu installieren habe ich dann gestern Nacht um 3 frustiert abgebrochen, da er sich dann auch irgendwann nach dem rebooten aufhängt.

    Wie komme ich denn der Ursache auf die Spur ?

    Hänge die EFI mal an, mir fehlt da im Augenblick der Wink mit dem Zaunpfahl.

    Die zusätzliche Grafikkarte fällt mir noch ein, ev. ist die nicht deaktiviert, die Biosversion, oder BT/Wlan Kexte die ev. nicht passen obwohl sie funktionieren oder oder oder ?

    Fast vergessen OC 0.8.3. hatte ich noch von 0.7.5. aktualisiert.

    Files

    • EFI.zip

      (15.39 MB, downloaded 15 times, last: )

    Hardware: (im Aufbau)

    Imac 2019 Monterey , Ipad IOS 15.X, Iphone .....

    Z390 Designare Catalina-Ventura

    T440P / T440S

    Z800

    Edited once, last by canyonwalker ().

  • Bin nur am Smartphone grad online... Aber würde mal alle SSDT und Patches, die nicht unbedingt gebraucht werden. Dann kann man weiterschauen, was es noch sein könnte


    Graka kannst du per bootarg versuchen zu deaktivieren.


    Moment mal, du hast Kexte die nicht passen? Ersetze die Kexte mit Kexte für die richte MacOS Version... Oder zum testen einfach deaktivieren... Tippe sogar auf die Kexte, weil ich das Problem auch schon hatte

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Public Beta 5

    MacMini  Late 2012 - Monterey - OC Legacy Patcher

    Dell XPS 13 7390  Intel® Core™ i7-10510u -OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Public Beta 5

    ASUS Rog Strix z490i Gaming  Intel® Core™ i5-10600K

  • Denke schon dass die Kexte passen, da sie funktionieren, aber muss es mal genau prüfen.

    Graka muss ich ebenfalls prüfen, aktuell läuft das System von einer externen SSD mit youtube seit zwei Stunden, lässt hoffen, hatte aber noch nichts geändert.

    Installversuch ist erneut abgebrochen, diesmal mit einer Fehlermeldung, die auf eine defekte Datei schließen lässt, was aber sehr unwahrscheinlich ist, da ich die SSD damit installiert hatte?

    Im Augenblick also echt Rätselraten angesagt;(

    Hardware: (im Aufbau)

    Imac 2019 Monterey , Ipad IOS 15.X, Iphone .....

    Z390 Designare Catalina-Ventura

    T440P / T440S

    Z800

  • canyonwalker


    Um was für eine SSD handelt es sich Hersteller und so.


    Hattest du ein paar kext raus genommen wegen des hochladen wegen der EFI , platz mangel ?

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • OSX-Einsteiger

    stimmt aus Platzgründen habe ich die größten gelöscht.

    Es handelt sich um eine samsung Mzvlb1t0hblr.

    Obige Nvme/SSD ist eine OEM 981a und scheint laut einer Info nicht mit Mac OS compatibel zu sein, gibt es sowas tatsächlich?

    Hardware: (im Aufbau)

    Imac 2019 Monterey , Ipad IOS 15.X, Iphone .....

    Z390 Designare Catalina-Ventura

    T440P / T440S

    Z800

    Edited once, last by canyonwalker: Ergänzung zu Inkompatibilität ().

  • Das mit der Nvme stimmt fachsächlich nicht jede läuft [hehee]

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • canyonwalker ja das Problem hatte schon mal jemand, dass er aufgrund einer gelisteten NVMe MacOS nicht installieren konnte...

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Public Beta 5

    MacMini  Late 2012 - Monterey - OC Legacy Patcher

    Dell XPS 13 7390  Intel® Core™ i7-10510u -OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Public Beta 5

    ASUS Rog Strix z490i Gaming  Intel® Core™ i5-10600K

  • Schade, wäre ja auch zu schön gewesen,(

    Aber schon seltsam, auf der ext SSD läuft es nun mit youtube die ganze Zeit ohne Problem.

    Die NVMe habe ich, da total NTFS, nachträglich aufgeteilt.

    Gibt nun 2 zusätzliche AFPS Partitionen, die ich für OSX verwenden wollte.

    Boote aktuell vom Stick, da ich die vorhandene Bootpartition / EFI auf der internen zunächst unverändert lassen wollte, bis die Installation durch ist.

    Hardware: (im Aufbau)

    Imac 2019 Monterey , Ipad IOS 15.X, Iphone .....

    Z390 Designare Catalina-Ventura

    T440P / T440S

    Z800

  • Nach vielen Stunden basteln, versuchen, formatieren ein- und ausbauen ist es gelungen.

    Der Rechner läuft nun mit Monterey 12.5. unter Opencore 0.7.8.

    Einzig der Bootloader sprich Open Core muss aktuell noch vom Stick geladen werden.

    Woran es liegt muss ich noch herausfinden, irgendwas kommt sich da in die Quere mit dem vorinstallierten Windows 11 bzw. dem Bootloader oder der EFI.

    So schwierig kann das aber dann eigentlich nicht sein. Irgendetwas hatte ich da mal gelesen woran das liegen könnte. EFI ist gegen überschreiben geschützt und meldet dann beim Start von Windows eine Wiederherstellung sei erforderlich. Mal schauen wie / was / wo;)

    Bisher funktionieren noch nicht:

    Headphones

    Touch Screen

    Mehr an internen Anschlüssen hat er auch dann nicht mehr;)

    Hardware: (im Aufbau)

    Imac 2019 Monterey , Ipad IOS 15.X, Iphone .....

    Z390 Designare Catalina-Ventura

    T440P / T440S

    Z800

    Edited once, last by canyonwalker ().

  • canyonwalker

    Changed the title of the thread from “Matebook X Pro 2020 will irgendwie nicht, nur für Windows ist mir der Rechner zu schade.” to “Matebook X Pro 2020 ist fast komplett Monterey ready;) Lediglich Dualboot intern geht noch nicht :))”.
  • Booter / Quirks / RuntimePermissions ist gesetzt?

  • Das muss ich dann "morgen" mal prüfen, jetzt wird es Zeit fürs Bett.

    An der Ecke war ich bisher noch nicht;)

    EasyUEFI muss ich mir dann jetzt wohl auch noch mal ansehen, Langeweile sieht anders aus, aber was tut man nicht alles für einen schicken Rechner:)

    GN

    Hardware: (im Aufbau)

    Imac 2019 Monterey , Ipad IOS 15.X, Iphone .....

    Z390 Designare Catalina-Ventura

    T440P / T440S

    Z800

  • canyonwalker

    Changed the title of the thread from “Matebook X Pro 2020 ist fast komplett Monterey ready;) Lediglich Dualboot intern geht noch nicht :))” to “Matebook X Pro 2020 ist fast komplett Monterey ready;) Lediglich Touchscreen geht noch nicht”.
  • NERD Yes,) geht bei diesem Gerät ja leider nicht anders.


    Ergänzung:

    So aktueller Stand Booteintrag mit EasyUEFI zugefügt und starten von der internen NVMe geht nun auch für WIN11 & OSX;)


    Jemand eine Ahnung wo die Daten/Datei liegt, in die man mittels EasyUEFI einen zusätzlichen Starteintrag zufügen kann?

    Liegt im NvRam, doof nur beim Clear Nvram gehen diese Einträge auch verloren:((

    -----------------------------------------------------------------------------------------

    Jetzt fehlt nur noch (Line-out und) Touchscreen;)


    Nach Update auf OC0.8.3 tut es auch Line-out ;)


    Ergo fehlt jetzt nur noch die Funktionalität Touch Screen.


    Razor12 kannst Du mir verraten wo genau ich den Touchscreen unter OSX aktivieren kann. Hatte zwar etwas gefunden (NoTouchID.kext) aber allein das deaktivieren war nicht die Lösung?

    Hardware: (im Aufbau)

    Imac 2019 Monterey , Ipad IOS 15.X, Iphone .....

    Z390 Designare Catalina-Ventura

    T440P / T440S

    Z800

    Edited 5 times, last by canyonwalker: Neuer Status & Titel ().

  • noTouchID hat mit Authentifizierung zu tun und nicht mit Touch-Screen.


    Ich habe das am T470 nicht zum laufen bekommen. Kannst ja mal unter Hardware nach Notebook's suchen und findest sicher unter Lenovo welche, wo das funktionieren soll. Nach m.E. hat grt einem Dell Latitude unter Mojave die Fingereingaben beigebracht. N.m.K. macht es aber keinen Sinn, da Apple selbst dazu keinerlei Unterstützung liefert. canyonwalker

    Grüße

    Arkturus

  • da war das beibringen auch nicht so wirklich schwierig. die touchscreens der dells und auch des yoga hängen am usb, der muss also ordentlich gemappt (intern) sein, das wars. bei catalina war die fingereingabe dann weg, der stift vom yoga (wacom) ging noch, wieder ohne nachhelfen. bigsur hab ich nicht getestet, der touch-dell ist auch nicht meiner.

    ich geh aber mal davon aus, dass der touchscreen hier nicht am usb hängt?


    und zum nutzen von touch: hab ich so gut wie nicht gemacht. macos ist nicht touchtauglich. der stift vom yoga macht in zeichenprogrammen etc. sinn, aber die bedienung der systems mit finger ist einfach mal mist.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist WIEDER DA!! nächster termin voraussichtlich: mittwoch 15.9.21, 19.00 uhr

  • grt Für den Touchscreen vom Dell gibt's auch ne SSDT.... Frag mich aber bitte nicht was sie genau bewirkt

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Public Beta 5

    MacMini  Late 2012 - Monterey - OC Legacy Patcher

    Dell XPS 13 7390  Intel® Core™ i7-10510u -OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Public Beta 5

    ASUS Rog Strix z490i Gaming  Intel® Core™ i5-10600K

  • Hmm schade, innerhalb des Browsers u.ä. find ich das schon nett.

    Angeblich ist es nur deaktiviert, allerdings nicht über das Bios, denn unter Win11 läuft es.

    Wie komme ich dem Teil denn auf die Spur, ich schaue mal unter Win was ich dazu finde.

    Hardware: (im Aufbau)

    Imac 2019 Monterey , Ipad IOS 15.X, Iphone .....

    Z390 Designare Catalina-Ventura

    T440P / T440S

    Z800

  • innerhalb des Browsers u.ä. find ich das schon nett

    kommt auf den durchmesser der fingerkuppe an.. und selbst mit zarten mädchenfingerchen muss frau schon sehr genau zielen, um die gewünschte bedienfläche zu erwischen. macht echt keinen spass.

    Hecatomb der dell mit touch bleibt bis auf weiteres wg. älterer adobeprogramme auf mojave. aber interessieren würde mich das auch. gehts da um den 5470 - bzw. touchdell der 6.gen mit usb-touch?

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist WIEDER DA!! nächster termin voraussichtlich: mittwoch 15.9.21, 19.00 uhr

  • grt ich schau mal bei Gelegenheit

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K - Radeon RX 590 - OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Public Beta 5

    MacMini  Late 2012 - Monterey - OC Legacy Patcher

    Dell XPS 13 7390  Intel® Core™ i7-10510u -OpenCore 0.8.4 - Windows 11 / Ubuntu / Big Sur / Monterey / Ventura Public Beta 5

    ASUS Rog Strix z490i Gaming  Intel® Core™ i5-10600K

  • Hätte da doch noch einen Punkt der mir unklar ist und zwar zum Thema Audio. Der Laptop hat 4 Lautsprecher, die ich nun im Audio-Midi-Setup zu einem Paar zusammengefasst habe. Für ein solches Gerät, welches jetzt annehmbar klingt kann ich/man allerdings die Lautstärke nicht anpassen.

    D.h. man muss vor die Lautstärke eines einzelnen Lautsprechers anpassen, die Lautstärke gilt dann autom. für das Paar. Ist das so üblich/normal oder kann man das ändern? Vielleicht hat ja MacPeet oder jemand eine Idee dazu?