macOS 13 VENTURA beta

  • „Symbolleiste anpassen“ im Finder geht jetzt auch.

    Laptop Acer Extensa 15 / Board 495 / i3 1,2 GHz 1005G1 / UHD (Ice Lake) Platform-ID 0x8A5C0001/ 8GB RAM / SMBIOS MacBookAir9,1 / WLAN - BT Intel 9462 / RTL8111 / ALC 255 / Ventura 13.0 / Opencore 0.8.6

  • Endlich habe ich die Beta9 auch drauf. Läuft echt gut!!!

    „Die Definition von Wahnsinn ist, immer wieder das Gleiche zu tun und andere Ergebnisse zu erwarten.“ - Albert Einstein

  • Mir kommt auch die Beta 9 viel schneller vor als die vorversionen und Monterey.


    gefühlt viel weniger Latenz zwischen Klick und Ausführung …..

  • DerTschnig


    Ist reaktionsschneller, liegt anscheinend daran, dass die Anzeige gestartet wird wenn das Rendern des Inhaltes noch nicht ganz durch ist.


    Ob Apple da um die eigene Hardware gut dastehen zu lassen einen interessanten Trick angewendet hat der bei allen gut Funktioniert ?


    Mal sehen ob der Mac Pro dann auch im nächsten Frühjahr wirklich das Licht der Öffentlichkeit erblickt.


  • Ich hatte mit B9 wiederholt das Problem, dass mit der Maus keine Klickevents ausgelöst werden konnten. Sowohl mit der pyhs. Maus (BT) als auch über Screensharing vom MBP2020 aus. Der Mauszeiger lässt sich bewegen, aber z.B in der Menüleiste oben lassen sich keine Aktionen ausführen. Offene Programm im Dock kommen nach Klick nicht hoch. Manche neue Programme lassen sich starten. EInstellungen z.B. nicht. Ich hab erst gedacht, die Mausbatterie ist nun endgültig durch (Wechsel der Batterie stand eh an), aber über Screensharing ging das auch nicht. Ich nutze tagsüber hauptsächlich RDP, Mail, Browser. Ich hab entweder RDP oder "Link to Mac or iPad" im verdacht. Letzteres hab ich mal deaktiviert.

  • Hallo Gemeinde,


    habe hier ein Problem um Ventura zu installieren,

    es geht um den x250 mit i7 5600u.

    Komme nach vielen "busy timeout (1) (240s) 'AppleACPICPU'

    in den installer, konnte Ventura auf HD installieren, nach ca 35 min reboot , wieder timeout dann kommt der Apfel und dann ein Firmware update error.

    Nun meine Frage, soll ich weiter versuchen oder ist das ganze nicht von Erfolg gekrönt?

    Hänge mal die EFI an.

    Danke im voraus.

    Images

    Files

    • EFI.zip

      (21.53 MB, downloaded 10 times, last: )

    2.) 12.6.1 auf x250 i7 2.6GHz 8GB HD5500 auf 500GB SSD mit OC 8.4 sowie Ventura Public 9 auf externe SSD mit 8.5

    3.) 10.15.7 + Win10 auf Q520 mit OC

    4.) 10.6.8 auf eeePC

    5.) Surface Pro 4 i5 6300u 2.4GHz,HD520,256GB Ubuntu 21.04 auf externer SSD je Win11 ; HS und Monterey

  • wellini


    Ich hab die gleiche CPU im T450s, welche ja im Prinzip so ziemlich den real MacBookPro's von 2015 entspricht.

    Diese sind aber offiziell bei Ventura rausgeflogen. Auch die Grafik dieser Art CPU ist rausgeflogen.

    Im Prinzip entspricht unsere CPU dem MacBookPro12,1, welches ich auch noch fahre bis Monterey.

    Du hast zwar auf SMBIOS 14.1 umgestellt, aber dies passt nicht wirklich mehr zur CPU, bzw. Grafik.


    Im Prinzip ist es wohl möglich, denn OCLP nebst PostInstaller bringt auf den real MacBookPro's 2015 die Funktion zurück.

    Erstelle Dir mal separat eine OCLP-EFI für einen MacBookPro12,1 und versuche dann dies in Dein normales OC einzubauen.

    Dort wird die Firmwareversion in der config hochgesetzt, damit es keine Firmware-Errors gibt.

    Um die Grafik für die HD5500 zurück zubringen, wird vermutlich auch der Postinstaller von OCLP gebraucht, nach Installation.


    Ich hab's zeitlich auch noch nicht geschafft diesen Weg zu versuchen. Kannst gern berichten, wenn Du schneller bist.


    Grundlegend muss ich aber fragen, welche OC-Version ist Deine EFI ? Zumindest Deine Kext's sind nicht aktuell, was wohl Bedingung ist, wenn man Ventura versuchen möchte.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  BCM94360NG  SSD 512GB + NGFF M2 SSD 512GB  macOS 12.6.2 / 13.1 DP4

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema 32" LG 4k  SSD 250GB+512GB  macOS 12.6.2 / 13.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  4k-TV 42"  BCM94360CD  SSD 2x250GB + 480GB  macOS 10.15.7 / 12.6.2 / 13.1 DP4

    MacMini2014: i5  2,8GHz  16GB DDR3  Intel Iris 5100  23" Apple-Cinema  1,12 TB Fusionsdrive  macOS 12.6.1

    iPhone8 64GB: iOS 16.1.1  iPad Pro 9,7" WiFi 32GB: iPadOS 16.2

  • MacPeet

    Danke für die schnelle Antwort, es sollte OC 8.0 sein, die Kexte habe ich gerade aktualisier, ohne Erfolg.

    Werde Deine Info mal Versuchen, aber nicht mehr heut.

    Danke und Gruß

    2.) 12.6.1 auf x250 i7 2.6GHz 8GB HD5500 auf 500GB SSD mit OC 8.4 sowie Ventura Public 9 auf externe SSD mit 8.5

    3.) 10.15.7 + Win10 auf Q520 mit OC

    4.) 10.6.8 auf eeePC

    5.) Surface Pro 4 i5 6300u 2.4GHz,HD520,256GB Ubuntu 21.04 auf externer SSD je Win11 ; HS und Monterey

  • Die 9. Beta hat ohne Probleme den Weg auf meine Rechner gefunden wobei das mit dem "ohne Probleme" nicht so ganz stimmt...


    Das T430 hat sich als Pflegefall erwiesen weil es hier keine so ganz gute Idee war den Spaß einfach mal so nebenbei zu erledigen. Tauscht man das Cryptex (OS.dmg) zum falschen Zeitpunkt aus führt das nämlich dazu das die Kiste nicht mehr startet und man kann dann wieder ganz von vorne anfangen. Ich bin durch den Hinweis auf eine Änderung im OCLP von hackmac004 schlussendlich auf den CryptexFixup.kext (https://github.com/acidanthera/CryptexFixup) aufmerksam geworden und was soll ich sagen einfacher als so wird das mit Ventura auf pre AVX2 Kisten nicht mehr. Kext mit rein und einfach installieren wie jedes andere macOS auch. Wieder einmal eine krasse und sehr runde Lösung die die Jungs und Mädels von acidanthera sich da ausgedacht haben. Wer es also auf Ivy und Co probieren möchte kann sich jetzt das bisher notwendige Gehampel mit dem os.dmg sparen.

  • griven

    Kannst du bitte einmal die kompilierte CryptexFixup.kext hier zum Download bereitstellen, damit man eine Ventura Installation unter Ivy Bridge testen kann. Vielen Dank!

    Laptop Acer Extensa 15 / Board 495 / i3 1,2 GHz 1005G1 / UHD (Ice Lake) Platform-ID 0x8A5C0001/ 8GB RAM / SMBIOS MacBookAir9,1 / WLAN - BT Intel 9462 / RTL8111 / ALC 255 / Ventura 13.0 / Opencore 0.8.6

  • Klar kann ich hier ;)

    Hier bitte: CryptexFixup-v1.0.0-RELEASE.zip

  • MacPeet

    Habe mir den OCLP- Patcher nach Anleitung von griven in #1461 erstellt. Habe nun auch einen Ordner indem alles vorhanden ist. So wie ich das sehe geht das ganze als Post-Installer. Soweit komm ich ja gar nicht. Da er bei mir ja immer einen Firmwareupdate machen will

    Bin ich da falsch?

    Danke und Gruß

    2.) 12.6.1 auf x250 i7 2.6GHz 8GB HD5500 auf 500GB SSD mit OC 8.4 sowie Ventura Public 9 auf externe SSD mit 8.5

    3.) 10.15.7 + Win10 auf Q520 mit OC

    4.) 10.6.8 auf eeePC

    5.) Surface Pro 4 i5 6300u 2.4GHz,HD520,256GB Ubuntu 21.04 auf externer SSD je Win11 ; HS und Monterey

  • Ich muss mir diese OCLP-Geschichte auf dem Hacki auch erst genauer anschauen und mal lesen, wie griven es gemacht hat.

    Er hat es ja sogar auf dem T430 geschafft.

    Der OCLP-Postinstaller wird erst nach Installation ausgeführt und soll die Grafik zurückbringen.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  BCM94360NG  SSD 512GB + NGFF M2 SSD 512GB  macOS 12.6.2 / 13.1 DP4

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema 32" LG 4k  SSD 250GB+512GB  macOS 12.6.2 / 13.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  4k-TV 42"  BCM94360CD  SSD 2x250GB + 480GB  macOS 10.15.7 / 12.6.2 / 13.1 DP4

    MacMini2014: i5  2,8GHz  16GB DDR3  Intel Iris 5100  23" Apple-Cinema  1,12 TB Fusionsdrive  macOS 12.6.1

    iPhone8 64GB: iOS 16.1.1  iPad Pro 9,7" WiFi 32GB: iPadOS 16.2

  • Man darf halt an der Stelle nicht vergessen das der OCLP in erster Linie für Apple Hardware gedacht ist. Die primäre Aufgabe des Patchers ist es aussortierten Macs ein längeres Leben zu bescheren und genau darauf ist er ausgerichtet. Die EFI die der Patcher erzeugt ist prima um zum Beispiel ein 2015er MacBook mit Ventura zu beglücken nutzt aber auf einem Hackintosh rein gar nichts weil eben die essentiellen Dinge die der Hackintosh zum Betrieb benötigt dort gar nicht enthalten sind.


    Macht man sich das bewusst dann wird klar das der Patcher für uns "nur" ein Werkzeug ist um den Post Install Root Patch auf die Platte zu bringen sprich er hilft uns den verlorenen Support für die Grafik zurück zu bekommen mehr nicht. Konkret bedeutet das für uns das wir die grundsätzlichen Vorraussetzungen für die Installation von Ventura selbst schaffen müssen.


    • OpenCore und Extensions auf die aktuellste Version bringen
    • SMBIOS wählen das die Installation von Ventura erlaubt oder wahlweise das BootArg no_compat_check hinzufügen
    • Bootargs ipc_control_port_options=0 und amfi_get_out_of_my_way=0x1 hinzufügen
    • SIP mittels 030A0000 deaktivieren
    • Je nach Plattform den CryptexFixup.kext hinzufügen


    Wenn das alles erledigt ist kann man an die Installation gehen wobei es hier notwendig sein kann (nicht muss) eine config für die Installation parat zu haben bei der kein WEG und keine DeviceProperties für die Grafik enthalten sind (ist beim T430 der Fall sobald die DevProps vorhanden sind gibt es kein Bild mehr). Die Installation unterscheidet sich hier dann nicht mehr von anderen macOS Installationen sprich das System wird installiert wie gewohnt (dank dem CryptexFixup inzwischen auch auf Hardware ohne AVX2 Support ohne das man zwischendrin das os.dmg tauschen müsste). Sobald alles installiert und eingerichtet ist kann man dann den Patcher ausführen und wählt hier dann nur "Post Install Root Patch" der Patcher erkennt eigenständig was er installieren muss. Im großen und ganzen ist das dann schon alles wobei man natürlich je nach Rechner und Gegebenheit mehr oder weniger Aufwand in Post Install Details investieren muss (Stichwort CPUPM -> CPUFriend, USBMapping -> ggf. geändertes SMBIOS usw.)...

  • wellini


    Ich habe mal deine EFI geupdatet , darf mann fragen worum du den HfsPlusLegacy.efi drin hattest ?

  • Hab soeben auch die Beta 9 installiert.


    Ist das bei euch auch so, dass ihr da manchmal 3-4 Mal "Software Update" klicken müsst, bis es mal durchläuft?


    Ich muss nie meine EFI anpassen, aber es zickt immer ein bisschen rum. Anfangs bekomme ich immer 1-2 Mal die Fehlermeldung, dass das Update nicht installiert werden konnte. Dann reagiert der Update Button nicht mehr. Und dann läufts nach 3-4 Anläufen einfach durch ohne Murren.


    Das geht jetzt schon seit ein paar Betas so. Nervt ein bisschen. Weiß nur nicht, ob das ein Hackintosh Phänomen ist, oder ob das auch auf normalen Macs passiert.

  • Hallo würde auch gern die beta testen doch bei mir lässt sich keine festplatte anwällen. Ich häng mal meine EFI mit an und hoffe jemand kann diese cheken.


    board ist ein Gigabyte z590 Master


    CPU 3,7 GHz 10-Core Intel Core i9


    GPU AMD Radeon RX 6800 XT 16 GB



    Danke

    Files

    • EFI.zip

      (11.74 MB, downloaded 6 times, last: )

    Edited 2 times, last by Gismo ().

  • nebeninfo zum oc dortania build changelog

    https://dortania.github.io/bui…=OpenCorePkg&viewall=true


    "b6b66a5 ocvalidate: Added CryptexFixup.kext" :)


    lg :)

  • Hallo,bin leider nicht so erfahren.Den kext habe ich jetzt gefunden. Könntest du mir die config.plist bearbeiten so lerne ich dazu.

  • bin leider nicht so erfahren

    Dann solltest du besser nicht mit einer Beta anfangen und vielleicht einen eigenen Thread aufmachen.

    MfG, docplag