Echte Hibernation, S4 Sleep oder hibernatemode 25

  • Ich habe es vor Kurzem, wie hier berichtet, geschafft an meinem Laptop den Hibernatemode 25 zum Laufen zu kriegen und somit echten S4 Sleep auf meinem Hackintosh:

    Echte Hibernation also S4 Sleep: hibernatemode 25 läuft nach einigem Basteln tadellos. Die aktuelle Konfiguration läuft wie folgt mit hibernatemode 3:
    • Der Laptop geht nach 4 Minuten Inaktivität oder durch Zuklappen in den normalen Sleep
    • Ist die Batterie über 50% geladen, geht der Laptop nach einer Stunde im Sleep (S3) in Hibernation (S4)
    • Ist der Ladezustand unter 50%, geht der Laptop nach 15 Minuten automatisch in Hibernationmode (S4)
    • Ist die Batterie bei 3%, wird der Laptop automatisch in Hibernation forciert
    • Wird die Batterie aktiv geladen, geht der Laptop immer nur in den normalen Sleep, nicht in Hibernation
    • Während Hibernation ist fast kein Akkuverbrauch zu registrieren, während Sleep wenige Prozente pro Stunde

    Da sich zu dem Thema nicht besonders viel finden lässt, hier mal ein eigenständiger Thread dazu.


    Wie ist denn dein aktueller Stand cobanramo? Funktioniert der normale Sleep Zustand problemlos?

    Wie sind die aktuellen pmset Settings und eventuell getroffene Modifikationen am Sleepimage?



    Ein paar Allgemeine Geschichten:

    Zum Debuggen hilft:


    pmset -g Voraussetzungen kontrollieren.


    Logs:

    Code
    1. log show --style syslog --source --debug --last boot > ~/desktop/log_complete.txt
    Code
    1. log show --predicate 'process == "kernel"' --style syslog --source --debug --last boot > ~/desktop/sys_log.txt
    Code
    1. sudo dmesg > ~/desktop/dmesg_hbfx.txt


    Für Hibernation braucht es ein funktionierendes und nicht gesperrtes sleepimage unter /private/var/vm/.


    Opencore Misc -> Boot -> HibernateMode mindestens auf Auto stellen, oder ggf. spezifizieren auf NVRAM.


    Als Mindestvorraussetzung muss normaler Sleep natürlich schonmal anstandslos funktionieren (hibernatemode=0), sonst braucht man garnicht erst mit hibernatemode=25 oder 3 anfangen...

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

    Edited once, last by kuckkuck ().

  • Hallo kuckkuck


    Nun bei mir ist es so das die Sleep Ordentlich funktioniert eben nur die Mode 25 nicht.

    Ich will das ganze tiefer Einblicken und lösen aber zurzeit bin ich bissl im stress bei der Arbeit, ich melde mich sobald bissl Luft hab mit den Detail Informationen.

    Das meiste die du da ansprichst ist bei mir schon im Einsatz und aktiv soweit ich mich erinnere, wär doch gelacht wenn wir den hibernation nicht lösen könnten. 😊


    gruss coban

     MSI-Z590Pro Wifi | Intel® Core™ i9-10900k CometLake | 32GB DDR4 RAM | Radeon RX 570 Red Devil | Nvme WD Black SN750 1TB | BCM94360NG | OpenCore aktuell / Catalina / BigSur / Monterey / Ventura Beta / Win 10 Pro / Win 11 Pro / Ubuntu / ChromeOS

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / Catalina / BigSur / Monterey / Win 10 Pro / Ubuntu

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / Catalina / BigSur / Monterey / Ventura Beta / Win 10 Pro / Win 11 Pro / Ubuntu / ChromeOS


    " Chasch nöd s Föifi und s Weggli ha."

  • Alles klar, melde dich einfach :)


    Als Erstes würde ich vorschlagen die pmset settings nochmal genau zu überprüfen, um normalen non-hibernate sleep zum laufen zu bringen, werden hier ja häufig so einige Settings umgestellt, die teilweise erstmal Hibernation deaktivieren. Siehe: https://dortania.github.io/Ope…l/sleep.html#preparations


    Ansonsten wäre dann natürlich wichtig zu wissen, wie sich der Laptop verhält, wenn er in Hibernation geht. Und dazu dann ein entsprechendes Log mit Zeitangaben, und/oder DebugEnhancer und HBFX Debug.

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • Zum Debuggen hilft:

    Lilu als Debug Variante und -liludbgall
    DebugEnhancer für aktivierten Debugoutput
    HibernationFixUp als Debug Variante mit -hbfxdbg und ggf. schonmal hbfx-ahbm=129 als bootarg, siehe: https://github.com/acidanthera/HibernationFixup


    pmset -g Voraussetzungen kontrollieren.

    So, die Ausgangslage ist so wie du angegeben hast;


    Bei mir tat schon immer die hibernatemode 0 & 3 wie es sollte, nur mit 25 klappte das nie.

    Auch die PowerNap tut seine sache, hier mal die alltags Ergebnis,

    Den Auto Einstellung hatte ich auch schon immer an;


    Heute Mittag zbspl. hab ich 100% geladen den Netzteil entfernt und den Laptop zugeklappt, vorhin als ich nachhause kam aufgeklappt und die Batterieanzeige war bei 97%, also nach 10,5 Stunden nur 3% verbrauch bei HibernateMode 3.


    Ich ändere grundsätzlich nie die Powereinstellungen oder den SleepImage dateisperre die du ansprichst.

    (Das Bild ist jetzt mit Netzkabel, daher die Abweichung von der Terminal Ausgabe)


    YogaSMC ist bei mir auch schon ne halbe Ewigkeit im Einsatz und tut seine sache:


    Und hier wären noch die Log Dateien du du ansprachst. (Mit Debug Files fällt natürlich das ganze bissl happig aus)

    Diese Logs hier sind mit HibernateMode 3;

    log_complete.txt.zip    sys_log.txt.zip    dmesg_hbfx.txt.zip


    Die folgenden Files unten wären dann mit HibernateMode 25,

    hab das per Terminal sudo pmset -a hibernatmode 25 eingestellt und 2x neugestartet, danach einfach den laptop zugeklappt.

    Es ging auch ohne Probleme in den sleep, hier blinkt aber die status Led nicht mehr.

    Nach aufklappen muss man Powerbutton betätigen;


    danach kommt die OpenCore Menü;


    danach das Bild hier


    log_complete.txt_HB25.zip    sys_log.txt_HB25.zip    dmesg_hbfx.txt_HB25.zip


    Das letzte mal den HibernatMode 25 getestet hab ich schon länger her, anscheinend hat sich auch hier wieder was geändert.

    Bei meinem jetzigen test bemerke ich das man nach der Betätigung der Powerbutton im Oc Menü auch die Tastatur verliert,

    es reagiert einfach nicht mehr, nach Ablauf der Timer von 3 Sek. kommt das Blaue Bild.

    Nach Reset bemerke ich das die tTastatur komplett ausgefallen ist biss ein Betriebsystem Gestartet wurde.

    Ergo verhält sich das ding wie bei "Monterey herunterfahren Bug", unter Bigsur scheint dieses herunterfahren jetzt mit HibernatMode 25 aktiviert zu sein.


    Nach erneutem starten kommt natürlich das übliche KP Bericht.


    So, jetzt bist du am zug ;-)
    Wo kann ich da jetzt das ding anpacken damit wir da das problem annähern :-)

    Gruss Coban

     MSI-Z590Pro Wifi | Intel® Core™ i9-10900k CometLake | 32GB DDR4 RAM | Radeon RX 570 Red Devil | Nvme WD Black SN750 1TB | BCM94360NG | OpenCore aktuell / Catalina / BigSur / Monterey / Ventura Beta / Win 10 Pro / Win 11 Pro / Ubuntu / ChromeOS

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / Catalina / BigSur / Monterey / Win 10 Pro / Ubuntu

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / Catalina / BigSur / Monterey / Ventura Beta / Win 10 Pro / Win 11 Pro / Ubuntu / ChromeOS


    " Chasch nöd s Föifi und s Weggli ha."

  • Moin, sorry für die späte Antwort.


    Zum testen kannst du vielleicht mal noch tcpkeepalive, powernap und proximitywake deaktivieren, nur um äußere Einflüsse zu verhindern.

    Es ging auch ohne Probleme in den sleep, hier blinkt aber die status Led nicht mehr.

    Nach aufklappen muss man Powerbutton betätigen

    Das ist erstmal soweit korrektes Verhalten, der Rechner scheint also zumindest in Hibernation zu gehen.

    log_complete.txt_HB25.zip sys_log.txt_HB25.zip dmesg_hbfx.txt_HB25.zip

    Leider kann ich keinen wirklichen Lilu oder HBFX Log Output in deinen Logs finden. Bist du dir sicher, dass du alle Debug Versionen richtig aktiviert hast?

    Sobald das der Fall ist, sollte Lilu gemeinsam mit HibernationFixup irgendwas in dieser Art ausspucken:

    Code
    1. localhost kernel[0]: (Lilu) HibernationFixup init: @ (DBG) HibernationFixup bootstrap DBG-145-2021-11-01

    Und direkt vor dem Sleep:

    Code
    1. localhost kernel[0]: (Lilu) HibernationFixup HBFX: @ (DBG) X86PlatformPlugin_sleepPolicyHandler sleepReason: 103, sleepPhase: 0, hibernateMode: 25, sleepType: 5
    2. localhost kernel[0]: (Lilu) HibernationFixup HBFX: @ (DBG) X86PlatformPlugin_sleepPolicyHandler standbyDelay: 10800, standbyTimer: 0, poweroffDelay: 0, poweroffTimer: 0
    3. localhost kernel[0]: (Lilu) HibernationFixup HBFX: @ (DBG) X86PlatformPlugin_sleepPolicyHandler ecWakeTimer: 0, ecPoweroffTimer: 0
    4. localhost kernel[0]: (Lilu) HibernationFixup HBFX: @ (DBG) Auto hibernate: sleep phase 0, set hibernate values

    Eine Zeitangabe zu wann du den Rechner in Hibernation versetzt würde auch helfen mich in den Logs schneller zurechtzufinden :)

    Ergo verhält sich das ding wie bei "Monterey herunterfahren Bug"

    Sagt mir aufgrund meiner mangelnden Monterey-Erfahrung leider nichts, hast du vielleicht einen Link für mich?

    Du kommst bei deinem Problem nach dem unendlichsten Versuch nicht weiter? Dann schreib mir eine Nachricht für eine TeamViewer Sitzung. Nur wenn es gar nicht mehr weiter geht!
    Alle anderen Fragen und Anliegen gehören ins Forum.

  • wie müssen die flag für ein funktionierendes SleepImage gesetzt werden? kuckkuck


    sieht das so ok aus?


    EDIT: hat sich erledigt. Nachdem ich womp noch auf 1 gesetzt habe, geht der Stromverbrauch im sleep gegen null. Wakeup funktioniert mit BT-Mouse und alles gut!

    Grüße

    Arkturus

    Edited once, last by Arkturus ().