Fragen für Hardware-Software-Upgrade

  • Hallo zusammen,

    ich möchte eventuell meinen derzeitigen Rechner etwas aufrüsten und in dem Zuge dann macOS updaten.

    Zurzeit habe ich ein Catalina, bei dem aber Sleep nicht mehr richtig funktioniert (USB ist immer tot, nachdem er aus dem Sleep wieder aufwacht, heißt Maus & Tastatur läuft dann immer nicht mehr)

    Da ich nicht glaube, dass ich mit meinem jetzigen Setup ohne Weiteres auf Monterey updaten kann, dachte ich auch an ein Hardware-Update, wenn es sich nicht vermeiden lässt.

    Am besten lief mit meinem Hardware-Setup Mavericks. Da lief eigentlich alles OOB und genau das hätte ich gerne wieder.


    Also Szenario A: Ich kaufe neue Hardware.

    Von meinem jetzigen Rechner würde ich eigentlich nur die Grafikkarte behalten, denn die wird ja denke ich mal noch auch in Monterey OOB unterstützt, oder?

    Bei der CPU dachte ich an irgendeinen älteren i9, aber mindestens i7. Machen da die Generationen einen großen Unterschied?

    Ich weiß leider nicht mehr, auf welche Chipsätze ich achten muss bzw. wo ich das recherchieren kann.


    Szenario B: Ich update nur macOS auf Montery

    Ist Clover eigentlich immer noch die beste Wahl als Bootloader?

    Ist meine Hardware dafür noch lauffähig? Sleep-Funktion sollte auch wieder funktionieren. Wenn ich auf die weiterhin verzichten muss, dann würde ich sogar eher zur neuen Hardware erstmal greifen, bevor ich dann um irgendwelche Patches etc. kümmern muss. Vorausgesetzt es läuft dann natürlich so viel es geht OOB.


    Ich hoffe ihr könnt mir etwas weiterhelfen, oder mir zumindest sagen, woher ich die richtigen Infos kriege.


    Vielen Dank im Voraus :)

    Desktop PC (macOS 12.4): Mainboard: ASRock ZH77 Pro3, CPU: Intel Core i5 3570K, GPU: Arez Radeon RX 580, 12GB RAM - OpenCore 0.8.1

  • Bis auf die magere Ausstattung beim RAM spricht eigentlich nichts dagegen, dein aktuelles System zu aktualisieren. Ein System mit Ivy-CPU, einer passenden Grafikkarte und genug RAM ist immer noch gut genug für Monterey. Möchte hier jetzt nicht wieder die Glaubensfrage lostreten, aber ich würde dir OpenCore als Bootloader empfehlen. Allein schon deswegen, weil es die meisten Nutzer für ältere Hardware nutzen.

  • …aber ich würde dir OpenCore als Bootloader empfehlen. Allein schon deswegen, weil es die meisten Nutzer für ältere Hardware nutzen.

    ok, würde ich ausprobieren, aber das habe ich noch nie benutzt. Gibt es dafür eine Anleitung im Board?

    Quote from Ozw00d

    Ich kann deine Konfiguration leider mobil nicht sehen. Kannst du diese hier mal auflisten?

    CPU: Intel i5 3570k

    GPU: AMD RX580

    Mainboard: ASrock ZH77Pro 3 und 12GB RAM

    Desktop PC (macOS 12.4): Mainboard: ASRock ZH77 Pro3, CPU: Intel Core i5 3570K, GPU: Arez Radeon RX 580, 12GB RAM - OpenCore 0.8.1

  • hallo kordon ,

    deine system-hardware-config sollte für monterey langen- (siehe bei mir im profil ähnlich) die grafikkarte ist stark genug, läuft - ob es "rennt" liegt dann wohl mitunter am jeweiligem program und dessen handling insgesamt :)


    die gute anleitung wäre der dortania-guide - mittlerweile bzw. aktuell unterstützt dieser version 0.7.8 also die soweit offiziel aktuelle0.7.8 also die soweit offiziel aktuelle - https://dortania.github.io/OpenCore-Install-Guide/


    softwaretools dazu- systemübergreifend

    ein plisteditor - https://github.com/ic005k/PlistEDPlus/releases


    und die opencore auxilary tools - https://github.com/ic005k/QtOpenCoreConfig/releases


    letzterer kann dein smbios vom clover importieren, ob damit dann auch schon die anderen sachen/ einstellungen übernommen werden, kann ich dir nicht beantworten, desweiteren sind dort beispielkonfigurationen vorhanden, an welchen man sich ggf. orientieren könnte- dennoch wäre es empfohlen sich den guide etwas genauer anzugucken


    lg und viel erfolg,

    wenn hakt sage bescheid, der thread ist ja offen

  • Hallo kordon ich habe hier auch noch ein GA-Z77X mit einem i5-3570K, damit habe ich mal etwas "rumgespielt" ( HighSierra, Mojave, Catalina) läuft sehr gut mit dem neuesten OpenCore,

    Du solltest dich aber genau an den dortania-guide halten, ist schon erstaunlich was da noch geht mit der "alten HW" , etwas overclocked (4,2GHz) geht das Dingen ganz gut für den Alltag....also , nur Mut und gutes Gelingen für dein Projekt.

  • Vielen lieben Dank an euch!

    Ich werde mich am Wochenende ransetzen und das ganze durchspielen. Ich gebe Rückmeldung, wie es lief.

    Desktop PC (macOS 12.4): Mainboard: ASRock ZH77 Pro3, CPU: Intel Core i5 3570K, GPU: Arez Radeon RX 580, 12GB RAM - OpenCore 0.8.1

  • kordon

    du kannst übrigens auf dem board via eines modbios eine nvme-ssd auf einem adapter im zweiten grafikslot benutzen bzw. auch auf den normalen pci-e wenn der adapter passt


    lg :)

  • Hallo, apfel-baum, kannst du mir das bitte näher erklären, was und wie, du da gemacht hast....ich würde das gerne mal machen....brauche ich da ein spezielles BIOS ? :thumbup: Wie gesagt ich habe hier ein GA-Z77X-D3H

  • bananaskin

    im prinzip ist das via win-raid, bzw. ltt und overclockers haben es danach gemacht - du brauchst dafür das uefitool und oder mmtool, sowie den "treiber"

    hier der winraid-link https://www.win-raid.com/t871f…ith-an-AMI-UEFI-BIOS.html


    ein "spezielles bios" brauchst du da nicht- ich mache vor dem nvme-mod übrigens erstmal ein soweit möglich update des bios via des ubu (uefi bios updater -vom win-raid forum) im anschluß wird gemodded, also die entsprechenden treiber hinzugefügt :)


    was da wichtig ist, wäre, ob noch genug platz da ist, und natürlich mitunter welche revision des boards und somit bios vorhanden ist- es passiert durchaus, das du für zwei "verschiedene" revisionen des boards einunddasselbe bios zum download-via hersteller- angeboten bekommst, dann reicht das natürlich auch für beide aus- aber darauf achten., sonst verflasht du dir das bios im zweifel.


    badbrain war schneller mit dem link, da habe ich noch getippt :)


    bananaskin

    dein board hat 2 revisionen, aber wenn ich das richtig gesehen habe -nur kosmetischer natur, also 1 bios für beide rev. :) - ggf. könnte man fürs modden einen seperaten thread machen - damit der te hier nicht verwirrt wird ;)

  • Apropos Bios.

    Ich weiß noch als Ich auf Catalina geupdatet habe, musste ich mein Bios downgraden. Warum genau konnte mir keiner sagen, aber nach dem downgrade konnte ich mit clover dann booten.

    Könnte das für OpenCore relevant sein?

    Sollte ich mein Bios also vorher wieder updaten, oder es erstmal so probieren?

    Desktop PC (macOS 12.4): Mainboard: ASRock ZH77 Pro3, CPU: Intel Core i5 3570K, GPU: Arez Radeon RX 580, 12GB RAM - OpenCore 0.8.1

  • meines erachtens kannst du dein bios auch nachher updaten- es sei denn du hast bereits eine m.2 ssd mitsamt adapter vor dir liegen- , der mod würde dir eben u.a. nvme bzw. m.2 s-ata ssd support bringen. einstellen mußt du es nach einem flash -so defaults sind eh wieder. -die efi für oc kannst du ja erstmal, wie immer- erstmal auf deinem bestehenden system zubereiten, und sie via eines experimentierstickes testen- wenn die läuft, kommt der nächste schritt, alles andere wäre albern, denn der bootloader sollte ja ersteinmal laufen.


    lg :)

  • Das Wochenende war ziemlich lang, aber ich habe mir mal gemäß der Anleitung versucht einen Installer-Stick mit OpenCore zu erstellen.

    OpenCore an sich startet auch, aber ich komme nicht in den Installer, es bleibt immer bei:  [EB|#LOG:EXITBS:START]

    hängen.

    Beim Recherchieren bin ich auf die Troubleshooting-Seite von OpenCore gestoßen, aber ich denke ein Booter-Issue oder ein UEFI-Issue ist es nicht, denn die Tipps dort haben nicht geholfen. Und gemäß Kernel-Issue habe ich nur AppleXcpmCfgLock eingeschaltet, aber auch das bringt mich nicht weiter.

    ich hänge auch mal meine EFI-Partition an, falls das für die Analyse weiterhilft.

    Ich weiß leider nicht weiter.


    Bin dankbar für jede Hilfe

    Files

    Desktop PC (macOS 12.4): Mainboard: ASRock ZH77 Pro3, CPU: Intel Core i5 3570K, GPU: Arez Radeon RX 580, 12GB RAM - OpenCore 0.8.1

  • In der log steht als letztest dies hier 94:028 00:257 AmiShimTimerBoostExit changed current period to 549183


    Das deutet auf SMC Kext Issue hin , du hast FakeSMC.kext und VirtualSMC.kext drin das beisst sich. Ich würde denn FakeSMC.kext deaktivieren false/no

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • Das hat leider nicht geholfen, aber ich habe beim Googlen herausgefunden, dass es wohl hilft wenn ich "RebuildAppleMemoryMap" aktiviere.

    Damit bin ich jetzt zumindest durch OpenCore gekommen.

    Aber beim Booten hänge ich jetzt an anderer Stelle. Ich habe den Bildschirm entsprechend abfotografiert.

    Vorsichtshalber habe ich auch nur VirtualSMC.kext drin, die FakeSMC.kext habe ich jetzt komplett außen vor gelassen.


    Warum gehts nicht weiter? Es sieht so aus, als ob alles geklappt hat.

    Mein USB-Stick blinkt auch nicht mehr, also er scheint nichts mehr vom Stick zu lesen.

  • hallo kordon ,

    wenn sich nix mehr tut beim usbstick, wäre eine idee auch mal einen der anderen usb-ports zu probieren, ggf. ist der von dir benutze außerhalb des portlimits, ein usb 3 oder grade nicht unterstützter. an solchen "kleinigkeiten" die es dann aber in sich haben, kann eine installation auch scheitern.


    lg :)

  • apfel-baum  kordon


    Kext geopdatet und die kext reihen folge angepasst .


    Die beiden SSDTs aktualisiert vielleicht hilft es ja :)

  • grade nochmal die konfig angeguckt- die sollte soweit auch unproblematisch mit monterey + laufen

  • Ich habe jetzt mit der aktualisierten EFI von OSX-Einsteiger alle USB-Ports durchprobiert.

    Jetzt kriege ich manchmal am Ende noch die zusätzliche Zeile:

    mcache: 4 CPU(s), 64 bytes CPU cache line size

    Sonst bleibt alles wie zuvor.


    Kann es irgendwie mit den SSDTs zusammenhängen?

    Als ich Clover genutzt habe, habe ich solche nie genutzt. Kann es sein, dass die irgendwie den USB-Ports reingrätschen?

    Ich erinnere mich auch, dass nicht alle USB-Ports für die Installation funktioniert haben, aber das gar keiner geht, ist neu :D

    Desktop PC (macOS 12.4): Mainboard: ASRock ZH77 Pro3, CPU: Intel Core i5 3570K, GPU: Arez Radeon RX 580, 12GB RAM - OpenCore 0.8.1