Red BIOS Editor und RX 580

  • Kennt sich jemand mit dem Red Bios Editor aus und hat da eigene Erfahrung.


    Ziel ist die Reduzierung des Stromverbrauchs der GraKa.


    Meine Sapphire RX 580 wird selbst im Desktop Idle an einem 4k Monitor sehr warm. Die Temperatur an den Heat Pipes ist so warm, dass man nicht länger diese berühren kann.


    Kann man die Stromaufnahme der GraKa reduzieren?


    Grüsse Florian

  • Via Injektion einer PPT Table bei den Device Properties. Aber vorgefertigte Tabellen/Generatoren gibt es nur für Vega56/65 und RX5x00(XT) hier im Forum. Aber das ist schon komplexer zu generieren.


    Aber erstmal die Frage ob Du schon den Schalter zwischen PowerBios und SilentBios auf das SilentBios an der Grafikkarte umgestellt hast? Das sollte schon einen markanten Unterschied machen.

  • Was noch wichtig ist - laufen die Lüfter der Karte, oder nicht?

    !!Kein Support per PN!!

    Vorsicht beim Update von CLOVER (v.5123 und neuer) !

    Wenn dein System gut läuft, erstell' einen Thread im Hardware Center mit EFI, und gib die verwendete Hardware dazu an.

    Bewegen im Hardware Center


    Welchen Bootloader sollte ich wählen? Hier gibt's eine Erklärung der Unterschiede, die einem bei der Entscheidung hilft: OpenCore EFI Bootloader 


    curse_pic.png

  • So kannst du die SoftPoweplayTables in Opencore injecten. Unter Anderem auch den Passiv Modus (Zero RPM) unter einer bestimmten Temperatur abstellen. Sieht bei mir zurzeit so aus.


    Lüfter anlaufen bei der Rx 580 abstellen



    device-id, model, no-gfx-spoof benötigst du nicht, da ich diese Einträge nur wegen der benötigten Fake-ID für meine RX550 drin habe.


    In Windows solltest du den ZeroRPM Mode der GPU auch einfach in den Radeon Settings deaktivieren können.



    Aber wenn deine Karte wirklich so heiß wird, würde ich auch mal die Wärmeleitpaste und Verschmutzungen (Staub) checken. Desweiteren läßt sich bei AMD Karten nicht vermeiden, dass bei einem Dual Monitor Setup mit unterschiedlichen Auflösungen und Frequenz die VRAM der GPU immer mit maximalen Takt laufen. Aber das scheint dich nicht zu betreffen.


    Auch gibt es bei Radeon Karten manchmal das Problem mit hohen Refresh Rates (144 Hz) und dem VRAM Takt. Das Problem scheint aber behoben zu sein: https://www.prad.de/radeon-und…en-gegen-hohen-vram-takt/

    Edited 3 times, last by LetsGo ().

  • Grundsätzlich würde mich ein "Low Power Modus" für die RX580 interessieren, da ich nur 2D in 4k benötige ...


    Die Sapphire RX 580 hat einen BIOS SWITCH, der die Karte im "Normal" BIOS Modus - wie genau der auch definiert sein soll ..., laufen lässt und einen "Compute" BIOS Modus, der sich so nennt. Zumindest stand es so im Beipackzettel ... wenn ich mich nicht irre ...


    Die Lüfter drehen sich nicht. Nur so alle 20 Minuten mal andrehen und gleich wieder aus.


    Die Heat Pipes Open auf der Stirnseite der Karte werden so heiß, unter Desktop Idle, dass ich dies keine 20 sec berühren kann.


    Staub ist kein Problem.


    mache mal einen Neustart mit bios switch ...


    Update:


    Mit umgestellten Schalter (hin zu Display-Steckern) sind die Heat Pipes viel kühler. So kann ich die dauerhaft berühren.

  • Ja "normal" ist der Silent Mode. Normal wird da die Leistungsaufnahme der Karte etwas limitiert verglichen zum Compute Mode. Und das sollte eigentlich auch zu geringeren Temperaturen unter Last führen.


    Aber deine ist ja eher im idle und so warm. Ich meine mich zu erinnern das AMD (einige?) Grafikkarte das Problem haben/hatten eine sehr hohe Leistungsaufnahme zu haben im Multimonitorbetrieb.


    Deswegen würde ich mal testen ob die Temperaturen markant besser werden wenn Du einen Monitor absteckst. Aber das ist langfristig wohl eher keine Option. Dann hilft nur undervolten via PPT Table und zwar auch schon in den kleinen Leistunsgmodi.

  • Kannst du mal Temps und den VRAM Takt im Idle posten.


    Die RX580 schaltet ab 50 Grad die Lüfter ein (soweit ich weiß), also ist es nicht so schlimm, wenn die Karte alle 20min andrehen. Aber nervig. Zero Fan deaktivieren löst schon mal das Lüfter anlaufen und wieder abstellen.


    Auch wenn die Karte erst vor Kurzem gekauft wurde, würde ich die Wärmeleitpaste checken. Meine RX550 war letztes Jahr auch neu und musste feststellen, dass die WLP schon eingetrocknet war. Kommt wahrscheinlich davon, dass die Karten schon einige Zeit rumliegen. Hat auch ein paar Grad gebracht.


    Und unter MacOS wird die GPU anscheinend sowieso ein bisschen wärmer, als unter WIN. Meiner Erfahrung nach.

  • Die Lösung mit dem Switch war nur temporär ... hat keinen (großen) Effekt erzielt


    Wie kontrolliere ich Temps und den VRAM Takt im Idle unter macOS?


    Die Polaris Chips sind eher Herdplatten ... im Vergleich zu den Nachfolgern/Nvidia ...

  • z.B. istatMenus (kostenpflichtig), Stats, HWMonitorSMC2


    VirtualSMC muss halt vorhanden sein.

  • Mal ein Vergleichswert. Meine Gigabyte RX580 idelt hier mit 0 rpm bei 47-50 Grad rum.


    Ich hab leider nur den Wert von "eul".

  • So sieht es jetzt aus. Stimmen die Watt-Angaben ??? 100W+x???




    im alten setup (nach 6 min)

  • Ok. IdleClock wäre zu hoch. Watt auch, wenn die richtig ausgelesen werden?


    So siehts bei mir aus. Wegen Dual Monitor steht halt der VRAM auf Anschlag und die Temp. ist halt min. auf 60 Grad. Aber meine taktet runter und die Leistungsaufnahme passt auch.



    Wie sieht es mit deiner EFI aus? Ist da alles auf dem neuestem Stand. Dann könnte man auch schon eher Auslesefehler ausschließen.

  • Habe meine Sapphire RX 570 Puls eingebaut. Die hat etwa 10°C weniger.

    Und operiert bei zwischen 90W-125W, während die RX 580 100W-140W zieht :think:


  • Falls das der Idle Clock Speed ist, wäre der meines Erachtens trotzdem zu hoch. Idle Power sollte auch erheblich runter gehen. Sollte eigentlich schon runtertakten, kann aber auch am 4 k Monitor liegen.


    Nochmals: Ist deine EFI, speziell die Kexte aktuell um Auslesefehler ausschließen zu können. Meine mich mich zu erinnern, dass das schon mal der Fall war.


    Denke mal das bei einer RX 580 Idle Power so maximal bei 30 W liegen sollte.


    Hier mal ein Bild, wie es aussehen sollte:


  • Wie gesagt. Testet das mal mit Single Monitor.


    Meine RX580 Single Monitor zeigt 22W an.



    Da war irgendwas mit stark erhöhter Leistungsaufnahme im Mutimonitorbetrieb.

  • Hat ja nur einen 4k Monitor angeschlossen, so wie ich das vom ersten Post verstehe.

  • Oh man ich bin überarbeitet. Das warst ja Du LetsGo mit dem Dual...


    Brauch Urlaub...



    Gruss,

    Joerg

  • floris


    Nimm mal das angehängte Tool zum auslesen. Ich glaube, du hast da eher Auslesefehler drin. Siehe Link. Hoher Stromverbrauch RX580 im IDLE?

  • edit:



    LetsGo


    hat eigentlich alles gesagt ;-)



    das Tool AMD GPU Menü spuckt bei mir keine Watt Angaben zur GPU aus ? Ist auch Grafisch irgendwie nicht so dolle.

  • msart


    Hast Recht. Nutze das Tool selber nicht (habs nur im anderen Thread gesehen), da ich mit iStatMenus und/oder HWMonitorSMC2 arbeite. Habe selber mit istatMenus keine Probleme.


    floris


    Sorry. Nimm besser HMMonitorSMC2 um die Leistungsaufnahme deiner GPU zu überprüfen.