Tastatur wird nicht erkannt, Layout kaputt, Tasten falsch belegt

  • Moin,


    ich habe gestern mein Haswell System mit OpenCore 0.7.5 ausgestattet und Monterey (mit SMBIOS iMac16,2) frisch installiert (kein Update).

    Der Installer war auf Englisch mit Englischem Tastaturlayout. Nach der Installation habe ich dann alles auf Deutsch umgestellt und natürlich auch mehrmals neugestartet.


    Aber heute ist mir aufgefallen, dass die < > und ^ Tasten (und vielleicht noch andere) falsch belegt bzw. vertauscht sind.


    Die Tastatureinstellungen in den Systemeinstellungen wollen die Tastatur nicht erkennen. Damit hatte ich unter den vorherigen macOS Versionen noch nie ein Problem (Hardware seit Jahren unverändert).


    Und wenn ich bei Eingabequellen schaue, sieht das Layout auch nicht gerade nach der typischen DE-Tastatur aus:


    Evtl. irgendwas in OpenCore vergeigt?

    (Alles auf dem neusten Stand, bzw. gestern die neusten Versionen geladen)


    Ansonsten habe ich in OpenCore noch "prev-lang:kbd" auf "en-US:0" (string) gestellt. Aber soweit ich verstanden habe sollte das ja nur Auswirkungen auf die OpenCore GUI bzw. den FileVault Login haben.

    <key>prev-lang:kbd</key>
    <string>en-US:0</string>


    Woran kann das liegen? Bzw. wie kann man das beheben?


    Vielen Dank schon mal :)

    jemue


    EDIT: Im Anhang noch die config.plist


  • Probiert mal das Layout.

  • Chris007 Ja, das kenne ich. Ich muss dazu bei mir einfach nur in der Systemeinstellung unter

    • Systemeinstellungen >Tastatur > Eingabequellen
    • Sprache hinzufügen. Undzwar "Deutsch" statt "Deutsch-Standard".
    • Dann "Eingabequellen in der Menüleiste anzeigen" aktivieren
    • In Menüleiste "Deutsch" auswählen.

    Danach funktioneren <,> und °,^ etc. auch wieder wie gewohnt.

    Edited 2 times, last by 5T33Z0 ().

  • Probiert mal das Layout.

    Das funktioniert :)


    Haben die was in Monterey geändert? Wie gesagt: Vorher hat's immer problemlos ohne irgendwelche Anpassungen funktioniert

  • 5T33Z0 hats beschrieben, woran es liegt. Aber bei meinem Layout sind glaube ich noch andere sinnvolle Änderungen (Windows Tastatur) gemacht worden, wenn ich mich nicht täusche. Kannst ja beides ausprobieren.

  • 5T33Z0 hats beschrieben, woran es liegt

    Das kann's bei mir nicht sein. Mit Deutsch-Standard kann ich kein @ mit Alt+L (bzw. option+L) eingeben. Und die < > und ^ Tasten verhalten sich sowohl bei Deutsch als auch Deutsch-Standard identisch (falsch / vertauscht)


    Btw: Mit deinem pc_layout funktionieren zwar nun die < und ^ Tasten, aber dafür ist es halt wirklich PC Layout und das @ ist auf Alt+Q und nicht mehr wie beim Mac üblich auf Alt+L :(

  • Also ich habe mit Karabiner zusätzlich das @ auf Alt Gr+ Q gelegt. Alt+Q ist Quit, wie beim Mac auch. Die Windows Taste ist Options und Alt halt Command.


    ich habe da noch ein Layout. Vielleicht ist das besser.

  • Gefühlt sind nun alle Sonderzeichen auf den falschen Tasten, und nur < > und ^ sind da wo ich sie haben will :D option+7 sollte das Pipe-Symbol sein. option+5 und 6 die eckigen Klammer, option+8 und 9 die geschweiften Klammern.


    Alt+Q ist Quit

    Auf dem mac ist das üblicherweise Cmd+Q, also auf einer Windows Tastatur entsprechend Win+Q.


    ich habe da noch ein Layout

    Wird sofort ausprobiert. Stay tuned :)


    EDIT: Ne, das ist komplett grauenvoll. < > und ^ sind vertauscht und @ ist auf alt+q bzw. alt-gr+q


    Ich will doch einfach nur mein Mac Keyboard Layout zurück :(

  • Library > Preferences > com.apple.keyboardtype.plist löschen und neustarten

  • Ok. Mein Fehler. Mein Layout ist eher an die Windows Tastatur angelegt. Aber 5T33Z0 hat ja die Lösung für dich.

  • Library > Preferences > com.apple.keyboardtype.plist löschen und neustarten

    Jetzt stehe ich wieder da wo ich angefangen habe: Nur < > und ^ sind vertauscht. Alles andere scheint wie gewünscht zu funktionieren.


    Mich wunder aber auch, dass das Layout auf den Bildern so falsch aussieht:



    Zwischen Shift und Y ist gar keine Taste zu sehen

  • Wie gesagt: deutsch, NICHT deutsch-standard verwenden. Und in Menüleiste umstellen, wie beschrieben

  • Wie gesagt: deutsch, NICHT deutsch-standard verwenden.

    Habe ich doch... Mit Deutsch-Standard habe ich dasselbe Problem und zusätzlich ist dort auch noch das @ auf alt-gr+Q statt auf alt-gr+L


    Deutsch-Standard ist gefühlt identisch zu deinem pc_tastatur Layout


    EDIT: Ich habe jetzt Karabiner Elements installiert und gestartet. Und nun geht's. Ich habe nichts angeklickt. Ich hab das Tool wirklich einfach nur gestartet


    Und nun wird in den Einstellungen auch ein passendes Tastatur Bild angezeigt



    Zusammengefasst: Karabiner installieren, unter Misc die Einstellungen in's System schreiben lassen, Karabiner deinstalliert. Und alles läuft endlich wie gewünscht.


    Danke euch!

    Edited 3 times, last by jemue ().

  • jemue


    VoodooPS2Controller.kext > rechtsklick "Paketinhalt anzeigen" > Contents > Plugins> VoodooPS2Controller.kext > "Paketinhalt anzeigen"> info.plist öffnen, suchen nach "Use ISO layout keyboard" auf true setzten. Falls es auf True steht, auf False setzen.