Sammelthread für BT Probleme unter Monterey

  • Hallo,


    das würde mich auch interessieren - bin auch noch auf der Suche nach einem neuen BT-Adapter.

    Ich nutze bisher einen Logilink BT2.0-Adapter. Der hat bis Catalina auch funktioniert (mit dem alten und dem neuen Magic Trackpad). Unter Monterey funktioniert mit dem nur noch das alte Trackpad.

    Hatte mir daher jetzt einen Logilink BT5.0-Adapter bestellt, mit dem funktionieren aber beide Trackpads nicht (BT bekomme ich damit nicht zum Laufen -ich nehme an, das liegt an dem Realtek-Chipsatz).


    Danke & Grüße

    Gigabyte Z87X-UD3H
    Opencore 0.7.5
    Intel I7-4770S
    4 x 8GB RAM Crucial
    MSI Radeon RX570 OC ARMOR 8GB
    Samsung SSD 1TB
    BT IOGEAR GBU521 W6

    OSX 12.0.1

  • denn werfe mal eine Blick in die Hardware-Rubrik, falls Du diese noch nicht entedeckt hast gibs hier Rezessionen auch zu BT-Geräten forrest

    Grüße

    Arkturus

  • Also für alle die BT Probleme mit einen USB Dongle haben:


    Hab soeben einen ASUS USB BT400 (Chipsatz: BCM20702) getestet und bei diesem Funktioniert mittels


    BlueToolFixup.kext


    Alles von AirPods über Magic Mouse, Trackpad bis hin zu AirDrop und Handoff (Letzten beiden Punkte natürliche nur in Kombination mit einer entsprechenden WLAN Karte).


    Das einzige was mir noch aufgefallen ist, es funktioniert AirDrop & Handoff nur zum Hackintosh hin aber nicht vom Hackintosh auf ein anderes Gerät. Was ich aber glaube an dem BlueToolFixup.kext liegt, denke das wird mit weiteren Updates behoben.

    Images

    iMacPro1.1 SMBIOS - MacPro1.1 Case - macOS Monterey 12.0.1 - Clover 5142
    -------------------------------------------------------------
    Intel Core i5-3570k 4 x 3,4 Ghz (Ivy Bridge)
    MSI Z77A-G43 Z77 1155
    MSI AMD RADEON RX 580 8 GB
    16 GB 1600 MHz DDR3 Ram
    Samsung U28E590 - 28" 4K

  • Danke für die Info. Nach dem Hardware-Hinweis habe ich mir den dort genannten IOGEAR GBU521 W6 gekauft. Mit dem funktioniert mein Trackpad 2 jetzt - aber scheinbar hätte es der halb so teure Asus auch getan :) ne WLAN-Karte hab´ ich nicht drin. Schönen Abend.

    Gigabyte Z87X-UD3H
    Opencore 0.7.5
    Intel I7-4770S
    4 x 8GB RAM Crucial
    MSI Radeon RX570 OC ARMOR 8GB
    Samsung SSD 1TB
    BT IOGEAR GBU521 W6

    OSX 12.0.1

  • Hab gerade auch nochmal verglichen, der IOGEAR GBU521 W6 hat auch den BCM20702 Chip genau wie der ASUS BT400.

    Also kurz zusammengefasst für Monterey einen BT Dongle mit dem oben genannten Chipsatz und es klappt wieder mit BT inkl. AirDrop/Handoff

    iMacPro1.1 SMBIOS - MacPro1.1 Case - macOS Monterey 12.0.1 - Clover 5142
    -------------------------------------------------------------
    Intel Core i5-3570k 4 x 3,4 Ghz (Ivy Bridge)
    MSI Z77A-G43 Z77 1155
    MSI AMD RADEON RX 580 8 GB
    16 GB 1600 MHz DDR3 Ram
    Samsung U28E590 - 28" 4K

  • Kann ich nicht bestätigen. Habe den Chipsatz in der BCM94630NG. Wifi und Bluetooth funktionieren aber weder Handoff noch Airdrop oder Universal Clipboard...

  • Betreffs BCM20702 oder BCM207023 BT-Chip, welche mit aktueller DP nativ laufen, brauchen alle Chip's, welche hinten dran noch Zusätze haben inzwischen die Kext's für den Inject.

    Beispiel BCM20702A1, BCM20702B2, BCM20702B3, etc. laufen mit aktueller DP nicht mehr nativ.


    CilentCipha

    Die BCM94630NG funktioniert OOB inclusive aller Services bis aktuelle Beta Monterey. Der Fehler muss irgendwo in Deiner Konfiguration liegen.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB  11.6.2 / 12.1 DP3

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema  SSD 250GB+512GB  macOS 12.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  SSD 2x250GB + 480GB  10.15.7 / 12.1 DP3

    iPhone8 64GB: iOS 15.1  iPad Pro 9,7" WiFi 32GB: iPadOS 15.2 DP3

  • MacPeet bei meiner BCM94630NG wird als Chipsatz BCM20702B0 angezeigt.


    Ich hab heute bei Reddit schon alles druntergeschrieben, da sind auch alle Screenshots von meinen Settings.

    Falls dir langweilig ist, kannst du gerne mal reinschauen. Mir gehen die Ideen aus...

    Bin um jeden Tipp dankbar

    https://www.reddit.com/r/hacki…cm94360ng_airdrop_issues/

  • Habe gerade nochmal geschaut auf aktueller DP3 Monterey.

    Tatsächlich zeigt meine BCM94630NG nun auch BCM20702B0 an unter Systeminformationen, was vorher mit nur BCM20702 angezeigt wurde, aber dennoch funktioniert hier alles.

    Habe aktuell die DP3 Monterey drauf und keine Probleme mit den Apple Services, sowie AirDrop, Airplay, etc., pp., alles geht hier.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB  11.6.2 / 12.1 DP3

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema  SSD 250GB+512GB  macOS 12.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  SSD 2x250GB + 480GB  10.15.7 / 12.1 DP3

    iPhone8 64GB: iOS 15.1  iPad Pro 9,7" WiFi 32GB: iPadOS 15.2 DP3

  • Was mich wundert: Im Hackintool wird bei "Firmware ladet" kein Päckchen angezeigt. Und in den System Infos fehlen alle Infos zu Airdrop, HAndsoff etc.

    Ich hab keine Idee was da noch reinfunkt. Normales Bluetooth funktioniert und Wifi läuft auch ohne Probleme. Nur die Services nicht...

  • Also, so sieht es im Hackintool aus mit meiner NG, bei der ja alles noch OOB geht:


    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB  11.6.2 / 12.1 DP3

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema  SSD 250GB+512GB  macOS 12.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  SSD 2x250GB + 480GB  10.15.7 / 12.1 DP3

    iPhone8 64GB: iOS 15.1  iPad Pro 9,7" WiFi 32GB: iPadOS 15.2 DP3

  • ok, da sehe ich erstmal keinen Unterschied.

    f6fhcw6wza281.jpg?width=1920&format=pjpg&auto=webp&s=882e1b86e76d0a1bc836a6d175684a37bb6e3181

  • Sehe ich auch keine Unterschiede, aber bei mir funktioniert AirDrop und Airplay, etc. pp., nativ auf BigSur und Monterey mit der NG.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB  11.6.2 / 12.1 DP3

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema  SSD 250GB+512GB  macOS 12.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  SSD 2x250GB + 480GB  10.15.7 / 12.1 DP3

    iPhone8 64GB: iOS 15.1  iPad Pro 9,7" WiFi 32GB: iPadOS 15.2 DP3

  • Wie sieht denn die Bluetooth Info in den Systeminformationen bei dir aus?

  • Ich schließe mich da MacPeet an bei mir funktioniert meine BCM94360NG auch OOB mit Airdrop, Handoff etc.

  • Kann auch bestätigen das die BCM94360NG OOB also ohne irgendwelche Kexte Wlan sowie Bluetooth mit allen Services seinen dienst tut.





    Gruss Coban

     MSI-Z590Pro Wifi | Intel® Core™ i9-10900k CometLake | 32GB DDR4 RAM | Radeon RX 570 Red Devil | Nvme WD Black SN750 1TB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Monterey Beta / Win 10 Pro / Win 11 Pro Beta / Ubuntu 21.04

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 21.04

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 21.04


    " Chasch nöd s Föifi und s Weggli ha."

  • Betreffs BCM20702 oder BCM207023 BT-Chip, welche mit aktueller DP nativ laufen, brauchen alle Chip's, welche hinten dran noch Zusätze haben inzwischen die Kext's für den Inject.

    Beispiel BCM20702A1, BCM20702B2, BCM20702B3, etc. laufen mit aktueller DP nicht mehr nativ.

    jetzt ergibt das auch Sinn, ich hab ja intern noch eine BCM94360CS2 drin die den BT Chip BCM20702B0 besitzt und dieser Chip lief auch ohne irgend einen inject Kext oder sonstiges.

    Der oben genannte ASUS BT400 Besitzt ja den BCM20702A1 Chip und dieser braucht unter Monterey den BlueToolFixup damit er wieder funktioniert.


    Bei beiden Chips laufen bei mir zumindest alle Apple Services, jedoch was ich noch festgestellt habe, entsperren mit der Apple Watch funktioniert nur mit dem BCM20702B0.

    iMacPro1.1 SMBIOS - MacPro1.1 Case - macOS Monterey 12.0.1 - Clover 5142
    -------------------------------------------------------------
    Intel Core i5-3570k 4 x 3,4 Ghz (Ivy Bridge)
    MSI Z77A-G43 Z77 1155
    MSI AMD RADEON RX 580 8 GB
    16 GB 1600 MHz DDR3 Ram
    Samsung U28E590 - 28" 4K

  • Hat noch jemand ne Idee, wieso es bei mir nicht läuft? Wenn keine Kexte geladen werden, was könnte denn noch Einfluss darauf haben?

  • Ich würde da vielleicht nochmal in der EFI schauen ob da noch ein kext vorhanden ist, oder ob unter Device Propertries was eingetragen ist, was damit zu tun haben könnte.


    1.
    Dell Optiplex 3060 mff

    I5 8500t

    8GB Arbeitsspeicher

    1TB Samsung 970 NVME M.2

    256GB Samsung 860 (Windows 10pro)

    WLAN-Bluetooth BCM94360NG
    Big SUR 11.6

    Bootloader: Opencore 0.6.2


    2.

    MacMini M1, 8GB Arbeitsspeicher, 512GB SSD

    Big SUR 11.6.1

  • ich finde nur 3 Einträge zu Bluetooth im NVRAM. Kext hab ich keine in der Efi...