Firmware auf BCM94360NG Modul neu flashen

  • Guten Abend,


    Nachdem ich nun das 2te BCM94360NG Modul nicht mehr nutzen kann, glaube ich nicht mehr an zufälle.

    Ich schätze das das Modul durch Nutzung unter Windows aus irgendeinem Grund die Firmware der Karte schädigt, so das das bluetooth danach weder unter Mac, noch unter Windows zu gebrauchen, bzw lauffähig gemacht werden kann.


    Aus welchen gründen das Modul iwann ein hauweg hat, entzieht sich meiner Vorstellungskraft und habe auch keine lust immer wieder neue karten dieser Baureihe zu bestellen.

    Nun möchte ich versuchen zb unter linux die firmware neu aufzuspielen, und wüsste gern ob das übehaupt möglich ist, und ob einer vielleicht eine geeignete Anleitung für mich hat. soweit ich mich erinnern kann, bin ich irgendwann mal im netz über dieses Thema gestolpert, erinnere mich aber nichtmehr an die genaue Seite.


    deshalb frage ich:


    1. ist es überhaupt möglich eine firmware wieder auf das Modul aufzuspielen


    2. woher bekomme ich die richtige firmware Version, passend zu diesem Modul


    3. wie genau mache ich das



    über Hilfe würde ich mich sehr freuen, hab wie bereits erwähnt schon zwei karten nun hier liegen, die das gleiche Problem haben.


    danke

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K Comet Lake - Intel UHD 630 - BCM94360NG - 500GB NVMe - 32GB RAM - OpenCore 0.7.6

    Dell XPS 13 7390  Intel® Core™ i7-10510u Comet Lake - Intel Iris Plus - Killer WLAN / Bluetooth Modul - 500GB NVMe - 16GB RAM - Big Sur / Monterey - MacBookPro16,3 - OpenCore 0.7.6

    Dell Latitude 7280  Intel® Core™ i7-7600u Kaby Lake - HD 620 - BCM94360NG Modul - 500GB NVMe - 16GB RAM - Big Sur / Monterey - MacBookPro15,2 - OpenCore 0.7.6

    ASUS H170 G11CB-DE006T  Intel® Core™ i5-6400 Skylake - HD 530 - BCM94360NG Modul - 256GB SSD - 16GB RAM - Big Sur / Monterey - iMAC17,1 - OpenCore 0.7.4

    Intel NUC6I7KYK  Intel® Core™ i7-6770HQ Skylake - Iris Pro 580 - Intel WLAN / Bluetooth Modul - 256GB NVMe - 16GB RAM - Big Sur - iMac17,1 - Open Core 0.7.6

  • Prinzipiell kannst du mal was versuchen was @headkatze zu einer 943602CS beigetragen hat.


    Eine Variante mit dfu-util und manuell uploaded Firmware in OS X, ich vermute aber deine Firmware ist entweder aktualisiert oder korrupt.


    Es soll woanders wohl geholfen haben genau diese Problematik zu lösen.


    Google mal (ab Seite 4 wird das interessant):

    Bluetooth stopped working after updating to 10.15.1



  • genau...iwas mit dfu-util hatte ich glaub was gelesen. ich schau mir mal die unbeliebte Seite an. war zwar nicht auf dieser Seite was ich damals gelesen hatte, aber scheint ja in dieser Richtung was zu sein.


    hoffe ich komme damit zurecht....stecke gleich mal mein anderen Rechner an und arbeite mich mal ein. wär echt schade um die zwei karten...neue kaufe ich mir von denen glaub erstmal keine mehr

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K Comet Lake - Intel UHD 630 - BCM94360NG - 500GB NVMe - 32GB RAM - OpenCore 0.7.6

    Dell XPS 13 7390  Intel® Core™ i7-10510u Comet Lake - Intel Iris Plus - Killer WLAN / Bluetooth Modul - 500GB NVMe - 16GB RAM - Big Sur / Monterey - MacBookPro16,3 - OpenCore 0.7.6

    Dell Latitude 7280  Intel® Core™ i7-7600u Kaby Lake - HD 620 - BCM94360NG Modul - 500GB NVMe - 16GB RAM - Big Sur / Monterey - MacBookPro15,2 - OpenCore 0.7.6

    ASUS H170 G11CB-DE006T  Intel® Core™ i5-6400 Skylake - HD 530 - BCM94360NG Modul - 256GB SSD - 16GB RAM - Big Sur / Monterey - iMAC17,1 - OpenCore 0.7.4

    Intel NUC6I7KYK  Intel® Core™ i7-6770HQ Skylake - Iris Pro 580 - Intel WLAN / Bluetooth Modul - 256GB NVMe - 16GB RAM - Big Sur - iMac17,1 - Open Core 0.7.6

    Edited once, last by Hecatomb ().

  • Ich hatte auf meinem T440 auch mal so ein Problem. Plötzlich war Bluetooth weg. Unter Windows funktonierte es auch nicht. Linux ebenso wenig. Hatte mich auch schon damit abgefunden das das Bluetoothmodul abgeraucht ist. Irgendwann habe ich dann die EFI komplett gegen eine andere ersetzt (Clover -> OC) und plötzlich war Bluetooth wieder da. Das wird vermutlich weniger mit OC zu tun haben als evtl. mit dem Bluetooth Injector Kext oder sonst irgendeine Kombination. Habe dann aber auch nicht weiter nachgeforscht.

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<

  • Sascha_77 du scheinst recht zu haben. die eine karte geht schon wieder, und das ohne das ich was gemacht hab. nach der zweiten hab ich aber noch nicht geschaut...da hat aber damals irgend was anderes als apple unter Treiber gestanden, und danach wär das bluetooth dann weg.... ich werde sobald ich geschaut hab berichten ob diese karte auch wieder geht.

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K Comet Lake - Intel UHD 630 - BCM94360NG - 500GB NVMe - 32GB RAM - OpenCore 0.7.6

    Dell XPS 13 7390  Intel® Core™ i7-10510u Comet Lake - Intel Iris Plus - Killer WLAN / Bluetooth Modul - 500GB NVMe - 16GB RAM - Big Sur / Monterey - MacBookPro16,3 - OpenCore 0.7.6

    Dell Latitude 7280  Intel® Core™ i7-7600u Kaby Lake - HD 620 - BCM94360NG Modul - 500GB NVMe - 16GB RAM - Big Sur / Monterey - MacBookPro15,2 - OpenCore 0.7.6

    ASUS H170 G11CB-DE006T  Intel® Core™ i5-6400 Skylake - HD 530 - BCM94360NG Modul - 256GB SSD - 16GB RAM - Big Sur / Monterey - iMAC17,1 - OpenCore 0.7.4

    Intel NUC6I7KYK  Intel® Core™ i7-6770HQ Skylake - Iris Pro 580 - Intel WLAN / Bluetooth Modul - 256GB NVMe - 16GB RAM - Big Sur - iMac17,1 - Open Core 0.7.6

  • Nutzt du irgendwelche Bluetooth Injektoren/Firmware Kexts ?

    Das wäre nämlich ein ganz großer Fehler, da die 94360NG nativ läuft!

  • Nein. Ich weiß natürlich das die Karte keine kexte braucht. Daran hat es nicht gelegen.


    Hab die Tage iwo gelesen das man unter Windows drauf achten soll erst den Treiber fürs WLAN zu installieren, und dann erst den Bluetooth Treiber. Dachte erst das es eventuell damit zu tun haben könnte. Woran es nun gelegen hat kann ich absolut nicht sagen. Schon komisch 😒

    MSI MEG z490i UNIFY  Intel® Core™ i9-10900K Comet Lake - Intel UHD 630 - BCM94360NG - 500GB NVMe - 32GB RAM - OpenCore 0.7.6

    Dell XPS 13 7390  Intel® Core™ i7-10510u Comet Lake - Intel Iris Plus - Killer WLAN / Bluetooth Modul - 500GB NVMe - 16GB RAM - Big Sur / Monterey - MacBookPro16,3 - OpenCore 0.7.6

    Dell Latitude 7280  Intel® Core™ i7-7600u Kaby Lake - HD 620 - BCM94360NG Modul - 500GB NVMe - 16GB RAM - Big Sur / Monterey - MacBookPro15,2 - OpenCore 0.7.6

    ASUS H170 G11CB-DE006T  Intel® Core™ i5-6400 Skylake - HD 530 - BCM94360NG Modul - 256GB SSD - 16GB RAM - Big Sur / Monterey - iMAC17,1 - OpenCore 0.7.4

    Intel NUC6I7KYK  Intel® Core™ i7-6770HQ Skylake - Iris Pro 580 - Intel WLAN / Bluetooth Modul - 256GB NVMe - 16GB RAM - Big Sur - iMac17,1 - Open Core 0.7.6

  • Strange… ich habe einige Karten davon im Einsatz (7 Stück) und hatte damit noch nie Probleme.

  • Hier bei mir sind es auch 4 die ohne problem ihr werk tun.

    Man muss einfach beachten das alle Bluetooth Karten eine sozusagen "second stage" Firmware brauchen die eben von Betriebsystem mit Treiber eingespielt werden.

    Mit "neu flashen" wird das irgendwie falsch rübergebracht, da wird nichts "geflasht" in dem sinn.

    Wenn die karte aus irgendeinem grund was falsches eingespielt wurde oder gar nicht eingespielt wurde läuft die auch nicht.

    Unter MacOS erkennt man dies meistens auch bei der Firmware Version "4096" angezeigt wird.

    In diesem Fall jetzt bei BCM94360NG reicht es vollkommen einmal die Karte eben Stromlos zu stellen.

    Oder einfach mit Windows die MacOS Bootcamp Treiber zu installieren.

    Oder auch unter ubuntu zbspl. mit...

    Code
    1. apt purge bcmwl-kernel-source
    2. apt-get install broadcom-sta-source
    3. apt-get install broadcom-sta-dkms
    4. apt-get install broadcom-sta-common

    die Broadcom Treiber Umgebung zu erneuern.

    Danach lüpt das auch wie es soll.


    Gruss Coban

    Files

     MSI-Z590Pro Wifi | Intel® Core™ i9-10900k CometLake | 32GB DDR4 RAM | Radeon RX 570 Red Devil | Nvme WD Black SN750 1TB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Monterey Beta / Win 10 Pro / Win 11 Pro Beta / Ubuntu 21.04

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 21.04

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 21.04


    " Chasch nöd s Föifi und s Weggli ha."