HP Envy x360 15-ed0157ng Touchscreen + Backlight Problem ?

  • Guten Abend zusammen,


    es geht um mein neues HP Envy x360 15-ed0157ng


    mit einem i5-1035G1, 16GB Speicher, Intel SSD, Intel Wifi AX201, Intel Ice Lake



    Es funktioniert soweit alles bis auf 3 Dinge#


    1. Das Display steht auf 100% Helligkeit es ist aber nur etwa 80% erst nach einem Sleep geht es auf volle 100% wie kommt das ?


    2. Der Touchscreen funktioniert leider nicht, es ist ein ELAN Touchscreen es wird über I2C angebunden genauso wie das Touchpad, letztere ist ein Synaptics was funktioniert wie es soll.


    ELAN 2514


    3. Das interne Mikrophone wird einfach nicht erkannt.



    Ich habe eine EFI erstellt anhand des Dortania OpenCore Guides erstellt. Die CPU Tastet wie sie soll auch Sleep läuft sowie die Akkuanzeige , WLAN ,Bluetooth, Tastatur, Touchpad, Sound, SDCardreader, Helligkeit per FN Tasten etc. Ja eigentlich alles

    Bis auf die 3 mir doch irgendwo Wichten Dinge.^^



    Für ein wenig Hilfe wäre ich dann doch dankbar grad in Sachen DSDT bekomme ich es einfach nie hin ^^ Und beim Sound hat MacPeet bisher immer ein Lösung gefunden sitze jetzt seit Sonntag dran.


    Hab mal meine EFI und einen IOReg Auszug angehangen. WLAN Kext und Ressourcen habe ich der Größe wegen entfernt. Die DSDT in Rohh


    LG und danke für jede Hilfe.


    Files

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Sapphire RX580 - macOS 11.0.1 - OC

    Elitebook 840 G1 : *1600x900* - Intel i5-4300U - 8GB DDR3 - M2 254GB + Intel SSD 320GB - Intel HD 4400 - macOS 11.0.1 - OC

  • Ich denke, wegen Audio kann ich hier im Moment nicht viel machen. Den x360 hatte ich hier schon mal als Baustelle.


    Kamera HP WideVision HD-IR-Kamera mit Kameraverschluss und integriertem Dual-Array-Digitalmikrofon
    Audio-Merkmale Audio von Bang & Olufsen; 3 Lautsprecher; HP Audio Boost 2.0


    Liegt hierbei an dem neuartigen zweifachen Mic's, mit den macOS so gar nicht will.

    Rein aus der Erinnerung habe ich dafür mit anderen Usern schon einige erfolglose Test's gefahren.


    Falls das Mic unter Linux/Linux-Live geht, kannst Du gern noch einen codec_dump machen.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB  11.6.1 / 12.0.1 (OC0.7.4)

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema  SSD 250GB+512GB  macOS 12.0.1

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  SSD 2x250GB + 480GB  10.15.7 / 12 DP10 (OCLP0.3.0)

    iPhone8 64GB: iOS 15.0.2  iPad Pro 9,7" WiFi 32GB: iPadOS 15.1

  • Erstaunlicher weise läuft es unter Ubuntu genauso wie der Touchscreen, ich mache jetzt mal direkt nen DSDT Dump.

    Files

    • codec_dump.txt

      (10.01 kB, downloaded 18 times, last: )

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Sapphire RX580 - macOS 11.0.1 - OC

    Elitebook 840 G1 : *1600x900* - Intel i5-4300U - 8GB DDR3 - M2 254GB + Intel SSD 320GB - Intel HD 4400 - macOS 11.0.1 - OC

  • ok, ich habe mal für den Test die LayoutID 13 verändert, welche Du verwendest.

    Falls tatsächlich was geht, kann ich ja später noch eine neue eigene ID erstellen.

    Versuch's einfach!


    trial.zip

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB  11.6.1 / 12.0.1 (OC0.7.4)

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema  SSD 250GB+512GB  macOS 12.0.1

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  SSD 2x250GB + 480GB  10.15.7 / 12 DP10 (OCLP0.3.0)

    iPhone8 64GB: iOS 15.0.2  iPad Pro 9,7" WiFi 32GB: iPadOS 15.1

  • Danke für deine Mühen, leider unverändert kein Mic

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Sapphire RX580 - macOS 11.0.1 - OC

    Elitebook 840 G1 : *1600x900* - Intel i5-4300U - 8GB DDR3 - M2 254GB + Intel SSD 320GB - Intel HD 4400 - macOS 11.0.1 - OC

  • Habe nochmal mit MuteGPIO 0 versucht:


    trial2.zip


    Edit:


    layoutID 12 könntest Du auch mal versuchen

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB  11.6.1 / 12.0.1 (OC0.7.4)

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema  SSD 250GB+512GB  macOS 12.0.1

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  SSD 2x250GB + 480GB  10.15.7 / 12 DP10 (OCLP0.3.0)

    iPhone8 64GB: iOS 15.0.2  iPad Pro 9,7" WiFi 32GB: iPadOS 15.1

    Edited once, last by MacPeet ().

  • teste ich später bin grad in Düsseldorf danke dir


    EdIt: Auch hier leider kein Mic MacPeet

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Sapphire RX580 - macOS 11.0.1 - OC

    Elitebook 840 G1 : *1600x900* - Intel i5-4300U - 8GB DDR3 - M2 254GB + Intel SSD 320GB - Intel HD 4400 - macOS 11.0.1 - OC

    Edited once, last by SirusX ().

  • Hi,

    Hab ein Envy x360 15. das Problem mit dem MIC habe ich auch. Bin seit Woche dran. Bisher kein Erfolg.


    Wie hast du das mit dem Sleep hinbekommen? Bildschirm nur dunkel oder wirklich Deepsleep?


    Ralph

  • Ach grauenhaft Sleep läuft nicht nur Display geht aus, Touchscreen geht nicht. Und die Hintergrund Beleuchtung gibt nur ca 80% solange bis er im Schein sleep war danach gibt er 100%


    Egal ob OC oder Clover will einfach nicht denke ohne jemanden der echt nen Plan von DSDT hat und des Patchen wird das auch nichts werden. Sehr schade aber meine Geduld und Nerven sind am Ende :keinkommentar:


    EDIT:


    Ich habe mal mit Clover die Original ACPI Tabellen ausgelesen vielleicht kann einer unserer Profis etwas damit anfangen.

    Files

    • origin.zip

      (111.45 kB, downloaded 13 times, last: )

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Sapphire RX580 - macOS 11.0.1 - OC

    Elitebook 840 G1 : *1600x900* - Intel i5-4300U - 8GB DDR3 - M2 254GB + Intel SSD 320GB - Intel HD 4400 - macOS 11.0.1 - OC

    Edited 2 times, last by SirusX ().

  • So viele viele Stunden und einer innere Einkehr später, habe ich nochmal alles von Grund auf neu aufgebaut. Nun läuft der Sleep jedoch die Power LED leuchtet dauerhaft weiter auch wenn er Schläft wie man dies behebt keine Ahnung ^^


    Und der Rest läuft wie er soll einzig HDMI/DMIC/USB-C-HDMI und volle Display Helligkeit nach Sleep da IceLake werden die Restlichen dinge in Zukunft von Whatevergreen/Lilu/Apple in Zukunft vielleicht per Update gefixt.


    Mein letztes Problem oder Anliegen an jedem der mir gern helfen möchte, wieso kackt die PS2 Notebook Tastatur ab und zu nach dem Sleep ab ? Kann mir hier wer helfen oder auch bei der Power LED ?


    EDIT: PS: Er lässt sich nur per MagicMouse aufwecken !?


    LG Mark EFI hab ich mal angehangen / -WiFi Kext

    Files

    iMac 18,3 : Acer 27'' WQHD: Asrock Fatality Z270 Gaming K4 - Intel i5-7600K - 16GB DDR4 Intenso - Sapphire RX580 - macOS 11.0.1 - OC

    Elitebook 840 G1 : *1600x900* - Intel i5-4300U - 8GB DDR3 - M2 254GB + Intel SSD 320GB - Intel HD 4400 - macOS 11.0.1 - OC