Welches SMBIOS bei AMD R7 240 und i7 3770 sowie Clover oder OpenCore?

  • LetsGo


    Das SMBIOS ist "iMac13,2".

    Beim googlen bin ich auch auf solche Fehlermeldungen gestoßen, soll mit Clover zu lösen sein.

    Ich probiere erst einmal alles an OpenCore aus.


    LG Franziska1993

    Files

    • EFI.zip

      (3.48 MB, downloaded 28 times, last: )

    Desktop macOS Betriebssysteme (siehe Spoiler):

  • Files

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • OSX-Einsteiger


    in der beigefügten config.plist muss ich noch die SSDT-GPU-SPOOF.aml verlinken bzw.

    unter APCI/add einfügen, oder?


    LG Franziska1993


    PS: OSX-Einsteiger Hat nichts gebracht, muss wohl einen andewren Weg gehen.

    Desktop macOS Betriebssysteme (siehe Spoiler):

    Edited once, last by Franziska1993 ().

  • Willst du es erst mal mit der Intel Grafik versuchen ? und da nach könnte mann sich um die R7 240 kümmern aber nur wenn du willst :


    Ich möchte das du mit den Clover Configurator denn Device Path von der R7 240 rauschst und postest .


    Edit:


    So müsstest es bei die aussehen .


    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

    Edited once, last by OSX-Einsteiger: Clover Device Path ().

  • Franziska1993


    Als erstes glaube ich sowieso, dass das mit der R7 240 schwierig wird. Man findet eigentlich so gut wie keine funktionierenden Builds.


    Hast du den EFI Ordner selbst erstellt?

    Für was sind diese Kexte (FakePCIID_XHCIMux.kext, FakePCIID.kext) eigentlich?

    Man könnte mal versuchen, die FakeSMC Kexte durch VirtualSMC zu ersetzen. Soll jetzt nicht heißen, das die FakeSMC Kexte nicht funktionieren. Aber die sind schon sehr alt und eigentlich kann man am Anfang mal auf die ganzen Sensoren verzichten. Solange man nicht zumindest ein funktionierendes System hat.


    Von welcher config.plist stammen die Bilder, die zuvor hochgeladen hast? Bei der config-kaputt.plist hast du die SSDT-GPU-SPOOF eingebunden und unter deviceproperties deine Fake-id eingetragen. Nur eines von beiden nutzen. Wobei ich mir nicht sicher bin ob der PCI Pfad in der SSDT überhaupt stimmt. Das Auslesen hat ja anscheinend unter WIN sowie Linux nicht hingehauen.


    Und in der config.plist ist nichts von beiden eingetragen.


    Aber wenn OSX-Einsteiger dran ist, lass ich euch mal machen. Sonst stifte ich noch zu viel Verwirrung.

  • LetsGo


    > Hast du den EFI Ordner selbst erstellt?


    Nein, entweder ist die EFI von Chrisatian oder Nordel.


    > Als erstes glaube ich sowieso, dass das mit der R7 240 schwierig wird. Man findet eigentlich so gut wie keine funktionierenden Builds.


    Richtig, allerdings habe ich die R7 240 geholt, weil die funktionieren soll.


    > Bei der config-kaputt.plist hast du die SSDT-GPU-SPOOF eingebunden und unter deviceproperties deine Fake-id eingetragen.


    Beides habe ich nicht benutzt, da kann ich Dir versichern, habe aber öfters die condig.list geändert und wieder neu verwendet.


    >Wobei ich mir nicht sicher bin ob der PCI Pfad in der SSDT überhaupt stimmt


    Laut Win10 ja, ich habe nur nicht jetzt auf den WinPC die Möglichkeit das Foto davon von meinen iPhone auf dem PC zu kopieren, das geht nur auf Catalina


    OSX-Einsteiger


    > Willst du es erst mal mit der Intel Grafik versuchen ?


    Die habe ich bereits vor langer Zeit zu laufen gebracht. Es geht mir jetzt nur um die R7 240, damit ich weiß, ob diese nun inuter macOS läuft oder nicht.


    PS: OSX-Einsteiger und LetsGo - Wir sind nah am Ziel, wie das Foto von gestern zeigt.

    Desktop macOS Betriebssysteme (siehe Spoiler):

  • Franziska1993


    Ist in der config-kaputt.plist der Device Path von deiner R7 240 richtig ?


    EDIT:


    Kext aktualisiert und VirtualSMC.kext hinzugefügt auch in der config.plis eingefügt und auf true/Yes gestellt .

    Deine FakeSMC.kext alle sind noch drin aber erst mal in der config.plist auf false/No gestellt.


    Ich habe in der SSDT-GPU-SPOOF.aml noch mal nach gebessert .

    Die Habe ich aus einer Clover config.plist die Fake entnommen .

    Files

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

    Edited once, last by OSX-Einsteiger ().

  • OSX-Einsteiger ich bin unterwegs und melde mich sobald ich Zuhause bin. Ich finde es gut das Du mir hilfst. Sollte es mit der EFI nicht klappen, benutze ich die Crash config und fotografiere den kompletten Error. Vielleicht lag es daran, das ich den fehlenden device Eintrag für die Ivy-Bridge CPU nicht in der config hatte. LG Franziska1993


    Update 21:53


    Die EFI hat leider nicht funktioniert und ist steckengeblieben (siehe Foto)


    Anbei noch ein Foto von Win10 wo ich den Pfad ermittelt habe:



    Heute schaffe ich es nicht mehr mit der Crash-config, aber morgen.

    Ich muss die komplette Fehlermeldung abfotografieren, um den Error

    via Google zu ermitteln.


    LG Franziska1993


    OSX-Einsteiger update 24.7.2021 - 13:34


    Habe in meinen Unterlagen die Lösung für das IOConsoleUsers: gIOScreenlock gefunden, da ich diesen Error

    bei meinen AMD FX Hack mit GT710 des öfteren hatte. Bei den Bootarg muss noch als Ergänzung "npci=0x2000" rein. Mal sehen, was nachher passiert - Bericht folgt

    Desktop macOS Betriebssysteme (siehe Spoiler):

    Edited 4 times, last by Franziska1993 ().

  • IOConsoleUsers: gIOScreenlock ist ein Grafikfehler.


    R7 240 unter Catalina mit Änderung des 7000er Kexts, noch machbar.

    Hol dir lieber ein aktuellere Graka.


    Edit

    @Franziska1993

    https://www.insanelymac.com/fo…8-ati-oland-family-cards/

    Intel - diverse geniale Hardware bis einschließlich Skylake, damals...

    AMD X6 1035T Silentmaxx TwinBlock - ASRock N68-S -8GB RAM - XFX HD 6450 Passiv - Etasis EFN-300

    AMD 7 3700X - Noctua NH-P1 - B550 Aorus Pro V2 - RX460 Passiv - Silentmaxx Fanless II 500 Platinum

    - - - - - - - - HOWTO: RYZENTOSH - - - - - - - -

    Edited once, last by ralf. ().

  • Hallo ralf.


    hast du irgendwo einen Anleitung für die Änderung des Kexts?


    Ich sehe nach der Anschaffung der R7 240 diese als Herausforderung.


    LG Franziska1993

    Desktop macOS Betriebssysteme (siehe Spoiler):

  • Franziska1993


    Du hast es fast , was ralf damit sagen will ist die fake ID entscheidet welcher Treiber geladen wird .


    Hast du unter Clover diese Fake ID ?

  • Hallo OSX-Einsteiger ,


    ich bin die ganze Zeit mit OpenCore und nicht mit Clover dran.


    Ich habe jedoch von jemanden Clover EFI's, unter anderen auch für Ivy-Bidge CPU

    die zu Catalina passen.


    Das die ID über den Treiber entscheidet, habe ich schon verstanden.


    Bei allen mir bekannten ID's die passen sollten oder andere verwendet haben, greifen

    auf den 7000 Kext zu.


    Alexey Boronenkov, der einen Youtube Kanal hat, verwendet sogar die 6798 ID.

    Die 6798 ID greift allerdings auf die 8000 er und X4000 Kexte zu.


    LG Franziska1993

    Desktop macOS Betriebssysteme (siehe Spoiler):

  • Franziska1993


    Hier eine EFI auf Basis vom Post 21 zurück .

    Ich habe bis auf denn config-kaputt.plist alle gelöscht und in config.plist umbenannt .


    Sollte die EFI so Funktionieren sage ich dir wo der Fehler war ;)

    Files

    • EFI.zip

      (3.53 MB, downloaded 12 times, last: )

    Hackbook HP Notebook - 15-ac135ng (ENERGY STAR)


    MacBookPro13,2 , CPU i5-6200U , 12GB RAM , Intel Grafik HD520 , OpenCore 0.7.0

  • Hallo OSX-Einsteiger,


    leider wieder ohne Erfolg, hängt bei:


    IOConsoleUsers: time (0) lin 0 llk 1,

    IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm0x0


    Obwohl ich danach das Bootarg npci=0x2000 noch dazu gegeben habe, was diesen

    ERfolg bisher immer beseitigt hat, gab es die gleiche Errormeldung.


    Ich werde mal die ander Meldung, wenn der Radeon Kextgeladen wird, mal genauer

    ergooglen (siehe Foto):




    Hier die komplette Errormeldung:


    AGDCC unauthorized client 'perfpowerservice' (IOService:/AppleACPIPlatFormExpert/PCI0@0/PEG0@1/IOPP/GFX0@0/AMD7000ControllerWrangler)


    AGDCC unauthorized client 'perfpowerservice' (IOService:/AppleACPIPlatFormExpert/PCI0@0/AppleACPIPCI/PEG0@/IOPP/HDAU@0,1/AMD7000ControllerWrangler)


    AGDCC unauthorized client 'perfpowerservice' (IOService:/AppleACPIPlatFormExpert/PCI0@0/PEG0@1/IOPP/GFX0@0/AtiDeviceControl)


    AGDCC unauthorized client 'perfpowerservice' (IOService:/AppleACPIPlatFormExpert/PCI0@0/PEG0@1/IOPP/GFX0@0/AtiDeviceControl/AppleGraphicsDevicePolicy/ACDPClientControl)



    LG FRanziska1993

    Desktop macOS Betriebssysteme (siehe Spoiler):

    Edited once, last by Franziska1993 ().