[Sammelthread] MacOS Monterey 12.x DEV-Beta Erfahrungen

  • Hatte sonst noch jemand das Problem, dass Beta 8 so alle 15 Minutenb aus dem Sleep aufwacht, irgendwas tut und wieder einschläft?

    Vermutlich Power Nap. Manchmal bekommt man das selbst durch Deaktivieren von Power Nap in den Einstellungen nicht in den Griff. In dem Fall kann man das Wake Scheduling mit einem Hotpatch deaktivieren. In der OpenCore Sample Config ist dafür ein Beispiel enthalten, kannst mal schauen ob das bei dir hilft. Power Nap braucht man ja in der Regel nicht.


    LG Chris


    Meine Hardware:

  • NIIIICE: UPDATE für Restrict Events:


    - Added macOS 12 software update support with any Mac model

    heißt die geschichte mit secureboot model swapp ist hinfällig ?


    KEIN SUPPORT PER PN!

    julian2_pic.png

  • Ja, das sieht ganz danach aus.... bin gerade noch am Installieren, Full-Installer Beta-8, Kext in den Boot-Stick eingepflegt....läuft bisher ohne Probleme...

    mein Standart-Bios ist iMac19.1.

    Alle reboots mit dem "neuen Stick" überstanden..... das sieht wirklich gut aus.... und schon bin ich bei dem Anmelde-Bildschirm(Länderauswahl....)


    Und läuft....

  • plutect Schon merkwürdig. Scheinbar sind wir hier die einzigen bei denen BT nach dem Wake tot ist.

    Aber mir gehen da langsam die Ideen aus denn der Broadcom Adpater funktioniert unter allen anderen Betriebssystem-Versionen bis einschliesslich 12.0 beta6 stets einwandfrei.


    Vielleicht hat ja noch jemand einen Tip .. :think:


    Grüße

  • Phoenix85  LetsGo

    Habe ich genau so gemacht wie LetsGo - Es ging sogar ohne die Comments ohne Probleme. Kannst Du evtl. mal die OC 0.74 DEBUG versuchen - evtl. siehst Du mehr?

    Hats Dir evtl. die plist zerlegt? Geht ocvalidate noch durch?

    Das zeigt OCValidate an:


    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Couldn't get array serialized at 0 index!

    OCS: Couldn't get array serialized at 1 index!

    OCS: Couldn't get array serialized at 2 index!

    OCS: Missing key ForceOcWriteFlash, context <Quirks>!

    Serialisation returns 54 errors!


    Booter->Quirks->ProvideCustomSlide is enabled, but OpenRuntime.efi is not loaded at UEFI->Drivers!

    Booter->Quirks->EnableWriteUnprotector is enabled, but OpenRuntime.efi is not loaded at UEFI->Drivers!

    CheckBooter returns 2 errors!


    Kernel->Patch[1]->Replace requires ReplaceMask to be active for corresponding bits!

    CheckKernel returns 1 error!


    UEFI->Quirks->RequestBootVarRouting is enabled, but OpenRuntime.efi is not loaded at UEFI->Drivers!

    CheckUEFI returns 1 error!


    Completed validating /Volumes/EFI/EFI/OC/config.plist in 1 ms. Found 58 issues requiring attention.


    So schaut die EFI aus:






  • Das Format für Drivers hat sich geändert. Daneben passe einige andere Sachen nicht zur neuen Version von OC. Entweder passt du das manuell in deiner config.plist an, oder startest neu mit der sample.plist und gleichst sie mit deiner alten ab.

    AMD Ryzen 9 3950X | ASUS Strix X570-I Gaming | 64GB DDR4-3600 CL16 RAM | Corsair MP600 M.2 NVMe | Radeon RX 6900 XT | Phanteks Enthoo Evolv Shift | Custom Loop | MacOS 12 | OpenCore

    Ryzen MacPro | EFI | RadeonSensor | Aureal

  • Weiterhin funktioniert das Update nicht.


    Habe ForceOcWriteFlash mit false in meine config.plist hinzugefügt.


    OC Aux sagt aktuell für OCValidate folgendes:


    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Arch, context <Add>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    OCS: Missing key Flavour, context <Tools>!

    OCS: Missing key RealPath, context <Tools>!

    OCS: Missing key TextMode, context <Tools>!

    Serialisation returns 50 errors!


    Kernel->Patch[1]->Replace requires ReplaceMask to be active for corresponding bits!

    CheckKernel returns 1 error!


    Completed validating /Volumes/EFI/EFI/OC/config.plist in 2 ms. Found 51 issues requiring attention.


    AdviseFeatures ist auf True

    SecureBoot Model auf Disabled

  • Hallo CMMChris,

    also alles sehr komisch. Hab das gerade mal mit der IORegistra mal geprüft und es scheint wirklich so das der Treiber "AppleGraphicsDevicePolicy" unter der Grafikkarte geladen ist. Das Boot-Arg habe ich bereits im System. Anscheinend funktioniert es unter Beta 8 nicht mehr korrekt. Ich werde nun das mit dem Kext Patch probieren.


    Update: Alles gemacht leider keine Änderung. Bin aktuell etwas ratlos....

  • Update: Alles gemacht leider keine Änderung. Bin aktuell etwas ratlos....

    Kannst du mir mal bitte die AppleGraphicsDevicePolicy Kext aus der Beta 8 hochladen? Würde da gerne mal in die info.plist schauen.

    LG Chris


    Meine Hardware:

  • CMMChris


    Läuft Deine M1-Kiste wieder?

    Bei meinem Mini M1 hier keine Probleme beim Update auf DP8.

    Schon echt komisch, was dort bei Dir da passiert ist, zumal schon andere M1-User hier keine Probleme gemeldet haben.

    Thinkpad T450s: i7-5600U  2,6GHz-3,2GHz  12GB DDR3  IntelHD 5500  14" intern  SSD 512GB + NGFF M2 SSD 512GB  11.6.2 / 12.1 DP3

    Real: MacMini M1: M1 CPU  3,57GHz  8GB DDR4  M1 GPU  30" Apple-Cinema  SSD 250GB+512GB  macOS 12.1 DP3

    MacPro3,1: 2 x Xeon E5462  2,8GHz  12GB DDR2  NVIDIA Quadro K600 1GB  SSD 2x250GB + 480GB  10.15.7 / 12.1 DP3

    iPhone8 64GB: iOS 15.1  iPad Pro 9,7" WiFi 32GB: iPadOS 15.2 DP3

  • hallo nochmals,


    bei mir hängt es noch immer: bei Beta 7 bekomme ich Invalid Firmware, aber die ist jetzt eh schon uninteressant geworden.


    Meine Frage: vom USB-Stick aus gebootet, bricht mir die Installation bei 12 Minuten übrig ab, es stehen *schreckliche* Dinge in meinem Log, aber wie erhalte ich Zugang zu diesem USB-Log? Das würde ich gerne mal ansehen, weil sehr schnell viele Fehler passieren, bevor die Maschine dann gar nichts mehr tut, auch keinen reboot.


    und noch was: egal, was ich auch im open core configurator ändere, vor allem da -v, wird nicht übernommen, es kommt immer nur der apfel, und das ist wirklich neu. Ich spiele auf der config.plist herum, aber es ändert sich nichts am bootverhalten. was ist da los? verwende opencore configurator 0.73, aber teils mit sample.plist vom 0.74. Ausserdem schreibt mir beim Systemstart, das OC-Config veraltert ist; also irgendwas läuft da ganz quer!


    von dem mal abgesehen, das der sound über HDMI nicht geht und der bluetooth-dongle inkompatible ist.


    nur nicht aufgeben, an alle, die daran werkeln!


    lizbeth

  • Läuft Deine M1-Kiste wieder?

    War nie tot. Mir hat es nur die externe SSD beim dritten Anlauf zerschossen. Genau deshalb installiere ich keine Betas auf der Internen. Wenn das dort passiert wäre, würde ich in die Röhre schauen, weil ich dann einen IPSW Restore machen müsste, was ohne zweiten Mac schwer ist. Mit der Beta 8 setze ich jetzt aus und warte auf die Nächste. Die Beta 8 lässt sich ohnehin nicht installieren. Hatte es noch mit einer Clean Install versucht, sowohl per Stick als auch Recovery - schlägt beides fehl.

    Hier ist der Kext.

    Merci, an der info.plist sehe ich nichts Auffälliges. Alles beim Alten. Was du auch noch testen könntest, ist com.apple.driver.AppleGraphicsDevicePolicy mit der Block Funktion von OpenCore am Laden zu hindern. Oder gibt es die nicht mehr? Bin mangels Bedarf nicht mehr ganz auf dem Laufenden in Sachen Hackintosh. :oops:

    LG Chris


    Meine Hardware:

  • mutterhunt


    Arbeite zwar nicht mit OC Configurator, aber bin mir absolut sicher, dass die OCC Version mit der OC Version übereinstimmen muss.


    Also, wenn du schon OC 0.7.4 verwenden möchtest, brauchst du auch die entsprechende OCC Version. dazu. https://mackie100projects.alte…ad-opencore-configurator/


    Persönlich finde ich es gerade am Anfang besser die config.plist mit einem plist Editor zu bearbeiten, als auf Tools zurückzugreifen. Denke man lernt etwas mehr dabei und ist nicht wirklich mit mehr Zeitaufwand verbunden. Aber ist nur meine Meinung.


    Und so sollte -v (verbose mode) in der config.plist eingetragen sein.



    CMMChris


    Bei mir funktionieren eh beide Monitore (RX550). Vielleicht liegts an den NAVI Karten?

  • Das wären jetzt mal die Werte vom Hauptmonitor

    Zum Verkauf geplant -> Board: GA-Z97X-UD5H-BK / CPU: i7-4790K / Grafikkarte: R280X / RAM: 16GB DDR3
    CNC Maschine (Apple Power Mac G5): Board: GA-Z77N-WiFi / CPU: i5-3570K / R280X / RAM: 16GB DDR3


    Rechtschreibung, Grammatik, Satzzeichen, Textformatierung und manchmal auch ein Komma führen zu einer besseren Verständlichkeit ;) :D

  • LetsGo Danke für den Tipp, es heisst auch immer veralterter bootloader. Das mit -v ist klar, ich nehme auch noch -alcbeta und sowas rein, aber es hilft nichts, ich habe die OC-Configurator bis zurueck in den Mai getestet, alle schreiben das gleiche: veraltert, wie updaten? Mein Drive - Backup trägt den 19.8.2021 als Beta 6, als auch die Grafik funktionerte, wovon ich jetzt um viele <Driver Errors> entfernt bin.