ThinkPad W540 Opencore

  • Hallo,


    Ich habe auf meinem ThinkPad W540 "itwlm" installiert. Jedoch, wenn ich "Heliport" starte steht dort nur "itwlm läuft nicht". Lässt sich dieses Problem lösen?



    Die Nachricht wurde nach meinem Wissen beantwortet, kein Gewähr auf Richtigkeit

  • B4tMaxt

    Removed the Label In Arbeit
  • Hast du es auch bei opencore in der config.plist hinzugefügt?

  • Oh ich hab Clover, kannst du das Thema verschieben, und was bedeutet hier Thema abonniert, wenn man es anklickt, und wie kann ich das rückgängig machen



    Die Nachricht wurde nach meinem Wissen beantwortet, kein Gewähr auf Richtigkeit

  • welchen kext hast du den hinzgefügt , gibt auch einen der ohne heliport auskommt ...

    läut dann über die macOS eigene WLAN Übersicht , bei mir kam nämlich die gleiche Meldung damals


    KEIN SUPPORT PER PN!

    julian2_pic.png

  • Und welcher Kext? Welches OS?

  • itwlm. Airportitwlm geht nicht. Ich verwende Catalina und was bedeutet Thema abonnieren?



    Die Nachricht wurde nach meinem Wissen beantwortet, kein Gewähr auf Richtigkeit

  • Airport läuft ohne Heliport.

    Wenn du das Thema abonniert hast (dein eigenes sowieso immer), bekommst du Benachrichtigungen.

    Hier kannst du das verwalten (Mobil)

  • Ok, nur wenn "Airportitwlm" in dem kext ordner von Clover ist, dann wird nichts von Wlan angezeigt. Bevor ihr fragt, die Karte steht auf der Unterstützung.



    Die Nachricht wurde nach meinem Wissen beantwortet, kein Gewähr auf Richtigkeit

  • Airportitwlm.kext gibt es in zwei Versionen. Einmal für Big Sur und einmal für Catalina. Du hast auch die richtige? Ansonsten habe ich die noch nicht mit Clover getestet. Mit OC läuft die Kexts - wie schon mehrfach gesagt wurde - inzwischen ohne Heliport.


    Gehe mal auf "Über diesen Mac" / Systembericht / WLAN und mach einen Screenshot.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • B4tMaxt

    Changed the title of the thread from “itwlm läuft nicht” to “ThinkPad W540 Opencore”.
  • Hallo,


    Habe mir jetzt überlegt zu Open Core umzusteigen, habe nach dem "Dortonia Open Core Guide" eine EFI erstellt und kann auch schon booten, jedoch fehlen noch ein paar Kleinigkeiten wie z. B: Airportitwlm, wie kann ich denn Apple Secure Boot aktiveren?


    Das ist aber nebensächlich, ich möchte ersteinmal die Grafikkarte und die Akkuanzeige zum laufen bringen, habe eine Intel HD Graphics 4600, Nvidia wurde per "-wegnoegpu" deaktiviert, im Anhang meine Open Core EFI



    Die Nachricht wurde nach meinem Wissen beantwortet, kein Gewähr auf Richtigkeit

    Edited 2 times, last by B4tMaxt ().

  • Lad mal deine Clover EFI hoch, vielleicht kann man den Batteriepatch ja übernehmen[floet].

    !!!KEIN SUPPORT PER PN!!!

    Edited 2 times, last by HackBook Pro ().

  • HackBook Pro Ok, hier ist die Clover EFI



    Die Nachricht wurde nach meinem Wissen beantwortet, kein Gewähr auf Richtigkeit

    Edited once, last by B4tMaxt ().

  • Die Datei SSDT-W540-BAT.aml fehlt in Deinem OC-Ordner. In der Config.plst hast Du sie eingebunden, aber im Ordner ist sie nicht vorhanden.

    Meine erstes Projekt

    INTEL NUC8i3BEH mit 32 GB DDR4-RAM, 500GB SSD, installiert MacOS Big Sur. OpenCore.

    Inzwischen läuft auch die festverbaute Intel-WLAN/Bluetooth-Karte, sowie der SD-Karten-Leser! :) - Macmini 8.1


    Mein zweites Projekt:

    AsRock H310-CM mit Intel Core I3-9100F, 16 GB DDR4-RAM, ASUS Rx560 4GB, OS Catalina, Clover - iMac19.1


    Mein drittes Projekt:

    Notebook HP-Probook 440 G6, Intel Core i5_8265U, Intel Grafik UHD-620, 16 GB DDR-4, WLAN-Karte BCM94369CS2 mit Flex-Adaper auf M.2, macOS Big Sur, OpenCore - MacBookPro 15.2


    Mein viertes Projekt:

    Gigabyte Z490M mATX, Intel Core i5-10500, 16 GB DDR4-RAM, ARock Radeon RX5500, 500GB NVMe M.2, BCM94360CS2 - macOS Big Sur, OpenCore - iMac 20.2

  • RenStad ok danke für den Tipp. Leider funktioniert es nicht.



    Die Nachricht wurde nach meinem Wissen beantwortet, kein Gewähr auf Richtigkeit

  • B4tMaxt Vielleicht braucht die SSDT Renames.

    !!!KEIN SUPPORT PER PN!!!

  • HackBook Pro welche, und Clover läuft die ohne Renames



    Die Nachricht wurde nach meinem Wissen beantwortet, kein Gewähr auf Richtigkeit

  • Vielleicht hat grt eine Idee, mit Batteriepatchs kenne ich mich nicht so aus, läuft bei meinem Dell ohne solchen.

    !!!KEIN SUPPORT PER PN!!!

  • da waren wir doch schon mal dran..

    ssdt hab ich glaube ich bereits erstellt. guck ich gleich, wenn ich am rechner bin.

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist WIEDER DA!! nächster termin voraussichtlich: mittwoch 15.9.21, 19.00 uhr

  • !!!KEIN SUPPORT PER PN!!!

  • weiss ich... da war ich ja fleissig dabei.. und nachgeguckt hab ich auch, ich hatte auch mal eine ssdt für den akku gebaut, die eigentlich meiner erfahrung nach - wenn sie richtig eingebaut wird, und die notwendigen renames eingefügt wurden - greifen sollte.

    ich häng sie noch mal dran.

    umbenannt werden muss: GBIF zu XBIF. GBST zu XBST, _WAK zu XWAK und _L1D zu XL1D


    und was nicht sein darf: ein rename von _EC zu irgendwas anderem, sowie LPC zu LPCB (oder wie auch immer anders)

    Files

    ersthilfe vor ort für altes zeugs (-> laptops) 8)

    berliner häckinTosh.stammTisch am 3.monatsmittwoch im maxFish/kunsthaus ACUD

    der stammtisch in berlin ist WIEDER DA!! nächster termin voraussichtlich: mittwoch 15.9.21, 19.00 uhr