Apple Watch Entsperren Lösungsansätze mit Apple WIFI Karten

  • Schönes Wochenende ins Forum,


    Mit der Apple Watch den Rechner zu entsperren ist schon eine feine Sache. Leider funktioniert das mit Hacks nicht immer. Da es mir doch irgendwie wichtig ist habe ich immer wieder versucht das zu Lösen und möchte hier mal meine Erfahrungen zusammenschreiben. Eventuell kommen neue Infos hinzu um das ganze weiter zu verfeinern.


    Zuerst mal mein Zenbook;

    In diesem ist eine BCM94360NG verbaut. Mit dieser Karte gibt es bei mir keinerlei Probleme mit dem entsperren durch die Apple Watch. Egal was passier, WIFI verbunden mit Netzwerk oder auch nicht, der Laptop wird immer entsperrt.


    Dann der Desktop Rechner:

    Zuletzt hatte ich diese Karte verbaut. Da bei diesem Adapter im Sleep Bluetooth komplett abschaltet funktionier nur das Entsperren von Admin Relevanten Task.

    Dies aber zuverlässig und immer.


    Da ich diese Karte anderweitig verwenden konnte habe ich mit für den Desktop Rechner eine Fenvi FV-T919 gegönnt.

    Bei dieser Karte wird Bluetooth im Sleep nicht abgeschaltet und ich kann auch mit dem Magic Trackpad meinen Rechner aufwecken.

    Was trotzdem nicht funktionierte war das automatische Entsperren nach dem Sleep.


    Mit folgenden Befehl war es mir mögliche eine Fehlermeldung dazu zu finden. Denn Befehl im Terminal eingeben und dann in den Sleep Modus versetzen.

    Code
    1. log stream --predicate 'category == "AutoUnlock" AND eventMessage contains "fail with error"'

    Fehlermeldung dann bei mir

    Code
    1. 2021-04-11 10:45:44.862575+0200 0x27be Default 0x0 439 0 sharingd: [com.apple.sharing:AutoUnlock] Client ack'd did fail with error: Error Domain=SFAutoUnlockErrorDomain Code=192 "AWDL network failed to start" UserInfo={NSLocalizedDescription=AWDL network failed to start}

    Ich habe dann mal versucht irgendwas herauszubekommen wie man denn AWDL Task beeinflusst. Leider habe ich dazu überhaupt nichts gefunden. Wenn man sich die System Log ansieht findet man einige Einstellungen dazu.

    Nur wie man die beeinflussen kann finde ich nichts dazu. Schade, eventuell hat jemand eine Idee.


    Letztendlich habe ich es jetzt jedoch auch geschafft das Apple Watch Entsperren auch auf dem Desktop aus dem Sleep funktioniert. Verstehen tue ich aber nicht warum es nur so geht. :/


    Was habe ich gemacht. Eigentlich nur dafür gesorgt das sich WLAN mit keinem Netzt verbindet aber trotzdem aktiv ist.


    Und warum auch immer funktionier Apple Watch entsperren jetzt genauso wie auf dem Laptop immer und zu 100 % zuverlässig.


    Wenn jemand dazu Ideen oder eigene Erfahrungen hat kann er diese gerne Teile.


    Weiterhin euch ein schönes Wochenende. Ich gehe jetzt zum Rennradfahren.

    Grüße und Good Hack Michael


    :hackintosh:

  • Also bei mir funktioniert das auch nicht immer zuverlässig. Wenn ich aber kurz ESC drücke und sofort Space wenn der Monitor ausschaltet funktioniert es eigentlich immer.


    Ich finde im pmset.log immer eine Fehlermeldung, daß der BT Treiber langsam ist. Ich schaue nachher noch einmal und poste das hier.


    Code
    1. 2021-04-11 13:30:52 +0200 Kernel Client Acks Delays to Wake notifications: [AirPort_BrcmNIC driver is slow(msg: SetState to 2)(457 ms)] [AMDFramebufferVIB driver is slow(msg: SetState to 2)(762 ms)] [IOUSBMassStorageInterfaceNub driver is slow(msg: SetState to 1)(1063 ms)] [IOUSBMassStorageDriverNub driver is slow(msg: SetState to 1)(1113 ms)] [PRT1 driver is slow(msg: SetState to 2)(1104 ms)] [AppleHDADriver driver is slow(msg: SetState to 1)(1462 ms)] [PRT0 driver is slow(msg: SetState to 2)(4444 ms)] [IOSCSIPeripheralDeviceType05 driver is slow(msg: SetState to 4)(5548 ms)] [IOSCSIPeripheralDeviceType00 driver is slow(msg: SetState to 4)(5576 ms)] [PRT0 driver is slow(msg: SetState to 2)(10985 ms)] [SPT5 driver is slow(msg: SetState to 2)(11721 ms)] [PRT3 driver is slow(msg: SetState to 2)(13293 ms)]

    Hier der betreffende Text aus dem pmset.log.


    Mir sagt dass, dass es zu lange dauert, den BT Treiber zu initialisieren und somit dann auch das Entsperren nicht geht.

    Edited once, last by G.com ().

  • Hallo G.com ,


    hast du diese beiden Schalter deaktiviert?


    Grüße und Good Hack Michael


    :hackintosh:

  • Jups, habe ich. Auch PowerNap etc. alles deaktiviert. Läuft zwar, bracuhe ich aber am Desktop nicht.

  • Also, ich habe das Problem noch immer. Auch das Ausschalten der automatischen Verbindung bringt keinen Unterschied. BT ist aber zumindest anhand der Kontrolleuchte auf der Karte immer an.


    Ich benutze Folgendes: Meine Karte

    Code
    1. log stream --predicate 'category == "AutoUnlock" AND eventMessage contains "fail with error"'

    Hat bei mir keine Fehlermeldung ausgeworfen.


    Was mich wurmt, es hat mal ganz zuverlässig funktioniert. Seitdem ist eigentlich nicht viel geändert. ABER, ich bleibe am Ball.

  • Kannst du mal folgenden Befehl eingeben

    Code
    1. sudo log erase --all

    Unmittelbar danach den Rechner in Sleep versetzen und wieder aufwecken mit Fehler.


    Danach sofort diesen Befehl eingeben

    Code
    1. log show > ./Desktop/log.txt

    und die Datei log.txt hier posten.

    Grüße und Good Hack Michael


    :hackintosh:

  • Ihr Wunsch ist mir Befehl :) Danke!


    BTW - es kam der Login Screen. Dann habe ich, wie immer ESC gedrückt und als der Bildschirm dunkel wurde, wieder die Maus bewegt und er hat wunschgemäß entsperrt. So sollte es das LOG ausdrücken.

    Files

    • log.txt

      (6.94 MB, downloaded 20 times, last: )
  • Das ist bei dir genau die gleiche Fehlermeldung.


    Code
    1. 2021-04-14 15:59:00.109706+0200 0x13a1 Error 0x0 611 7 sharingd: [com.apple.sharing:AutoUnlock] Failed to start AWDL Error Domain=com.apple.wifi.apple80211API.error Code=-3903 "(null)"
    2. 2021-04-14 15:59:00.109707+0200 0x13a1 Default 0x0 611 7 sharingd: [com.apple.sharing:AutoUnlock] AWDL started
    3. 2021-04-14 15:59:00.109707+0200 0x13a1 Default 0x0 611 7 sharingd: [com.apple.sharing:AutoUnlock] invalidateResponseTimer
    4. 2021-04-14 15:59:00.109717+0200 0x13a1 Default 0x0 611 7 sharingd: [com.apple.sharing:AutoUnlock] Auth lock session notifying delegate with error: Error Domain=SFAutoUnlockErrorDomain Code=192 "AWDL network failed to start"

    Bei dir hilft nicht die Haken bei automatisch Verbinden zu entfernen. Danach einmal WIFI deaktivieren und dann wieder aktivieren? WIFI Symbol ist bei mir dann gelb.

    Grüße und Good Hack Michael


    :hackintosh:

  • Probiert. Hatte keinen Unterschied gemacht. Werde es aber noch einmal testen.

  • Das hier muss dann nicht grün sondern gelb sein. Nur bei WLAN.


    Grüße und Good Hack Michael


    :hackintosh:

  • Ja, war es. Hatte aber nicht beim einzelnen Netzwerk, sondern global “automatisch verbinden” auf der Übersichtsseite abgewählt.

  • Verbinde dich bitte mal über denn Hotspot von deinem iPhone und versuche das Entsperren.

    Grüße und Good Hack Michael


    :hackintosh:

  • Bin gerade in einem Online Event. Danach gerne 😂


    Ich hatte auch schon mit festen IP’s gearbeitet.


    Hatte gelesen, das BT 4.1 mit dem 5 Ghz Wlan negativ korreliert.


    Habe schon mein Mesh abgestellt, damit er den AP schneller findet. Alles kein Unterschied.

  • Habe eine feste IP bei mir im Heimnetz über den PI.

    Grüße und Good Hack Michael


    :hackintosh:

  • Also, Iphone Hotspot. Auch kein Unterschied


    Feste IP ist über die Fritzbox vergeben und auch am Rechner eingetragen.


    Testweise habe ich jetzt das 5 GHz Netzwerk rausgenommen. Macht auch keinen Unterschied.


    So, nach Zwangsreboot - früher mit page fault - heute kein Thema mehr, dafür vmsel insert...


    Ich werde wohl nie ein voll lauffähiges System haben :) Es nervt, 2 Wochen keine Probleme, dann plötzlich aus dem OFF - wieder Wake Reboots. Ist bei mir iwie immer so, ich arbeite mir nen Wolf, es läuft zwei, drei Wochen und dann kommen Fehler. Warum...k.A.


    Melde mich gleich.


    UPDATE: Nix hat etwas geändert.


    UPDATE 2: Seit heut läuft es, wie geschmiert. Keine Veränderungen, alles beim Urzustand. Nur anstatt der Eingabeaufforderung wartet er nun länger und dann kommt Entsperren mit der Apple Watch...


    Ich sach ja, meine Kiste ist ein Mädchen..

    Edited 3 times, last by G.com ().

  • Hast du jetzt eine Netzwerk verbunden mit WLAN?

    Grüße und Good Hack Michael


    :hackintosh:

  • Ja...hatte ich, zwischenzeitlich aber auch mal wieder einen Absturz 😂 Mal sehen, wie es später ist.


    Gerade getestet, hat auf Anhieb geklappt. Einzige Unterschiede - ich habe ERP im Bios aktiviert und das CPU-PLL wieder auf Auto gesetzt.

  • ozw00d Was heißt das denn genau? Kannst Du das Entsperren aktivieren? Funktioniert das Entsperren von Apps? Hast Du eine originale Airport Karte?

  • Hey G.com Funktioniert nichts mit der Apple Watch. Habe das ganze aktiviert in den System Preferences.

    Es funktioniert nichts weder das entsperren wenn im Standby oder das entsperren von Apps.


    Ich hab eine Fenvi T-919