M2 Nvme abschalten Asus Z490, wie am besten?

  • Die Situtation:

    Mein Asus Z490 Strix Gaming F Board ist derzeit mit 2 Nvme M2 SSDs bestückt,

    und zusätzlich mit 2 SATA SSDs, letztere mit Catalina und einem W10 Clone, meist habe

    ich die Sata-Kabel einfach abgesteckt. Auf der kleineren Nvme Big Sur mit OC, auf der

    größeren 1Tb W10 Prof. Nun mein Problem, bei Updates des jweiligen Systems

    sollte man ja besser die jeweils andere Nvme deaktivieren, bzw. mindestens bei

    Neuinstallationen.


    Frage: wie deaktiviere/aktiviere ich korrekt bei meinem Board eine Nvme M2?
    Klingt simpel, ist es aber leider nicht bei dem UEFI. Der Einfachheithalber habe ich

    die Pdf Anleitung des Boards verlinkt. Wer kann mir eine genaue, korrekte Anweisung

    geben, mit genauem Pfad? Habe es zwar schon manchesmal geschafft, aber danach

    nicht mehr, die jeweilige Nvme wieder zu aktivieren. Sorry, für die vielleicht blöde Frage.

    Danke für Hinweise ;-).


    https://dlcdnets.asus.com/pub/…-F_BIOS_manual_EM_WEB.pdf

    Asus Z170M-E D3, Intel i5-7600K, 32 Crucial Ballistic Sport, Samsung Evo 960 M2,1Tb Samsung 850Evo + Crucial MX300 525Gb, Gigabyte RX 460 4Gb, 700W Netzteil Be Quiet, Dell 27" U2715H Monitor, Dual-Boot Win 10 + Sierra + High Sierra.

  • Garnicht. NVME läuft über PCIe und lässt sich nicht deaktivieren. Die einzige Möglichkeit besteht daran die "Platte" auszubauen. Was aber nicht nötig ist bei Updates. Wenn du Windows aber neuinstallieren möchtest ist es mehr oder weniger ratsam da Windows dumm ist und immer wieder die erste Platte will. Zumindest was den Bootloader betrifft. Wenn er den EFI von OC findet schreib es gerne da mal rein.

    • Gigabyte z390 Gaming M
    • i7-9700k
    • MQUPIN Gigabit-Netzwerkkarte, BCM94360CS2 (nativ)
    • Sapphire RX 580 Nitro+
    • OpenCore 0.6.3
    • 11.0.1 (20B28

  • aha, das hatte ich gar nicht bedacht, danke für den Hinweis! Ich war schon versucht, wieder ein "downgrade" auf ein Sata-SSD statt der zweiten Nvme zu machen. Hilfreich wäre dann vielleicht auch ein Sata Umschalter im 5 1/4" Slot, gibt es ja in diversen Ausführung, das wäre einfacher ;-).

    Asus Z170M-E D3, Intel i5-7600K, 32 Crucial Ballistic Sport, Samsung Evo 960 M2,1Tb Samsung 850Evo + Crucial MX300 525Gb, Gigabyte RX 460 4Gb, 700W Netzteil Be Quiet, Dell 27" U2715H Monitor, Dual-Boot Win 10 + Sierra + High Sierra.

  • Wenn er den EFI von OC findet schreib es gerne da mal rein.

    probier mal aus den Ordner von „EFI“ in etwas anderes umzubenennen, dann dürfte Windows den auch nicht mehr finden. Einen Stick dann zum Booten zu haben ist natürlich selbstverständlich!

    iMac Pro: Asus Prime Z390-A, i5-9600K, Vega 56, BCM943602cs - OC
    MacBook Pro 13" 2020: Lenovo IdeaPad 5-15IIL05: i7-1065G7, Iris Pro Plus G7, Intel AX201 - OC
    ________________________________

    - Dortania OC Install Guide | Dortania OC ACPI Guide | Dortania OC Post-Install Guide

    - Was ist mein Problem? > Ordentlich beschreiben!

    - Gibt es das schon im Forum? > Suche nutzen

    - Wie kann mir geholfen werden? > Ordentlich beschreiben! Nett sein & Danke sagen!

  • stimmt, auch noch eine gute Idee ;-)

    Asus Z170M-E D3, Intel i5-7600K, 32 Crucial Ballistic Sport, Samsung Evo 960 M2,1Tb Samsung 850Evo + Crucial MX300 525Gb, Gigabyte RX 460 4Gb, 700W Netzteil Be Quiet, Dell 27" U2715H Monitor, Dual-Boot Win 10 + Sierra + High Sierra.

  • Habe zwar kein Z490-.Board, aber bei der Installation von Win10 auf eine SATA-SSD damals ein ähnliches Problem.
    Zwar konnte ich den WIndows-Install-Stick direkt booten und er erkannte auch die SATA-SSD als Ziel, aber im nächsten Schritt, kopieren der Windows-Dateien, hing die Kiste dann fest.

    Erst als ich tatsächlich die NVMe komplett ausgebaut hatte, konnte ich auf die SATA-SSD installieren.

    Das umbenennen des EFI-Ordners habe ich damals aber nicht getestet...


    Mit der Nutzung der SATA-SSD ohne andere Datenträger, hat diese aber auch eine eigene EFI-Partition für Windows bekommen, was der Modularität des ganzen Aufbaus hilft...

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • bei Updates des jweiligen Systems

    sollte man ja besser die jeweils andere Nvme deaktivieren


    Wenn ein Medium aktiviert oder deaktiviert werden muss kann ich als alternative lösung dies hier bieten...



    Einfach ne Linux Live Stick nehmen, Gparted starten, den "unerwünschten" Medium anwählen, rechte Maus auf den EFI dessen und die beiden "Flags" deaktivieren.

    Ab jetzt sollte dieses Medium nicht starbar und die EFI nicht mehr für Betriebsysteme vorhanden sein.

    Später kann man den ja wieder auf dem gleichen Weg aktivieren.

    Gruss Coban

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • danke Euch, ihr habt super Ideen ;-)!

    Asus Z170M-E D3, Intel i5-7600K, 32 Crucial Ballistic Sport, Samsung Evo 960 M2,1Tb Samsung 850Evo + Crucial MX300 525Gb, Gigabyte RX 460 4Gb, 700W Netzteil Be Quiet, Dell 27" U2715H Monitor, Dual-Boot Win 10 + Sierra + High Sierra.

  • probier mal aus den Ordner von „EFI“ in etwas anderes umzubenennen, dann dürfte Windows den auch nicht mehr finden. Einen Stick dann zum Booten zu haben ist natürlich selbstverständlich!


    Ist ja wohl logisch das er den dann nicht mehr findet. Er heisst ja anders. Änder aber nicht s daran das Windows dann einen eigenen erstellt Names EFI. Es geht auch eher darum das er auf die EFI Partition der NVME schreibt und nicht die vorgegebene SATA SSD nimmt. Ob auf der EFI Partition irgendwelche Ordner sind ist nicht das Problem. Sondern das sie genutzt wird.


    Das die Geschichte mit GParted funktioniert kann ich mir beim besten Willen nicht vorstellen. Weil die Installation einen Bootloaders immer die Partition auf aktiv setzt auf dem er installiert wird. Nur weil eine Partition auf nicht Bootbar gesetzt wird ist sie nicht gleichzeitig nicht sichtbar.

    • Gigabyte z390 Gaming M
    • i7-9700k
    • MQUPIN Gigabit-Netzwerkkarte, BCM94360CS2 (nativ)
    • Sapphire RX 580 Nitro+
    • OpenCore 0.6.3
    • 11.0.1 (20B28

  • die Partition auf aktiv setzt

    UEFI --> ESP/EFI

    MBR --> "Active setzen"


    Da wird nichts active gesetzt, da wo kein ESP/EFI vorhanden ist kann auch nicht nach einem Booteintrag gesucht werden oder geschrieben werden...
    Gesucht oder gecheckt wird nach einem ESP/EFI, ohne diese flags gibt es den auch nicht.


    Gruss Coban

     MSI-B150M Mortar | Intel® Core™ i7-6700 Skylake | 64GB DDR4 RAM | Intel® HD Graphics 530 | Samsung NVMe 960 EVO / 1x2 TB HDD | BCM943602BAED DW1830 | OpenCore aktuell / macOS Catalina 10.15 / Windows 10 Pro / Ubuntu 20.04 LTS

     Lenovo S340-15IIL | Intel® Core™ i7-1065G7 IceLake | 12GB DDR4 RAM | Intel® Iris Plus Graphics G7 | Nvme Intel SSDPEKNW512G8L/SSD Samsung 256GB | BCM94360NG | OpenCore aktuell / macOS Catalina 10.15 / BigSur 11.0 / Win 10 Pro / Ubuntu 20.04 LTS


    " Chasch nöd s Föifi und s Weggli ha."

  • Ist ja wohl logisch das er den dann nicht mehr findet. Er heisst ja anders. Änder aber nicht s daran das Windows dann einen eigenen erstellt Names EFI. Es geht auch eher darum das er auf die EFI Partition der NVME schreibt und nicht die vorgegebene SATA SSD nimmt. Ob auf der EFI Partition irgendwelche Ordner sind ist nicht das Problem. Sondern das sie genutzt wird.

    Ich verstehe deinen Punkt nicht, es ist eine Lösung des Problems. Bei OC und Clover machen wir nichts anderes, als ständig EFI ordner zu verschieben, aber hier soll es falsch sein? Zumal man das bei Windows nur 1x macht und gut ist.

    iMac Pro: Asus Prime Z390-A, i5-9600K, Vega 56, BCM943602cs - OC
    MacBook Pro 13" 2020: Lenovo IdeaPad 5-15IIL05: i7-1065G7, Iris Pro Plus G7, Intel AX201 - OC
    ________________________________

    - Dortania OC Install Guide | Dortania OC ACPI Guide | Dortania OC Post-Install Guide

    - Was ist mein Problem? > Ordentlich beschreiben!

    - Gibt es das schon im Forum? > Suche nutzen

    - Wie kann mir geholfen werden? > Ordentlich beschreiben! Nett sein & Danke sagen!

  • Ich glaub du verstehst das Boot-Prinzip nicht.

    Das Bios/UEFI sucht nach EFI-Partition(en) und dann EFI/BOOT/BOOTx64.efi.

    Wenn du jetzt Windows installierst hast du hat natürlich die Möglichkeit den EFI Ordner von OC in Wolke umzubenennen. Dann schreibt dir Windows auf genau diese EFI- Partition EFI/BOOT/BOOTx64.efi und dann hast du 2 Ordner.

    EFI/BOOT/BOOTx64.efi und Wolke/BOOT/BOOTx64.efi. Das BIOS/UEFI schaut aber nicht nach Wolke somit kannst du OSX nicht mehr starten. Und genau das ist das Problem. Sobald Windows eine vorhanden EFI-Partition findet nutzt es diese auch. Egal ob es die gleiche NVME ist oder eine x-beliebige SATA. Natürlich kannst du OC EFI/BOOT/BOOTx64.efi von USB zu starten und wieder zurückzukopieren aber dann hast du keinen Bootloader mehr für Windows.

    • Gigabyte z390 Gaming M
    • i7-9700k
    • MQUPIN Gigabit-Netzwerkkarte, BCM94360CS2 (nativ)
    • Sapphire RX 580 Nitro+
    • OpenCore 0.6.3
    • 11.0.1 (20B28

  • Hast du schon Mal Windows über OC gebootet?

    iMac Pro: Asus Prime Z390-A, i5-9600K, Vega 56, BCM943602cs - OC
    MacBook Pro 13" 2020: Lenovo IdeaPad 5-15IIL05: i7-1065G7, Iris Pro Plus G7, Intel AX201 - OC
    ________________________________

    - Dortania OC Install Guide | Dortania OC ACPI Guide | Dortania OC Post-Install Guide

    - Was ist mein Problem? > Ordentlich beschreiben!

    - Gibt es das schon im Forum? > Suche nutzen

    - Wie kann mir geholfen werden? > Ordentlich beschreiben! Nett sein & Danke sagen!

  • Ja na klar. Hab 2 verschiedene Festplatten mit jeweils eigenen EFI Partitionen samt EFI Folder. Mit den Pfaden wie oben beschrieben.

    • Gigabyte z390 Gaming M
    • i7-9700k
    • MQUPIN Gigabit-Netzwerkkarte, BCM94360CS2 (nativ)
    • Sapphire RX 580 Nitro+
    • OpenCore 0.6.3
    • 11.0.1 (20B28

  • Ich gehe davon aus, dass das wie bei mir angelegt ist.

    OC ist aber nur in der EFI der macOS-Platte eingesetzt.


    Bei mir schurrt das einwandfrei.

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Geht auch in einem EFI-Ordner. Darin ist dann ein OC-und ein Microsoft-Ordner. Ist doch kein Ding?

    ASUS PRIME X299-DELUXE i9-9940X • DDR4 64GB • SSD 960 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon RX Vega 64 • BMD Intensity Pro 4K

    ASUS WS X299 SAGE/10G i9-10980XE • DDR4 64GB • SSD 970 PRO 1TB • Thunderbolt3 Titan Ridge • 2x AMD Radeon VII • BMD DeckLink 4K Extreme 12G


    Ordnung ist die primitivste Form von Chaos. (Hans-Jürgen Quadbeck-Seeger)

  • Mich würde die GParted Geschichte interessieren. So wie es erklärt ist kann ich es mir leider nicht vorstellen. Soll aber nicht bedeuten das es nicht funktioniert. Vllt kann das mal jemand Testen und Nachspielen. Das effektivste und schnellste ist in meinen Augen die NVME fix auszubauen. 1x Schraube. SATA betrifft das ja nicht da lassen sich die einzelnen Ports um BIOS/UEFI deaktivieren. Jedes OS samt eigenem Bootloader ist meiner Ansicht nach weiterhin die eleganteste Lösung :)

    Und betreffen tut das auch nur die Neuinstallation vom Windows. OS X und Linux lassen sich nachträglich auf die eigene Festplatten ohne Murks installieren. Windows Updates können auch nachträglich im Dualboot installiert werden.

    • Gigabyte z390 Gaming M
    • i7-9700k
    • MQUPIN Gigabit-Netzwerkkarte, BCM94360CS2 (nativ)
    • Sapphire RX 580 Nitro+
    • OpenCore 0.6.3
    • 11.0.1 (20B28

  • apfelnico

    Natürlich geht das auch... sogar Linux kann da noch mit rein.

    Ich finde es aber praktisch, wenn ich die einzelnen OS auch separat von einander booten kann... also z.B. Windows ohne das die macOS Platte vorhanden sein muss...

    Gruß
    Al6042

    Keine Unterstützung per PN... Eure Anfragen gehören ins Forum, nicht in mein Postfach!

  • Ich hatte an anderer Stelle schon mal das Tool WinNTSetup erwähnt. Dort kann man u. a. festlegen in welche ESP Windows seinen Bootloader ablegen soll.

    Ich hatte keine Lust die NVMe-SSD auszubauen. Bei einem ITX-System ist es nicht damit getan nur eine Schraube zu lösen, also bin den Weg mit WinNTSetup gegangen und das hat funktioniert. Windows hat die EFI auf der NVMe (auf der macOS installiert ist) nicht angefasst.

    MfG, docplag



  • Man kann auch den Weg über VMware gehen. Einfach die Zielplatte als pyhsisches Volume dort angeben und dann von der Windows.iso booten und den ersten Installationsschritt dort durchführen. Er fragt da ja noch keine Hardware ab sondern kopiert stuhr die Dateien rüber. Danach kann man dann die Windowsplatte normal booten und er führt den 2. Installationsschritt durch.


    So habe ich bis jetzt immer meine Windows's installiert.


    Code
    1. /Applications/VMware\ Fusion.app/Contents/Library/./vmware-rawdiskCreator create /dev/diskX fullDevice /ZIELPFAD/ZU/VMWARENAME.vmwarevm/external-hdd ide

    Airportkompatible Karte trotz BIOS Whitelist? >> Klick <<